16:00:12 <adrian_otto> #startmeeting containers
16:00:13 <openstack> Meeting started Tue Oct  6 16:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <openstack> The meeting name has been set to 'containers'
16:00:20 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-10-06_1600_UTC Our Agenda
16:00:25 <adrian_otto> #topic Roll Call
16:00:28 <apmelton> o/
16:00:28 <rlrossit> o/
16:00:29 <adrian_otto> Adrian Otto
16:00:31 <mfalatic> o/
16:00:34 <hongbin> o/
16:00:37 <Tango> Ton Ngo
16:00:38 <bradjones___> o/
16:00:38 <muralia1> o/
16:00:40 <sew1> o/
16:00:44 <VikasC> o/
16:00:57 <juggler> Perry Rivera o/
16:01:14 <adrian_otto> hello apmelton, rlrossit, mfalatic, hongbin, Tango, bradjones___, muralia1, sew1, VikasC, and juggler
16:01:30 <muralia1> hey adrian
16:01:40 <daneyon_> o/
16:02:03 <adrian_otto> hello daneyon_
16:02:11 <juggler> hello adrian!
16:02:32 <adrian_otto> #topic Announcements
16:02:36 <adrian_otto> 1) Reminder: New weekly meeting schedule. We will no longer alternate. Instead we will always meet Tuesdays at 1600 UTC.
16:02:48 <chandankumar> o/
16:02:48 <VikasC> wonderful
16:02:52 <VikasC> :)
16:02:52 <vilobhmm11> o/
16:02:53 <adrian_otto> you all showed up at the right time, so let anyone else know who might still be on the old schedule
16:02:58 <adrian_otto> helo vilobhmm11
16:03:07 <vilobhmm11> hello adrian_otto
16:03:40 <adrian_otto> 2) We have two new core reviewers as of 205-10-06 at 00:00 UTC. Welcome Vilobh Meshram and Hua Wang as our newest members of magnum-core!
16:03:53 <daneyon_> Congratulations!
16:03:58 <hongbin> welcome
16:03:59 <VikasC> congratulations!
16:04:08 <muralia1> congrats!
16:04:10 <chandankumar> congrats :)
16:04:22 <vilobhmm11> thanks all ! :)
16:04:37 <adrian_otto> both of these team members have done a ton of work reviewing code for magnum,and have each made meaningful contributions, so we are proud to have them on our team.
16:04:45 <mfalatic> congratulations!
16:04:57 <vilobhmm11> thanks again ! :)
16:05:12 <adrian_otto> 3) Our Liberty release did not cut yet due to a few critical reviews that still need to be merged.
16:05:20 <adrian_otto> #link https://review.openstack.org/#/q/status:open+project:openstack/magnum+branch:master+topic:bp/secure-kubernetes,n,z We need to revise/merge these
16:05:40 <adrian_otto> we also have a func test missing for external-lb which we can talk about a bit later in our agenda
16:06:59 <adrian_otto> 4) Elections
16:07:21 <adrian_otto> Magnum's election opened last week. If you have not participated, I urge you to do so to elect our M cycle PTL.
16:07:30 <adrian_otto> I am not sure when it closes
16:07:53 <manjeets_> already done
16:07:54 <adrian_otto> if you need help finding your CIVS email, I can direct you to the election officials
16:08:09 <adrian_otto> okay, on to action item review
16:08:14 <adrian_otto> #topic Action Items
16:08:55 <adrian_otto> 1) adrian_otto to announce meeting time change to ML
16:09:05 <adrian_otto> Status: incomplete (sort of)
16:09:23 <adrian_otto> this was mentioned in another email, but deserves one of it's own. I'll tackle that in a moment.
16:09:31 <adrian_otto> that concludes action items
16:09:50 <adrian_otto> #topic Blueprint/Bug Review
16:10:17 <adrian_otto> before I begin on this, I wanted to recognize something that Hongbin did that was really smart
16:10:34 <hongbin> ??
16:10:50 <adrian_otto> there was a new update to requirements.text (or global requirements)? that would have brought us out of alignment with Liberty requirements
16:11:04 <hongbin> I see
16:11:05 <adrian_otto> and he astutely voted against merging it until we branch liberty
16:11:21 <vilobhmm11> https://review.openstack.org/#/c/230566/
16:11:27 <vilobhmm11> this is the patch : ^^
16:11:31 <adrian_otto> so I would simply ask our other approvers to recognize that comment, and not to act on that until we create our branch
16:11:40 <adrian_otto> we are very close, but not quite there yet
16:11:57 <juggler> thanks hongbin!
16:12:01 <hongbin> yes, or even I should put a -2
16:12:08 <adrian_otto> if we can't get there in a day or so I'll branch anyway, and we'll need to resubmit open patches to backport them
16:12:33 <adrian_otto> so, thanks hongbin for that
16:12:37 <hongbin> np
16:12:45 <adrian_otto> Essential Blueprint Updates
16:12:47 <rlrossit> hongbin: I would -2 because that can't go in
16:12:57 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/objects-from-bay Obtain the objects from the bay endpoint (vilobhmm11)
16:13:07 <adrian_otto> rlrossit: I can take care of that
16:13:19 <adrian_otto> since I'm the one who will need to create the branch
16:13:45 <adrian_otto> vilobhmm11: this BP is marked as "Good Progress"
16:13:50 <vilobhmm11> adrian_otto : patches that are up for review for k8s obj were failing because of dependency on
16:13:55 <vilobhmm11> magnumclient changes
16:13:56 <adrian_otto> I know there are a couple of open reviews still, right?
16:14:05 <vilobhmm11> adrian_otto : yes
16:14:20 <vilobhmm11> after we discussed about this https://review.openstack.org/#/c/231219/ patch yesterday
16:14:23 <adrian_otto> ok, let's call those out individually
16:14:30 <vilobhmm11> ok
16:14:41 <adrian_otto> and is there any work that is not yet up for review that is needed to mark this BP as "Implemented"?
16:14:57 <vilobhmm11> no everything is up for review
16:15:18 <manjeets_> I have one which I would like to divide in two bp's marked the done as complete
16:15:29 <vilobhmm11> https://review.openstack.org/#/c/231219/ patch is needed to make sure functiona tests for https://review.openstack.org/#/c/223367/ passes
16:15:43 <adrian_otto> ok, thanks, so I'm going to open an etherpad right now for code we must merge before branch, or that must be reworked to backport into a branch prior to release candidate tagging
16:16:48 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-liberty-release-todo Must-do-for-release
16:17:00 <vilobhmm11> thanks!
16:17:32 <vilobhmm11> adrian_otto : thats it for objects from bay…last week we had 6 pacthes merged in for this feature
16:17:46 <vilobhmm11> thanks everyone for the reviews
16:17:48 <adrian_otto> excellent. Thanks for driving that effort!
16:18:17 <adrian_otto> I have listed those open ones on the etherpad. I'll ask reviewers to stalk that etherpad for the next day or so until we get these all done.
16:18:57 <suro-patz> vilobhmm11: if you create the dependency from https://review.openstack.org/#/c/223367/ on https://review.openstack.org/#/c/231219/ - the functional test should pass then, right?
16:19:07 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-kubernetes Secure the client/server communication between ReST client and ReST server (madhuri)
16:19:19 <adrian_otto> I don't think madhuri is present today
16:19:36 <adrian_otto> anyone else working on these items who can update us?
16:20:04 <adrian_otto> if not, I'll seek volunteers to adopt these patches to push them across the finish line
16:20:26 <suro-patz> adrian_otto: I can
16:20:31 <adrian_otto> thanks suro-patz
16:20:48 <adrian_otto> so your goal will be to adjust the existing patch sets so they can be approved for merge
16:21:02 <suro-patz> adrian_otto: sure
16:21:06 <adrian_otto> I think we are really close on these, and just need some TLC to get them done
16:21:20 <adrian_otto> will you need another contributor to back you up?
16:21:29 <suro-patz> I had earlier resurrected the https://review.openstack.org/#/c/207324/ - so a bit familiar
16:21:44 <adrian_otto> yes, that was awesome, thanks!
16:22:02 <adrian_otto> ok, let's look at the next BP
16:22:08 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/external-lb Support the kubernetes service external-load-balancer feature (Tango)
16:22:20 <adrian_otto> Tango: I see this is done with the exception of the func test
16:22:34 <Tango> The patches for Fedora and docs merged, thanks to everyone for the reviews
16:22:43 <sdake> o/
16:22:45 <adrian_otto> yes, indeed!!
16:22:52 <adrian_otto> hello sdake!
16:22:56 <sdake> heyguys
16:23:06 <sdake> sorry i've been lagging lately,h ad a super flu for the last 6 weeks
16:23:33 <juggler> yeah Tango
16:23:37 <adrian_otto> sdake: Sorry that lasted so long, that's terrible! Are you well again?
16:23:44 <sdake> yup rockin now
16:23:45 <sdake> thanks
16:23:51 <adrian_otto> oh, good!
16:23:52 <juggler> o/ sdake...glad you're feeling better
16:24:10 <sdake> generaitng energy to prepare for usmmit :)
16:24:15 <Tango> Hi sdake, got well just in time for Tokyo!
16:24:19 <sdake> yar
16:24:28 <adrian_otto> Tango (and team): on the subject of the test, should we hold the release for that, or should we split that into a tech debt bug, and proceed without it?
16:24:35 <Tango> The functional test is simple: create a pod and service for nginx, then query the LB VIP for the nginx welcome message.
16:24:55 <Tango> but it's kind of stuck because of the manual step to set up the password
16:25:00 <sdake> we odn't have functional test requirements for any other feature
16:25:03 <hongbin> I think we can release without the test
16:25:13 <sdake> i think we can raise the bar, but seems a bit unfair to do it right prior to releae
16:25:26 <sdake> like raise th bar "going forward"
16:25:30 <adrian_otto> ok, Tango, please open a tech-debt bug ticket against the func test
16:25:35 <Tango> ok, will do
16:25:42 <adrian_otto> and we can revisit that in a subsequent effort.
16:25:51 * sdake claps for tango :)
16:25:54 <adrian_otto> We will discuss functional testing strategy and requirements in Tokyo
16:26:01 <sdake> most painful blueprint ever ;)
16:26:05 <sdake> agree
16:26:09 <Tango> :)
16:26:25 <adrian_otto> sdake: I am 100% on board with raising our bar for review acceptance following a burts of func test enrichment.
16:26:43 <sdake> ya i just htink doing right now isn't all that helpful :)
16:26:43 <adrian_otto> but that's something we'll discuss together
16:26:48 <adrian_otto> agreed
16:26:57 <hongbin> +1
16:27:02 <Tango> +1
16:27:04 <adrian_otto> and the last BP in our nag list, is complete:
16:27:08 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-docker Secure client/server communication using TLS (apmelton)
16:27:19 <apmelton> complete and working with the atomic-3 image
16:27:30 <adrian_otto> WHOOT
16:27:31 <sdake> what about aotmic-5?
16:27:44 <juggler> excellent
16:27:47 <sdake> apmelton ^^
16:27:49 <apmelton> sdake: it seems like there's an issue with the docker daemon in our atomic-5 image
16:27:50 <Tango> sdake: some issues with docker run
16:27:56 <sdake> got it
16:28:02 <adrian_otto> so we do have an open issue with fedora-atomic-5
16:28:11 <apmelton> it crashes when ever I try to create containers...
16:28:18 <adrian_otto> and this might be a good time to point some fresh eyes at that one
16:28:19 <daneyon_> ouch
16:28:22 <sdake> fantastic
16:28:24 <apmelton> but only through docker cli itself, for some reason k8s can boot containers just fine
16:28:39 <apmelton> I also pulled down the docker package from fedora packages and it fails as well
16:28:44 <apmelton> so... I think we have a bad build
16:28:51 <Tango> We upgrade from docker 1.5 to 1.7.1, there seems to be some issues we haven't figured out yet
16:29:11 <adrian_otto> would 1.8 work?
16:29:23 <Tango> We can try building with that
16:29:44 <daneyon_> Is their a bug open on this image issue?
16:29:46 <sdake> could try with the docker daemon from docker inc as well
16:29:55 <Tango> I took a look last week and confirmed the problem, but got tied up with other things.
16:30:01 <daneyon_> Does it need to be resolved for release?
16:30:02 <adrian_otto> daneyon_: good question
16:30:08 <adrian_otto> this is a showstopper
16:30:23 <adrian_otto> so we should make sure we have a critical bug open for it
16:30:35 <adrian_otto> we can't have known crash conditions in our releases
16:30:46 <adrian_otto> apmelton: shoudl I make one now?
16:31:26 <daneyon_> Let's make sure the workaround of the atomic-3 release is highlighted in the bug.
16:32:00 <apmelton> adrian_otto: I can handle it
16:32:08 <daneyon_> Maybe this is a good reason to discuss an image mgt strategy at the design summit.
16:32:18 <daneyon_> How long will we continue to support atomic-3, etc..
16:32:22 <adrian_otto> thanks apmelton. Please paste the bug link into this channel when ready for collab on this.
16:32:35 <adrian_otto> daneyon_: agreed
16:32:54 <adrian_otto> sdake: do you happen to have our summit discussion topic etherpad link around anywhere?
16:33:01 <adrian_otto> I have lost track of it (sorry!)
16:33:08 <sdake> yes give me a moment to find it
16:33:10 <daneyon_> apmelton Can you add the bug here too: https://etherpad.openstack.org/p/magnum-liberty-release-todo
16:33:11 <adrian_otto> tx!
16:33:45 <sdake> #Link magnum
16:33:47 <manjeets_> when is liberty release for magnum ?
16:34:01 <sdake> #link https://etherpad.openstack.org/p/magnum-tokyo-summit-sessions
16:34:10 <apmelton> actually there's https://bugs.launchpad.net/magnum/+bug/1499219
16:34:10 <openstack> Launchpad bug 1499219 in Magnum "Failed to start docker daemon on atomic-5 image" [Undecided,Fix committed] - Assigned to Eli Qiao (taget-9)
16:34:34 <apmelton> let me see if my devstack had that patch
16:35:12 <apmelton> yes it did, so I think there's still an issue
16:35:31 <sdake> adrian_otto what i did to solve the too many sessions problem is have people rank from 1-15 what they wanted to see
16:35:36 <sdake> and take an avergae of the voting
16:35:41 <sdake> (did this for kolla)
16:36:02 <adrian_otto> sdake: tx!
16:36:06 <sdake> did over 2 sessions to get everyone that may not be able to make one or the other
16:36:20 <daneyon_> apmelton looks like the fix was implemented in swarm but not k8s
16:36:47 <apmelton> daneyon_: which fix?
16:36:57 <daneyon_> apmelton: https://review.openstack.org/#/c/227210/
16:37:22 <hongbin> daneyon_: k8s already has it I believe
16:37:25 <apmelton> ah gotcha
16:37:36 <adrian_otto> ok, item 11 on https://etherpad.openstack.org/p/magnum-tokyo-summit-sessions covers the functional Testing topic
16:40:32 <adrian_otto> ok, looks like that's well in hand for now
16:40:38 <adrian_otto> #topic Open Discussion
16:41:03 <daneyon_> adrian_otto do u know when we will finalize the design summit schedule?
16:41:41 <daneyon_> gsagie from the Kuryr team was looking for some details so he can coordinate on his side to address the Kuryr/Magnum integration topic
16:41:44 <adrian_otto> daneyon: that's something we should see if we can close out this week
16:42:34 <daneyon_> adrian_otto OK. Do you want to take an action on that or should someone else?
16:42:38 <adrian_otto> #adrian_otto to check into finalizing our summit discussion topic schedule, and release it for addition to the main schedule
16:42:48 <daneyon_> thx
16:42:53 <bradjones___> On the UI front, should have the create forms out in the next few days then the spec will be complete apart from some functional test which hopefully will get to next week
16:42:59 <adrian_otto> #action irc://chat.freenode.net:6667/#adrian_otto to check into finalizing our summit discussion topic schedule, and release it for addition to the main schedule
16:43:19 <vilobhmm11> adrian_otto : IMHO there are few topics which plan to address same problem. I think it would be nice to combine them and have a single session for them…that way we can have lots to discusss
16:43:33 <daneyon_> Awesome news bradjones___
16:44:33 <sdake> daneyon_ the design summit session schedule has to be put in cheddar in 1 week or so
16:44:51 <sdake> which means the community needs to have the full schedule asap :)
16:45:06 <sdake> cheddar = the tool for managing the session schedule for ptls
16:45:20 <juggler> thank you. i was getting hungry..
16:45:50 <daneyon_> sdake thanks for the add'l info. adrian_otto sounds like we need to finalize things soon. Ping me on irc if you need a hand with the action item.
16:47:01 <apmelton> adrian_otto: here's the bug for the atomic-5 docker issue: https://bugs.launchpad.net/magnum/+bug/1503366
16:47:01 <openstack> Launchpad bug 1503366 in Magnum "Docker daemon crashing with atomic-5 image" [Undecided,New]
16:47:53 <Tango> apmelton: So it seems to be the source from koji?
16:47:54 <sdake> wow they built and released an rpm and it doen't even work?
16:48:01 <sdake> what a bunch of fail
16:48:10 <sdake> they have a 2 ack process for rpms!
16:48:22 <sdake> tango try using 1.8.1 rpm
16:48:30 <Tango> Yeah, will do that
16:48:31 <sdake> or an older koji rpm
16:48:44 <daneyon_> apmelton did  u have problems with the atomic-6 image too?
16:48:55 <hongbin> sdake: Tango: I wonder why not using the official RPM instead of the koji* one
16:48:56 <sdake> we shouldn't be crankingout new image sall the time btw
16:49:01 <sdake> only when there are major upgrades :)
16:49:06 <Tango> daneyon_: It's the same, only difference is the bug fix for kube-controller-manager
16:49:11 <sdake> hongbin the reason is we nee d the latest version of k8s
16:49:18 <apmelton> daneyon_: I hadn't tried atomic-6 myself, it doesn't seem like devstack uses it yet
16:49:26 <daneyon_> Tango OK, good to know.
16:49:34 <apmelton> I seem to remember someone tried it though, was it you daneyon_?
16:49:48 <sdake> without the latest version of k8s, all of magnum is non-operational with fedora atomic
16:50:01 <hongbin> I see
16:50:20 <sdake> because of our python api is implemented to 1.z
16:50:23 <sdake> (of k8s0
16:50:31 <sdake> not 3beat3
16:50:34 <sdake> or whatever the version was we were using in atomic-3
16:50:43 <sdake> and the same version in the official images
16:50:50 <sdake> note after fedora 24 w ewont have to maintain images anymore
16:50:56 <sdake> we should just beable to use whatever fedora releaes
16:51:02 <sdake> since the api should theoretically be stable
16:51:23 <daneyon_> I'm going to add scaling to the tokyo ep. Check this out
16:51:24 <daneyon_> #link http://blog.kubernetes.io/2015/09/kubernetes-performance-measurements-and.html
16:51:49 <daneyon_> I think we eventually need to perform similar scaling tests for Magnum.
16:52:31 <Tango> +1
16:52:37 <vilobhmm11> daneyon_ : +1
16:52:43 <Tango> very important for cloud provider
16:54:22 <daneyon_> It would be great if we could pull it off.
16:55:01 <daneyon_> fyi we had quite a bit of discussion around HA/scale during last week's networking subteam meeting
16:55:04 <daneyon_> #link http://eavesdrop.openstack.org/meetings/container_networking/2015/container_networking.2015-10-01-18.00.html
16:55:16 <Tango> It would require very large environment to test, so I guess it would be some kind of benchmark with instructions
16:55:54 <adrian_otto> what comes with measuring and publishing performance metrics is a commitment to understand them, and enter a loop of continuous improvement for addressing where there are weak areas
16:56:13 <daneyon_> I think it's important that all bay types offer a reasonable level of HA/scale to meet our goal of production ready Magnum.
16:56:21 <adrian_otto> so I'd discourage testing that's not accompanied with a willingness to address those soft spots
16:56:59 <daneyon_> adrian_otto agreed
16:57:33 <adrian_otto> ideally I'd like to see publications that are before/after comparisons
16:57:33 <daneyon_> adrian_otto have you heard anything from GOOG about their announcement to participate in OS/Magnum?
16:58:08 <adrian_otto> daneyon_: I have followed up a few times, but they have been pretty quiet so far
16:58:31 <daneyon_> bummer
16:58:44 <adrian_otto> probably drowning in prioritization of an unlimited backlog of opportunity
16:58:50 <sdake> adrian_otto agree getting into scale tesitng is a commitment and i dont think we want to do that yet :)
16:59:11 <adrian_otto> sdake: yes, there are some more fundamental things that we should focus on first
16:59:35 <sdake> if someone wants to do it more power to em
16:59:42 <adrian_otto> I'd love to have a super responsive defect/fix cycle to accompany initial adoption
16:59:45 <sdake> but i think as a project we have higher prioriteis
16:59:50 <daneyon_> adrian_otto 1 min left
16:59:59 <juggler> if that :)
16:59:59 <adrian_otto> tx daneyon_
17:00:02 <adrian_otto> let's wrap.
17:00:09 <daneyon_> thx!
17:00:15 <apmelton> o/
17:00:26 <juggler> thanks all!
17:00:30 <VikasC> thanx all
17:00:37 <adrian_otto> Our next meeting is Tuesday 2015-10-13 at 1600 UTC. See you all then!
17:00:40 <adrian_otto> #endmeeting