16:03:59 <adrian_otto> #startmeeting containers
16:04:00 <openstack> Meeting started Tue Nov 24 16:03:59 2015 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:04 <openstack> The meeting name has been set to 'containers'
16:04:07 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-11-24_1600_UTC Our Agenda
16:04:13 <adrian_otto> #topic Roll Call
16:04:15 <adrian_otto> Adrian Otto
16:04:16 <daneyon_> o/
16:04:18 <vilobhmm1> o/
16:04:18 <dimtruck> o/
16:04:20 <rpothier> o/
16:04:21 <muralia1> o/
16:04:22 <Kennan> o/
16:04:22 <yolanda> o/
16:04:27 <hongbin> o/
16:04:28 <Tango> o/
16:04:34 <jimmyxian> o/
16:04:34 <houming> o/
16:04:37 <eghobo> o/
16:05:19 <adrian_otto> hello daneyon_ vilobhmm1 dimtruck rpothier muralia1 Kennan yolanda hongbin Tango jimmyxian houming and eghobo
16:05:25 <rlrossit> o/
16:05:30 <adrian_otto> #topic Announcements
16:05:52 <adrian_otto> first of all, I wanted to extend special thanks to hongbin for chairing our meeting last week.
16:06:01 <Guest72939> o/
16:06:03 <hongbin> np
16:06:05 <daneyon_> you da man hongbin
16:06:30 <adrian_otto> second, if you have any open bugs chances are you noticed a bunch of activity yesterday and last night
16:06:43 <adrian_otto> 1) Bug cleanup underway
16:06:59 <Drago> o/
16:07:01 <adrian_otto> Most open bugs were targeted to a release
16:07:17 <adrian_otto> I'm planning to go through the Wishlist ones and see which ones should actually be un-targeted.
16:07:25 <adrian_otto> we closed over 350 bugs
16:07:53 <adrian_otto> 2) magnum and python-magnumclient 1.1.0 released (but not announced)
16:08:05 <yolanda> great
16:08:12 <suro-patz> o/
16:08:35 <adrian_otto> I need to take a moment to look in pypi to see if the client showed up there
16:09:19 <juggler> o/
16:09:28 <adrian_otto> #link https://pypi.python.org/pypi/python-magnumclient/1.1.0 Our New Client
16:10:13 <adrian_otto> 3) As daneyon_ mentioned on our ML, there will be no network subteam meeting this week due to a US holiday on Thursday (Thanksgiving)
16:10:22 <adrian_otto> any other announcements from team members?
16:11:13 <adrian_otto> if you notice problems with the tagged release, just let me know and I can tag another.
16:11:27 <adrian_otto> then when we think that code is solid, we can announce it
16:12:09 <adrian_otto> #topic Container Networking Subteam Update
16:12:12 <adrian_otto> #link http://eavesdrop.openstack.org/meetings/container_networking/2015 Previous Meetings
16:12:22 <adrian_otto> daneyon_: any remarks?
16:12:41 <daneyon_> The big news here is that the Magnum CNM has been implemented for swarm bay types using the flannel network-driver
16:12:48 <adrian_otto> whoot!!
16:13:03 <juggler> :)
16:13:20 <hongbin> awesome!
16:13:29 <jimmyxian> Cool!
16:13:40 <daneyon_> The team has also decided not to implement the CNM using flannel for Mesos. This is b/c Mesos does not support etcd, which is required for flannel.
16:14:11 <daneyon_> we had a lot of good discussion around containerizing flannel
16:14:31 <daneyon_> this would be applicable to all services running on nodes
16:14:50 <daneyon_> wanghua is working on this effort
16:15:00 <daneyon_> #link https://blueprints.launchpad.net/magnum/+spec/run-kube-as-container
16:15:41 <daneyon_> and Tango is working on option #3 of this patch to add flannel's host-gw mode
16:15:46 <daneyon_> #link https://review.openstack.org/#/c/241866/
16:16:06 <Tango> option #2 ?
16:16:35 <daneyon_> the host-gw mode aligns nicely with our networking model (shared L3 for nodes) and should provide a non-overlay solution.... improving networking performance.
16:17:13 <daneyon_> Tango option #2 of https://review.openstack.org/#/c/241866/
16:17:49 <daneyon_> Please let me know if I misunderstood our discussion from last week.
16:17:58 <Kennan> what's option #2 means ?
16:18:08 <Kennan> replace with host-gw ?
16:18:18 <daneyon_> As adrian_otto mentioned, not meeting this week due to Thanksgiving.
16:18:32 <adrian_otto> daneyon_: what happened with "hongbin follows up with Daneyon for the submeeting discussion"?
16:18:41 <Tango> Kennan: It means the user can specify different backend options: udp, vxlan, host-gw
16:18:46 <adrian_otto> are we continuing the subteam meetings, or merging back in here?
16:19:15 <daneyon_> adrian_otto thanks for the reminder
16:19:32 <Kennan> Tango: is it tried with CNM labels >
16:19:33 <Kennan> ?
16:19:48 <daneyon_> We did have a brief discussion on whether to continue the sub team meetings now that the Magnum CNM is well underway.
16:19:54 <Tango> Kennan: Yes it will be done with labels
16:20:02 <daneyon_> I am indifferent to either direction.
16:20:14 <Tango> I am ok either way
16:20:16 <tcammann> hello, sorry I'm late
16:20:18 <Kennan> ok Tango: will check your patch when reday
16:20:18 <adrian_otto> ok, so unless anyone feels differently, let's not change anything
16:20:20 <daneyon_> What would the rest of the team like to do? Keep the meetings going or stop them?
16:20:43 <adrian_otto> daneyon_: as long as Stackers are showing up, we can keep them going
16:20:53 <adrian_otto> if attendance trails off, that will be our signal to stop
16:21:06 <daneyon_> adrian_otto I think that's a good approach.
16:21:16 <daneyon_> +1 on that
16:21:30 <Tango> So far we still have good discussion
16:21:35 <daneyon_> adrian_otto I think that's it.
16:21:40 <daneyon_> agreed Tango
16:21:45 <adrian_otto> thanks daneyon_
16:21:45 <adrian_otto> #topic Review Action Items
16:21:50 <adrian_otto> 1) hongbin follow up with Adrian Otto for the release of python-mangumclient
16:21:50 <adrian_otto> Status: COMPLETE (Thanks hongbin and adrian_otto!)
16:21:58 <adrian_otto> 2) hongbin follows up with Daneyon for the submeeting discussion
16:21:58 <adrian_otto> Status: COMPLETE (Meetings will continue)
16:22:04 <adrian_otto> 3) hongbin starts a ML to discuss the renamed file issue
16:22:08 <adrian_otto> did I miss this one?
16:22:14 <hongbin> Done
16:22:21 <daneyon_> and I really appreciate everyone's involvement. I think we have come a long way in the last few months.
16:22:27 <hongbin> I sent a ML. The team gave feedback
16:22:31 <adrian_otto> can we get a #link to it for posterity's sake?
16:22:41 <tcammann> You replied adrian_otto!
16:22:50 <adrian_otto> daneyon_: thanks for your continued leadership.
16:22:58 <daneyon_> :-)
16:23:04 <adrian_otto> tcammann: goes to show my memory is leaky
16:23:14 <hongbin> finding the link
16:23:38 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079796.html
16:23:43 <juggler> adrian_otto happens to us too
16:23:50 <juggler> !
16:24:28 <adrian_otto> Status: COMPLETE (Thanks again hongbin! <3)
16:24:46 <adrian_otto> #topic Blueprint/Bug Review
16:24:58 <adrian_otto> now, although I made like a thousands changes in the bug tracker
16:25:06 <adrian_otto> I have not finished with the blueprints yet
16:25:16 <adrian_otto> many of them have been approved, but not yet targeted to a release
16:25:26 <adrian_otto> we had an etherpad to list them
16:25:41 <adrian_otto> has anyone kept track of that link by chance (I can refer to notes otherwise)
16:26:12 <Kennan> #link https://etherpad.openstack.org/p/mitaka-magnum-planning
16:26:22 <adrian_otto> Kennan: thanks!!
16:26:23 <juggler> thx Kennan
16:26:40 <Kennan> :)
16:26:57 <adrian_otto> #action adrian_otto to review https://etherpad.openstack.org/p/mitaka-magnum-planning and use it to target Mitaka blueprints
16:27:32 <adrian_otto> in order to actually do the targeting, it would be helpful for all directionally approved blueprints to get T-shirt size level-of-effort estimates
16:27:56 <adrian_otto> this is not something based on story points, just a ballpark guess.
16:28:56 <adrian_otto> so for the high/critical importance ones (including networking CNM stuff, probably) I will hound you for team updates in this section of our team meetings
16:29:19 <adrian_otto> with that said, are there any work items (bugs, or bp's) that require team discussion today?
16:30:07 <houming> This one: #link https://review.openstack.org/#/c/246609/
16:30:58 <houming> should we validate baymodel’s attribute before bay-creation?
16:32:05 <adrian_otto> they might be changed after the baymodel is created
16:32:31 <Tango> I think houming means at the point of bay-create
16:32:38 <adrian_otto> so if I add a baymodel that refers to image-id 1234, and then I delete image 1234, then baymodel creates on that baymodel will fail
16:33:14 <adrian_otto> but bays actually rely on baymodels
16:33:19 <houming> Yes, at the point of bay-cration, before it sent request to heat, we check the existence of OpenStack resources.
16:33:44 <adrian_otto> a bay without a corresponding baymodel will not work either. That's where improvement is needed, to tie them together better.
16:33:54 <vilobhmm1> houming: have you cheked does nova boot verify the flavor parameters before booting an instance ?
16:34:11 <Tango> houming: We should validate those that are not validated by Heat
16:34:24 <Kennan> + 1 Tango
16:34:35 <hongbin> vilobhmm1: In thoery, heat stack-create will verify flavor before creating a stack
16:34:40 <houming> yes. Nova will fail immidately when the image/network is not existed.
16:34:56 <tcammann> Still would prefer that Magnum checks these
16:34:57 <adrian_otto> Tango: if we allow the heat stack create to fail, we might not have as nice of an exception to raise
16:35:11 <tcammann> Otherwise you will have to dig into the heat stack to find the issue
16:35:15 <Kennan> seems not need double check right now. if heat handle that and response informative
16:35:16 <vilobhmm1> houming : sure… we should also validate it..
16:35:19 <adrian_otto> whereas, if we do the checks, we could potentially have a very actionable exception
16:35:20 <houming> In K8S bay creation, flavor_id seems not be checked. I verfied it today.
16:35:32 <tcammann> adrian_otto: +1
16:36:08 <adrian_otto> thanks for looking at that houming
16:36:11 <tcammann> regardless if heat checks or not, we should verify it to warn the user directly.
16:36:20 <vilobhmm1> +1
16:36:36 <hongbin> My only concern is the performance impact of double validation
16:36:48 <hongbin> Each validation is an API call, which is not cheap
16:36:57 <Kennan> I did not think need all checks (only check what heat not good at )
16:37:00 <tcammann> Bay creation is a slow process
16:37:06 <tcammann> heat is slow!
16:37:07 <Tango> Right, f we send a bunch of API request for each attribute.
16:37:18 <adrian_otto> agreed, hongbin. We should reserve double checking for things that are likely to happen and have big impact.
16:37:36 <adrian_otto> if heat does a check, and raises a sensible exception we can parse, that's going to perform better
16:37:39 <houming> Yes, bay creation is slow and not a frequent operation.
16:37:44 <Tango> We should be able to query heat for failure cause
16:38:34 <Kennan> we need to support bay-creation in scale case, I rememeber it was about one bp
16:39:31 <tcammann> I still don't think the bottle neck will be on API calls
16:39:57 <adrian_otto> bay creation performance is probably not our top concern
16:40:08 <adrian_otto> but user experience is important
16:40:27 <Tango> Validation is very helpful, and giving user good error message is great. We just need to check what's the best approach.
16:40:31 <adrian_otto> so let's make the debugging required as painless as possible when interacting with magnum
16:41:05 <tcammann> If we hit scale/perf issues later, we can refactor
16:41:19 <hongbin> agreed
16:41:21 <vilobhmm1> we talking about the API call to glance to pull the image data right ? I agree with Tom it shouldn't be a bottleneck as such
16:41:22 <adrian_otto> and I'd like to make performance decisions based on experimental data rather than based on pure worry.
16:43:25 <houming> OK, I’ll calculate the cost time of validaton API calls.
16:43:39 <Kennan> sounds good houming:
16:43:41 <Tango> houming: +1
16:43:45 <vilobhmm1> +1
16:43:49 <adrian_otto> thanks houming. Any more on this item?
16:44:08 <houming> So, we have a agreement that we should do validation, in bay-cration before it send the request to heat. right?
16:44:14 <adrian_otto> any more work items to cover as a team prior to advancing our agenda?
16:44:27 <jimmyxian> agreed adrian_otto
16:44:29 <Kennan> I think so houming
16:44:40 <Tango> houming: Do you want to discuss soft error vs hard error?
16:44:56 <adrian_otto> houming: that's the direction, unless we can get the equivalent user experience by calling heat and parsing the error reason.
16:45:04 <vilobhmm1> houming : Yes!
16:45:36 <Kennan> Tango: do you mean validate baymodel case ?
16:45:46 <houming> Tango, my opoion is hard error in Bay-Cration.
16:45:51 <Kennan> seems bay-creation only hae hard error
16:45:58 <Kennan> s/hae/has
16:46:11 <houming> and do you mean also add soft error in Baymodel creation?
16:46:17 <adrian_otto> bradjones: yt?
16:46:21 <bradjones> here
16:46:31 <Tango> houming: yes
16:46:35 <adrian_otto> ok, let's get a subteam update… one moment while I switch the topic
16:47:02 <adrian_otto> #topic Magnum UI Subteam Update (bradjones)
16:47:23 <bradjones> Things are moving quickly in the UI world :)
16:47:39 <bradjones> there are patches out for detail views for containers/bays and bay models
16:47:56 <bradjones> which look really good so shout out to Shuu for the good work
16:48:16 <bradjones> Last week it was mentioned that we should have a road map for the UI work
16:48:32 <bradjones> I've started putting together a document just to collect some informal ideas
16:48:41 <bradjones> #link https://etherpad.openstack.org/p/magnum-ui-feature-list
16:49:03 <bradjones> if people could have a look and add there thoughts there it would be greatly appreciated
16:49:18 <bradjones> I'll start a mailing list thread as well linking that page
16:49:23 <bradjones> the more thoughts the better
16:49:48 <adrian_otto> thanks bradjones!
16:49:58 <Tango> bradjones: So we can add as wishlist and you will reoganize?
16:50:12 <bradjones> Tango: sure that works
16:50:20 <adrian_otto> #topic Open Discussion
16:50:21 <adrian_otto> #link https://review.openstack.org/#/c/247083/ Tempest plugin work (dimtruck)
16:50:42 <dimtruck> this is an initial effort to port our tempest tests to tempest plugin
16:50:55 <dimtruck> they're blocked on adding tempest to gates
16:50:55 <adrian_otto> #link https://review.openstack.org/#/c/248123/ Adding tempest to gate (dimtruck)
16:51:03 <dimtruck> which i did with that patch ^
16:51:23 <dimtruck> i also added it to openstack-infra's meeting agenda for later today to see if it can get some eyes
16:51:41 <yolanda> i can review
16:51:43 <dimtruck> once it lands, i can continue refactoring the tempest plugin.
16:51:45 <dimtruck> thanks yolanda!
16:51:54 <adrian_otto> thanks for driving that dimtruck. This is really important to get right.
16:52:05 <tcammann> yup, thanks dimtruck
16:52:16 <dimtruck> good news is that our tests do not need to be refactored at all. tempest will just pick them up!
16:52:17 <adrian_otto> that's everything in our agenda
16:52:26 <Kennan> good job dimtruck
16:52:30 <adrian_otto> dimtruck: very good news!!
16:52:41 <yolanda> i wanted to show a blueprint i created, to build fedora images using dib
16:52:47 <yolanda> i believe i put that on agenda...
16:53:12 <dimtruck> oh yolanda - it probably made it to previous week's (i remember seeing it on 11/17 when i was waiting to add mine)
16:53:28 <yolanda> #link https://blueprints.launchpad.net/magnum/+spec/fedora-atomic-image-build
16:53:43 <yolanda> dimtruck, yes, may be that
16:53:44 <juggler> thx dimtruck
16:54:11 <yolanda> so in order to add support for shade, that's one of our blocker
16:54:30 <yolanda> in last meeting, we suggested to explore image creation using disk image builder, so i create the initial blueprint
16:54:42 <tcammann> Is shade used in infra?
16:54:48 <daneyon_> the net subteam discussed creating a network-driver support matrix
16:54:59 <daneyon_> any suggestions where this matrix should live?
16:55:03 <yolanda> tcammann, yes, it's used
16:55:06 <yolanda> for ansible and for nodepool
16:55:23 <tcammann> ok I see, thanks yolanda
16:55:34 <adrian_otto> yolanda: directionally approved and targeted for mitaka
16:55:38 <tcammann> daneyon_: the wiki probably the best place
16:55:42 <yolanda> adrian_otto, thanks
16:55:51 <Tango> yolanda: +1
16:55:54 <daneyon_> tcammann will do
16:56:39 <yolanda> ok so i will start progress on it
16:57:01 <daneyon_> tcammann do you suggest under the resources section? https://wiki.openstack.org/wiki/Magnum#Resources
16:57:13 <adrian_otto> time check, we have just a few minutes remaining
16:57:15 <daneyon_> or in the main page?
16:57:28 <Kennan> daneyon_ seems in etherpad is better
16:57:34 <adrian_otto> let's wrap up, and plan to carry unfinished discussions to conclusion in #openstack-containers
16:58:16 <daneyon_> goodbye
16:58:51 <juggler> safe travels for those doing so!
16:59:19 <yolanda> bye
16:59:25 <adrian_otto> thanks everyone for attending today. Our next meeting will be Tuesday 2015-12-01 at 1600 UTC. See you then!
16:59:32 <adrian_otto> #endmeeting