16:00:47 <hongbin> #startmeeting containers
16:00:47 <openstack> Meeting started Tue Jan 12 16:00:47 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:51 <openstack> The meeting name has been set to 'containers'
16:00:56 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-01-12_1600_UTC
16:01:02 <hongbin> #topic Roll Call
16:01:07 <madhuri> o/
16:01:12 <Tango> o/
16:01:13 <houming> o/
16:01:14 <HimanshuGarg> o/
16:01:16 <hongbin> o/
16:01:19 <muralia> o/
16:01:25 <rpothier_> o/
16:01:28 <sew1> o/
16:01:28 <Kennan> o/
16:01:32 <levi_b> o/
16:01:39 <eghobo> o/
16:01:47 <rods> o/
16:02:00 <tcammann> hullo
16:02:19 <hongbin> Thanks for joining the meeting madhuri Tango houming HimanshuGarg muralia rpothier_ sew1 Kennan levi_b eghobo rods tcammann
16:02:45 <muralia> hi everyone. hi hongbin
16:02:53 <hongbin> hey
16:02:54 <vilobhmm11> o/
16:03:04 <hongbin> #topic Announcements
16:03:11 <dimtruck> o/
16:03:12 <hongbin> 1) adrian_otto is absent today, so hongbin is our pro-tem chair.
16:03:23 <thomasem-away> o/
16:03:31 <thomasem> o/
16:03:31 <hongbin> Any other announcement from our team member?
16:03:57 <hongbin> hi vilobhmm11 dimtruck thomasem
16:04:03 <vilobhmm11> hi hongbin
16:04:18 <hongbin> #topic Review Action Items
16:04:26 <hongbin> 1) adrian_otto to plan midcycle by ML (Completed)
16:04:33 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-January/083785.html
16:04:49 <hongbin> #topic Container Networking Subteam Update (daneyon)
16:05:08 <hongbin> It looks daneyon is not here
16:05:21 <hongbin> Here is the previous meeting:
16:05:27 <hongbin> #link http://eavesdrop.openstack.org/meetings/container_networking/2016
16:06:07 <hongbin> In the last networking meeting, we have a agreed
16:06:07 <tcammann> I think he was planning to fold the subteam back into the Magnum team
16:06:19 <hongbin> tcammann yes
16:06:35 <hongbin> AGREED: Move the subteam meeting back to the general magnum meeting
16:06:55 <hongbin> Any concern about that?
16:07:34 <juggler> o/
16:07:34 <hongbin> OK. Let's move on
16:07:39 <suro-patz> o/
16:07:45 <hongbin> #topic Magnum UI Subteam Update (bradjones)
16:07:53 <hongbin> Brad has a conflict and won’t be able to attend today.
16:08:21 <hongbin> #topic Essential Blueprint Updates
16:08:34 <hongbin> 1) Magnum APIs Test coverage in Tempest Lib (dimtruck)
16:08:41 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-tempest
16:08:46 <dimtruck> looks like magnum apis tests landed
16:08:56 <dimtruck> i'm worried about swarm a little there
16:09:11 <hongbin> dimtruck: yes. Thanks for the great work!
16:09:14 <dimtruck> so i'll be spending this week in figuring out why it sometimes flakes out.
16:09:24 <dimtruck> not sure if anyeone else had any headway
16:09:46 <hongbin> dimtruck: I looked at your tests. It looks some testing hosts don't have enough disk space
16:10:02 <dimtruck> hmmm
16:10:04 <hongbin> dimtruck: Therefore, the nova scheduler weren't able to schedule a host. The bay failed
16:10:21 <dimtruck> maybe a pre-validation of disk space would be worth it prior to running tests and skipping them otherwise
16:10:25 <dimtruck> i'll take a look - thanks hongbin
16:10:48 <hongbin> Thanks dimtruck
16:10:57 <hongbin> Any question for this blueprint?
16:11:04 <Kennan> make sure not use much disk space in one host. or else you need complated external volume
16:11:47 <dimtruck> right...i'll have some follow up questions after the meeting Kennan :)
16:11:50 <juggler> completed or complicated?
16:11:55 <Tango> dimtruck: Any documentation on the tempest tests?
16:12:10 <dimtruck> Tango: there's a bit that i added with the previous patch
16:12:15 <dimtruck> but i should definitely expand on that
16:12:15 <juggler> Kennan: completed or complicated?
16:12:26 <Kennan> complicated juggler
16:12:31 <juggler> ah
16:12:41 <Tango> dimtruck: maybe add in the BP
16:13:03 <dimtruck> will do!
16:13:30 <hongbin> Thanks dimtruck
16:13:38 <hongbin> Next one
16:13:41 <hongbin> 2) Magnum Troubleshooting Guide (Tango)
16:13:47 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-troubleshooting-guide
16:14:27 <hongbin> Tango: I think you have uploaded a patch for this?
16:14:31 <vilobhmm11> https://review.openstack.org/#/c/263940/
16:14:37 <vilobhmm11> looks like this got merged
16:14:40 <Tango> We got the initial skeleton, now I am filling in the sections.  Any help is welcome, especially if you know how to debug certain aspect
16:14:55 <Tango> I should add a section on gate debugging
16:15:15 <hongbin> Tango: Yes, that is good to add
16:15:31 <Tango> I will start with networking, since that's what I am doing now and it's fresh in my mind
16:16:12 <dimtruck> Tango: if this helps, i have some notes here for debugging magnum gates:
16:16:18 <dimtruck> #link https://etherpad.openstack.org/p/magnum_devstack_gate
16:16:34 <Kennan> yes, it is good for cowork on this guide. just make sure not duplicate when claim one section :)
16:16:46 <Tango> dimtruck: That's great.  would you like to fill in this section?
16:16:53 <dimtruck> Tango: definitely
16:17:19 <Tango> I will put in TODO list in the BP, so everyone can claim a section
16:17:37 <Kennan> that's good way
16:17:57 <vilobhmm11> +1
16:18:12 <hongbin> Thanks Tango
16:18:20 <hongbin> Next one
16:18:24 <hongbin> 3) Magnum User Guide for Cloud Operator (Tango)
16:18:30 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:18:51 <Tango> Similarly, we got the skeleton, we can follow the same approach
16:19:23 <hongbin> #link https://review.openstack.org/#/c/263599/
16:20:11 <hongbin> Thanks Tango . For others, please feel free to contribute to some sessions if you like to
16:20:26 <hongbin> 4) resource quota (vilobhmm)
16:20:36 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/resource-quota
16:20:51 <vilobhmm11> the patch is out for reviewhttps://review.openstack.org/#/c/259201/
16:21:10 <hongbin> #link https://review.openstack.org/#/c/259201/
16:21:13 <vilobhmm11> as we have a plan to discuss whether this needs a spec or not will be covered today
16:21:41 <vilobhmm11> this https://review.openstack.org/#/c/259201/ is a base patch on the basis of which few more patches will be submitted
16:21:52 <vilobhmm11> dependign on exclusive magnum resources
16:21:56 <vilobhmm11> like baymodel etc
16:22:12 <vilobhmm11> thats it from my end hongbin
16:22:50 <hongbin> Thanks vilobhmm11 .
16:23:06 <hongbin> I saw Jay Lau requested a spec for this blueprint
16:23:11 <vilobhmm11> hongbin : i personally think we don;t need a spec here
16:23:21 <hongbin> vilobhmm11: ack
16:23:35 <hongbin> Do anything else want a spec?
16:23:42 <hongbin> s/anything/anyone/
16:23:44 <Tango> We did have a long discusson on the ML
16:23:56 <Kennan> I pesonal thinking spec is good to make thoughtful design
16:24:11 <vilobhmm11> if we had a close intergration with  heat or needed to check integraition with other projects it makes a worthwhile attempt to do a cross project spec but we don't need a spec partitularly for this blueprint resource-quota
16:24:44 <Tango> We should at least gather the key points from the ML discussion in the BP so there is a record
16:25:03 <Kennan> what's your resource quota related implementaion methods like TLS related
16:25:11 <Kennan> I think spec like that make sense
16:25:23 <Tango> Or put that in the spec to be even more formal.  The spec doesn't have to be long
16:25:25 <Kennan> as quota also a important feature
16:25:56 <vilobhmm11> sure…if the key points need to go somewhere then they should be in the spec
16:26:13 <vilobhmm11> but if everyone agrees for a spec I can draft one and submit for review
16:26:19 <vilobhmm11> today
16:26:29 <Tango> I would support that
16:26:35 <Kennan> I did not think spec take much effort, it only take efforts for thinking
16:27:05 <Kennan> +1 spec
16:27:18 <vilobhmm11> Kennan : its already thought of :) so we should be quick to proceed ahead…other points that I might have missed can be covered in the review
16:27:22 <madhuri> +1 for spec
16:27:26 <Tango> It also helps with communication, so later people won't repeat the same questions
16:27:42 <vilobhmm11> hongbin : ^^
16:27:50 <hongbin> OK. Looks everyone is happy.
16:27:54 <vilobhmm11> Alrite then will submit a patch for spec then
16:28:13 <vilobhmm11> and then we can proceed with the patches
16:28:14 <hongbin> vilobhmm11: Thanks for your willingness for the work
16:28:42 <hongbin> #agree vilobhmm11 will work on a spec for resource quota
16:28:44 <Kennan> vilobhmm11: others can help submit your spec changes if they have more valueable inputs
16:29:15 <vilobhmm11> hongbin : np Kennan : for sure…ideas are welcome
16:29:38 <juggler> +1 spec , and thanks vilob for contributing to the draft :)
16:29:57 <hongbin> Any other input for this blueprint?
16:29:58 <vilobhmm11> np
16:30:24 <hongbin> OK. Next one
16:30:28 <hongbin> 5) Add functional testing for mesos cluster (eliqiao)
16:30:34 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/mesos-functional-testing
16:30:50 <hongbin> eliqiao: there?
16:31:31 <hongbin> I saw the test is already there. Looks like this BP is completed
16:32:02 <hongbin> Will confirm it with eliqiao later
16:32:46 <hongbin> #action hongbin confirm the latest status of meos-functional-testing with eliqiao
16:32:58 <hongbin> Next one
16:33:02 <hongbin> 6) splite gate-functional-dsvm-magnum per cluster coe (eliqiao)
16:33:22 <hongbin> Looks like this one was done as well
16:33:58 <hongbin> #action hongbin confirm the latest status of gate-functional-dsvm-magnum with eliqiao
16:34:21 <hongbin> We finished the essential blueprints
16:34:35 <hongbin> Any further question before advancing topic?
16:35:07 <vilobhmm11> hongbin : whats the timeline for finishing the feature ?
16:35:43 <vilobhmm11> for magnum do we have cut-off dates to make a feature for mitaka
16:35:45 <hongbin> vilobhmm11: I guess it is by the mitaka release date
16:36:31 <vilobhmm11> hongbin : ok http://docs.openstack.org/releases/schedules/mitaka.html
16:37:05 <vilobhmm11> asked because few projects have there own schedule as well…wanted to be sure just in case
16:37:25 <hongbin> vilobhmm11: I think Magnum is flexible about the schedule
16:37:42 <Tango> right, we have been picking our own release date
16:37:43 <hongbin> vilobhmm11: It can be postpone if important features are not landed
16:37:57 <vilobhmm11> hongbin : ok
16:38:26 <vilobhmm11> Tango : agree
16:38:49 <hongbin> OK. Next topic
16:38:53 <hongbin> #topic Midcycle
16:38:59 <hongbin> #link http://doodle.com/poll/k8iidtamnkwqe3hd Find a date for the Magnum Midcycle
16:39:20 <hongbin> If you are able to attend the midcycle, please vote a date
16:39:35 <Kennan> hongbin do we have recording for that ?
16:39:50 <hongbin> Recording for the midcycle?
16:40:03 <Kennan> yes, seems china guys not able to join that
16:40:19 <hongbin> Generally, someone will write down the meeting logs.
16:40:43 <hongbin> which is a summary of the key points
16:40:50 <Kennan> any etherpad discussion topics on that day?
16:40:57 <Tango> We have been having the live web meeting as well
16:40:57 <Kennan> or IRC channel
16:41:11 <hongbin> Kennan: No, we haven't decided the topics
16:41:14 <madhuri> Webex will be there?
16:41:31 <Kennan> Tango: is it possible to have live web meeting ?
16:41:43 <Kennan> not heard that in maillist
16:41:53 <Tango> madhuri: normally we have the webex session with audio
16:42:15 <Tango> although it can be hard to follow
16:42:41 <Kennan> OK. hope to have more updates what's the final related, like etherpad, topics, IRC possible, web meeting
16:42:42 <Tango> Do we have a location yet?
16:43:19 <hongbin> Tango: I think it is on bay area
16:43:31 <hongbin> Tango: The HP office
16:43:39 <hongbin> tcammann_: Do you have more details?
16:43:50 <tcammann> If we have a date I can ask :)
16:43:58 <tcammann> No approval yet
16:44:30 <hongbin> We can have an AI for the PTL to pick a date?
16:45:00 <juggler> sounds good hongbin
16:45:11 <Tango> tcammann: is it poosible to get a pre-approval based on the potential date?  looks like 2/17-19 has the most vote.
16:45:27 <hongbin> #action Adrian Otto pick a date for midcycle based on the feedback from http://doodle.com/poll/k8iidtamnkwqe3hd
16:46:34 <hongbin> Any other midcycle related discussion?
16:47:11 <hongbin> #topic Open Discussion
16:47:36 <hongbin> 1) Jay Lau requested a spec for Resource Quota.
16:47:36 <tcammann> Tango: I'll put an ask in tomorrow, see what I can do
16:48:04 <hongbin> We already disucssed the resource quota
16:48:11 <Tango> Thanks tcammann
16:48:58 <hongbin> Do anyone have anything to discuss. Now is the time
16:50:09 <mvelten> hi there
16:50:18 <hongbin> hi mvelten
16:50:22 <juggler> hey mvelten
16:50:40 <mvelten> is there anyone working on this one ? https://blueprints.launchpad.net/magnum/+spec/support-for-different-docker-storage-driver
16:50:48 <juggler> welcome mvelten
16:50:55 <mvelten> we are willing to if not
16:51:12 <hongbin> mvelten: We have discussed that before
16:51:48 <hongbin> mvelten: I recalled we don't have agreement on this feature
16:52:01 <mvelten> you mean in a previous meeting ? will have a look at the archives
16:52:18 <hongbin> mvelten: Because we are not sure if this is needed by our users
16:52:46 <hongbin> mvelten: Yes, but in previous previous .. meeting.
16:53:18 <hongbin> mvelten: So, basically, if some of our users asked for this feature, we will revisit it
16:53:47 <hongbin> mvelten: If you want to work on an item, I can help you after the meeting
16:54:24 <houming> As you know, we have GreatFireWall in China, how to smoothly use Magnum services without proxy? Because proxy speed is also very slow and not stable sometimes.
16:54:28 <mvelten> great :)
16:55:52 <hongbin> houming: Here is the document for the proxy
16:55:55 <hongbin> #link http://docs.openstack.org/developer/magnum/magnum-proxy.html
16:56:12 <hongbin> houming: Do you read it before?
16:56:19 <houming> yes.
16:56:46 <hongbin> houming: It doesn't solve what you need?
16:57:35 <houming> I tried. but with proxy, the Swarm cluster can be successfully created, but the agent are not show in docker ps.
16:57:54 <houming> s/ps/info/
16:58:07 <hongbin> houming: I see. Sounds like a bug in the proxy implementation?
16:58:37 <Kennan> no hongbin: I think it is related network slow issue (it depends on your proxy)
16:58:41 <houming> yes, maybe. the log says etcd is not configed suceessfully.
16:59:06 <hongbin> houming Kennan : ack.
16:59:13 <houming> log info inside Fedora Atom is not enough to debug.
16:59:26 <Tango> Restart etcd?
16:59:30 <hongbin> I think it will be great if you can log the issues as a ticket
16:59:41 <houming> Tango. restart not work:(
16:59:56 <Kennan> houming try like k8s or mesos what we did, it should work
17:00:07 <houming> OK, I’ll try to reproduce and open a bug.
17:00:08 <Kennan> for swarm, it shuold als work
17:00:10 <juggler> room wrap time
17:00:14 <hongbin> OK. Time is up
17:00:21 <vilobhmm11> houming : please file a ticket with logs as hongbin mentioned we can have a deeper look.
17:00:35 <houming> vilobhmm11 OK.
17:00:41 <hongbin> Overflow on the openstack-containers channel
17:00:49 <hongbin> #endmeeting