16:01:43 <adrian_otto> #startmeeting containers
16:01:44 <openstack> Meeting started Tue Feb  2 16:01:43 2016 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:48 <openstack> The meeting name has been set to 'containers'
16:02:29 <thomasem> o/ Hello!
16:02:33 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-02-02_1600_UTC Our Agenda
16:02:37 <adrian_otto> #topic Roll Call
16:02:39 <adrian_otto> Adrian Otto
16:02:41 <thomasem> Thomas Maddox
16:02:46 <hongbin> o/
16:02:46 <muralia> murali allada
16:02:46 <madhuri> o/
16:02:47 <HimanshuGarg> o/
16:02:49 <rods> o/
16:02:51 <rpothier> o/
16:02:53 <levi_b> o/
16:03:16 <eghobo> o/
16:03:27 <coreyob> o/
16:04:02 <adrian_otto> hello thomasem hongbin muralia madhuri HimanshuGarg rods rpothier levi_b eghobo and coreyob
16:04:25 <muralia> hello everyone
16:04:32 <suro-patz> o/
16:04:35 <bradjones> o/
16:04:52 <dimtruck> o/
16:04:55 <localloop127> o/
16:05:22 <adrian_otto> hello suro-patz bradjones dimtruck localloop127
16:05:41 <dane> o/
16:07:31 <adrian_otto> hello dane. Let's begin.
16:07:36 <adrian_otto> #topic Announcements
16:08:12 <adrian_otto> 1) Welcome Ton Ngo and Egor Guz as our new core reviewers.
16:08:40 <thomasem> Congratulations!
16:08:45 <adrian_otto> thanks to both of you for your considerable contributions to Magnum. We are proud to have you.
16:08:55 <madhuri> Congratulations
16:09:07 <eghobo> thx
16:09:12 <adrian_otto> I will plan to revisit the addition of new members on the first day of each month going forward
16:09:34 <adrian_otto> 2) Review queue swept. Inactive reviews have been set to abandoned state, meaning that they are not actionable by reviewers. If you have submitted reviews that were not merged, and you have not updated, recently, please look for them in abandoned state, and revive them:
16:09:42 <adrian_otto> #link https://review.openstack.org/#/q/status:abandoned+project:openstack/magnum Abandoned Reviews
16:09:57 <thomasem> Yeah, I think I saw one Andrew had worked on go inactive.
16:10:01 <thomasem> in my inbox
16:10:01 <adrian_otto> please keep in mind that an abandon action by the PTL is not the same as a -2 vote
16:10:18 <adrian_otto> it simply means that I recognize the review is not actionable because it is stale
16:10:31 <adrian_otto> so please scoop those up and bring them back to life
16:10:51 <adrian_otto> questions or concerns on these?
16:11:49 <adrian_otto> ok, next
16:11:54 <adrian_otto> 3) Midcycle.
16:12:01 <tcammann> woop
16:12:02 <adrian_otto> #link https://wiki.openstack.org/wiki/Magnum/Midcycle
16:12:11 <adrian_otto> thanks to tcammann we have a swank location
16:12:17 <adrian_otto> there is an eventbrite
16:12:27 <adrian_otto> if you are attending, register with an in-person ticket
16:12:44 <adrian_otto> if you are remote, there is a special ticket for that, but I can not yet guarantee how we will accommodate you
16:12:59 <adrian_otto> in the past we have done our best to include remotes for key discussions
16:13:13 <adrian_otto> but it really depends on the facility whether that will work well
16:13:38 <adrian_otto> the address is there as well.
16:13:56 <adrian_otto> please let me and Tom know if you have any questions or concerns about the midcycle
16:14:12 <tcammann> I'll find out if we can do a webex or similar soon
16:14:39 <adrian_otto> I did make a standby ticket just in case we need more than 18, and we can shuffle folks around if needed
16:14:46 <adrian_otto> in the past that number has been just about right
16:15:52 <adrian_otto> ok, there is an etherpad where we will begin assembling agenda content
16:16:43 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-mitaka-midcycle-topics Midcycle Agenda
16:17:06 <adrian_otto> I will source your input from that etherpad to form the agenda, and slot it by time
16:18:10 <adrian_otto> any other announcements from team members?
16:18:44 <adrian_otto> #topic Review Action Items
16:18:52 <adrian_otto> 1) adrian_otto to champion consensus and merge of https://review.openstack.org/268852
16:18:59 <adrian_otto> Status: Complete. Review merged. Any opposing viewpoints remaining to consider?
16:19:37 <coreyob> I'm still a little dubious about the security of using a secondary domain instead of the project's domain
16:19:50 <coreyob> but I'll follow up with those concerns as I find concrete examples
16:20:26 <adrian_otto> ok, we'll be open to revisit this if there are concerns to address
16:21:13 <adrian_otto> my ask is that if we dislike the approach, that we make actionable suggestions for a better approach along with our criticisms.
16:21:46 <adrian_otto> any more thoughts on this topic?
16:22:26 <adrian_otto> ok, next action item
16:22:31 <adrian_otto> 2) adrian_otto to produce a wiki page that explains Magnum's ability to support native API access and wrapped (limited) access to that funcitonality through our contiainers resource, and pointers to points of debate.
16:22:42 <adrian_otto> nice spelling errors in there ;-)
16:22:46 <adrian_otto> Status: in progress
16:23:03 <adrian_otto> I have been polling a few of you seeking use cases for our /containers endpoint
16:23:18 <adrian_otto> if you have one, please let me know, so I can incorporate that into our POV
16:23:39 <adrian_otto> I will expose this initially as a draft, and we can discuss it prior to finalizing the project POV
16:23:49 <adrian_otto> any questions?
16:24:15 <adrian_otto> ok, let's advance
16:24:21 <adrian_otto> #topic Magnum UI Subteam Update (bradjones)
16:24:27 <bradjones> hi
16:24:30 <adrian_otto> hi!
16:24:55 <bradjones> so the last major bp (creating bay models) finally merged which is awesome
16:25:19 <adrian_otto> #action adrian_otto to produce a wiki page that explains Magnum's ability to support native API access and wrapped (limited) access to that functionality through our containers resource, and pointers to points of debate.
16:25:35 <bradjones> at this point there is nothing major left to do from the bps
16:25:36 <adrian_otto> sweet
16:25:50 <bradjones> I think now that has merged it would be a great time to take a closer look at docs
16:25:58 <bradjones> explaining using and extending in the future
16:26:05 <adrian_otto> ok, so I'd like to work together with you to put a demo together of the UI
16:26:18 <adrian_otto> and we can put that on the Magnum project wiki page
16:26:23 <bradjones> adrian_otto: sounds great
16:26:34 <adrian_otto> and docs would be the logical follow-up to that
16:26:47 <bradjones> ok let's aim for demo first then docs to follow then
16:27:05 <adrian_otto> excellent. Let's take that as an action item
16:27:09 <adrian_otto> sound ok?
16:27:12 <bradjones> sure
16:27:32 <adrian_otto> #action bradjones and adrian_otto to work on a demo of the Magnum UI for publication on the Magnum project wiki page.
16:27:53 <adrian_otto> we can regroup after the meeting to earmark time for that.
16:28:00 <bradjones> sounds good
16:28:19 <adrian_otto> #topic Blueprint Review
16:28:27 <adrian_otto> #link https://review.openstack.org/#/c/206467/ Add guide for TLS support in Magnum. (abandoned) needs revival
16:28:52 <adrian_otto> madhuri: this one has an important issue where two of the images look the same
16:28:53 <madhuri> I will submit a revision soon
16:29:10 <adrian_otto> ok, terrific. If you need help from the team, please let us know.
16:29:21 <madhuri> Sure. Thank you!
16:29:27 <adrian_otto> #topic Essential Blueprint Updates
16:29:51 <adrian_otto> I will come back to the suro-patz ones in just a moment.
16:30:03 <suro-patz> sure
16:30:26 <adrian_otto> the launchpad site has been really slow for me recently
16:30:46 <adrian_otto> takes 40 seconds or so to respond
16:31:08 <adrian_otto> actually now it's throwing errors
16:31:19 <adrian_otto> so I can do this from memory, or look at our minutes from last meeting
16:31:37 <adrian_otto> Tango, I know you have a docs BP in progress that you updated in the past 24 hours.
16:31:42 <adrian_otto> can you give us an update on that?
16:32:03 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/user-guide User Guide Blueprint
16:32:20 <hongbin> adrian_otto: I think Tango is on PTO
16:32:30 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-troubleshooting-guide Troubleshooting Guide Blueprint
16:32:42 <adrian_otto> ok, both of those are advancing, but rather slowly
16:33:15 <adrian_otto> vilobhmm11: you have one too
16:33:22 <vilobhmm11> adrian_otto : after the discussion in weekly meeting last time the spec was updated https://review.openstack.org/#/c/266662/9 is about to get merged
16:33:23 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/resource-quota Resource Quota Blueprint
16:33:37 <vilobhmm11> it should be merged in today or so
16:34:01 <dimtruck> adrian_otto: there's also this #link https://blueprints.launchpad.net/magnum/+spec/magnum-tempest
16:34:13 <adrian_otto> ok, based on my research so far, it might make sense to revisit the priority of rate controls for /containers resources
16:34:45 <adrian_otto> so I'll provide that feedback in the 266662 review linked above
16:35:32 <vilobhmm11> adrian_otto : sure makes sense…for now would like to start with bays but going ahead definately would propose a seperate blueprint and work on it…i m in the process f information gathering about strong usecases for rate control for container resource
16:35:44 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-tempest (dimtruck)
16:35:57 <dimtruck> so we have 2 patches left
16:36:12 <dimtruck> one coreyob is updating to remove tempest from test-requirements.txt
16:36:18 <adrian_otto> vilobhmm11: thanks I appreciate it. I just want to calibrate our efforts so that we are focused where it will make the most difference for users.
16:36:19 <coreyob> done ^
16:36:32 <vilobhmm11> adrian_otto : sure
16:36:37 <adrian_otto> thanks coreyob and dimtruck
16:36:38 <dimtruck> and the second one i finally coverted to test_bays for cert testing so that it finishes in a reasonable time.
16:36:41 <dimtruck> adrian_otto: quick question
16:36:49 <dimtruck> how do i mark a blueprint completed? :)
16:36:53 <dimtruck> do i just tell you or...
16:36:59 <adrian_otto> I can mark it right now
16:37:01 <adrian_otto> one sec
16:37:04 <dimtruck> because once these two land, we are good to go
16:37:25 <adrian_otto> ok, I marked it as implemented
16:37:41 <dimtruck> awesome!  thank you!
16:37:43 <adrian_otto> I can put it to pending code review first though
16:37:48 <dimtruck> oh yes
16:37:55 <adrian_otto> then you can just lmk when they merge
16:38:00 <dimtruck> will do
16:38:07 <adrian_otto> ok, set accordingly
16:38:26 <adrian_otto> that concludes essential blueprint status
16:38:38 <adrian_otto> #topic Other Blueprint Updates
16:38:45 <adrian_otto> (suro-patz)Needs review: #link https://blueprints.launchpad.net/magnum/+spec/async-container-operations
16:39:05 <adrian_otto> #link https://review.openstack.org/#/c/275003/ Spec for Async Container Operations
16:39:29 <adrian_otto> #link https://review.openstack.org/#/c/267134/ Implementation of Async Container Operations
16:39:38 <suro-patz> As requested during the ongoing review, I have put a spec for the design
16:39:57 <suro-patz> the design was discussed over ML and recorded in the Blueprint Whiteboard
16:40:11 <vilobhmm11> link for spec https://review.openstack.org/#/c/275003/
16:40:17 <adrian_otto> thanks suro-patz
16:40:20 <suro-patz> I request you all to take a look, review and provide feedback
16:40:40 <vilobhmm11> suro-patz : i will have a look today at the spec
16:40:43 <adrian_otto> good, I will certainly provide input
16:41:04 <suro-patz> thanks vilobhmm11, adrian_otto
16:41:27 <vilobhmm11> np
16:41:45 <adrian_otto> any other blueprints, bugs, or work items to discuss as a team today?
16:42:05 <adrian_otto> #topic Open Discussion
16:43:22 <adrian_otto> I did present magnum for NASA JPL
16:43:49 <suro-patz> Super!
16:43:56 <adrian_otto> there was a definite interest for a number of BigData projects. They are particularly interested in the Mesos bay type.
16:44:23 <adrian_otto> JPL is one of the most active scientific computing centers in the world
16:44:37 <adrian_otto> so I see that as a really compelling use case.
16:44:42 <madhuri> This is awesome
16:44:49 <vilobhmm11> thats awesome adrian_otto
16:45:37 <adrian_otto> they also recorded the session, and redistributed it on their own network where all the scientists can learn about the cloud technology presented during the Cloud LEAP event.
16:45:37 <dimtruck> sweet!
16:46:01 <adrian_otto> I expect we will find lots of opportunities for new security features
16:46:14 <adrian_otto> as some of their projects are rather sensitive in nature
16:46:42 <adrian_otto> and there are regulatory hurdles to clear when setting up infrastructure
16:48:40 <adrian_otto> as mentioned a while back… for those of you in the Bay area, the OpenStack meetup group for the San Francisco Bay Area will be holding a meetup about Magnum on Feb 18th, also hosted by HPE in Sunnyvale, so those of us attending the Midcycle can go to that.
16:49:01 <adrian_otto> if you'd like to have a part in the presentation, just let me know and I'll be sure to give you the stage.
16:50:00 <adrian_otto> also, you will notice a few more engineers from Rackspace have begun contributing
16:50:25 <adrian_otto> and are currently working on a number of things to add Magnum capability to Carina
16:50:43 <adrian_otto> success with this effort will mark the first public cloud use case for Magnum
16:50:54 <adrian_otto> so let's do our best to support them
16:51:41 <coreyob> thanks adrian_otto!
16:51:51 <vilobhmm11> sure
16:52:36 <adrian_otto> we will have a good look at some of the topics during the midcycle too
16:54:05 <adrian_otto> remember to share your input on the midcycle topic list, even if you are unable to attend:
16:54:08 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-mitaka-midcycle-topics
16:56:48 <adrian_otto> we have a few minutes remaining
16:56:59 <adrian_otto> any other topics to touch on before we wrap up?
16:57:42 <adrian_otto> Thanks for attending today. Our next team meeting will be on 2016-02-09 at 1600 UTC. See you then!
16:57:59 <adrian_otto> #endmeeting