16:00:20 <hongbin> #startmeeting containers
16:00:21 <openstack> Meeting started Tue Aug 2 16:00:20 2016 UTC and is due to finish in 60 minutes. The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:24 <openstack> The meeting name has been set to 'containers'
16:00:25 <hongbin> #topic Roll Call
16:00:32 <muralia_> o/
16:00:37 <tonanhngo> Ton Ngo
16:00:44 <Drago> o/
16:00:50 <strigazi> Spyros Trigazis
16:00:59 <dane_leblanc_> o/
16:01:06 <rpothier> o/
16:01:55 <hongbin> Thanks for joining the meeting muralia_ tonanhngo Drago strigazi dane_leblanc_ rpothier
16:02:06 <eghobo> o/
16:02:09 <adrian_otto> Adrian Otto
16:02:10 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-08-02_1600_UTC Today's agenda
16:02:18 <hongbin> Anything needs to be added to the agenda?
16:02:43 <hongbin> #topic Announcements
16:02:50 <hongbin> 1. Welcome Spyros Trigazis to join the Magnum core team
16:02:58 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-July/100455.html
16:02:59 * adrian_otto applause
16:03:00 <muralia_> woohoo! congrats
16:03:13 <Drago> Congrats strigazi!
16:03:15 <adrian_otto> well deserved
16:03:25 <strigazi> Thanks you :)
16:03:29 <yatin> Congrats strigazi
16:03:43 <rajiv__> Congrats strigazi
16:03:44 <hongbin> Thanks strigazi for your significant contribution
16:03:48 <tonanhngo> Congrats Spyros!
16:04:03 <hongbin> 2. Vote for mascot ended. The team mascot is sharp.
16:04:09 <hongbin> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_15e176081cd9d2b1
16:04:28 <hongbin> I sent the choice to the OpenStack foundation
16:04:41 <hongbin> If no other team picked this mascot, we will get it
16:04:45 <adrian_otto> hongbin: did we also send waves as an alternate?
16:04:50 <adrian_otto> oh, ok
16:04:52 <hongbin> yes
16:05:16 <hongbin> #topic Review Action Items
16:05:18 <hongbin> None
16:05:26 <hongbin> #topic Essential Blueprints Review
16:05:31 <hongbin> 1. Support baremetal container clusters (strigazi)
16:05:37 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:05:42 <hongbin> strigazi: ^^
16:06:17 <strigazi> Not much this week, we are looking into creating a CI for testing magnum and ironic on our infra
16:06:34 <strigazi> we might open it for everyone if it goes well
16:07:01 <strigazi> with devstack vms with more memory
16:07:43 <hongbin> strigazi: How about the CI with OpenStack infra?
16:07:45 <strigazi> That's it, last week we did some benchmarks for magnum with rally. I'll tell you on the midcycle
16:08:15 <strigazi> hongbin: what do you mean?
16:08:46 <hongbin> strigazi: Maybe to clarify, are you setting up a third-party CI or a pipeline in OpenStack Infra
16:09:33 <strigazi> third-party CI like in other projects, but it's not final
16:10:08 <strigazi> in openstack infra it seems that we have memory limitations
16:10:40 <hongbin> strigazi: We cannot work around the memory limitation?
16:11:19 <strigazi> we'll try. In one of the tests the vm was swapping
16:11:39 <hongbin> I see
16:12:14 <hongbin> Thanks strigazi for working on this
16:12:21 <hongbin> Any question for strigazi ?
16:12:55 <hongbin> 2. Magnum User Guide for Cloud Operator (tango)
16:13:00 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:13:05 <hongbin> tonanhngo: ^^
16:13:07 <tonanhngo> The TLS section was merged.
16:13:30 <tonanhngo> The bay section is still under review
16:14:41 <tonanhngo> I don't have new section today
16:15:59 <hongbin> tonanhngo: ack. anything else?
16:16:12 <tonanhngo> Thanks to Spyros and Ricardo for great feedback
16:16:31 <strigazi> https://review.openstack.org/#/c/340670/3/doc/source/userguide.rst@327
16:17:48 <strigazi> tonanhngo: Do you think that is unecessary? For example last week we were creating bays in parralel, with different requests of course
16:18:08 <tonanhngo> Not sure what you mean
16:19:19 <strigazi> A user doesn't have to wait for a bay to have status CREATE_COMPLETE
16:19:44 <tonanhngo> ah ok, I will update that part
16:20:03 <tonanhngo> Thanks for the observation
16:20:19 <strigazi> thanks
16:20:20 <hongbin> Thanks tonanhngo
16:20:31 <hongbin> 3. COE Bay Drivers (jamie_h, muralia)
16:20:36 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/bay-drivers
16:20:39 <hongbin> muralia_: ^^
16:21:07 <muralia_> I don't have any updates since last week. i've been on vacation for a few days and just got back. I will continue working on my patch
16:21:37 <strigazi> I have a question for everyone
16:21:50 <strigazi> Are we going to remove the replication controller object?
16:22:02 <muralia_> yes we should.
16:22:11 <strigazi> ok, I'm almost tehre
16:22:15 <strigazi> ok, I'm almost there
16:22:16 <strigazi> thanks
16:22:40 <hongbin> Thanks muralia_ . Any other question?
16:23:02 <hongbin> #topic Kuryr Integration Update (tango)
16:23:12 <hongbin> tonanhngo: ^^
16:24:16 <tonanhngo> We hit a little snag last week. The Kuryr image is broken because it got rebuilt using the refactored repos, which are not complete
16:25:44 <tonanhngo> I told the Kuryr team, they will build and tag a stable image
16:25:46 <adrian_otto> tonanhngo: that's one of our images, or something made by the Kuryr team?
16:25:55 <tonanhngo> It's by Kuryr
16:25:56 <adrian_otto> I see
16:26:57 <hongbin> Thanks tonanhngo . Anything else?
16:27:16 <tonanhngo> That's all for now
16:27:20 <hongbin> Thanks
16:27:29 <hongbin> #topic Other blueprints/Bugs/Reviews/Ideas
16:27:35 <hongbin> 1. Midcycle topics
16:27:41 <hongbin> #link https://etherpad.openstack.org/p/magnum-newton-midcycle-topics
16:28:02 <hongbin> I put all the topics to the agenda
16:28:28 <hongbin> There are three slots left, which we can use to discuss alternative topics
16:28:47 <hongbin> I invited strigazi to give a presentation at the opening
16:29:08 <hongbin> strigazi: will share the experience of using Magnum at his group
16:29:45 <strigazi> One more topic: Add local (configurable) docker registry
16:29:57 <hongbin> At the end of the first day, we could plan a team event (drinks or dinner or others)
16:30:10 <hongbin> strigazi: ack. feel free to add it to the etherpad
16:30:15 <strigazi> added
16:30:40 <Drago> Great to see the agenda filled out. Excited to have everyone here.
16:30:56 <hongbin> muralia_: adrian_otto Do you have any arrangement for a team event (drinks? dinner?)
16:30:59 <rochaporto> enjoy, pity i can't make it but next time :)
16:31:17 <muralia_> yes, we were thinking about drinks at the rackspace office friday evening
16:31:31 <adrian_otto> hongbin: lets get that discussion opened with the midcycle attendees
16:31:39 <hongbin> ok
16:31:48 <adrian_otto> thursday evening there is a community meetup
16:32:01 <adrian_otto> all team members are welcome, and encouraged to attend
16:32:16 <hongbin> link to the meetup?
16:32:19 <muralia_> http://www.meetup.com/Docker-Austin/events/232067917/
16:32:36 <hongbin> Awesome
16:32:37 <muralia_> weird how out mid-cycles fall on docker meetup days
16:32:43 <muralia_> our*
16:32:48 <strigazi> :)
16:32:48 <adrian_otto> #link http://www.meetup.com/Docker-Austin/events/232067917/
16:33:42 <hongbin> Any other question / comment for the midcycle?
16:34:17 <hongbin> 2. Microversioning implementation
16:34:23 <hongbin> #link https://review.openstack.org/#/c/343060/
16:35:03 <muralia_> jvgrant: ^
16:35:07 <hongbin> The patch above is a proposal to implement a decorator for specifying microversion
16:35:37 <hongbin> Eli Qiao gave a -2 with comments that he don't like the decrorator approach
16:35:53 <jvgrant> this provides a common framework and style versioning,
16:36:32 <jvgrant> currently it would be checking and making changes within each api method
16:36:59 <jvgrant> this really is just providing a more structured versioning style
16:37:29 <jvgrant> it based on Nova's way of doing it using a decorator
16:37:43 <muralia_> yes, i prefer the decorator approach for versioning. we'll be using it a lot more when we implement lifecycle operations etc.
16:37:59 <adrian_otto> I also prefer the decorators.
16:38:05 <Drago> +1 decorators
16:38:05 <hongbin> me as well
16:38:13 <vijendar> +1 decorators approach
16:38:26 <hongbin> Any opposing point of view?
16:38:30 <adrian_otto> is Eli in attendance today?
16:38:38 <hongbin> eliqiao: ^^
16:38:45 <akhilakishore> +1 decorators approach
16:38:54 <hongbin> I guess he is offline since it is late everning for him
16:38:55 <jvgrant> i think Eli's main concern was the additional complexity
16:39:19 <adrian_otto> well he used a -2 vote, which we need to consider carefully
16:39:41 <adrian_otto> I'm reluctant to support an alternate decision without a conversation about it
16:39:50 <adrian_otto> even though I don't agree with him
16:40:09 <hongbin> I will ping him later for discussing it further
16:40:13 <adrian_otto> thanks hongbin
16:40:21 <jvgrant> thanks hongbin
16:40:34 <hongbin> #action hongbin discuss with eliqiao for the microversion implementation
16:40:35 <Drago> Does anyone know if he will be at the midcycle?
16:40:43 <hongbin> No, he won't
16:40:58 <hongbin> He didn't sign the event.
16:41:23 <hongbin> and flighting from China to US is $$$
16:41:43 <tonanhngo> can we arrange a conference call at a convenient time for him?
16:41:43 <hongbin> I guess it is very hard for him to get approval
16:42:09 <adrian_otto> I think we all can relate. Okay, let's do our best to consider his POV.
16:42:51 <hongbin> OK. Then, I can talk to him to schedule a call
16:43:36 <hongbin> Anything else for this topic?
16:44:26 <hongbin> #topic Open Discussion
16:45:24 <hongbin> If nothing else to discuss, let's end the meeting a bit earlier
16:45:38 <rochaporto> i have a question on the param names for the client
16:45:41 <rochaporto> with all the -id
16:45:59 <rochaporto> there's a patch to drop it in external-network-id. could we do it for all? it's confusing
16:46:09 <rochaporto> maybe adding new ones and flagging the old ones as deprecated
16:46:20 <rochaporto> or else we do it for the osc only
16:46:42 <hongbin> I think flagging the old ones as deprecated is the correct approach
16:46:56 <hongbin> Just renaming will break backward-compatibility
16:47:06 <rochaporto> sure
16:47:55 <adrian_otto> rochaporto: is your concern that fact that some attributes contain the string "-id" and others do not?
16:48:36 <rochaporto> yes, and the -id itself being there
16:48:43 <rochaporto> given that it can take the name too
16:49:09 <hongbin> Definitely the *-id suffix should be removed
16:49:09 <adrian_otto> early on it only accepted an id
16:49:22 <yatin> @rochaporto are your taliking about: https://bugs.launchpad.net/python-magnumclient/+bug/1599393
16:49:23 <openstack> Launchpad bug 1599393 in python-magnumclient "magnum baymodel-create optional parameter(external_network_id) needs update" [Undecided,In progress] - Assigned to yatin (yatinkarel)
16:49:25 <adrian_otto> we added the code to accept names as a convenience a bit later
16:49:38 <tonanhngo> This should improve the user experience
16:49:53 <adrian_otto> ok, the issue is clear to me now, thanks.
16:49:59 <rochaporto> yatin: yes, but same is true for other params
16:50:22 <rochaporto> small thing, but might as well get it done
16:50:22 <yatin> Yes, i commented on the bug itself
16:50:50 <hongbin> yatin: Are you the preson who working on fixing the bug?
16:50:58 <yatin> Yes
16:51:18 <hongbin> yatin: Do you have enough instruction on how to proceed ?
16:52:22 <hongbin> yatin: For example, how to flag an attribute as deprecated, and add the new one ....
16:52:53 <yatin> hongbin: no, but i will try to find out.
16:53:04 <yatin> if you approve this
16:53:21 <hongbin> yatin: ok. ping the #openstack-containers if you need help
16:53:37 <hongbin> yatin: Thanks for volunteering to fix this bug
16:53:50 <yatin> Ok
16:54:28 <rochaporto> thanks :) i'll look into other params in parallel
16:55:13 <hongbin> All, thanks for joining the meeting today. The Magnum midcyle will hold at this Thursday & Friday. Hope to see you all there
16:55:20 <hongbin> #endmeeting