16:00:32 <hongbin> #startmeeting containers
16:00:33 <openstack> Meeting started Tue Aug 30 16:00:32 2016 UTC and is due to finish in 60 minutes. The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:38 <openstack> The meeting name has been set to 'containers'
16:00:38 <hongbin> #topic Roll Call
16:00:43 <strigazi> Spyros Trigazis
16:00:45 <muralia> murali allada
16:00:46 <jvgrant_> Jaycen Grant
16:00:48 <swatson> Stephen Watson
16:00:49 <tonanhngo> Ton Ngo
16:00:54 <Hieu> Heu LE o/
16:00:55 <rochaporto> Ricardo Rocha
16:00:57 <rpothier> Rob Pothier
16:01:35 <hongbin> thanks for joining the meeting strigazi muralia jvgrant_ swatson tonanhngo Hieu rochaporto rpothier
16:01:43 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-08-30_1600_UTC Today's agenda
16:01:49 <eghobo> o/
16:01:49 <hongbin> Anything needs to be added to the agenda?
16:02:17 <hongbin> #topic Announcements
16:02:24 <hongbin> 1. The python-magnumclient repo is freezed for preparing Newton release.
16:02:24 <strigazi> could we start with FF?
16:02:43 <hongbin> strigazi: we will discuss that later in the agenda
16:03:25 <hongbin> currently, the client repo is freezed, I am going to submit a release to release python-magnumclient for newton
16:04:06 <hongbin> however, please feel free to let me know if you have client patches for newton
16:04:26 <hongbin> we can do a FFE or a backport accordingly
16:04:41 <hongbin> any question about this?
16:05:18 <hongbin> #topic Review Action Items
16:05:24 <hongbin> none
16:05:31 <hongbin> #topic Essential Blueprints Review
16:05:37 <hongbin> 1. Support baremetal container clusters (strigazi)
16:05:43 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:05:47 <hongbin> strigazi: ^^
16:06:37 <strigazi> I was on vacations last week so I don't have anything to report. I'm working on atomic_swarm and mesos.
16:07:22 <muralia> strigazi: if you've noticed, i spilt the k8s ironic support into a new driver.
16:07:24 <strigazi> For mesos maybe easier since it's plain ubuntu and the image might be the same
16:07:26 <muralia> we should do the same
16:07:50 <strigazi> I saw that
16:08:12 <strigazi> that's all
16:08:30 <tonanhngo> muralia: makes sense
16:09:00 <strigazi> if we have more than 90% similarity on the templates
16:09:13 <strigazi> it would create much code duplication
16:09:28 <strigazi> but I'll submit different drives
16:09:31 <strigazi> but I'll submit different drivers
16:10:09 <strigazi> Does anyone has another comment?
16:10:46 <hongbin> I guess no
16:10:50 <hongbin> thanks strigazi
16:10:57 <hongbin> 2. Magnum User Guide for Cloud Operator (tango)
16:11:02 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:11:07 <hongbin> tonanhngo: ^^
16:11:46 <tonanhngo> I am writing the section on Scaling, almost done, should upload later today. Got too many distractions last week.
16:11:56 <tonanhngo> that's about all
16:12:11 <strigazi> scaling of deployment?
16:12:52 <strigazi> tonanhngo ^^
16:13:47 <strigazi> He might disconnected
16:13:59 <hongbin> I guess he mean scaling of the COE
16:14:03 <strigazi> ok
16:14:07 <hongbin> add/remove nodes
16:14:28 <hongbin> thanks tonanhngo
16:14:29 <strigazi> I think we talked about this again
16:14:39 <hongbin> 3. COE Bay Drivers (muralia)
16:14:46 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/bay-drivers
16:14:52 <hongbin> muralia: ^^
16:15:08 <tonanhngo> Sorry I got a call
16:15:16 <muralia> so, as discussed last week, we want to continue supporting server_type, os and coe during baymodel creation along with --drivername.
16:15:28 <muralia> so i added the mapping in each driver
16:15:36 <muralia> just like we do today with template_def.
16:16:14 <muralia> because we are reaching feature freeze soon
16:16:31 <muralia> im focusing on server_type, os and coe first before i submit a patch for --driver
16:16:38 <muralia> so everything will stay compatible
16:17:23 <muralia> so with the new mapping, i need to load all drivers using stevedore one by one and create the master mapping.
16:18:03 <muralia> i want to do this once when magnum starts. and then at bay creation time, we can look at the map and decide which driver to use.
16:18:07 <muralia> working on that currently.
16:18:19 <muralia> thats all for now.
16:18:21 <tonanhngo> so would the new option --drivername would replace some of the existing options, like --coe?
16:18:32 <muralia> eventually.
16:18:51 <tonanhngo> and when we add a new driver, we would need to restart the conductor?
16:18:51 <muralia> but we need to keep that for now and deprecate it in a release or 2
16:19:10 <muralia> yes we need to. thats how stevedore works.
16:19:32 <strigazi> the option and the field in clusterTemplate will be replaced?
16:19:38 <adrian_otto> muralia: That restart is not necessarily service affecting, is it?
16:19:58 <strigazi> At this point it is
16:20:13 <adrian_otto> I expect our API can still queue instructions for the conductor when it's down
16:20:13 <tonanhngo> ok, we might want to think about some command to manage drivers to make it more user friendly for the operators.
16:20:23 <muralia> strigazi: yes. i'll change those. adrian_otto: i dont think so, but i need to test it to see
16:20:37 <Drago> Depends if the conductor was doing things at the time, doesn't it?
16:20:44 <strigazi> Drago yes
16:20:56 <strigazi> if there is a bay in creation
16:21:01 <muralia> tonanhngo: we'll be adding a 'driver list'.
16:21:05 <rochaporto> right now if you restart the conductor while it's deploying a bay things go wrong
16:21:27 <Drago> If you do blue-green deployments, I think you'd be fine
16:21:33 <hongbin> a feature to add/remove driver in api without restarting would be cool
16:21:50 <adrian_otto> rochaporto: that makes sense. We would need a way to freeze/thaw the orchestration state.
16:21:58 <tonanhngo> It's really a separate topic, but we also want to make sure the conductor going down won't affect service
16:22:01 <strigazi> when I installed the suse driver
16:22:13 <adrian_otto> but we could look at a way to support draining for conductors
16:22:14 <strigazi> I didn't need to restart
16:22:45 <Drago> tonanhngo, adrian_otto: +1
16:22:49 <tonanhngo> conductor can go down for other reasons
16:23:18 <hongbin> I think there is a patch to add support for adding/removing "service"
16:23:29 <hongbin> where "service" could be magnum-api or magnum-conductor
16:23:40 <muralia> strigazi: really? let me look at that some more then.
16:23:54 <strigazi> doning it again now
16:24:01 <hongbin> a way is to set the conductor "service" to maintain mode, then it won't accept request anymore
16:24:03 <muralia> hongbin: i think that service was something else right? wasnt it related to k8s?
16:24:27 <hongbin> muralia: no, it is not k8s service. it is magnum service
16:24:38 <hongbin> muralia: type magnum service-list, you could see
16:25:42 <strigazi> muralia: verified, I install teh driver again I did list-templates and saw the template definition again
16:26:01 <muralia> nice
16:26:30 <muralia> thats all for my update. I would like this work to get merged in with this release without the --driver support in the cli
16:26:48 <hongbin> thanks muralia
16:26:54 <hongbin> 4. Rename bay to cluster (jvgrant)
16:27:00 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/rename-bay-to-cluster
16:27:04 <hongbin> jvgrant_: ^^
16:27:18 <jvgrant_> Lots of good progress this week, majority of external facing changes now done
16:27:28 <jvgrant_> https://review.openstack.org/#/c/362660/ - conf options
16:27:39 <jvgrant_> is the remaining review for anything a user sees
16:27:56 <jvgrant_> working on all the internal references, objects, and db now.
16:28:07 <jvgrant_> https://review.openstack.org/#/c/359470/ - ClusterTemplate db and internal references
16:28:19 <jvgrant_> https://review.openstack.org/#/c/360054/ - Certificate object and references
16:28:28 <jvgrant_> https://review.openstack.org/#/c/362485/ - Functional test updates
16:28:39 <jvgrant_> trying to break them up as small as i can for reveiw
16:28:51 <strigazi> :)
16:29:05 <jvgrant_> after a few more of these merge there will be one final patch with the bay db and objects changes
16:29:13 <jvgrant_> after that we should be done :)
16:29:40 <jvgrant_> big thanks to swatson for the client and conf changes, and everyone who has given good feedback in reviews
16:29:51 <swatson> I should add that consensus from Oslo and Nova is that we mention in release notes what all the CONF changes were
16:30:02 <swatson> Deprecating in oslo config is just 1 step
16:30:24 <jvgrant_> that is all
16:30:39 <hongbin> sweston: yes, a release note to document the conf changes is nice
16:31:19 <swatson> hongbin: Is there a way to make sure we don't miss noting the changes in an official release?
16:32:19 <hongbin> sweston: AFAIK, there is no automate way to detect missing of release note
16:32:31 <hongbin> sweston: we rely on reviewers to catch that
16:33:04 <swatson> hongbin: Is there a review created specifically for release notes? Or some wiki to update?
16:33:04 <hongbin> sweston: I will change the release note again when I am doing a release
16:33:11 <swatson> hongbin: OK
16:33:13 <hongbin> s/change/check/
16:33:54 <hongbin> #link https://github.com/openstack/magnum/blob/master/doc/source/dev/reno.rst
16:34:30 <swatson> I'll check it out
16:34:32 <hongbin> sweston: the link above is the guide for release note
16:34:51 <hongbin> thanks jvgrant_ for the hard work on renaming :)
16:35:08 <tonanhngo> massive change !
16:35:18 <hongbin> #topic Kuryr Integration Update (tango)
16:35:27 <hongbin> tonanhngo: ^^
16:35:31 <tonanhngo> I attended the Kuryr meeting yesterda
16:35:48 <tonanhngo> The team is splitting up the refactoring into two releases
16:36:17 <tonanhngo> first one should be done this week, then followed by the second one in a few weeks to add the RPC/Rest server
16:36:41 <tonanhngo> For our purpose, I think I will just wait for the second release
16:37:00 <tonanhngo> since it would involve more changes in our integration
16:37:28 <tonanhngo> I am continuing debugging the Swarm deployment using the Mitaka version
16:38:01 <tonanhngo> Currently there is some problem with the Neutron agent on the VM creating a VIF
16:38:24 <tonanhngo> So I am comparing with the working environment to see what's missing
16:38:45 <tonanhngo> I am adding another patch to handle the configuration in Magnum
16:39:11 <tonanhngo> That's about all for now
16:39:43 <hongbin> any question for tonanhngo ?
16:40:16 <hongbin> ok, advance topic
16:40:19 <hongbin> #topic Other blueprints/Bugs/Reviews/Ideas
16:40:26 <hongbin> 1. Decide the time for Magnum feature freeze
16:40:32 <hongbin> #link http://releases.openstack.org/newton/schedule.html Newton release scheduler
16:41:04 <hongbin> right now, the client repo is freezed
16:41:13 <hongbin> we need to decide when to freeze the server repo
16:41:51 <adrian_otto> we have one feature we really want to land before freeze
16:41:55 <hongbin> the deadline to release magnum server is Sep 26-30, which is the final release candidate
16:42:01 <adrian_otto> vijendar: that's your patch
16:42:28 <muralia> the version info patch
16:42:32 <muralia> is that it?
16:42:35 <tonanhngo> link?
16:42:41 <strigazi> https://review.openstack.org/#/c/359249/
16:42:55 <strigazi> tonanhngo ^^
16:43:12 <adrian_otto> Yes, https://review.openstack.org/359249
16:43:37 <hongbin> ok, we can merge that one before the freeze
16:43:41 <adrian_otto> one of our product integrations depends on that one. It looked close to merge when I reviewed it yesterday, but just FYI... we carea bout that one a lot.
16:44:26 <tonanhngo> ok, we can give it priority in reviewing
16:44:28 <strigazi> the patch looks good, but a merge conflict was created today
16:44:38 <vijendar> adrian_otto hongbin I have updated patch with your review comments… please take a look again
16:44:40 <strigazi> it's solved
16:44:48 <adrian_otto> tx
16:44:57 <hongbin> vijendar: will do that
16:45:15 <vijendar> strigazi: I rebased this morning
16:45:23 <hongbin> besides the version info patch, any other patches that needs to be included in Newton?
16:45:26 <vijendar> thanks adrian_otto hongbin strigazi
16:45:39 <jvgrant_> i'd like all the bay to cluster stuff to make it in
16:45:47 <hongbin> jvgrant_: ack
16:45:48 <jvgrant_> it is close
16:46:28 <muralia> same with the driver work. maybe a weeks worth of work more. mostly for testing
16:46:40 <hongbin> muralia: ack
16:46:47 <rochaporto> +1 drivers
16:47:04 <hongbin> any others?
16:47:49 <tonanhngo> please take a look at the user guide to see if any particular section needs to be filled out
16:47:54 <hongbin> #agreed try to merge bay info, drivers, cluster renaming patches before freezing the magnum server repo
16:48:03 <strigazi> are we going to create a release this week?
16:48:17 <strigazi> as mentioned by Doug in the ML?
16:48:37 <hongbin> strigazi: yes, doug wants a release by this week
16:48:49 <hongbin> strigazi: however, that is not necessary to be the final release
16:49:05 <hongbin> strigazi: we can do another release before the deadline
16:49:15 <tonanhngo> It usually takes several iterations
16:50:05 <strigazi> we might want a release soon for distro packagers work on
16:50:42 <hongbin> strigazi: by this week?
16:50:58 <strigazi> At CERN we build the packages our own so we don't depend on that much
16:51:28 <strigazi> it's not clear to me, some projects have releases already and the packaging started
16:51:50 <strigazi> if we can do many iterations
16:52:00 <strigazi> let's do one this week
16:52:12 <hongbin> ok
16:52:27 <strigazi> and be sure to include the patches mentions in the next iterations
16:52:32 <strigazi> and be sure to include the patches mentioned in the next iterations
16:53:10 <strigazi> @all what do you think?
16:53:38 <muralia> im ok with that
16:53:43 <hongbin> wfm
16:53:51 <tonanhngo> sounds reasonable
16:54:29 <strigazi> it's mostly needed for the dependencies
16:54:48 <strigazi> the new patches don't introduce new dependencies anyway
16:55:36 <adrian_otto> wfm too
16:55:47 <hongbin> yes, also keep in mind that the requirement repo will freeze at some time
16:56:04 <hongbin> after the requirement repo is freezed, new dependencies cannot be added
16:56:42 <hongbin> another thing to keep in mind
16:56:51 <hongbin> the string freeze deadline is this week
16:57:10 <hongbin> so after this week, we are not allowed to change the translation string
16:57:34 <hongbin> #topic Open Discussion
16:58:02 <tonanhngo> Quick question for the team
16:58:24 <tonanhngo> a colleague of mine wants to add a driver for Ubuntu on Swarm
16:58:56 <tonanhngo> I will work with him. Should this go into contrib? or is there enough interest to put it as a supported driver?
16:59:29 <strigazi> To start iterating on it we can start from contrib
16:59:58 <tonanhngo> ok. We will use 16.04, any concern?
17:00:11 <strigazi> +1
17:00:12 <hongbin> time is up
17:00:18 <tonanhngo> thanks
17:00:21 <hongbin> all, thanks for joining the meeting
17:00:25 <hongbin> #endmeeting