16:00:14 <adrian_otto> #startmeeting containers
16:00:14 <openstack> Meeting started Tue Oct  4 16:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'containers'
16:00:22 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-10-04_1600_UTC Our Agenda
16:00:30 <adrian_otto> #topic Roll Call
16:00:34 <adrian_otto> Adrian Otto
16:00:35 <Drago1> o/
16:00:36 <swatson> Stephen Watson o/
16:00:37 <jvgrant> Jaycen Grant
16:00:38 <tonanhngo> Ton Ngo
16:00:39 <strigazi> o/
16:00:39 <hieulq_> Hieu LE o/
16:00:41 <dane_leblanc_> o/
16:00:43 <muralia> o/
16:00:57 <hongbin> o/
16:01:19 <diga_> o/
16:01:28 <adrian_otto> Hello Drago1 swatson jvgrant tonanhngo strigazi hieulq_  dane_leblanc_ muralia hongbin and diga
16:01:34 <eghobo> o/
16:02:56 <adrian_otto> hello eghobo
16:03:06 <adrian_otto> #topic Announcements
16:03:13 <adrian_otto> 1) There will be no team meeting on 2016-10-25 because that is the week of the OpenStack Summit in Barcelona.
16:03:27 <adrian_otto> 2) I have responded indicating that the Magnum team will definitely participate in the PTG in Atlanta in February.
16:03:28 <adrian_otto> #link http://www.openstack.org/ptg
16:04:01 <adrian_otto> Does anyone have questions about either of these? We will cover Design Summit planning later in our agenda today.
16:04:54 <adrian_otto> #topic Review Action Items
16:04:57 <adrian_otto> 1) #action adrian_otto follow up with Kuryr PTL to arrage a joined session
16:05:15 <adrian_otto> Status: Pending.
16:05:34 <adrian_otto> I do have information from ttx about when the various session timeslots are planned
16:05:50 <adrian_otto> so I expect to have topics roughly arranged to those over the next week or so.
16:06:00 <adrian_otto> #action adrian_otto follow up with Kuryr PTL to arrange a joined session
16:06:16 <adrian_otto> #topic Essential Blueprint Review
16:06:23 <adrian_otto> Support baremetal container clusters (strigazi)
16:06:29 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:07:07 <strigazi> I was mostly testing the optional private network approach and there is a bp for that
16:07:11 <strigazi> fetching
16:07:32 <strigazi> #link https://blueprints.launchpad.net/magnum/+spec/decouple-private-network
16:07:53 <strigazi> With this change it will be possible to consolidate the bm vm drivers
16:08:10 <adrian_otto> thanks strigazi
16:08:27 <strigazi> adrian_otto have a look at the bp
16:08:35 <adrian_otto> it will be nice to have a single driver for each COE/OS
16:08:35 <strigazi> it's not approved yet
16:08:51 <strigazi> That is the goal,
16:08:59 <adrian_otto> ok, one moment.
16:09:09 <strigazi> then all drivers will be bm/vm compatible
16:09:30 <strigazi> assuming there are bm images :)
16:09:41 <muralia> how would we choose between a vm and bm?
16:09:42 <strigazi> thanks
16:09:46 <muralia> if a driver supports both?
16:09:47 <adrian_otto> okay, I approved the direction
16:09:50 <strigazi> --server-type
16:09:59 <adrian_otto> and I set the definition status to Drafting
16:10:04 <strigazi> it will use the same templates
16:10:16 <strigazi> muralia ^^
16:10:31 <adrian_otto> we can talk a bit later about the right Series Goal and Milestone Target for it
16:10:49 <muralia> sure
16:11:04 <strigazi> it's very close
16:11:14 <strigazi> muralia, do you have a question?
16:11:35 <muralia> yes, we wanted to get away from looking at multiple flags before choosing a driver
16:11:47 <muralia> now we'll have drivername and server_type
16:12:09 <Drago1> It will still be one driver
16:12:10 <strigazi> So you prefer to maitain two driver?
16:12:14 <strigazi> So you prefer to maitain two drivers?
16:12:51 <muralia> sure. just getting --driver from the user should be good enough
16:12:59 <adrian_otto> let's table design discussion on this for now, and revisit it either in open discussion or in a subsequent topic section in an upcoming meeting. I do want to capture this, but I'm worried we may not have adequate time to cover what's planned for today.
16:13:17 <muralia> ok
16:13:25 <adrian_otto> thanks muralia and strigazi
16:13:31 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/user-guide Magnum User Guide for Cloud Operator (tango)
16:13:40 <tonanhngo> I don't have further update, likely won't get to revisit the user guide until after the summit.  I think there is sufficient content for now.
16:13:44 <tonanhngo> Unless Spyros wants to cover the operator guide, we can probably drop this from the agenda for now.
16:14:18 <adrian_otto> should this BP be marked as Implemented, and superseded by a more narrowly scoped BP?
16:14:48 <adrian_otto> or is there actually work on the user guide that needs to be complete to consider this done?
16:15:08 <tonanhngo> Well, I guess we can mark it as implemented, but of course it will be updated on an ongoing basis
16:15:16 <strigazi> +1
16:15:24 <tonanhngo> documentation is never done
16:15:28 <adrian_otto> I see the guide as a living document, so we will always be improving it
16:15:33 <adrian_otto> exactly
16:16:02 <adrian_otto> ok, marking it as such. Feel free to open more BP's for the remaining scope.
16:16:15 <tonanhngo> sounds good, thanks Adrian
16:16:40 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/bay-drivers COE Bay Drivers (muralia)
16:16:49 <adrian_otto> (Cluster Drivers)
16:16:49 <muralia> https://review.openstack.org/#/c/374906/
16:17:01 <muralia> so the functional tests are still timing out and failing
16:17:28 <strigazi> There is a problem with the OSIC cluster and the devstack neutron configuration
16:17:33 <muralia> I see a comment from spyros this morning and he's seeing the same behaviour as me. they pass on my devstack
16:17:55 <adrian_otto> so when I looked into this late last week it looked like there were external web resources used by python (libraries I think) that were failing to download in order to set up the gate test system.
16:18:05 <strigazi> the problem is that we use 10/8
16:18:15 <adrian_otto> has that trouble continued, or are there other problems that I did not notice?
16:18:21 <strigazi> adrian_otto, that is another problem and it is fixed
16:18:22 <muralia> thats been fixed now.
16:18:47 <adrian_otto> ok, I'm glad to hear that.
16:18:50 <muralia> this morning, tests actually ran and failed due to time outs
16:19:09 <adrian_otto> do we need team participation or guidance from any other teams to get through the current trouble?
16:19:33 <adrian_otto> I'm thinking timeouts = slow servers, or did we change the gate tests so they take longer now?
16:19:42 <strigazi> Let me explain for a minute
16:20:19 <strigazi> The osic cluster uses a physical network 10.0.0.0/8
16:20:45 <strigazi> and we use the same to provide the private network in the dsvm
16:21:04 <strigazi> because of that rabbit it unreachable
16:21:14 <adrian_otto> oh, I see
16:21:22 <strigazi> the neutron devstack team works on that
16:21:38 <strigazi> I have pushed a temporary fix until they address the issue
16:21:47 <strigazi> we'll if it works
16:21:48 <adrian_otto> so what if we used another RFC/1918 address range for our purposes?
16:21:53 <muralia> did that get merged?
16:21:54 <strigazi> https://review.openstack.org/381940
16:22:12 <strigazi> adrian_otto, yes that is the solution
16:22:39 <adrian_otto> but in patch 381940 the subnet is in the 10.0.0.0/8 block.
16:23:18 <adrian_otto> it's just an address toward the end of the block
16:24:08 <strigazi> What network do you propose?
16:24:08 <adrian_otto> okay, let's continue that discussion on the comment stream for:
16:24:12 <adrian_otto> #link https://review.openstack.org/381940
16:24:44 <adrian_otto> 172.16.0.0/12 Might work well for that
16:24:52 <strigazi> ok
16:25:19 <muralia> if other have time, do download the driver patch and test it while we wait for the gates to pass.
16:26:04 <adrian_otto> ok, that concludes review for essential blueprints. Thanks muralia.
16:26:08 <adrian_otto> #topic Other Blueprints/Bugs/Reviews/Ideas
16:26:15 <adrian_otto> Kuryr Integration Update (tango)
16:26:19 <tonanhngo> Hongbin and I attended the Kuryr meeting yesterday.
16:26:35 <tonanhngo> They have dropped the rest/api driver design due to the security concern we raised
16:26:46 <adrian_otto> oh, wow
16:26:50 <tonanhngo> Now they are considering other ideas
16:27:34 <tonanhngo> Hongbin suggested breaking the agent into two parts and 2 potential ways to handle secure connection
16:28:11 <tonanhngo> They asked us to post to the ML to ask for ideas from the Keystone team.  I will do that later today
16:28:28 <adrian_otto> sweet. I'm thrilled to hear it. Thanks hongbin and tonanhngo.
16:28:34 <tonanhngo> (describe the scenario and the requirement)
16:28:35 <adrian_otto> any other remarks on this topic?
16:28:57 <tonanhngo> We also suggested inviting the Keystone team to join our Barcelona session to discuss further
16:29:15 <tonanhngo> I did talk to the Keystone PTL (Steve) about this use case
16:29:56 <adrian_otto> thanks tonanhngo
16:30:05 <tonanhngo> He doesn't see a good solution
16:30:15 <tonanhngo> This may require something new
16:30:40 <adrian_otto> this might be something to put on the PTG schedule
16:30:49 <adrian_otto> and Summit
16:31:09 <tonanhngo> we can see what we get from the ML
16:31:12 <adrian_otto> one last topic to clear before we get to Summit Session Planning
16:31:25 <adrian_otto> tonanhngo: okay to assign you an action for that?
16:31:35 <tonanhngo> Sure
16:31:58 <adrian_otto> #action tonanhngo to lead am ML discussion to find potential solutions for secure Kuryr/Magnum integration.
16:32:05 <adrian_otto> s/am/an/
16:32:17 <adrian_otto> next topic is:
16:32:18 <adrian_otto> Grenade gate for testing upgrades (Drago)
16:32:42 <adrian_otto> #undo
16:32:42 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f66f46d4450>
16:32:59 <adrian_otto> #action tonanhngo to lead an ML discussion to find potential solutions for secure Kuryr/Magnum integration.
16:33:19 <adrian_otto> Drago: anything to cover for this week on this topic?
16:33:29 <Drago> So there is a project called Grenade that has a plugin that would allow us to test rolling upgrades to make sure no patch breaks upgrading from one version to the next
16:33:41 <Drago> Heat has such a gate. Here's their spec for it https://github.com/openstack/heat-specs/blob/master/specs/liberty/upgrade-tests.rst
16:34:01 <Drago> I think Magnum should have a grenade gate as well
16:34:13 <adrian_otto> #link https://github.com/openstack/heat-specs/blob/master/specs/liberty/upgrade-tests.rst Heat Grenade Gate
16:34:17 <jvgrant> +1
16:34:21 <adrian_otto> +1
16:34:22 <strigazi> for our service?
16:34:24 <muralia> +1
16:34:28 <strigazi> or to test the drivers?
16:34:29 <hongbin> Drago: what exactly we are going to use this project to test?
16:34:32 <adrian_otto> yes, strigazi
16:34:35 <Drago> For the service
16:34:43 <strigazi> ok
16:34:48 <strigazi> sounds good
16:35:03 <adrian_otto> any opposing points of view to consider?
16:35:08 <hongbin> I am still not sure what is covered by using that test?
16:35:46 <muralia> i guess we would test upgrades from the last magnum release (newton) to the latest in master
16:36:10 <hongbin> ok, that is basically a db migration
16:36:10 <Drago> hongbin: It ought to function as it does for Heat. So the spec (and its links) should have the info you need
16:36:32 <hongbin> ok, i need sometime to go though the spec
16:36:43 <Drago> hongbin: As I understand it, it runs the service at different versions at the same time too, so not just a db migration
16:37:06 <hongbin> so it run a mitaka magnum, and a newton magnum?
16:37:27 <Drago> Yes. Install M, upgrade one to N, then other to N
16:38:14 <hongbin> what kinds of pitfall this test is going to capture?
16:38:56 <hongbin> maybe we don't need to discuss teh details in this meeting
16:39:05 <Drago> hongbin: See https://github.com/openstack-dev/grenade#theory-of-upgrade
16:39:20 <hongbin> i am ok to postponse the discussion in irc
16:39:47 <adrian_otto> https://github.com/openstack/heat-specs/blob/master/specs/liberty/upgrade-tests.rst has a problem description section which would roughly apply to Magnum clusters as well.
16:40:09 <Drago> That's all I had
16:40:25 <adrian_otto> thanks Drago
16:40:35 <adrian_otto> #topic Summit Session Planning
16:40:59 <adrian_otto> #link https://etherpad.openstack.org/p/ocata-magnum-topics Summit Session Planning Etherpad
16:41:15 <adrian_otto> I'd like all of your input on the topics we should cover together in Barcelona
16:41:20 <strigazi> where is the old document?
16:41:29 <adrian_otto> one moment, I will look
16:42:00 <adrian_otto> was it https://etherpad.openstack.org/p/magnum-newton-midcycle-topics ?
16:42:17 <Drago> https://etherpad.openstack.org/p/magnum-newton-midcycle-topics-restored-998
16:42:19 <adrian_otto> the etherpad server seems really slow for me
16:42:22 <Drago> Restored link ^
16:42:23 <strigazi> https://etherpad.openstack.org/p/magnum-ocata-summit-topics
16:42:49 <strigazi> from here: http://eavesdrop.openstack.org/meetings/containers/2016/containers.2016-09-20-16.00.log.html
16:42:49 <adrian_otto> oh, let's not use mine then
16:42:59 <adrian_otto> Let's use this one:
16:43:04 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-newton-midcycle-topics
16:43:26 <adrian_otto> but that's for newton
16:43:34 <adrian_otto> so I will copy those over to here:
16:43:36 <Drago> adrian_otto: https://etherpad.openstack.org/p/magnum-ocata-summit-topics
16:43:47 <adrian_otto> right:
16:43:49 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-ocata-summit-topics
16:47:47 <Drago> Lots of typing going on in the etherpad. What did we want to discuss about this during the meeting?
16:49:33 <hongbin> Drago: i just took a lot at the Grenade project. it seems it is a good idea to use it in magnum
16:49:55 <Drago> hongbin: Good :)
16:50:38 <adrian_otto> Let's get the topics in the etherpad and put some votes on them to judge relative importance of each
16:50:59 <adrian_otto> and in a few minutes we can enter Open Discussion
16:51:12 <adrian_otto> we will revisit this again next week once I have matched what we have with our scheduled timeslots
16:53:11 <adrian_otto> our nodegroup pool design sessions will probably need 2 hours
16:53:54 <adrian_otto> thoughts on having both a fishbowl and discussion on that one?
16:54:24 <adrian_otto> ok, feel free to continue putting detail into the etherpad
16:54:35 <adrian_otto> I will enter open discussion as well now
16:54:41 <adrian_otto> #topic Open Discussion
16:55:03 <Drago> jvgrant and I are going to try go get as much of the spec ironed out as possible so that people can review it before the summit and we have a better idea of what needs to be discussed there
16:55:28 <adrian_otto> thanks Drago and jvgrant
16:55:29 <Drago> adrian_otto: Still +1 to fishbowl and discussion
16:55:51 <Drago> adrian_otto: Maybe have the fishbowl first?
16:56:23 <adrian_otto> ideally we would meet as a team and arrange our thoughts nicely around the spec, and then be ready to show that in a fishbowl for wider community input.
16:56:43 <adrian_otto> but I do see the wisdom in reversing it if we have a spec worked out in advance
16:56:59 <Drago> adrian_otto: Yes, that's what I was hoping the lead-up to the summit would be
16:57:24 <Drago> Otherwise I would agree that it'd make sense to do the fishbowl 2nd
16:57:26 <adrian_otto> I'd like us to be well prepared on all topics with supporting written plans (or problem statements) for each
16:57:47 <jvgrant> since we have all the initial design from mid-cycle and our first spec, it would be good to get a fishbowl, and then the last session to finalize to be ready to implement
16:58:06 <adrian_otto> ok, I'm happy to hold the fishbowl first, and then use a team session following that to act on the input.
16:58:20 <Drago> adrian_otto: Perhaps we should dedicate some time in the last weekly meeting before the summit to have a more focused discussion on NodeGroups
16:58:21 <adrian_otto> jvgrant: +1
16:58:44 <adrian_otto> okay, I can put our agendas up for the next two weeks
16:58:51 <adrian_otto> on the meetings page for Magnum
16:58:55 <Drago> Which would be the 18th? And let everyone know about that next week
16:59:01 <adrian_otto> yep
16:59:03 <Drago> Thanks
16:59:37 <Drago> jvgrant: Maybe we could have an action item to get as much of the spec done this week as we can
16:59:37 <adrian_otto> thanks everyone for attending today. Our next meeting will be 2016-10-11 at 1600 UTC
16:59:58 <adrian_otto> #endmeeting