16:00:25 <adrian_otto> #startmeeting containers
16:00:26 <openstack> Meeting started Tue Nov  1 16:00:25 2016 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-11-01_1600_UTC Our Agenda
16:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:31 <openstack> The meeting name has been set to 'containers'
16:00:32 <adrian_otto> #topic Roll Call
16:00:37 <adrian_otto> Adrian Otto
16:00:40 <strigazi> Spyros Trigazis
16:00:41 <muralia> murali allada
16:01:02 <randallburt> o/
16:01:03 <vijendar2> o/
16:01:04 <Drago5> o/
16:01:11 <jvgrant> Jaycen Grant
16:01:34 <adrian_otto> hello strigazi muralia randallburt vijendar2 Drago5 and jvgrant
16:02:46 <adrian_otto> #topic Announcements
16:02:56 <adrian_otto> 1) Daylight savings time ends in the US on Sunday Nov 6th at 2:00 AM. This will cause our meeting to take place an hour earlier in most local timezones because we track UTC. Check your calendar reminders to make sure they reflect the correct timezone.
16:03:32 <strigazi> Could we have calendar for this?
16:03:38 <adrian_otto> every time we have a shift in DST we always have contributors who suffer from scrambled calendars.
16:03:39 <strigazi> To update automatically?
16:03:55 <strigazi> The docs team I think has one, I can sk
16:04:00 <adrian_otto> strigazi: I have done that in the past, but that has it's own pitfalls
16:04:01 <strigazi> s/sk/ask
16:04:12 <adrian_otto> its own
16:04:13 <strigazi> Can't be set in UTC?
16:04:27 <strigazi> my docs calendar is correct after the change
16:04:32 <adrian_otto> yes, the solution is to look at what you have in your calendar, and adjust the timezone to UTC
16:04:41 <adrian_otto> and if it does not have that setting you can use GMT
16:05:26 <adrian_otto> and it's probably worth taking a quick look to see if that causes a scheduling conflict with your other commitments so you have time to address those.
16:05:27 <strigazi> ok
16:05:42 <adrian_otto> ok, any other announcements from team members?
16:06:15 <adrian_otto> Thanks to all of you who attended the summit, and for those of you who did not, we missed you.
16:06:33 <adrian_otto> #topic Review Action Items
16:06:41 <adrian_otto> 1) adrian_otto to email Magnum/Kuryr teams with details about joint meetup plans prior to summit. Status: COMPLETE
16:06:49 <adrian_otto> 2) strigazi to create a magnum-specs repo
16:06:51 <strigazi> It's happening https://review.openstack.org/#/c/391770/
16:07:02 <adrian_otto> Status: COMPLETE
16:07:10 <adrian_otto> thanks strigazi
16:07:25 <adrian_otto> #topic Blueprints/Bugs/Reviews/Ideas
16:07:28 <strigazi> not merged yet, I'll notify you all as soon as it is
16:07:35 <adrian_otto> Should we have a team meeting on Nov 22, or skip that date due to US holidays (Thanksgiving, Nov 24)?
16:07:58 <strigazi> I can't make it
16:07:59 <adrian_otto> the reason for my question is that it's very common for those in the US to take that week off of work to travel for the holiday
16:08:16 <adrian_otto> so if several of us would be absent, it might make sense to skip it
16:08:20 <strigazi> But if it's only me, I'm ok
16:08:26 <jvgrant> probably a good idea. attendance will be lite
16:08:45 <Drago> Do we have quorum rules?
16:08:45 * randallburt votes to skip it
16:09:15 <adrian_otto> no, we don't have a quorum rule. Whether we hold a meeting is the prerogative of the PTL.
16:09:30 <adrian_otto> ok, so I have two interested in a skip.
16:09:38 <adrian_otto> anyone feel strongly that we should hold it that week?
16:09:47 <vijendar_> skip +1
16:09:52 <adrian_otto> ok
16:10:06 <adrian_otto> #agreed we will not meet on 2016-11-22
16:10:15 <randallburt> request general review of the idea proposed https://review.openstack.org/#/c/389835. Should have an update with proposed class changes today.
16:10:35 <adrian_otto> #action adrian_otto to mark our agenda such that the 2016-11-22 meeting will be planned as cancelled.
16:11:06 <adrian_otto> thanks randallburt for proposing that
16:11:09 <randallburt> np
16:11:18 <adrian_otto> I'll definitely review that today
16:11:24 <randallburt> thanks!
16:11:32 <strigazi> Why this requires a new spec and not an update in the previous one? It seems to me like an involving work on the same subject
16:12:22 <adrian_otto> strigazi: best practice is not to modify a spec after implementation unless it would confuse our community
16:12:23 <strigazi> The bay-drivers spec only implies heat as default, doesn't explicitely say use only heat
16:12:28 <randallburt> strigazi:  I was unaware of the previous one. IIRC, though the other one extends lifecycle methods while this encapsulates existing ones
16:12:30 <strigazi> ok
16:12:56 <randallburt> strigazi:  but the implementation is highly coupled to Heat and Heat "bleeds" through to a *lot* of other places
16:13:40 <adrian_otto> randallburt: let's add a blueprint and link it in the commit message.
16:13:40 <strigazi> I'm not against it just clarifying
16:13:43 <randallburt> strigazi:  k
16:13:55 <randallburt> adrian_otto:
16:13:57 <randallburt> will do
16:14:23 <randallburt> hopefully I can spec this such that untangling won't be terribly difficult
16:14:37 <adrian_otto> okay, this week and next week, I'd like contributors who plan to complete new features to raise their blueprints for team review
16:14:51 <adrian_otto> so I can be sure that we have targeted them against the next release
16:15:13 <strigazi> https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades
16:16:16 <strigazi> #link https://review.openstack.org/392193
16:16:19 <strigazi> spec ^^
16:16:26 <strigazi> it's WIP
16:16:49 <adrian_otto> ok, I linked the spec to the BP for you
16:17:04 <vijenda__> I have submitted a spec/patch for review https://blueprints.launchpad.net/magnum/+spec/magnum-admin-api  https://review.openstack.org/#/c/391537/ and https://review.openstack.org/#/c/391301/
16:18:08 <adrian_otto> strigazi: https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades is now targeted to ocata-3.
16:18:21 <strigazi> Thanks
16:18:57 <Drago> Is this meeting going to go over news from the summit for those unable to attend?
16:18:57 <strigazi> Sorry, just remembered
16:19:13 <adrian_otto> Drago: yes, we can cover that
16:19:30 <strigazi> I ping the suse guys, and they want to add a third party CI for their suse k8s driver
16:21:04 <adrian_otto> vijenda__: is completion of the Admin API a short/medium/long term objective?
16:21:12 <adrian_otto> November, December, or January?
16:22:06 <vijendar1> adrian_otto:  it depends on what are all the features we wanted to implement in admin api
16:22:08 <adrian_otto> strigazi: that would be great
16:22:29 <adrian_otto> vijendar1: let's give it our best guess for now, and we can adjust if needed
16:22:48 <vijendar1> adrian_otto:  December
16:22:50 <adrian_otto> ok
16:23:16 <adrian_otto> vijendar1: that's now targeted for ocata-2.
16:23:24 <vijendar1> adrian_otto: ok. thanks
16:23:52 <adrian_otto> ok, before we proceed to summit review, are there any more BP's to review?
16:24:25 <strigazi> Is the osc bp accepted for ocata?
16:24:41 <jvgrant> Drago: will the nodegroup additions we discussed yesterday be new blueprints or just part of the same one?
16:24:53 <adrian_otto> strigazi: have a link to that tone handy?
16:24:55 <Drago> jvgrant: I think separate, with separate specs
16:25:08 <strigazi> adrian_otto, looking
16:25:28 <Drago> jvgrant: But that falls under the adding of blueprints in the next couple weeks that adrian_otto mentioned
16:25:30 <strigazi> Drago jvgrant I added some notes on the versioning
16:25:46 <jvgrant> Drago: ok
16:25:48 <strigazi> I can add  a spec too
16:26:01 <Drago> strigazi, jvgrant: Can we talk about strigazi's spec after?
16:26:17 <jvgrant> sure
16:26:21 <strigazi> adrian_otto: https://blueprints.launchpad.net/magnum/+spec/openstackclient-support
16:26:34 <strigazi> Drago jvgrant OK
16:27:03 <strigazi> We can ask the team now for the general direction and add details later today
16:27:08 <adrian_otto> that blueprint is a perfect example of what not to do
16:27:15 * adrian_otto fixing it.
16:27:17 <adrian_otto> one morment
16:27:28 <strigazi> adrian_otto the OSC?
16:27:37 <adrian_otto> yeah, that's a mess
16:28:44 <adrian_otto> ok, done.
16:29:03 <strigazi> Drago jvgrant, CT versions are a dependncy for upgrades and upgrades is my #1 priority
16:29:13 <adrian_otto> #topic OpenStack Summit Restrospective
16:29:40 <Drago> strigazi: Good to know
16:29:40 <strigazi> I can start on this one and work in parallel with nodegroups
16:30:36 <adrian_otto> so, last week was the OpenStack summit. All of the general sessions were recorded and are available here for review:
16:30:45 <adrian_otto> #link https://www.openstack.org/videos/summits/show/7 Summit Videos
16:32:32 <adrian_otto> I explained Magnum on stage with Jonathan Bryce in the day-2 keynote: https://www.youtube.com/watch?v=Tmub7D6JS24 along with the PTLs from Kolla and Kuryr
16:32:59 <adrian_otto> Drago and I gave a Magnum+OpenStack Ansible workshop
16:33:11 <adrian_otto> with ~100 attendees
16:33:29 <adrian_otto> that was not recorded, and neither were the Design Summit Sessions, of which we had several.
16:33:49 <Drago> The OpenSUSE guys gave a Magnum+k8s talk and it was packed.
16:33:53 <adrian_otto> the key topics were the NextGen (NodeGroup) and related changes to Magnum
16:34:29 <adrian_otto> tango and winnie from IBM gave a talk with strigazi and Ricardo from CERN on magnum scalability
16:34:35 <adrian_otto> let's share a link to each of these
16:35:04 <adrian_otto> #link https://www.openstack.org/videos/video/toward-10000-containers-on-openstack Toward 10,000 Containers on OpenStack
16:36:00 <Drago> #link https://www.openstack.org/videos/video/openstack-and-magnum-kubernetes-as-a-service-for-everyone OpenSUSE's Magnum+k8s talk
16:36:05 <adrian_otto> yep!
16:37:01 <adrian_otto> another key topic in the design summit was the topic of lifecycle operations and upgrades, where we got some valuable community input
16:37:31 <adrian_otto> we had a joint session with the Kuryr team, and another with the Keystone team
16:38:08 <adrian_otto> on the networking side, there was strong affirmation of the use case of connecting VMs and Containers together on common private neutron networks.
16:39:32 <Drago> +1
16:41:15 <adrian_otto> we did reach a consensus in our work room sessions about our intended policy for glance image builds
16:41:52 <adrian_otto> we decided to do our best to build new images for each new COE release as they are announced so the "current" release of each is consistently supported in Mangum
16:42:21 <adrian_otto> we will offer documentation for cloud operators to build their own images if they prefer to use upstream linux distro packaging instead of code directly from the COE community teams.
16:42:51 <adrian_otto> strigazi volunteered to kick off the required build on these occasions.
16:42:56 <randallburt> nice. image building is a pain.
16:43:10 <adrian_otto> we can make that process pretty smooth, we think
16:43:29 <adrian_otto> and we think it can be automated to a large extent
16:43:36 <randallburt> yep
16:43:54 <strigazi> if it's not automated it's not done :)
16:44:01 <randallburt> so true
16:44:02 <adrian_otto> so we'll work with strigazi to prove that hunch
16:44:24 <randallburt> problem is getting the upstream distros to keep up
16:44:33 <adrian_otto> any other key takeaways from the summit that team members would like to share?
16:44:59 <strigazi> We'll try to offer ubuntu cluster drivers too
16:45:16 <strigazi> rg For users with contracts with canonical
16:45:20 <strigazi> eg For users with contracts with canonical
16:45:29 <Drago> #link https://wiki.openstack.org/wiki/Design_Summit/Ocata/Etherpads#Magnum Magnum etherpads from the summit
16:45:52 <adrian_otto> I also did some thinking about the inclusion criteria for new drivers.
16:46:36 <adrian_otto> as long as the driver is known to work with at least one production use case, has at least one maintainer committed to keeping it updated, and has a third party CI to verify it works, then we can allow it in trunk.
16:46:58 <adrian_otto> otherwise, they can live in contrib with a support caveat statement.
16:47:05 <strigazi> sounds reasonable
16:48:09 <adrian_otto> ok, let's proceed to open discussion... unless there are questions or concerns about the above?
16:48:31 <strigazi> A question,
16:49:16 <strigazi> we won't remove the current CIs for swarm, k8s, mesos, and ironic, right?
16:49:20 <adrian_otto> I did not mention that the day 1 keynote had a magnum demo in it
16:50:02 <adrian_otto> #link https://www.openstack.org/videos/video/openstack-for-the-work-that-matters-1 Keynote with Magnum demo
16:50:57 <adrian_otto> strigazi: we should be open to moving driver testing to third party CI if they require features that openstack CI does not support (ie: multi-node)
16:51:18 <adrian_otto> but we must not take a step backward in either unit testing or functional testing.
16:51:30 <strigazi> makes sense
16:51:52 <adrian_otto> ok
16:51:52 <adrian_otto> #topic Open Discussion
16:51:54 <yatin> I wish to work on following bp's and i need direction on them so i can proceed:
16:51:57 <yatin> https://blueprints.launchpad.net/magnum/+spec/secure-etcd-cluster-coe
16:52:03 <yatin> https://blueprints.launchpad.net/magnum/+spec/add-support-different-strategy-in-swarmbay
16:52:08 <yatin> https://blueprints.launchpad.net/magnum/+spec/secure-etcd-cluster-coe(Not sure why same bp name is registered)(Increase UT Coverage for magnumclient and add coverage job to CI)
16:52:18 <adrian_otto> ok, taking a look
16:53:32 <Drago> yatin: Do you mean https://blueprints.launchpad.net/magnum/+spec/magnumclient-ut-coverage ?
16:53:39 <yatin> Yes
16:53:45 <strigazi> secure-etcd-cluster-coe it very much needed
16:53:52 <adrian_otto> yatin, do you have enough time to submit patches for each of these?
16:53:58 <yatin> Yes
16:54:13 <adrian_otto> ok, I targeted the first one for ocata-1 and marked it as Essential.
16:54:32 <yatin> i can start from this week
16:54:41 <strigazi> add-support-different-strategy-in-swarmbay I think we need some more details
16:54:54 <adrian_otto> wait, we have two different blueprints with the same URL? How is that possible?
16:55:13 <Drago> adrian_otto: I don't think we do...
16:55:13 <yatin> Yes, i am also not sure why it happend:
16:55:37 <strigazi> Drago +1
16:55:45 <yatin> the url mentioned by Drago is the correct one.
16:55:52 <yatin> https://blueprints.launchpad.net/magnum/+spec/magnumclient-ut-coverage
16:56:46 <adrian_otto> yatin: https://blueprints.launchpad.net/magnum/+spec/add-support-different-strategy-in-swarmbay is now approved and targeted for ocata-2.
16:57:40 <yatin> adrian, can you assign me this as i tried to contact xianchaobo twice but hasn't received the reply.
16:58:17 <adrian_otto> yes
16:58:39 <adrian_otto> yatin: https://blueprints.launchpad.net/magnum/+spec/magnumclient-ut-coverage is now approved and targeted for ocata-2.
16:59:05 <yatin> adrian: Thanks
16:59:24 <adrian_otto> yatin, what's your exact launchpad id?
16:59:43 <yatin> yatinkarel
16:59:52 <adrian_otto> ok
17:00:05 <adrian_otto> done
17:00:39 <adrian_otto> you are now the assignee on add-support-different-strategy-in-swarmbay. Please coordinate with  xianchaobo to make sure you don't duplicate work.
17:01:03 <adrian_otto> time up
17:01:28 <adrian_otto> next meeting: 2016-11-08 at UTC 1600
17:01:31 <adrian_otto> #endmeeting