16:01:46 <adrian_otto> #startmeeting containers
16:01:47 <openstack> Meeting started Tue Nov 29 16:01:46 2016 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:51 <openstack> The meeting name has been set to 'containers'
16:02:21 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-11-29_1600_UTC Our Agenda
16:02:25 <adrian_otto> #topic Roll Call
16:02:28 <adrian_otto> Adrian Otto
16:02:29 <jvgrant> Jaycen Grant
16:02:34 <tonanhngo> Ton Ngo
16:02:38 <hongbin> o/
16:02:45 <yatin> Yatin Karel
16:02:46 <randallburt> o/
16:02:54 <strigazi> Spyros Trigazis
16:02:57 <rpothier> Rob Pothier
16:03:05 <Drago_> o/
16:03:19 <jasond> o/
16:03:24 <adrian_otto> welcome jvgrant tonanhngo hongbin randallburt yatin strigazi rpothier Drago_ and jasond
16:04:09 <adrian_otto> #topic Announcements
16:04:38 <adrian_otto> We usually skip meetings during key holiday weeks, as we did last week. December 25th is a major holiday, and we have a meeting that may be scheduled for Dec 27th.
16:05:10 <adrian_otto> I wanted to get a sense of how many of us will be at work that day, and whether it makes sense to plan to skip that one.
16:05:12 <adrian_otto> thoughts?
16:05:32 <Drago_> Skip
16:05:36 <randallburt> Skip
16:05:43 <strigazi> skip
16:05:44 <tonanhngo> Skip
16:05:45 <yatin> Skip
16:05:48 <jvgrant> skip
16:06:09 <adrian_otto> #agreed we will skip our meeting on 2016-12-27
16:06:10 <adrian_otto> thanks!
16:06:17 <adrian_otto> any announcements form team members?
16:06:22 <adrian_otto> s/form/from/
16:07:21 <adrian_otto> #topic Review Action Items
16:07:30 <adrian_otto> 1) ACTION: strigazi to start a ML thread about cluster-drivers repo
16:08:11 <adrian_otto> strigazi: did we open this thread as planned?
16:08:11 <strigazi> DONE, fetching the link
16:08:16 <adrian_otto> thanks.
16:08:43 <strigazi> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107613.html
16:09:00 <adrian_otto> perfect, thanks.
16:09:03 <adrian_otto> #topic Blueprints/Bugs/Reviews/Ideas
16:09:13 <adrian_otto> We have 4 essential blueprints to touch on
16:09:22 <adrian_otto> and then we can expand to additional work items
16:09:36 <adrian_otto> #link https://blueprints.launchpad.net/magnum/ocata Ocata Blueprints
16:10:09 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/nodegroups Nodegroups (Drago)
16:10:12 <adrian_otto> this is (1/4)
16:10:36 <Drago_> The spec is ready for feedback
16:10:57 <Drago_> jvgrant has finished all of the TODOs in the spec and removed the WIP tag
16:11:13 <adrian_otto> #link https://review.openstack.org/352734 Nodegroup Spec
16:11:26 <Drago_> We have decided to push the Heat changes into its own blueprint
16:11:50 <adrian_otto> looks like tonanhngo and hongbin have asked for revisions
16:12:00 <jvgrant> the general idea is in the nodegroup spec but all the heat details will be in the separate spec
16:12:01 <Drago_> https://blueprints.launchpad.net/magnum/+spec/nodegroups-heat
16:12:55 <adrian_otto> looks like some of Ton's remarks still need to be addressed. Is that assessment fair?
16:13:02 <jvgrant> adrain_otto: i'll go over those today and update the review
16:13:20 <adrian_otto> ok, do we have any big gaps to clear to merge the spec?
16:13:50 <adrian_otto> if not, we can advance to the next status item. I just want to give this one fair time for discussion, if needed.
16:14:02 <Drago_> No, only small things
16:14:09 <adrian_otto> ok, thanks.
16:14:10 <jvgrant> maybe? It looks like from the template version review that there might be some questions around how the templates work now
16:14:13 <Drago_> It would help if others would give their feedback for it
16:14:30 <adrian_otto> next is (2/4):
16:14:37 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/template-versioning Template Versioning
16:14:46 <adrian_otto> jvgrant: remarks?
16:15:18 <jvgrant> Under review.  Lots of discussion.  Mostly on how the versioning will be used by the upgrade spec and the changes from node groups
16:15:42 <adrian_otto> #link https://review.openstack.org/392327 WIP Spec for Template Versioning
16:15:44 <jvgrant> the change to the data structure will be important to support both.
16:16:32 <tonanhngo> It would help if we have a description of how the specs depends on each other, or a high level view showing how things are divided up
16:16:44 <tonanhngo> not sure where to put this.
16:16:49 <Drago1> We need to take time today to discuss this spec
16:16:57 <hongbin> i think we need an etherpad to work everything out
16:17:20 <tonanhngo> one way is for each spec to descripe the expectation from other specs
16:17:23 <jvgrant> agreed, there seemed to be some confusion on the interactions between each spec
16:17:24 <adrian_otto> I can create one if we don't already have one
16:17:29 <yatin> I too tried to understand idea but got confused with flatten attributes/template versions/cluster upgrades/node groups
16:18:09 <adrian_otto> they are all related, so that confusion is understandable.
16:18:13 <Drago1> Do we need a super-spec
16:18:33 <adrian_otto> We could make a "2.0" blueprint to link to each spec
16:18:33 <jvgrant> that is why they were broken out into separate specs to help, but we lose the big picture some
16:18:41 <jvgrant> i think an etherpad showing the connections will help
16:18:57 <adrian_otto> ok, let's start with an etherpad that helps relate them
16:18:59 <adrian_otto> one moment
16:20:25 <adrian_otto> #link https://etherpad.openstack.org/p/ocata-magnum-next-api Next API Etherpad
16:21:37 <adrian_otto> ok, so we have the start of that there
16:21:52 <adrian_otto> please fill that in with concerns. We can spend 10 minutes now on this
16:31:12 <Drago1> tonanhngo: I really liked your concept of having attributes be basically dedicated to specific commands
16:31:52 <tonanhngo> Drago1: I think it helps the users also to understand and manage the attributes
16:32:12 <Drago1> jvgrant: ^
16:32:24 <strigazi> ^^ where is this comment?
16:32:31 <Drago1> strigazi: sec
16:33:04 <Drago1> strigazi: tonanhngo's most recent comment on https://review.openstack.org/#/c/392327/
16:33:21 <adrian_otto> ok, so I think we have the start of an etherpad there that we can use to weave the overall story together
16:33:44 <adrian_otto> we don't need to perfect it this minute, but I would like to get the concerns listed so we can be sure to address them all
16:34:06 <strigazi> I think we try to do the biggest set changes in the smallest cycle so far :)
16:34:47 <tonanhngo> Some part of the etherpad can go into a release note or something to explain to users the concept in V2 API
16:35:18 <jvgrant> strigazi: agreed, that is why we need to be careful about doing too much. I know there is a lot we could do with these new features but we should do the iteratively
16:36:27 <adrian_otto> yatin: was this etherpad enough to clear up your concerns, or are there ideas that we need to tighten up?
16:36:43 <yatin> Ethepad would be a great plus
16:37:45 <adrian_otto> ok, let's advance to the next status item unless we need further discussion on this today
16:37:50 <adrian_otto> agreed?
16:37:58 <Drago1> No
16:38:04 <jvgrant> just one question i wanted to make sure was clear
16:38:17 <adrian_otto> ok, we can stay on this
16:38:21 <jvgrant> does everyone understand how templates work in the new version?
16:38:35 <Drago1> Well, I guess we can move on but I'd like to come back to template versioning and cluster/clustertemplate attribute handling
16:38:46 <jvgrant> previously our ClusterTemplates had separate info that got pulled into even the driver
16:39:08 <hongbin> jvgrant: i think you can clarify them in the etherpad
16:39:15 <hongbin> jvgrant: under the "operations" session
16:39:43 <jvgrant> now they will just be a reference that has the same attributes as cluster and used for ease of use for users
16:40:53 <jvgrant> hongbin: ok, will do
16:41:39 <hongbin> jvgrant: i think you can update the "data model" session as well (add the template version tables there)
16:42:09 <jvgrant> hongbin: ok, good idea
16:42:14 <adrian_otto> jvgrant: can you look at line 32 and see if the bracketed wording makes sense. I'm struggling to articulate the summary of that.
16:42:18 <hongbin> then, i will explain why i don't think it is a good idea to design the data model in that way
16:42:45 <yatin> jvgrant: This was the same impression i got when looked flatten attributes but after reading template version things started getting confused, i will revisit again the spec and etherpad.
16:43:12 <adrian_otto> ok, we are running low on time, so let's touch on the other two essential blueprints now, and enter open discussion. We can revisit this there as well.
16:43:30 <yatin> adrian_otto: Ok
16:43:41 <adrian_otto> item (3/4)
16:43:47 <Drago1> jvgrant, adrian_otto: It's awfully nodegroup-centric
16:44:18 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/flatten-attributes Flatten Attributes (strigazi)
16:44:36 <adrian_otto> this one is still marked as New.
16:44:47 <Drago1> Spec has been merged
16:44:59 <Drago1> Thanks all for reviewing
16:45:17 <strigazi> I have done good progress I'll submit soon for final reviewing
16:45:31 <adrian_otto> #link https://review.openstack.org/393094 Flatten Attributes Spec
16:45:51 <strigazi> The changes concern only the data model, the functionality remains the same
16:46:09 <adrian_otto> ok, so marked the definition as Approved
16:46:14 <strigazi> thanks
16:46:54 <adrian_otto> and I marked it as Started
16:47:11 <strigazi> one thing
16:47:43 <strigazi> this change modifies the two major tables in our db
16:48:03 <strigazi> and we don't have tests to do validations
16:48:20 <strigazi> like pre and post modification tests
16:48:32 <adrian_otto> should we add those as work items?
16:48:44 <adrian_otto> seems reasonable
16:49:14 <strigazi> I think this is  a separate task, not sure if I can pull it off by myself easily
16:49:47 <Drago1> strigazi: Are you talking about something like the grenade gate?
16:49:50 <adrian_otto> well, we can at least describe the desired result
16:50:28 <strigazi> eg https://github.com/openstack/ironic/blob/master/ironic/tests/unit/db/sqlalchemy/test_migrations.py
16:50:37 <Drago1> Okay, will look
16:50:51 <adrian_otto> ok, anything more on this status item?
16:50:55 <strigazi> no
16:50:57 <adrian_otto> last one (4/4) is:
16:51:30 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-etcd-cluster-coe Secure Central Data store , etcd (yatin)
16:51:40 <yatin> Submitted 1st patch for review: https://review.openstack.org/403501
16:54:17 <adrian_otto> ok
16:54:18 <strigazi> fyi, swarm-mode doesn't need etcd and let me ask, should I push a v2 swarm in a new dir or on the current driver?
16:54:25 <adrian_otto> great progress, thanks yatin!
16:54:36 <yatin> Ricardo has some suggestions, if others can look over it then i can give it a go and proceed with same approach for kubernetes as well.
16:54:59 <yatin> strigazi: Yes i checked a bp is there for swarm-mode
16:55:34 <adrian_otto> ok, that concludes status on essential blueprints. Any other work items we can touch on during open discussion
16:55:35 <strigazi> yes on what? we will have two swarm drivers?
16:55:45 <adrian_otto> #topic Open Discussion
16:56:02 <vijendar1> could you guys review this spec https://review.openstack.org/#/c/391537/
16:56:24 <vijendar1> please provide your feedback/comments
16:57:34 <yatin> strigazi: Yes for swarm mode don't require etcd,
16:58:55 <adrian_otto> strigazi: yes, that's right.
16:58:56 <yatin> strigazi: I think it would be a separate cluster driver
16:59:07 <adrian_otto> it should be a separate driver
16:59:10 <strigazi> ok, thanks
16:59:15 <strigazi> that was my question
16:59:18 <yatin> strigazi: System got too slow, sorry for that\
16:59:48 <adrian_otto> hongbin: did you have a moment to look at https://review.openstack.org/391537 (vijendar1)
17:00:09 <adrian_otto> I'm happy to work through your concerns.
17:00:27 <hongbin> will get back to the review (sorry, i am focusing on the template version spec right now)
17:00:41 <adrian_otto> our next meeting will be 2016-12-06 at 1600 UTC. Thanks everyone for attending!
17:00:47 <adrian_otto> #endmeeting