16:00:00 <adrian_otto> #startmeeting containers
16:00:01 <openstack> Meeting started Tue Jan  3 16:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'containers'
16:00:07 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-01-03_1600_UTC Our Agenda
16:00:17 <Drago> o/
16:00:57 <adrian_otto> #topic Roll Call
16:00:57 <adrian_otto> Adrian Otto
16:01:01 <jasond> o/
16:01:02 <randallburt1> o/
16:01:04 <hieulq_> o/
16:01:05 <jvgrant> Jaycen Grant
16:01:23 <hongbin> o/
16:01:26 <randallburt> o/
16:01:29 <randallburt> that's better
16:01:32 <adrian_otto> hello jasond jvgrant Drago randallburt and hongbin
16:02:41 <adrian_otto> While we await other attendees, I'll share that I thought it was interesting that there are five Tuesdays in January this year.
16:03:43 <adrian_otto> strigazi mentioned that he will not attend today, but will join us next week.
16:04:02 <adrian_otto> #topic Announcements
16:04:34 <adrian_otto> 1) Happy New Year! I'm looking forward to a great 2017!
16:05:06 <adrian_otto> I'm glad to see you back after the holidays, and extend gratitude to those who worked straight through.
16:05:23 <adrian_otto> any announcements from team members?
16:06:01 <adrian_otto> #topic Review Action Items
16:06:04 <adrian_otto> 1) ACTION: adrian_otto to add http://lists.openstack.org/pipermail/openstack-dev/2016-November/107613.html to our 2012-01-03 team meeting agenda.
16:06:10 <adrian_otto> Status: Complete
16:06:18 <adrian_otto> we will cover this later in the agenda
16:06:27 <adrian_otto> #topic Blueprints/Bugs/Reviews/Ideas
16:06:32 <adrian_otto> Essential Blueprints
16:06:47 <adrian_otto> I expect many/most of these will have no comments this meeting
16:06:53 <adrian_otto> 1) #link https://blueprints.launchpad.net/magnum/+spec/flatten-attributes Flatten Attributes [strigazi]
16:07:10 <adrian_otto> strigazi is not here to comment. Anyone else have remarks on this?
16:07:32 <adrian_otto> 2) #link https://blueprints.launchpad.net/magnum/+spec/nodegroups Nedegroups [Drago]
16:07:52 <Drago> I'm back from vacation. Happy New Year to everyone. No update.
16:07:57 <jvgrant> I updated the spec and review a couple weeks ago
16:08:11 <jvgrant> to address concerns, waiting on further feedback
16:08:17 <adrian_otto> ok, I'll plan to review the spec
16:08:19 <jvgrant> https://review.openstack.org/#/c/352734/
16:09:17 <adrian_otto> thanks jvgrant
16:09:23 <adrian_otto> any other discussion on this BP?
16:10:07 <adrian_otto> 3) #link https://blueprints.launchpad.net/magnum/+spec/secure-etcd-cluster-coe Secure Central Data store(etcd) [yatin]
16:10:17 <adrian_otto> yatin is not here to comment. Anyone else have remarks on this?
16:10:26 <adrian_otto> I see that it still has at least one review remaining open
16:10:35 <adrian_otto> but looks close to finished to me.
16:10:41 <adrian_otto> any other remarks on this?
16:11:07 <adrian_otto> 4) #link https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades Cluster Upgrades [strigazi]
16:11:09 <adrian_otto> strigazi is not here to comment. Anyone else have remarks on this?
16:11:42 <adrian_otto> Other Work Items (none)
16:11:48 <adrian_otto> #topic Managing cluster drivers as individual distro packages
16:11:57 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107613.html
16:13:06 <adrian_otto> My gut reaction is to handle this in tree to keep it simple to begin with, and break it out if it becomes burdensome. Thoughts?
16:13:59 <hongbin> the tc was discussing a similar topic (how to deal with third party driver)
16:14:01 <Drago> Is there a way to have them in-tree but be installable, so that they can be uninstalled just like a third-party driver?
16:14:18 <hongbin> it is better to wait for the tc to make a decision, then come back to how to deal with it in magnum
16:14:54 <Drago> In-tree is good for development and trying magnum out, but I think it should be easy to remove the default drivers
16:15:07 <randallburt> hongbin:  were they on their way to giving guidance or are they just starting discussion?
16:15:28 <hongbin> i think they are in the middle of the discussion
16:16:03 <randallburt> hongbin:  cool, then yeah, I think I agree with adrian_otto and hongbin in that its fine for now and then see what tc says in a few weeks
16:16:17 <jasond> i also like in-tree for ease of development
16:16:34 <jasond> it worked well for heat resources
16:16:43 <randallburt> jasond:  yeah, makes dev easy but not fun for operators
16:16:44 <adrian_otto> So we could start in-tree (option 1) and revisit that if the tc offers actionable guidance to the contrary
16:17:13 <randallburt> jasond:  its a bit of a pita for Heat resources tbh. This same discussion comes up in Heat ever other cycle too
16:17:32 <Drago> If we don't have them in-tree, we'll probably have to have a package for common driver files too or completely duplicate everything. Not fun
16:17:40 <jasond> randallburt: we could always separate them out once the code becomes more stable
16:18:26 <randallburt> jasond:  agreed. doing it now while the driver interface was just updated isn't a great idea
16:18:57 <randallburt> and we'll need a stable driver interface if we want to separate and encourage third party driver dev
16:19:01 <adrian_otto> hongbin: do you have any objections to starting in tree-and breaking out later?
16:19:18 <hongbin> adrian_otto: np from me
16:19:44 <adrian_otto> ok, I'll record an action item to respond to the thread referencing this chat
16:20:07 <adrian_otto> #action adrian_otto to respond to http://lists.openstack.org/pipermail/openstack-dev/2016-November/107613.html with a reference to this chat.
16:20:17 <adrian_otto> any other remarks on this topic?
16:20:31 <adrian_otto> #topic Open Discussion
16:21:16 <adrian_otto> We plowed through the agenda in record pace. Looks like we can afford to end early today.
16:22:00 <hieulq_> hi adrian_otto
16:22:07 <adrian_otto> hieulq_: hi
16:22:19 <hieulq_> I proposed the BP related to integrate OSProfiler in Magnum
16:22:20 <hieulq_> https://blueprints.launchpad.net/magnum/+spec/osprofiler-support-in-magnum
16:22:28 <hieulq_> Can you take a look?
16:22:31 <adrian_otto> ok
16:22:45 <hieulq_> Thanks :)
16:25:33 <adrian_otto> hieulq: if we approved this blueprint, is this something you could commit to completion in the Ocata release cycle? That gives you less than a month.
16:26:53 <adrian_otto> #link https://releases.openstack.org/ocata/schedule.html Ocata Release Schedule
16:27:32 <adrian_otto> Jan 23 it would need to be frozen.
16:28:21 <adrian_otto> hieulq: you still there?
16:28:27 <hieulq_> adrian_otto: yes
16:28:33 <hieulq_> Just thinking about the plan
16:28:45 <hieulq_> I'm preparing some patch-set related to this BP
16:29:20 <hieulq_> But it could miss the frozen date
16:30:04 <adrian_otto> I suppose that's not a problem as long as it's added in a way that's disabled by default, and has clear comments that it's not yet supported.
16:30:04 <hongbin> is there any reason the bp has to land in ocata?
16:30:38 <adrian_otto> I was worried about having a partially completed feature that we may need to patch out
16:31:20 <hongbin> there are potentially a few partially completed features (e.g. nodegroup, upgrade). i think that is unavoidable
16:31:54 <hieulq_> hongbin: yes
16:32:52 <hieulq_> hongbin: so it's better to wait till next cycle, right?
16:33:43 <hongbin> hieulq_: personally, i don't think it is necessary to wait, just start the implementation right away should be ok.
16:34:13 <hieulq_> hongbin: I'm on my way to implement it :-)
16:34:25 <hieulq_> And it could help us a lot in debugging the problem
16:35:07 <hieulq_> so I hope this BP at least got approved
16:38:22 <adrian_otto> approved
16:38:25 <adrian_otto> thanks hieulq
16:38:38 <adrian_otto> any other discussion before we wrap up today?
16:38:52 <hieulq_> Thanks adrian_otto
16:39:24 <adrian_otto> Our next team meeting will be on 2017-01-10 at 1600 UTC. See you then!
16:39:28 <adrian_otto> #endmeeting