16:01:14 <juggler> #startmeeting containers
16:01:14 <openstack> Meeting started Tue Apr 25 16:01:14 2017 UTC and is due to finish in 60 minutes. The chair is juggler. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:15 <tmorin1> have a good meeting :)
16:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:18 <openstack> The meeting name has been set to 'containers'
16:01:22 <juggler> ty tmorin1
16:01:26 <adrian_otto> I asked juggler to start for me
16:01:36 <adrian_otto> Our Agenda: https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-04-25_1600_UTC
16:01:43 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-04-25_1600_UTC Our Agenda
16:02:04 <juggler> #topic Roll Call
16:02:09 <adrian_otto> Adrian Otto
16:02:23 <strigazi> Spyros Trigazis
16:02:25 <tonanhngo> Ton Ngo
16:03:03 <juggler> Perry Rivera
16:03:27 <juggler> hello adrian_otto strigazi tonanhngo...welcome!
16:03:38 <juggler> #topic Announcements
16:04:12 <adrian_otto> no announcements prepared
16:04:33 <adrian_otto> I am at the departure gate for a flight this morning, so I am unable to stay for the full duration of our scheduled time
16:04:35 <juggler> any additional announcements all?
16:04:42 <adrian_otto> I anticipate we'll have a shorter meeting
16:05:22 <juggler> ok..moving on...
16:05:24 <juggler> #topic Review Action Items
16:05:40 <juggler> no additional Action Items planned...
16:05:45 <juggler> Any new ones to add?
16:06:21 <adrian_otto> strigazi: I did not notice any actions in the past meeting transcript
16:06:27 <adrian_otto> there were none, correct?
16:06:30 <strigazi> yes
16:06:33 <adrian_otto> ok, thanks
16:06:51 <juggler> great strigazi!
16:07:24 <juggler> ok..moving on...
16:07:26 <juggler> #topic Blueprints/Bugs/Reviews/Ideas
16:07:39 <juggler> we have 3 items scheduled to cover..
16:07:50 <strigazi> I was on holidays last week,
16:07:51 <juggler> #link https://blueprints.launchpad.net/magnum/+spec/flatten-attributes
16:08:04 <adrian_otto> strigazi: did you want to cover the heat-agent topic this morning?
16:08:13 <strigazi> so I don't have anything to report.
16:08:20 <strigazi> adrian_otto yes
16:08:24 <strigazi> before that
16:08:37 <adrian_otto> I'm sure that there are no updates for the essential blueprints this week
16:09:10 <juggler> next up:
16:09:11 <juggler> #link https://blueprints.launchpad.net/magnum/+spec/nodegroups
16:09:32 <juggler> don't recall seeing Drago here today...
16:09:44 <juggler> any info on this one?
16:11:10 <strigazi> nothing here
16:11:26 <juggler> ok...moving on...
16:11:42 <juggler> strigazi, any news on:
16:11:43 <juggler> #link https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades
16:11:43 <juggler> or
16:11:54 <juggler> the addl work item?
16:12:08 <adrian_otto> let's get to the head-agent topic
16:12:11 <adrian_otto> heat
16:12:20 <strigazi> ok
16:12:22 <juggler> ok
16:12:30 <juggler> #topic Work Item
16:12:47 <juggler> #link 30mb compressed / uncompressed 111mb containerized heat-agent based on alpine linux. https://hub.docker.com/r/strigazi/heat-container-agent/tags/
16:12:53 <juggler> oops correction:
16:13:13 <juggler> #link https://hub.docker.com/r/strigazi/heat-container-agent/tags/ 30mb compressed / uncompressed 111mb containerized heat-agent based on alpine linux.
16:13:23 <juggler> go for it strigazi
16:14:22 <strigazi> I tried it and seems to work fine. Could be used for use cases where if we can mount specific dirs
16:15:02 <strigazi> I don't know how it will go on the ci
16:15:23 <strigazi> another thing I tried was a "magnum agent"
16:15:48 <juggler> how did that go?
16:16:00 <strigazi> not really an agent. I just put all our scripts an manifests in an alpine container ~5mb
16:16:08 <strigazi> ok ~6mb
16:16:30 <juggler> nice
16:16:40 <strigazi> great! but it's like putting a large amount of magnum in a container
16:16:48 <adrian_otto> strigazi: does that image need to download more python libs, or does it have everything it needs to run?
16:16:55 <strigazi> bash
16:17:09 <strigazi> only bash
16:17:20 <juggler> ah
16:17:20 <adrian_otto> oh, ok
16:17:26 <strigazi> to be percise sh
16:17:32 <strigazi> not even bash
16:17:44 <juggler> any recommendations from your end?
16:17:51 <juggler> (to strigazi)
16:18:07 <strigazi> I don't know about that direction, it's like a data container
16:18:36 <juggler> ok
16:18:43 <adrian_otto> it's hard to get valid testing around an approach like this
16:18:43 <strigazi> It mostly solves the user data limit problem
16:18:46 <juggler> thanks for your valuable feedback
16:18:49 <juggler> strigazi
16:18:57 <adrian_otto> specifically, no unit tests.
16:19:25 <juggler> #topic Open Discussion
16:19:28 <adrian_otto> but considering how simple this is, it might not justify a unit test
16:19:36 <adrian_otto> https://hub.docker.com/r/strigazi/heat-container-agent/~/dockerfile/ is pretty thin :-)
16:19:57 <juggler> Entering Open Discussion...any topics/q's/concerns?
16:20:01 <adrian_otto> oh, on another subject, I think we should switch to meeting every two weeks
16:20:05 <adrian_otto> rather than weekly
16:20:13 <adrian_otto> thoughts?
16:20:21 <strigazi> works for me
16:20:23 <tonanhngo> Seems reasonable
16:20:38 <adrian_otto> ok, anyone opposed to it?
16:21:24 <tonanhngo> we can always switch back to weekly if necessary
16:21:39 <juggler> good thought
16:21:40 <adrian_otto> cool, I'll take that as an action item
16:21:41 <juggler> #action adrian_otto to update team meeting schedule to */2 weeks
16:21:46 <adrian_otto> thanks juggler
16:22:00 <juggler> well, if there is no other news, shall we adjourn?
16:22:07 <strigazi> sure
16:22:20 <adrian_otto> that's all I wanted to cover today, thanks juggler for your help
16:22:41 <adrian_otto> oh wait
16:22:52 <adrian_otto> two weeks form now is during the OpenStack Summit in Boston
16:23:03 <juggler> ah yes, who is attending?
16:23:09 <strigazi> me
16:23:12 <tonanhngo> I will be there
16:23:13 <juggler> not me :(
16:23:15 <adrian_otto> so our next meeting should be three weeks out
16:23:16 <adrian_otto> o/
16:23:19 <juggler> their in spirit
16:23:22 <juggler> er there
16:23:26 <adrian_otto> oh, you will be a sight for sore eyes, Ton!
16:24:00 <tonanhngo> :)
16:24:13 <strigazi> +1 :)
16:24:18 <juggler> :)
16:24:28 <juggler> final thoughts folks?
16:25:15 <adrian_otto> alright, so our next meeting will be 2017-05-16 at 1600 UTC in #openstack-meeting-alt
16:25:16 <adrian_otto> then */2 weeks from that point
16:25:34 <strigazi> +1
16:25:39 <juggler> +1
16:25:45 <tonanhngo> +1
16:25:49 <juggler> great seeing everyone!
16:26:00 <juggler> thanks for attending.
16:26:03 <juggler> #endmeeting