16:01:29 <adrian_otto> #startmeeting containers
16:01:30 <openstack> Meeting started Tue May 30 16:01:29 2017 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:33 <openstack> The meeting name has been set to 'containers'
16:01:54 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-05-30_1600_UTC Our Agenda
16:01:58 <adrian_otto> #topic Roll Call
16:02:04 <adrian_otto> Adrian Otto
16:02:10 <strigazi> Spyros Trigazis
16:02:21 <ArchiFleKs> Kevin Lefevre
16:02:25 <tonanhngo> Ton Ngo
16:02:58 <adrian_otto> hello strigazi ArchiFleKs and tonanhngo
16:04:32 <adrian_otto> #topic Announcements
16:04:40 <adrian_otto> 1) strigazi , you have one
16:04:59 <strigazi> Magnum is accepted to run jobs on CentOS CI https://bugs.centos.org/view.php?id=13192
16:05:41 <strigazi> I stated working on it. The centos folks are very helpful
16:05:55 <adrian_otto> excellent!
16:06:02 <strigazi> We will have jobs on physical machines soon I think
16:06:59 <tonanhngo> So we should see fewer false negative on the job?
16:07:24 <strigazi> tonanhngo Yes, almost none
16:07:50 <strigazi> We should be able to add more complex tests
16:08:06 <tonanhngo> great, so now we should take the failed job more seriously
16:08:23 <strigazi> Yeap
16:08:55 <adrian_otto> any other announcements from team members?
16:09:21 <adrian_otto> #topic Review Action Items
16:09:27 <adrian_otto> 1) adrian_otto to target https://blueprints.launchpad.net/magnum/+spec/integrate-kuryr-kubernetes for Pike, with a comment that it's okay for this to slip to Queens if needed.
16:09:42 <adrian_otto> I did not complete this because I need to set up a new series in Launchpad.
16:09:58 <adrian_otto> I don't expect to have time for this until late this week.
16:10:04 <adrian_otto> I will carry it forward
16:10:08 <adrian_otto> #action adrian_otto to target https://blueprints.launchpad.net/magnum/+spec/integrate-kuryr-kubernetes for Pike, with a comment that it's okay for this to slip to Queens if needed.
16:10:38 <adrian_otto> #topic Blueprints/Bugs/Reviews/Ideas
16:10:51 <adrian_otto> In this section we may discuss any work item
16:11:27 <strigazi> I did some work on upgrades and the use of the heat container agent
16:11:57 <strigazi> On upgrades, I have two work items
16:12:30 <strigazi> One is to to have the etcd data in a cinder volume to be able to upgrade single master clusters, (k8s clusters)
16:13:36 <adrian_otto> that works now?
16:13:38 <strigazi> And the other is to to upgrade in two steps, Master first and then node. With two different api calls. Very similar to GKE
16:14:38 <strigazi> adrian_otto You can rebuild the vm with a new image or even a new vm and keep the etcd data.
16:15:08 <adrian_otto> good
16:15:37 <strigazi> GKE has max 5 mins k8s api downtime. We can have something similar.
16:15:55 <strigazi> The application running in the cluster should not have any downtime
16:15:58 <adrian_otto> yes, that should be fine
16:17:46 <adrian_otto> any other discussion on work items?
16:18:44 <strigazi> For the heat-agent
16:19:12 <strigazi> It worked, even on the CI. WIP https://review.openstack.org/#/c/468816/
16:19:48 <strigazi> With this feature we can relief the user_data passed with cloud-init to the vms
16:20:27 <strigazi> That's it from me
16:20:40 <adrian_otto> what do you mean by "relief"?
16:21:07 <strigazi> adrian_otto We are reaching the limit of 64KB of user_data
16:21:49 <strigazi> We need to reduce the size because we may need to add more custom scripts
16:21:49 <tonanhngo> do we still pass some data through user_data?
16:21:56 <adrian_otto> ok, so using the heat agent reduces the size of data we need to put in user data
16:22:14 <strigazi> And we reduce the load on the nova db
16:22:25 <strigazi> adrian_otto yes.
16:22:30 <adrian_otto> but that load shifts to heat
16:23:07 <strigazi> tonanhngo yes, not all data can be passed with the heat-agent
16:23:16 <strigazi> eg, start the heat agent
16:23:17 <tonanhngo> ok
16:23:21 <strigazi> or start docker
16:23:37 <strigazi> adrian_otto yes we will increase the load in heat, but
16:23:51 <strigazi> it will be only during creation
16:24:26 <strigazi> if we don't expect to update that data, the heat agent won't poll heat. AFAIK
16:25:16 <strigazi> Note the action, CREATE https://review.openstack.org/#/c/468816/1/magnum/drivers/k8s_fedora_atomic_v1/templates/kubemaster.yaml@478
16:26:04 <adrian_otto> we will need it to poll in case of conducting upgrades
16:27:27 <strigazi> I think if it has action CREATE, we don't need to. I will check
16:28:00 <adrian_otto> I think it's still okay even if it does poll heat for upgrades
16:28:16 <strigazi> btw, if a deployment has zaqar available. The can use the push model.
16:28:26 <adrian_otto> because you can change your heat transport to Zaqar to eliminate that if you need to support a huge number of clusters.
16:28:48 <adrian_otto> we should put that in our docs though as an anticipated scalability issue
16:28:52 <strigazi> Anyway the polling time can be large in the case of upgrades
16:28:58 <strigazi> yes
16:29:23 <adrian_otto> we can make the interval configurable as well
16:30:00 <strigazi> it configurable in heat I think but we can have a value in magnum as well
16:33:59 <adrian_otto> #topic Open Discussion
16:34:27 <adrian_otto> feel free to raise any topic here for discussion
16:34:52 <strigazi> I'm good
16:35:05 <tonanhngo> me too
16:35:16 <adrian_otto> ok, any objections to wrapping up now?
16:35:29 <strigazi> sure
16:35:46 <tonanhngo> Thanks Spyros for great update
16:36:04 <adrian_otto> Our next team meeting will be on 2017-06-13 at 1600UTC in #openstack-meeting-alt
16:36:04 <adrian_otto> See you then!!
16:36:05 <adrian_otto> thanks for attending everyone
16:36:12 <adrian_otto> #endmeeting