16:01:47 <strigazi> #startmeeting containers
16:01:47 <openstack> Meeting started Tue Sep  5 16:01:47 2017 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:50 <openstack> The meeting name has been set to 'containers'
16:02:03 <strigazi> #topic Roll Call
16:02:12 <strigazi> Spyros Trigazis
16:02:38 <adrian_otto> Adrian Otto
16:02:47 <slunkad> Sayali Lunkad
16:02:54 <ykarel> Yatin Karel
16:03:16 <mnaser> o/
16:04:06 <strigazi> Thanks for joining the meeting adrian_otto slunkad ykarel mnaser
16:04:24 <mvpnitesh> MVP Nitesh
16:04:29 <strigazi> Our agenda is at https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-09-05_1600_UTC
16:04:33 <strigazi> hello mvpnitesh
16:04:38 <strigazi> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-09-05_1600_UTC
16:04:48 <strigazi> #topic Announcements
16:05:17 <strigazi> A minor one, chandankumar is working on https://governance.openstack.org/tc/goals/queens/split-tempest-plugins.html
16:05:26 <strigazi> #link https://governance.openstack.org/tc/goals/queens/split-tempest-plugins.html
16:05:38 <strigazi> #topic Review Action Items
16:05:54 <strigazi> strigazi to review existing BPs and complete the list for Queens blueprints
16:05:59 <strigazi> #link https://etherpad.openstack.org/p/magnum-queens-planning
16:06:49 <strigazi> I want through all of them, There are some that I will manage but contributions are welcome. The first section
16:06:57 <strigazi> s/want/went
16:07:31 <strigazi> The bps in the second section need a assignee
16:07:45 <strigazi> #topic Essential Blueprints Review
16:07:45 <mnaser> i personally can help in roboustness/stability of things as we see issues come up in prod.  i can help in assistance in reviewing stuff as well
16:08:02 <strigazi> mnaser: Thanks
16:08:13 <strigazi> Review Federation API specification https://review.openstack.org/#/c/489609/
16:08:50 <strigazi> I would like you to have a look in this spec ^^ so that we can finilize it
16:09:15 <strigazi> We have already a contributor who started the spec, testing and implementation
16:09:54 <strigazi> We tested a magnum cluster federated with one more magnum cluster + one in GCP + Azure + Oracle Cloud
16:09:58 <mnaser> and for those who want to read it in a much easier way - you can click on the build link and get this - http://docs-draft.openstack.org/09/489609/9/check/gate-magnum-specs-docs-ubuntu-xenial/f1da039//doc/build/html/ :)
16:10:07 <strigazi> It looks promising if we can have it ready
16:10:42 <mvpnitesh> strigazi assign me 2 or 3 blueprints, i'll work on them.
16:11:00 <strigazi> To federate clusters with one api call or click in horizon
16:11:39 <strigazi> mvpnitesh: you can select from the Short-list
16:12:26 <strigazi> @all, Do you any input on the  Federation API specification ?
16:12:31 <mvpnitesh> Sure, i'll select them and i'll inform you
16:12:41 <strigazi> adrian_otto ykarel ?
16:12:57 <ykarel> strigazi, haven't gone through it yet
16:12:59 <strigazi> mnaser Are you interested in it?
16:13:01 <ykarel> will go this week
16:13:22 <mnaser> strigazi reading, but so far so good.  in a public cloud pov, it's a great idea because it promotes easy multicloud architecture
16:13:24 <adrian_otto> strigazi not yet, but I can check it out
16:13:40 <strigazi> slunkad: Would it be a fit for you? once we have the core code in we can add implementation for the suse driver
16:14:10 <mnaser> "Add support for including external Kubernetes clusters (deployed in GKE, ACS, AWS, ...) in a Magnum federation."
16:14:18 <mnaser> would be nice if that included... deployed in Magnum :D
16:14:26 <mnaser> but i assume that's a given :p
16:14:54 <strigazi> you mean federate magnum cluster together?
16:14:58 <mnaser> yep
16:14:59 <slunkad> strigazi: yeah as far as I understand it does
16:15:20 <strigazi> mnaser: that is the first to be supported :)
16:15:26 <mnaser> strigazi i assumed so :)
16:15:44 <strigazi> We can clear that up :)
16:16:13 <mnaser> other than that, it wfm
16:17:12 <mnaser> i think down the line we should look into using the heat agents, it should be a bit of a priority
16:17:20 <mnaser> we're getting really close to the 64K limit for cloud-init
16:17:48 <strigazi> mnaser: I have started it this
16:17:50 <mnaser> and it will also help make scale-up and down easier with some quiscing code and things like ugprades possible
16:18:01 <strigazi> #link https://review.openstack.org/#/c/468816/
16:18:20 <strigazi> And the implementation I'm working in uses the heat-agent
16:18:22 <ykarel> strigazi, is kubernetes support for federation cluster production ready? last week i was in a meetup there they told it's not production ready yet,
16:18:44 <strigazi> I mean for the upgrades.
16:19:17 <strigazi> ykarel: We have federated magnum clusters with 3 different public clouds
16:19:36 <strigazi> By the time Queens is released we will have two more kubernetes releases
16:20:00 <ykarel> strigazi, Ok, may be the guys were outdated with the updates
16:20:30 <strigazi> So it is ready not sure what production ready means, but we can iterate on it if there are bugs
16:20:44 <ykarel> Ok
16:20:56 <mnaser> strigazi that's great (re: heat-container-agent). it should be a priority imho :) good to hear!
16:21:01 <mnaser> (anyways, we should stick to the agenda)
16:21:37 <strigazi> mnaser: yeap, the heat-container-agent will be ready, it is almost done.
16:21:45 <mnaser> ++
16:22:19 <strigazi> So, for new features I'll manage the first section an slunkad will take the suse driver
16:22:28 <strigazi> s/an/and
16:23:12 <strigazi> I have created the milestones in launchpad and I'll target the BPs this week.
16:23:40 <slunkad> awesome
16:23:44 <strigazi> #action strigazi to target BPs for specific queens milestones
16:24:45 <strigazi> If more people want to take some BP I'll target it later.
16:24:53 <strigazi> Do you want to add anything?
16:25:22 <slunkad> I'm good for now
16:26:09 <strigazi> ok, let's move to Open Discussion then
16:26:19 <strigazi> before that
16:26:48 <strigazi> Prepare magnum 5.0.2
16:27:46 <strigazi> There are some patches in stable/pike already. We can do a point release next Thursday, what do you think?
16:27:49 <strigazi> mnaser: ^^
16:28:04 <mnaser> i submitted something to backpotr
16:28:08 <mnaser> let me check if it merged
16:28:17 <strigazi> one week sounds good?
16:28:22 <mnaser> https://review.openstack.org/#/c/499842/ + a backport
16:28:52 <mnaser> so if we can just keep an eye out on those
16:28:57 <mnaser> it wfm
16:30:01 <strigazi> So, release 5.0.2 in a week after those fixes, potentially more. ok for all?
16:30:39 <mvpnitesh> ++
16:30:42 <slunkad> yes
16:30:49 <ykarel> yes
16:31:04 <ykarel> mnaser, i commented on it, i tried that patch
16:31:45 <strigazi> #agreed release magnum 5.0.2 at 2017-09-14
16:31:56 <strigazi> #topic Open Discussion
16:32:25 <strigazi> Any other business?
16:32:26 <mnaser> ykarel cool we can discuss that further in the review
16:32:34 <ykarel> mnaser, Ok
16:32:46 <mnaser> everything is good at our side, perhaps aim to get 1.7.5 once we can get it and lookout for coredns 1.0.0
16:33:56 <strigazi> mnaser: 1.7.5 is a matter of time. And as soon as we get it you can use the kube_tag label
16:34:08 <strigazi> coredns will be released this week too
16:34:36 <strigazi> I added the fix that interest us in the release notes of coredns too
16:35:26 <strigazi> I think we are covered, wrap the meeting early?
16:35:59 <mnaser> i agree :)
16:36:05 <slunkad> +1
16:36:10 <ykarel> +1
16:36:15 <strigazi> cool
16:36:23 <strigazi> Thanks for joining folks
16:36:28 <strigazi> #endmeeting