16:00:38 <strigazi> #startmeeting containers
16:00:39 <openstack> Meeting started Tue Sep 26 16:00:38 2017 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:42 <openstack> The meeting name has been set to 'containers'
16:00:44 <strigazi> #topic Roll Call
16:00:45 <adrian_otto> Adrian Otto
16:00:51 <slunkad> Sayali Lunkad
16:00:51 <strigazi> Spyros Trigazis
16:02:52 <strigazi> Thanks for joining the meeting adrian_otto slunkad
16:03:15 <strigazi> Meeting agenda:
16:03:21 <strigazi> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-09-26_1600_UTC
16:03:29 <strigazi> #topic Announcements
16:04:50 <strigazi> The 5.0.2 will be postponed since new bug have been found in stable/pike but not  in 5.0.1, we need to fix them first
16:04:52 <ykarel> o/
16:05:42 <strigazi> If you don't have any other announcements we can move on
16:06:03 <strigazi> #topic Review Action Items
16:06:43 <strigazi> I have updated the Blueprint review list and I updated the cluster-upgrades spec
16:07:11 <strigazi> #topic Blueprints/Bugs/Reviews/Ideas
16:07:36 <strigazi> Add support of k8s cluster over opensuse distro https://blueprints.launchpad.net/magnum/+spec/k8s-opensuse-support
16:07:44 <mvpnitesh> Strigazi: Hi
16:07:52 <slunkad> I have created a patch for that https://review.openstack.org/#/c/507522/
16:07:56 <strigazi> slunkad: cool
16:08:01 <slunkad> but it is still WIP
16:08:09 <strigazi> mvpnitesh: hi
16:08:14 <strigazi> slunkad: cool
16:08:30 <strigazi> slunkad: is it working at all, can we test?
16:08:37 <mvpnitesh> I've completed https://blueprints.launchpad.net/magnum/+spec/ask-confirm-when-delete-bay and https://blueprints.launchpad.net/magnum/+spec/deprecate-magnum-client
16:08:55 <strigazi> mvpnitesh we can have a look right after
16:09:22 <slunkad> well at this point it successfully accepts the request to create a cluster but fails because stuff is missing in the template
16:09:29 <strigazi> slunkad: ok
16:09:38 <mvpnitesh> strigazi : ok
16:09:56 <strigazi> slunkad do you want to add something else?
16:10:06 <ykarel> slunkad, so functional tests are not there?
16:10:16 <slunkad> strigazi: I am adapting to the new changes made though ocata and pike
16:10:25 <slunkad> ykarel: no not at this point
16:11:03 <strigazi> slunkad it is easy to add them for kubernetes, we can comment in your review
16:11:24 <slunkad> strigazi: sure!
16:11:49 <slunkad> that would be nice
16:11:51 <slunkad> thanks!
16:11:51 <ykarel> slunkad, ack, it would be good if tests are along or atleast how to tests it
16:12:09 <strigazi> Next is: Use the heat agent and Software Deployments in heat templates https://blueprints.launchpad.net/magnum/+spec/heat-agent
16:12:17 <slunkad> ykarel: yes I will figure out a way to add the image that we are using
16:12:23 <ykarel> slunkad, Ok
16:13:09 <strigazi> I just updated the patch, so input is welcome, I need to remove the WIP and push the Dockerfile
16:13:12 <strigazi> https://review.openstack.org/#/c/468816/
16:13:31 <ykarel> strigazi, you mentioned centos atomic? in bp
16:14:04 <strigazi> ykarel it works in both
16:14:27 <strigazi> I mention fedora/centos atomic
16:14:32 <ykarel> Ok, but we are not having centos atomic, that why i asked
16:15:09 <strigazi> I mentioned because the transition is easy
16:15:38 <ykarel> Ok
16:15:49 <strigazi> Is there another comment on this bp?
16:16:24 <strigazi> Next: Allow alternative docker registry for infrastructure images https://blueprints.launchpad.net/magnum/+spec/alternative-infra-images-registry
16:16:39 <strigazi> Patch is ready for review k8s_fedora: Add container_infra_prefix label https://review.openstack.org/#/c/497223/
16:16:54 <strigazi> slunkad: you can do a smiliar patch for suse later\
16:17:21 <slunkad> strigazi: yes
16:17:44 <strigazi> ykarel: adrian_otto this patch is ready for review, input welcome.
16:17:56 <ykarel> strigazi, sure will take a look
16:17:59 <adrian_otto> ok
16:18:26 <strigazi> Next: Cluster upgrades https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades
16:18:44 <strigazi> the spec is updated
16:19:30 <strigazi> I think we should discuss this subject in the spec
16:19:41 <strigazi> Do you want to comment something on this?
16:20:40 <strigazi> I have three more items in the agendam let's take the good one first
16:21:02 <strigazi> Kubernetes packages and container images available for 1.8.0.beta.1 and 1.8.0.rc1
16:21:11 <strigazi> beta https://koji.fedoraproject.org/koji/taskinfo?taskID=22007947
16:21:20 <strigazi> containers for beta: https://hub.docker.com/r/openstackmagnum/kubernetes-kubelet/tags/
16:21:25 <strigazi> rc1 https://koji.fedoraproject.org/koji/taskinfo?taskID=22070736
16:21:42 <strigazi> tmr I'll push the containers for 1.8.0.rc1
16:22:14 <strigazi> You can try them with magnum pike (and with *tls* only)
16:22:30 <strigazi> just change the labels kube_tag
16:23:09 <strigazi> The two remaining times were triggered by the magnum upgrade at CERN
16:23:16 <strigazi> s/times/items/
16:23:36 <strigazi> There are 5 bugs in the agenda:
16:23:44 <strigazi> kubernetes-dashboard is accesible without authorixation or authentication with NodePort https://bugs.launchpad.net/magnum/+bug/1719548
16:23:45 <openstack> Launchpad bug 1719548 in Magnum "kubernetes-dashboard is accesible without authorixation or authentication with NodePort" [Undecided,New]
16:23:47 <strigazi> sync cluster task not running with send cluster metrics enabled https://bugs.launchpad.net/magnum/+bug/1719267
16:23:48 <openstack> Launchpad bug 1719267 in Magnum "sync cluster task not running with send cluster metrics enabled" [Undecided,New]
16:23:50 <strigazi> kubernetes-fedora: Fix prometheus config https://bugs.launchpad.net/magnum/+bug/1719187
16:23:51 <openstack> Launchpad bug 1719187 in Magnum "kubernetes-fedora: Fix prometheus config" [Undecided,In progress] - Assigned to Spyros Trigazis (strigazi)
16:23:53 <strigazi> Limit the name of the Instance names https://bugs.launchpad.net/magnum/+bug/1718947
16:23:53 <openstack> Launchpad bug 1718947 in Magnum "Limit the name of the Instance names" [Critical,Confirmed]
16:23:56 <strigazi> OSC client can not delete cluster-template with . (period) in name https://bugs.launchpad.net/magnum/+bug/1718930
16:23:57 <openstack> Launchpad bug 1718930 in Magnum "OSC client can not delete cluster-template with . (period) in name" [Undecided,New]
16:24:20 <strigazi> 1718930 1718947 1719267 need an assignee
16:24:51 <strigazi> mvpnitesh: you can take any of those if you want :)
16:24:58 <slunkad> I can fix https://bugs.launchpad.net/magnum/+bug/1718947
16:24:59 <openstack> Launchpad bug 1718947 in Magnum "Limit the name of the Instance names" [Critical,Confirmed]
16:25:05 <mvpnitesh> i can work on Bug 1718930
16:25:07 <openstack> bug 1718930 in Magnum "OSC client can not delete cluster-template with . (period) in name" [Undecided,New] https://launchpad.net/bugs/1718930
16:25:16 <strigazi> slunkad: cool
16:25:36 <strigazi> mvpnitesh: it is the same for show and i think the others commmands too
16:25:56 <strigazi> And the final item is "Changes in the cluster-update command"
16:26:27 <mvpnitesh> actually , we should allow the user to use '.' in the clustername, this happened in other components also, tomorrow i'll discuss on this with u in the openstack-containers channel
16:26:48 <strigazi> Right now, the update command for clusters, is basically the scale command
16:26:51 <strigazi> mvpnitesh: ok
16:27:32 <strigazi> the problem is that it passes all the parameters from cluster template and all the heat-templates.
16:29:06 <strigazi> Passing the heat templates is not needed because old clusters might exist and then we may try to update by passing the templates of an uprgaded magnum service.
16:29:59 <strigazi> Also passing all the cluster template parameters is not necessary since we try to update the cluster not the cluster template.
16:30:43 <ykarel> strigazi, valid point
16:30:49 <strigazi> We can update only the parameters we need to, so that the object semantics can be changed later.
16:31:46 <strigazi> I'll have more details in the next meeting
16:32:17 <strigazi> #action strigazi to draft a bp or bug for changes in cluster-update command.
16:32:29 <strigazi> That is it from me
16:32:55 <strigazi> mvpnitesh: what did you want to talk about
16:33:34 <mvpnitesh> I've completed https://blueprints.launchpad.net/magnum/+spec/ask-confirm-when-delete-bay
16:33:49 <mvpnitesh> review of this is pending https://review.openstack.org/#/c/497205/
16:33:53 <strigazi> ok, I'll review as soon as possible
16:34:08 <strigazi> apologies for the delay
16:34:29 <mvpnitesh> One more bp https://blueprints.launchpad.net/magnum/+spec/deprecate-magnum-client is almost done i've to fix one UT from https://review.openstack.org/#/c/503952/
16:35:03 <strigazi> mvpnitesh: would you be interested in adding functional tests for the client?
16:35:10 <mvpnitesh> strigazi: i've some 7 to 8 patchs reviews are pending, please review them when ur free
16:35:22 <strigazi> mvpnitesh: ok
16:35:30 <mvpnitesh> strigazi: that BP is assigned to me and from 2moro i'll be working on that
16:35:42 <strigazi> mvpnitesh: great
16:36:03 <strigazi> let's move to Open Discussion
16:36:08 <strigazi> #topic Open Discussion
16:36:26 <strigazi> Any other business?
16:37:10 <strigazi> ok then see you all next week then
16:37:14 <slunkad> bye!
16:37:21 <strigazi> Thanks for joinning!
16:37:26 <strigazi> #endmeeting