16:00:41 <strigazi> #startmeeting containers
16:00:42 <openstack> Meeting started Tue Jan 16 16:00:41 2018 UTC and is due to finish in 60 minutes. The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:45 <openstack> The meeting name has been set to 'containers'
16:00:47 <strigazi> #topic Roll Call
16:00:58 <strigazi> Spyros Trigazis
16:01:33 <slunkad> Sayali Lunkad
16:01:48 <oikiki> o/
16:02:48 <strigazi> Thanks for joining the meeting slunkad oikiki
16:03:20 <strigazi> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2018-01-16_1600_UTC
16:03:24 <strigazi> agenda: ^^
16:03:32 <strigazi> #topic Announcements
16:03:36 <strigazi> None
16:03:39 <strigazi> #topic Review Action Items
16:03:55 <strigazi> strigazi to look for a new meeting time APAC friendly [incomplete]
16:04:48 <strigazi> I'll move it to the next week with 09:00 UTC winning
16:04:55 <strigazi> #topic Blueprints/Bugs/Ideas
16:05:12 <strigazi> Cluster Federation https://review.openstack.org/#/q/status:open+project:openstack/magnum+branch:master+topic:bp/federation-api
16:06:09 <strigazi> This feature is in good state and the assignee will move with the implementation of the first driver. [kubernetes on fedora atomic]
16:06:24 <strigazi> Feel free to review it
16:06:34 <strigazi> Next:
16:06:47 <strigazi> Cluster healing spec: https://review.openstack.org/#/c/529897/
16:07:56 <strigazi> I gave it a +1 for now, this feature has slight changes on the values returend by the API. Third party clients or application might be affetced. So have a look.
16:08:42 <strigazi> I will investigate what openstack provides provides for this kind of changes.
16:09:02 <strigazi> Next: Cluster Upgrades: spec: https://review.openstack.org/#/c/433728/
16:09:47 <strigazi> Please give it a look, I picked it up again and plan to finish the implementation as it is now in the spec.
16:10:57 <strigazi> Finally from me, some patches standing to update the kubernetes driver with RBAC and fix compatibility between different k8s versions.
16:11:04 <strigazi> kubernetes patches: RBAC, config fixes, CI fix https://review.openstack.org/#/q/status:open+project:openstack/magnum+branch:master+topic:bug/1726482
16:11:48 <strigazi> I would like to highlight here the CI patch which solves a know issue with gophercloud used by the kubernetes openstack cloud provider.
16:12:31 <strigazi> https://review.openstack.org/#/c/496229/8/devstack/lib/magnum it enables redirection for the keystone API v3 --> identity/v3
16:12:56 <strigazi> This problem has different silutions per deployment.
16:13:28 <strigazi> That is all from me, questions or other feature you want to discuss?
16:13:34 <strigazi> #topic Open Discussion
16:13:52 <strigazi> I just saw your patch oikiki
16:14:05 <strigazi> slunkad: you updated as well
16:14:08 <oikiki> the one right now strigazi?
16:14:18 <strigazi> Do you need any help?
16:14:20 <strigazi> oikiki: yes
16:14:39 <oikiki> well it's my first pass at it, so if im totally off track...
16:14:41 <slunkad> strigazi: yeah was just a small update, not sure if that helps the ci to move forward yet
16:14:42 <strigazi> Haven't review it just saw it is in
16:15:39 <strigazi> slunkad looks good, it should work now
16:15:47 <oikiki> strigazi: im not finished or anything, but figured id push it
16:15:55 <oikiki> as a wip
16:16:11 <strigazi> oikiki good thinking xD
16:16:22 <slunkad> strigazi: yeah let's see if it works as much as it does locally
16:16:58 <oikiki> strigazi did you look at my other patch #1?
16:17:45 <strigazi> oikiki yes looks good, I'm testing and I'll try to merge tmr
16:17:54 <oikiki> ok thank you strigazi
16:18:40 <strigazi> oikiki: I'll take a look to your new patch as soon as we finish the meeting.
16:18:55 <oikiki> strigazi: ok remember it's not done!
16:19:05 <strigazi> oikiki: slunkad Is there anything else you need to discuss?
16:19:13 <strigazi> oikiki: I will :) it's ok
16:19:20 <oikiki> :)
16:19:41 <slunkad> strigazi: do we already have a schedule for the PTG?
16:20:14 <strigazi> slunkad good point, no
16:20:33 <strigazi> #action strigazi to draft the PTG schedule
16:22:26 <slunkad> nothing else for me
16:23:20 <oikiki> nothing from me
16:24:16 <strigazi> cool, let's end the meeting, until next time :)
16:24:25 <strigazi> bye
16:24:25 <strigazi> #endmeeting