16:00:25 <strigazi> #startmeeting containers
16:00:26 <openstack> Meeting started Tue Jan 30 16:00:25 2018 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:29 <openstack> The meeting name has been set to 'containers'
16:00:31 <strigazi> #topic Roll Call
16:00:44 <slunkad> hi
16:00:49 <vabada> hi
16:01:01 <strigazi> hello slunkad vabada
16:01:32 <oikiki> 0/
16:02:00 <strigazi> hi oikiki
16:02:35 <oikiki> hi strigazi
16:03:16 <strigazi> Meeting agenda:
16:03:19 <strigazi> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2018-01-30_1600_UTC
16:03:29 <strigazi> #topic Announcements
16:03:41 <strigazi> Next week on Thursday we will branch, push for your changes
16:04:58 <vabada> that's for the queens release, right?
16:05:14 <strigazi> vabada: yes
16:05:16 <oikiki> what does that mean?
16:05:30 <strigazi> So, what this mean for the three of you that join the meeting
16:05:36 <strigazi> s/mean/means
16:06:28 <strigazi> For slunkad, it would be nice to take the suse driver in tree, some working flavor of it, so people can have an opportunity to test
16:07:03 <strigazi> For oikiki, the two first tasks for the periodic tasks are needed to get merged
16:07:42 <oikiki> ah ok
16:07:59 <strigazi> oikiki: the first one, to make the send_metrics task is very important due to a bug in the kubernetes client, I'll explain later
16:08:06 <slunkad> strigazi: yeah I made some progress on the image too so hope we can manage in time
16:08:24 <strigazi> for vabada, try to push the patch to drop the ironic driver
16:08:53 <strigazi> slunkad: cool
16:09:45 <strigazi> let's move one, we can discuss this later again
16:09:53 <vabada> I'm working on it. I'll ask some questions later after the meeting regarding the work done by Mathieu Velten
16:10:01 <strigazi> ok
16:10:07 <strigazi> #topic Review Action Items
16:10:14 <strigazi> strigazi to look for a new meeting time APAC friendly [incomplete]
16:12:06 <strigazi> I will try to make this meeting tha last one in this time
16:12:34 <strigazi> #action strigazi to send email for the new meeting time
16:12:43 <strigazi> #topic Blueprints/Bugs/Ideas
16:13:01 <strigazi> kubernetes python client and eventlet incompatibility
16:13:08 <strigazi> #link https://github.com/eventlet/eventlet/issues/147
16:13:35 <strigazi> After kubernetes client 4.0.0 there is the above incompatibility issue ^^
16:14:34 <strigazi> Magnum has three periodic tasks, one to sync the magnum service, one to update the cluster status and one send cluster metrics
16:15:09 <strigazi> The send_metrics task uses the kubernetes client for kubernetes clusters and it crashes
16:15:46 <strigazi> The really big problem is that it also crashes the cluster status sync task
16:16:26 <strigazi> This why, we need the patch from oikiki, to be able to diasble the task until the problem is fixed.
16:16:51 <oikiki> i see.
16:16:52 <vabada> I got that error today in devstack. Count on me for any testing that needs to be done
16:17:11 <strigazi> Best case scenario is to fix eventlet to play well with the  multiproccessing module
16:17:19 <strigazi> vabada: you can test oikiki 's patch
16:17:27 <strigazi> oikiki: can you fetch the link?
16:17:36 <oikiki> sure one se
16:17:52 <vabada> sure. Count on me oikiki
16:18:03 <oikiki> thanks vabada: https://review.openstack.org/#/c/529098/
16:19:24 <strigazi> if any of you want's to dive in eventlet, is more that welcome :)
16:20:21 <strigazi> Finally, an option for us would be to use the api with python requests
16:20:40 <strigazi> or even the kubectl binary
16:21:24 <strigazi> or not use eventlet, this quite a change
16:21:28 <strigazi> ok next
16:22:13 <strigazi> Fix for multimaster clusters:
16:22:18 <strigazi> #link https://bugs.launchpad.net/magnum/+bug/1742420
16:22:20 <openstack> Launchpad bug 1742420 in Magnum "Pod's can't communicate with kube-apiserver in multi master cluster" [Undecided,In progress] - Assigned to Spyros Trigazis (strigazi)
16:22:37 <strigazi> this line seem to fix the issue https://review.openstack.org/#/c/533593/12/magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-master.sh@26
16:23:05 <strigazi> vabada: oikiki slunkad Could you test it?
16:23:44 <strigazi> I'll leave comments on the bug for how to test,
16:23:45 <slunkad> sure
16:24:11 <strigazi> basically, you need a 3-master cluster and check if coredns and the dashboard are working
16:24:27 <vabada> that's great. I was thinking something like that
16:24:30 <vabada> I'll do it
16:24:55 <oikiki> ok
16:25:10 <strigazi> Two final items from me
16:26:14 <strigazi> I will try to push a lot for a first itetation on cluster federation and cluster upgrades, so I will ask for help on testing
16:26:21 <strigazi> #link https://review.openstack.org/#/q/status:open+project:openstack/magnum+branch:master+topic:bp/federation-api
16:26:42 <strigazi> #link https://review.openstack.org/#/q/status:open+project:openstack/magnum+branch:master+topic:bp/cluster-upgrades
16:27:11 <strigazi> That was it from me, let's move to
16:27:14 <strigazi> #topic Open Discussion
16:27:40 <strigazi> oikiki: did you have time to look into the swarm-mdoe monitoring?
16:27:46 <vabada> great, count on me for testing. If there are some guidelines, I'd be happy to help.
16:27:55 <strigazi> vabada: thanks
16:28:31 <oikiki> strigazi: i started on it but have been sick for the last few days... could we talk about it in a day or so. my progress stalled and i cant think so well today.
16:28:44 <strigazi> oikiki: sure
16:28:51 <oikiki> strigazi: i think im going to have to go back to bed after meeting :(
16:29:02 <strigazi> oikiki: :(
16:29:11 <oikiki> strigazi: i'll definitely help out on testing as well tho
16:29:31 <slunkad> strigazi: https://review.openstack.org/#/c/520063/ this is passing since I switched to using opensuse as the base image but I'm not entirely sure it is doing what it needs to
16:29:43 <slunkad> oikiki: get well soon!
16:29:59 <oikiki> slunkad: thank you!
16:30:06 <vabada> get well oikiki
16:30:12 <strigazi> slunkad I saw it passing but it doesn't build anything
16:30:18 <slunkad> yeah
16:30:18 <oikiki> thanks vabada!
16:30:41 <slunkad> cuz locally I get errors with the build
16:32:05 <strigazi> slunkad: are there any examples on other suse images built with diskimage-builder?
16:32:26 <strigazi> maybe AJaeger could help
16:32:53 <slunkad> strigazi: I asked him but he doesn't really know
16:33:11 <strigazi> ok, let's take a look after
16:33:19 <slunkad> and I think there should be an example but I haven't found it yet
16:33:24 <slunkad> ok great
16:34:04 <strigazi> vabada: about ironic, any luck with devstack?
16:34:59 <vabada> not really. Have tried different environments, and even though cloud-init finishes, the heat WAIT_CURL API calls fails due to authentication failed.
16:35:21 <vabada> in the master node, so cluster creation fails due to timeout
16:35:42 <strigazi> vabada did you try with a custom template that only signals heat?
16:36:05 <vabada> no, I could do that. You mean running it directly from heat?
16:36:14 <strigazi> we can try to narrow it like this,
16:36:15 <strigazi> yes
16:36:30 <vabada> ok. good point. I'll do that
16:37:07 <strigazi> take kubemaster.yaml and remove almost everything, we need only to test wait_curl
16:37:37 <vabada> ok, yes I did that once for another error, should be easy
16:37:41 <vabada> thanks strigazi
16:37:49 <strigazi> @all any other business?
16:38:51 <strigazi> said twice
16:39:02 <strigazi> Thanks slunkad oikiki vabada
16:39:11 <strigazi> #endmeeting