10:00:03 <strigazi> #startmeeting containers
10:00:04 <openstack> Meeting started Tue Mar 6 10:00:03 2018 UTC and is due to finish in 60 minutes. The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:07 <openstack> The meeting name has been set to 'containers'
10:00:11 <strigazi> #topic Roll Call
10:00:14 <flwang> o/
10:00:19 <strigazi> o/
10:01:12 <strigazi> I guess it is the two of us flwang :)
10:01:20 <flwang> yep
10:01:58 <strigazi> Since it was the PTG last week we will just start planning the next cycle.
10:02:02 <flwang> do we need a quick summary for PTG?
10:02:46 <strigazi> #topic PTG-Recap
10:03:01 <strigazi> Subjects discussed:
10:03:20 <strigazi> Etherpad:
10:03:24 <strigazi> #link https://etherpad.openstack.org/p/magnum-ptg-rocky
10:03:31 <strigazi> 1. Cluster Upgades Phase II and Status Update
10:04:28 * strigazi strigazi to push of a 6.2.0 release sinece magnum is project with intermediary cycle
10:05:11 * strigazi strigazi to update spec for cluster upgrades phase II by upgrading with cluster templates
10:05:30 <strigazi> 2. Cluster Drivers
10:06:28 <strigazi> There was interest only on the kubernetes drivers and fedora-atomic and suse.
10:07:04 <strigazi> 3. Cluster healing and Status Monitoring
10:07:35 * strigazi Iterate on the cluster healing spec
10:08:12 * strigazi Iterate on the cluster healing spec for the new statuses new-field vs existing status field.
10:09:03 * strigazi INvestigate solution for the kubernetes client with cotyledon or oslo.service with our own limited set of requests
10:09:22 <strigazi> flwang: this your right? ^^
10:09:34 <flwang> yes
10:09:37 <strigazi> 4. Documentation
10:09:55 * strigazi slunkad_ to work on docs restructure
10:10:16 * strigazi strigazi to draw and document magnum architecture
10:10:22 <slunkad_> hi!
10:10:44 <strigazi> 5. puppet-openstack-integration
10:11:23 * strigazi strigazi to followup with the addition of magnum to puppet-openstack-integration with the rdo team
10:11:26 <strigazi> slunkad_: hello
10:11:48 <strigazi> I think thats it for the PTG
10:12:46 <strigazi> Do you want to add something?
10:14:11 <strigazi> I guess no. slunkad_ flwang ?
10:14:13 <flwang> good for me
10:14:24 <flwang> because I involved in most of the topics
10:14:31 <slunkad_> for me too
10:14:40 <strigazi> cool :)
10:15:48 <strigazi> #topic meeting topics for next week
10:16:18 <strigazi> #action strigazi to report back on cluster upgrades
10:16:29 <strigazi> I forgot to mention this bug:
10:16:38 <strigazi> #link https://bugs.launchpad.net/magnum/+bug/1752433
10:16:39 <openstack> Launchpad bug 1752433 in Magnum "trust invalid when user is disabled" [Undecided,New]
10:17:06 <strigazi> #action strigazi to follow-up the status of trust rotation with the heat team
10:18:12 <flwang> strigazi: for the first glance, i don't think it's a really critical one. did you see it before in production?
10:18:33 <strigazi> When the user account that created a cluster is deleted the trust becomes invalid and magnum can't fetch certs from barbican and the kubernetes provider is unusable
10:19:19 <strigazi> on heat side, stack updates will not work since heat has another trust tied to the user who created the cluster
10:19:29 <strigazi> yes, we saw this in production
10:19:57 <strigazi> it's critical
10:20:09 <slunkad_> I would agree
10:20:39 <strigazi> in shared clusters amongst many users when the user account of the creator is deleted it is a problem
10:21:33 <strigazi> And deployments like ours, with Active Directory or other central identity managers we can not just not delete the user
10:22:24 <flwang> ok, good to know. thanks
10:22:54 <strigazi> flwang: do you want to add an action item for you for next week?
10:22:58 <strigazi> slunkad_: ^^
10:23:21 <flwang> strigazi: i would start to take a look at the cotyledon or oslo.service
10:23:36 <flwang> strigazi: and i'm still testing calico with other components
10:23:47 <slunkad_> strigazi: I could
10:23:53 <strigazi> #action flwang to report back for cotyledon or oslo.service
10:24:09 <strigazi> #action flwang to five feedback on calico
10:24:28 <strigazi> #action strigazi to test kubernetes dashboard with calico
10:24:44 <strigazi> slunkad_: something for docs or opensuse?
10:24:51 <slunkad_> strigazi: for the docs
10:25:02 <flwang> strigazi: we can discuss that issue of calico+dashboard offline, i have some findings
10:25:13 <strigazi> slunkad_: Propose a new structure for magnum's docs
10:25:37 <strigazi> #undo
10:25:38 <openstack> Removing item from minutes: #action strigazi to test kubernetes dashboard with calico
10:25:50 <strigazi> #action strigazi to test kubernetes dashboard with calico
10:25:59 <strigazi> #action slunkad to propose a new structure for magnum's docs
10:26:05 <strigazi> flwang: ok
10:26:40 <strigazi> Do you need guys to discuss anything in the meeting?
10:27:54 <slunkad_> is anyone going to work on the bug you mentioned with the trusts?
10:28:04 <strigazi> slunkad_: I will
10:28:13 <slunkad_> strigazi: alright
10:28:13 <strigazi> slunkad_: Do you want to work on it?
10:28:23 <strigazi> I assumed it is me :)
10:29:14 <slunkad_> strigazi: it seems to be critical for you'll so I would not commit to it for this week but if you don't get time till next week I can take it up
10:30:27 <strigazi> slunkad_ sounds good
10:30:44 <slunkad_> that's all for me
10:31:26 <strigazi> flwang: all good for the meeting?
10:31:37 <flwang> strigazi: good for me
10:31:46 <flwang> i assume it could be a short one ;)
10:32:14 <strigazi> cool, thanks folks, we can other topics offline
10:32:20 <strigazi> #endmeeting