15:00:48 <sarob> #startmeeting craton
15:00:49 <openstack> Meeting started Mon Jun  6 15:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <sigmavirus24> o/
15:00:53 <openstack> The meeting name has been set to 'craton'
15:00:57 <sarob> roll call!
15:01:12 <sigmavirus24> Hi! I'm Ian Cordasco (Rackspace)
15:01:34 <sarob> hey sigmavirus24
15:01:56 <sigmavirus24> hey there sarob
15:02:31 <sulo> o/ folks, Sulochan Acharya from Rackspace
15:02:39 <sarob> hello sulo
15:03:05 <sarob> there wasnt an agenda posted at
15:03:26 <sulo> yeah we've been kinda heads down with phase 1 stuff
15:03:33 <sarob> #link https://wiki.openstack.org/wiki/Meetings/craton
15:03:43 <sarob> lets start there
15:03:45 <sulo> hopefully from next week we have a better meeting plan
15:03:54 <sarob> #what's phase 1 stuff
15:04:00 <sarob> #topic what's phase 1 stuff
15:04:15 <sulo> so i think we discussed this briefly during first meeting
15:04:31 <sarob> give me very high level
15:04:38 <sulo> we wanted to get a minimal working product (MVP sort)
15:04:51 <sulo> with atleast a working inventory
15:04:56 <sarob> for newton release
15:04:57 <sulo> with rest and python api
15:05:07 <sarob> sounds reasonable
15:05:20 <sarob> some thought around python version
15:05:37 <sarob> assuming the plan is to write it in python
15:06:01 <sulo> sarob: so i think the consensus is py3 all the way
15:06:15 <sarob> expected
15:06:34 <sulo> but support py27 for client
15:06:37 <sarob> so the code at #link https://github.com/rackerlabs/craton
15:06:43 <sarob> is the start?
15:06:51 <sulo> sarob: yes
15:07:26 <sulo> we've been tracking issues etc there as well for now
15:07:40 <sulo> but i assume we will move to openstack infra soon
15:07:53 <sarob> long list
15:08:30 <sarob> i can take care of the move when we have a team discussion to move
15:08:39 <sulo> sounds good
15:08:54 <sulo> i think it should be a action item for next meet
15:08:55 <sarob> we will need to move the issues to launchpad
15:08:57 <sarob> as well
15:09:05 <sulo> +1
15:09:05 <sarob> oh, agenda sstart now
15:09:16 * sarob likes
15:10:21 <sarob> #action sarob add when to move to openstack github org to next weeks agenda
15:10:56 <sarob> ill write up some basic steps like launchpad use
15:11:07 <sulo> cool
15:11:08 <sarob> newton release publish
15:11:18 <sulo> also there is some work started on the cli
15:11:30 <sarob> client is good
15:11:39 <sarob> separate repo?
15:11:47 <sulo> yes
15:12:01 <sulo> i think folks have started to work on the doc in teh same repo right now
15:12:22 <sarob> python-craton-client?
15:12:39 <sarob> or just doc on what to build so far?
15:13:14 <sulo> i think jim has python-craton reserved or soemthing need to check on that but yes in general
15:13:17 <sulo> sarob: yes https://github.com/rackerlabs/craton/pull/84
15:13:26 <sarob> roger that
15:13:31 <sulo> is a start .. i think we need to clenup the api docs a bit more
15:13:41 <sulo> so that it matches up with what the cli expects
15:14:11 <sulo> i am refering to https://github.com/rackerlabs/craton/blob/master/craton/api-ref/swagger/swagger-inventory-api.yaml
15:14:19 <sulo> and is purely for craton-inventory
15:14:29 <sulo> we will surely have more on workflow api
15:14:41 <sarob> okay so i think phase 1 : inventory, basic client, major bugfixes, api = newton releaese
15:14:50 <sarob> plus docs
15:15:14 <sulo> that sounds good
15:15:20 <sarob> thats probably alot for a new team
15:15:29 <sulo> yeah
15:16:10 <sarob> ill work on getting you a few contributors from my larger team
15:16:19 <sulo> so one item i had was what if anything do we want to add in inventory modeling
15:16:33 <sulo> this question purely comes from our previous discussion
15:16:56 * sarob reviewing
15:16:56 <sulo> i think few folks from walmart labs were looking at including cinder swift into inventory
15:17:34 <sulo> i had started tracking it here: https://github.com/rackerlabs/craton/issues/63
15:17:56 <sulo> would be nice to include any changes in this cycle
15:18:27 <sulo> this is assuming that the current inv model does not meet the need
15:18:42 <sarob> looks like hvprash and anton put their hand up
15:19:05 <sarob> hvprash_: you online?
15:19:11 <sarob> hvprash: you online?
15:19:43 <sarob> #action hyprash, anton: researching https://github.com/rackerlabs/craton/issues/63
15:19:46 <sulo> we can leave that as something to discuss next week if folks are not around today
15:19:53 <sarob> yup
15:19:59 <sulo> k
15:20:13 <sarob> action list for follow up
15:20:42 <sarob> speaking of that
15:20:58 <sarob> #topic follow up action items from last week
15:21:02 <sarob> #link http://eavesdrop.openstack.org/meetings/craton/2016/craton.2016-05-23-14.31.html
15:21:22 <sulo> thanks for that :)
15:21:36 <sarob> #info item 1 we just pushed to next week
15:21:57 <sarob> #info item 2 jimbaker describe integration with external rest api-based cmdb (such as rackspace core)
15:22:12 <sarob> jimbaker: is on vaca
15:22:18 <sarob> i heard
15:22:21 <sulo> yeah he is out today
15:23:30 <sarob> #link https://github.com/rackerlabs/craton/issues/2
15:23:42 <sarob> is that the issue tracking the action item?
15:24:27 <sulo> yes
15:24:29 <sigmavirus24> sarob: I think #2 describes Craton's API?
15:24:44 <sulo> we might not be tracking the correct ones though
15:24:50 <sulo> for that epic
15:25:08 <sarob> closer inspection looks like the issue doesnt exist yet
15:26:00 <sarob> any details on what type of integration we are talking about here?
15:26:30 <sigmavirus24> sarob: I think of the cmd integration like keystone's ldap integration
15:26:33 <sigmavirus24> Does that make sense?
15:26:42 <sulo> i think it was about integrating external cmdb type systems example rax or oneops with craton api
15:27:10 <sarob> okey dokey
15:28:01 <sarob> #action jimbaker follow up on describe, post issue on integration with external rest api-based cmdb (such as rackspace core, oneops)
15:28:22 <sarob> that is for last week
15:29:03 <sarob> #topic new topics
15:30:42 <sarob> i have one or two people that are going to start working on this project
15:30:58 <sulo> awesome
15:31:00 <sarob> ill see if i can get them up this early ;)
15:31:17 <sarob> everyone seems to be on hawaii time
15:31:44 <sarob> which is convenent for holding meetings in hawaii
15:32:24 <sarob> anything else for the record before I call this meeting?
15:32:39 <sulo> nothing from my side
15:32:46 <sulo> thanks sarob
15:32:58 <sarob> thanks for attending
15:33:05 <sarob> have a great week
15:33:25 <sarob> #endmeeting