14:59:41 <jimbaker> #startmeeting craton
14:59:41 <openstack> Meeting started Mon Jun 20 14:59:41 2016 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:44 <openstack> The meeting name has been set to 'craton'
15:00:10 <sulo> o/
15:00:12 <sarob> o/
15:00:14 <jimbaker> o/
15:00:27 <MeganR> o/
15:02:03 <jimbaker> the eavesdrop for the agenda is actually one week old - for june 6, not june 13
15:02:13 <jimbaker> anyone have an up-to-date link?
15:02:55 <jimbaker> i will suggest however discussing a demo that sulo and i did last friday first
15:03:18 <jimbaker> b3rnard0 will be posting the video to youtube shortly
15:03:33 <jimbaker> #action b3rnard0 youtube demo link
15:04:47 <jimbaker> to recap, most of the issues we were tracking for https://waffle.io/rackerlabs/craton?milestone=MVP (what i have been calling recently phase 1) are done
15:05:30 <jimbaker> the remaining issues - OSIC ingest and ansible inventory - we did in fact demo, they just need to be finalized
15:07:00 <jimbaker> sulo, do you want to add a diff to get that ansible inventory fixed on my PR?
15:07:15 <sulo> yeah i will do that
15:07:34 <jimbaker> cool, that will be very helpful - just whatever you did to get it to work for the demo :)
15:07:49 <rainya> (made it!)
15:07:51 <sulo> ok
15:08:03 <jimbaker> rainya, o/
15:08:06 <sulo> hi rainya
15:08:35 <sarob> morning!
15:08:51 <jimbaker> sarob, good to see you!
15:08:58 <sarob> thx
15:09:33 <jimbaker> so the demo was open, but we did a bad job of promoting it outside of the OSIC team
15:10:21 <jimbaker> this week we are going to try to open up communications further. it will be a continual process
15:10:57 <jimbaker> sarob, do you have last week's eavesdrop handy by chance?
15:11:06 <sarob> hmm, let me see
15:11:12 <jimbaker> this is the first item for us to cover, but the agenda has the june 6 link
15:11:33 * jimbaker is stalling for time apparently :)
15:11:59 <jimbaker> anyway, i think the demo went well
15:12:28 <sulo> jimbaker: last weeks log ?
15:12:29 <jimbaker> sulo drove the actual demo
15:12:30 <sulo> http://eavesdrop.openstack.org/meetings/craton/2016/craton.2016-06-13-15.15.html
15:12:34 <jimbaker> sulo, thanks
15:12:43 <sarob> thx
15:13:01 <sulo> should we discuss where we are with the action items ?
15:13:29 <jimbaker> in particular, we demonstrated using craton's inventory rest api to load and query against the osic reference cluster
15:13:52 <jimbaker> this included ansible inventory integration; and showing how variables can override
15:14:08 <jimbaker> sarob, and with that, let's move to that part of the agenda
15:14:24 <jimbaker> #topic action items from last week
15:14:45 <sarob> soooo
15:14:51 <jimbaker> sarob, what's the status of that infra patch?
15:15:15 <sarob> i need to know the core-reviews
15:15:21 <jimbaker> (we are now ready to make a changeover at any time, now that we have completed phase 1 work)
15:15:34 <jimbaker> (if with minor cleanup)
15:15:43 <sarob> and i need to be added to the launchpad https://launchpad.net/~craton
15:15:56 <jimbaker> sarob, so i just added you to the ~craton group
15:16:06 <sarob> excellent
15:16:18 <jimbaker> sarob, should we make that group open to anyone who wants to add themselves?
15:16:28 <sarob> that group sure
15:16:47 <jimbaker> yeah, we can always add a ~craton-dev or whatever
15:16:48 <sarob> im going to create a core-reviewers group
15:17:11 <sarob> that will be the only ones that can modify the launchpad craton group
15:17:21 <sarob> and same group
15:17:30 <jimbaker> sarob, +1
15:17:39 <sarob> for permitting merge through gerrit
15:17:59 <sarob> i should be done with all the bit today
15:18:03 <sarob> bits
15:18:06 <jimbaker> so the usual openstack practice. thanks for taking care of that!
15:18:22 <sarob> shirely
15:18:24 <jimbaker> ok, so sounds like good progress on that action item, sarob
15:18:40 * jimbaker was working on the blueprint re integration patterns
15:19:01 <jimbaker> i made the following progress: started a blueprint placeholder
15:19:43 <sarob> for specs?
15:19:46 <jimbaker> also i had some good discussions re integration with oneops with VitalyZ
15:20:03 <jimbaker> and with nova, cinder with KrishR
15:20:33 <jimbaker> sarob, this most likely will drive some spects
15:20:35 <jimbaker> specs
15:20:51 <sarob> we need a place to land specs in the repo
15:21:07 <jimbaker> sarob, so my feeling is that blueprints should start specs
15:21:16 <sarob> right on
15:21:21 <jimbaker> with docs about those specs making their way into the repo once approved
15:22:04 <jimbaker> blueprints seem to be reasonably lightweight for this purpose
15:22:07 <sarob> so blueprint in launchpad
15:22:13 <jimbaker> yes
15:22:24 <sarob> if complicated enough then spec in repo with review
15:22:26 <jimbaker> go through the approval process
15:22:45 <jimbaker> sarob, ahh, this is where i can see scope for misunderstanding
15:23:00 <jimbaker> so i think all specs going forward should use blueprints
15:23:07 <sarob> yeah
15:23:19 <sarob> but not all blueprints need a spec?
15:23:25 <jimbaker> but not everyone reads the blueprints, nor should they
15:24:00 <jimbaker> so detailed out specs, especially ones relevant to users of craton, should go in the repo
15:24:14 <jimbaker> it's two places, so that's not so great
15:24:31 <jimbaker> but docs are often that way
15:24:44 <sarob> i always add URL to each in each
15:24:57 <jimbaker> sarob, +1
15:25:40 <cmspence> jimbaker: is the expectation that going forward (once infra is ready) we will transition from existing git repos and waffle?
15:25:51 <jimbaker> i will continue to work on that blueprint re integration patterns
15:26:08 <jimbaker> cmspence, yes, we are fully going to move over to standard openstack practice
15:26:33 <jimbaker> waffle, github issues, github PRs was just a stopgap for us
15:26:36 <rainya_> Waffle has been fun at least :) Standards for the win!
15:26:58 <jimbaker> rainya_, i agree that waffle is rather nice/lightweight
15:27:22 <sarob> storyboard will save us!
15:27:23 <rainya> it raises a larger question of if the existing standards could be streamlined, but well out of scope for this project
15:27:54 <jimbaker> i'm ok with us using storyboard, but i do not know the way
15:28:13 <sarob> its still in development
15:28:17 <jimbaker> b3rnard0 could be our gandalf here
15:28:30 <rainya> jimbaker, as you all ID the need for communication assitance, which seems to be a challenge for any new project with the team fully engaged in development, tap me for that please?
15:28:44 <sarob> im dubious if it will be ready
15:28:57 <jimbaker> rainya, that sounds great!
15:29:23 <rainya> meeting notifications, "newsletters", spec process changes, etc -- things you'd like a program manager type for; dont' have the bandwidth for code contribution but i can help with the program stuff
15:29:38 <jimbaker> thanks for volunteering here, it's very much appreciated
15:30:03 <sarob> rainya, jimbaker: lets start dropping all email on openstack-dev
15:30:11 <sarob> its a start
15:30:24 <jimbaker> sarob, that was my action item in fact :)
15:30:33 <sarob> at least cc: openstack-dev
15:30:59 <rainya> sarob jimbaker, excellent idea
15:30:59 <jimbaker> sarob, first one must write the emails :)
15:31:14 <rainya> jimbaker, i'll write something up, send to you for review/proof and then you can either send it or i can
15:31:32 <jimbaker> rainya, i'm happy to review with you something
15:31:38 <rainya> as a new meeting / project, having a summary of "hey, we had a meeting this week go read about it!" is a good start
15:31:39 <jimbaker> we could just do it up on an etherpad
15:31:44 <jimbaker> and if you write it, please send it :)
15:32:06 <rainya> heh, but then I can't stay under the radar ;)
15:32:12 <sarob> etherpad meeting notes are a good idea
15:32:28 <rainya> #action rainya to draft etherpad note to openstack-dev with jimbaker
15:32:34 <rainya> (i didn't action correctly i don't think)
15:32:35 <jimbaker> thanks!
15:32:46 <jimbaker> i need to do it as chair
15:32:47 <jimbaker> #action rainya to draft etherpad note to openstack-dev with jimbaker
15:33:02 <rainya> cool, well now I feel useful and a contributing member! woot!
15:33:15 <jimbaker> it's the usual open source way
15:33:23 <jimbaker> step in where there's a problem
15:33:28 <jimbaker> good stuff
15:33:48 * sarob hand up
15:33:55 <jimbaker> sarob, ?
15:33:58 <sarob> i need a core-review list
15:34:06 <jimbaker> (also i was going to ask about antongribok's action item)
15:34:10 <sarob> core-reviewer
15:34:23 <sarob> i was being funny
15:34:27 <sarob> putting my hand up
15:34:31 <sarob> sigh
15:34:42 <jimbaker> sarob, is this something we need to do from ~craton launchpad?
15:34:42 * sarob drops mic
15:34:55 <sarob> part of creating project stuff
15:35:37 <jimbaker> right, let me suggest we move this discussion to #craton - i know i have not read the manual here so-to-speak
15:35:50 <jimbaker> and we don't have too much time left in this meeting
15:35:56 <sarob> no prob
15:36:11 <jimbaker> so how about sarob, you and i work together today as we have time to finalize everything we can do right now
15:36:31 * jimbaker was too busy last week for finalizing phase 1/demo. not so bad now
15:37:01 <jimbaker> #action jimbaker works with sarob re outstanding openstack infra issues
15:37:23 <sarob> jimbaker: yeah ive gots mgmt stuff going on
15:37:43 <sarob> between that today can give you some time
15:37:49 <jimbaker> sounds good, and thanks
15:38:26 <jimbaker> re antongribok's action item, there's a meeting tomorrow about this
15:38:56 <jimbaker> rainya, you will want to be part of that, and regardless we will want to make sure this meeting is publicized
15:39:54 <jimbaker> there are actually two pieces here: 1. what inventory modeling do we need to accommodate describing hardware devices for swift/ceph/cinder setup
15:40:48 <jimbaker> 2. what can we do to better support integrating with the services that are setup - also include nova here
15:41:06 <jimbaker> anyway, that's the scope for that meeting
15:41:23 <jimbaker> kvprash is organizing; sulo and i will also be attending
15:41:25 <rainya> jimbaker, what time / place for tomorrow?
15:41:34 <rainya> jimbaker, or is it in the meeting etherpad we started
15:41:59 <jimbaker> sulo, can you find that meeting invite?
15:43:01 <jimbaker> rainya, hopefully we will doc here in this meeting, but if not, it will be discussed on #craton
15:43:09 <rainya> +1
15:43:54 <jimbaker> and going forward, this is incredibly important for getting communications opened up for the project as a whole
15:44:27 <jimbaker> as an aside, we are having a retrospective/planning meeting this wednesday, we will also be sure to make that call public
15:46:09 <jimbaker> sarob, did we get anything set up with VitalyZ to discuss oneops integration?
15:46:57 <sarob> jimbaker: if you have a perf time, let me know, i will pass it on
15:47:17 <sarob> jimbaker: he is on another call right now
15:47:35 <jimbaker> sarob, no worries. i suspect end of week is best for me
15:47:46 <sarob> jimbaker: passing on
15:48:05 <jimbaker> time is running out here... time to move on :)
15:48:14 * sarob is a irc to slack interpeter
15:48:21 <jimbaker> sarob, :)
15:48:43 * jimbaker is a poorly coded select loop
15:49:14 <jimbaker> #topic outstanding issues
15:49:33 <jimbaker> waffle provides a good summary: https://waffle.io/rackerlabs/craton
15:50:14 <jimbaker> so we will want to triage this backlog - are these cards still relevant? etc
15:51:29 <jimbaker> overall, i see three key things we will be looking at: 1. workflows, including scheduling; 2. inventory extensions, including RBAC; 3. integration
15:52:30 <jimbaker> the meetings tues/wed will help define these priorities; we will also be working with the taskflow project to be sure to use their capabilities for our workflow needs
15:53:21 <jimbaker> rainya, btw, i think this will be some key info to expose to openstack-dev about what we are doing
15:54:15 <rainya> jimbaker, roger that
15:54:52 <rainya> jimbaker, will be drafting our first email on https://etherpad.openstack.org/p/craton-meetings
15:55:08 <jimbaker> rainya, thanks, sounds like a good place to take care of that
15:55:23 <rainya> time check: 5 minutes
15:55:37 <jimbaker> any other questions as we wrap up?
15:55:43 <jimbaker> #topic wrap up
15:57:22 <jimbaker> cool. i think the team put in some amazing effort to get phase 1 (basically) completed; and hopefully everyone had some great rest/relaxation over the weekend
15:58:03 <jimbaker> looking forward to some more great work!
15:58:15 <jimbaker> time to move discussion over to #craton
15:58:24 <sarob> cheers!
15:58:25 <jimbaker> thanks everyone!
15:58:49 <jimbaker> #endmeeting