14:59:31 <jimbaker> #startmeeting craton
14:59:33 <openstack> Meeting started Mon Jun 27 14:59:31 2016 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:37 <openstack> The meeting name has been set to 'craton'
15:00:48 <jimbaker> #topic agenda setting
15:01:13 <jimbaker> so there may be a problem with openstack wiki, which is where we have the agenda posted
15:01:13 <sigmavirus24> o/
15:01:13 <Zucan> o/
15:01:13 <jimbaker> usual place: https://wiki.openstack.org/wiki/Meetings/craton; but also we are using https://etherpad.openstack.org/p/craton-meetings
15:01:13 <sigmavirus24> jimbaker: you mean the fact that new accounts can't be created?
15:01:32 <jimbaker> sigmavirus24, that is a well-known issue
15:01:34 <sigmavirus24> jimbaker: yeah most projects use etherpads
15:01:34 <Zucan> The agenbda is working for me: https://wiki.openstack.org/wiki/Meetings/craton
15:01:40 <Zucan> Remove the semicoplon off the url
15:02:11 <jimbaker> Zucan, sure: https://wiki.openstack.org/wiki/Meetings/craton - always ensure a space after a url :)
15:02:19 <sulo> o/
15:02:19 <Zucan> heh heh :)
15:03:00 <jimbaker> anyway, i think we need to switch over as well. the wiki is going away and we usually use etherpad for this purpose anyway
15:03:38 <turvey> o/
15:03:56 <cmspence> o/
15:04:03 <jimbaker> sigmavirus24, so does https://etherpad.openstack.org/p/craton-meetings work for you?
15:04:27 <sigmavirus24> jimbaker: absolutely :)
15:05:04 <jimbaker> awesome
15:07:06 <jimbaker> every one of those points just makes me feel better about it ;)
15:09:07 <jimbaker> fortunately the only thing we have put on the wiki up until now is agendas. which we now stop doing
15:09:07 <jimbaker> oops i just realized i was looking at two channels (#craton as well)
15:09:07 <jimbaker> so sigmavirus24 posted on #craton: "the wiki is hosted on an ancient operating system with ancient PHP installed and an unsupported version of the wiki software iirc" (i occasionally see bouncer lag so i was assuming the case here)
15:09:08 <jimbaker> sorry about that
15:09:08 <sigmavirus24> oh yeah, I should have posted that in here :/
15:09:11 * sigmavirus24 is distracted and under-caffeinated
15:09:39 <jimbaker> so any objection to us stopping the use of the wiki? we will need to get a small patch done against the overall meeting site
15:10:23 <sulo> sounds good to me
15:10:31 <jimbaker> seeing no passionate people for antiquated php...
15:10:31 <turvey> silence sounds like consent to me
15:10:35 <jimbaker> indeed
15:10:48 <cmspence> same, especially since most of us were having issues with it
15:10:52 <Zucan> +1 to etherpad only :)
15:11:13 <sarob> sorry im late
15:11:23 <sarob> freenode wouldnt let me on
15:11:24 <jimbaker> #action jimbaker will work with sarob to get the link appropriately patched from old bad wiki to etherpad
15:11:50 <sarob> ill catch up on log
15:12:02 <jimbaker> (that should have had more context - but there's only one wiki page - the meeting wiki)
15:12:52 <jimbaker> sarob, we are just going to start using https://etherpad.openstack.org/p/craton-meetings going forward. just need to do some cleanup there, but seems reasonable place to start
15:13:24 <jimbaker> since everyone is here and talking about wikis is completely boring... i suggest we now talk about meetings :)
15:13:38 <jimbaker> #topic midcycle meetup
15:13:57 <sarob> all caught up
15:14:10 * sarob just needs coffee :/
15:14:10 <jimbaker> at the openstack summit, we agreed that our midcycle would be at the operators meetup midcycle
15:14:25 <sarob> +1
15:15:03 <jimbaker> that midcycle has been set - it will be hosted by bloomberg in NYC on aug 25 & 26
15:15:25 <jimbaker> in addition, openstack east is happening the preceding two days, also in NYC
15:15:46 <sarob> do you have the etherpad link?
15:15:57 <sarob> im looking and not finding
15:16:00 <sulo> we are planning for craton specific meet during the same ?
15:16:27 <jimbaker> sulo, correct - i suggest we do take advantage of the two meetings for our midcycle
15:16:59 <sulo> ok. can we post this on openstack-dev to attract more interested parties ?
15:17:00 <jimbaker> many operators are planning to do the same. more importantly this gives us a good meeting location
15:17:05 <jimbaker> sulo, absolutely
15:18:13 <jimbaker> here's the link to the operators midcycle confirmation - http://lists.openstack.org/pipermail/openstack-operators/2016-June/010788.html
15:18:34 <jimbaker> and the corresponding openstack east: http://www.openstackeast.com/
15:18:57 <sulo> jimbaker: also, will we need to get a place/room allocated for us ? .. not sure how that works ?
15:19:42 <jimbaker> sulo, openstack events that have any dev focus will have some breakout space. but we should confirm specifics
15:19:53 <sulo> ok
15:21:41 <jimbaker> so here's what we can focus on: the first two days will be focused on craton dev midcycle correction; the two days at the operators can then focus on taking that plan to operators for fine tuning
15:22:43 <jimbaker> obviously it will be a mix during the 4 days. but this should have enough time to help us work on completing phase 2 of work, and move on to the next phase
15:23:28 <jimbaker> so any objections here? hopefully this sounds like a good plan in terms of having our meetup
15:24:25 <sulo> +1
15:24:38 <Zucan> +1
15:24:38 <sigmavirus24> Can y'all take good notes for those of us who won't be there?
15:25:11 <jimbaker> sigmavirus24, certainly. we will make certain it's captured in an etherpad, which we have done a decent job to date i believe
15:25:18 <sulo> i think we should record most of the sessions if we can
15:25:52 <jimbaker> sulo, if possible, that sounds good. but etherpad should be the principal doc
15:26:08 <sulo> yeah thats fine
15:26:39 <jimbaker> (i refer all the time to https://etherpad.openstack.org/p/Fleet_Management for example, which was our kickoff meeting for introducing this project)
15:26:57 <jimbaker> #action jimbaker will announce our midcycle meetup on openstack-dev
15:27:39 <sarob> cool
15:28:18 <jimbaker> in terms of trip planning - please make travel plans such that you are available tues morning through fri 5p
15:28:23 <jimbaker> in NYC
15:28:55 <jimbaker> if you want to attend the full meeting
15:29:09 <jimbaker> now to far more interesting stuff!
15:29:21 <jimbaker> #topic retrospective and phase 2 planning
15:29:46 <jimbaker> https://etherpad.openstack.org/p/craton-phase2-planning
15:30:59 <jimbaker> we still need to figure out specific dates; however, the intent of the craton team is to complete audit & remediation workflow support in time for barcelona
15:31:25 <jimbaker> phase 2 focuses on audit workflows, plus extending the inventory support we have done to date
15:31:56 <jimbaker> (the diff with remediation workflows is that scheduling of work is different)
15:32:39 <jimbaker> i believe we should use FLT005 from https://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/fleet-management.html as the motivating user story
15:33:13 <jimbaker> specifically the support of the openstack ansible security role
15:34:23 <jimbaker> this requires capture of the security audit data into inventory, possibly extending the support in that role for such capture
15:35:25 <jimbaker> other work items we have identified focus on integration, such as with nova and with tooling like oneops
15:36:23 <jimbaker> sarob, any update on the meeting planned with VitaliyZ?
15:36:40 <sarob> he has time tommorrow
15:36:48 <sarob> what works for y'all?
15:37:28 <jimbaker> sarob, i believe 1500 UTC probably works best - so same time as today
15:37:51 <jimbaker> i know sulo would like to attend
15:38:06 <sulo> yes, this time is good for me
15:38:33 <jimbaker> (context here: this is with respect to oneops integration. we are exploring this as an interesting integration point with an open source CMDB/governance/workflow platform)
15:39:22 <jimbaker> sarob, can you add the meeting to https://etherpad.openstack.org/p/craton-meetings once we have the specifics?
15:39:51 <sarob> yeah will do
15:39:55 <jimbaker> thanks
15:40:44 <jimbaker> i encourage everyone to look at the planning we are doing in https://etherpad.openstack.org/p/craton-phase2-planning
15:41:56 <jimbaker> i do think it matches what we discussed with stakeholders; prioritization input will be valuable!
15:43:00 <jimbaker> if you have questions, let's address those at the end of today's meeting
15:43:10 <jimbaker> #topic current work
15:43:51 <jimbaker> sulo, anything you want to discuss with the issues you have been working on?
15:44:25 <sulo> i am finishing up the ansible-inventory api endpoint .. then working on adding few missing rest endpoints for project and user creation
15:44:50 <sulo> and somethign interesting that we discussed last week
15:45:17 <sulo> is more work on modes
15:45:29 <sulo> for integrating network devices etc
15:45:43 <sulo> some ideas captured here https://docs.google.com/document/d/1N3f_H3bjZ1a08wkxRLCMt5ANXRGmFAOEUZ_mtI3BYxw/edit
15:46:22 <jimbaker> sulo, what additions if any do we need to our underlying inventory modeling?
15:46:25 <sulo> one interesting bit being modeling in racks
15:46:41 <sulo> so we can do variables resolution on rack
15:51:28 <jimbaker> sulo, do we need to break this out; or can we use the label support for such var resolution?
15:51:48 <sulo> i think we will need to break this out
15:51:55 <sulo> particularly because it nests stuff like ip subnets and policies for per rack basis
15:51:55 <jimbaker> perhaps we should bring back label DAG support?
15:52:02 <sulo> it would be nice to get this done though labels
15:52:06 <jimbaker> VitaliyZ raised the same issue, which is why they came up with the CI approach
15:52:08 <jimbaker> i believe labels are the same thing for us
15:52:08 <sulo> yeah that makes sense
15:52:09 <jimbaker> anyway, i
15:52:25 <jimbaker> am glad to see good progress on network device modeling questions - that will definitely drive good dev work
15:53:22 <sulo> in that doc .. (c) is the property that might be difficult to track though labels .. but we probably need to get a working set going to get a good idea
15:54:13 <jimbaker> (c) looks like a good test case
15:54:13 <sulo> right now though, we are doing that though variables .. just dont have api to get that data speciically
15:54:13 <sulo> so yeah .. its a good test case
15:54:13 <jimbaker> sulo, do we have data for the network devices test bed?
15:54:13 <sulo> yeah i have been playing with Rackspace specific data
15:54:14 <sulo> i will ask for more generic data from hvprash_ team .. or anyone else here who want to pitch in
15:54:14 <sarob> i gots to jump a bit early
15:54:14 <jimbaker> ack, we need to make this available
15:54:14 <jimbaker> sarob, take care
15:54:22 <sarob> patch for openstack project here https://review.openstack.org/#/c/332470/2
15:54:31 <jimbaker> 5 min to go
15:54:36 <jimbaker> #topic questions?
15:55:03 <sarob> im going to set no-op for jobs
15:55:19 <sarob> until we have some more bits in the repos
15:55:23 <sarob> cheers
15:55:33 <jimbaker> sarob, cool, and thanks!
15:55:39 <sulo> sarob: cool. thanks
15:56:06 <jimbaker> sulo, let's discuss more modeling shortly on #craton
15:56:16 <sulo> ok
15:56:52 <jimbaker> the other question i would like to raise with you there is with respect to access contexts (!) a term i just came up with for managing the alternatives we need to work with various devices
15:57:04 <jimbaker> including say the VPN issue we are facing
15:57:12 <jimbaker> in the osic ref cluster
15:57:44 <jimbaker> anyway, i think we can just move over discussion and follow up questions at this point to #craton
15:58:22 <jimbaker> #endmeeting