14:58:52 <jimbaker> #startmeeting craton
14:58:53 <openstack> Meeting started Mon Jul 18 14:58:52 2016 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:58:56 <openstack> The meeting name has been set to 'craton'
14:59:05 <jimbaker> agenda can be found here: https://etherpad.openstack.org/p/craton-meetings
14:59:22 <sulo> o/
15:00:09 <jimbaker> #topic community
15:00:22 <jimbaker> sulo, o/
15:01:13 <jimbaker> the operators midcycle registration opened:  https://opsmidcyclenyc2016.eventbrite.com
15:01:36 <jimbaker> sulo, i assume you got your ticket?
15:02:21 <sigmavirus> o/
15:03:00 <jimbaker> sigmavirus, o/
15:03:50 <turvey> o/
15:04:45 <jimbaker> i think we can start this meeting up now
15:04:58 <jimbaker> i was just mentioning the agenda at https://etherpad.openstack.org/p/craton-meetings
15:05:26 <cmspence> o/
15:05:28 <jimbaker> and in particular that the registration for the operators midcycle meetup has opened
15:06:30 <jimbaker> so please join us there - we will hopefully have a good chance to discuss what we have done to date, and get any course correction feedback from our actual customers
15:06:39 <jimbaker> (= operators)
15:07:11 <jimbaker> also worth pointing out: sarob, sulo, and i submitted this talk: https://docs.google.com/document/d/1_jbZ1TGHxl5HTjd8I6nrZBESbPaFNqgpU2IEF4xcH9E/edit?usp=sharing
15:07:27 <jimbaker> "Simplify Day 2 operations (and get some sleep!) through the Craton project"
15:08:18 <jimbaker> the title is due to KrishR, who also helped in some of the initial drafting
15:10:06 <jimbaker> feedback certainly wanted on that talk; but more importantly what it will take to show off things - and of course complete the corresponding code!
15:10:52 <jimbaker> #topic open action items
15:11:21 <jimbaker> cmspence, thanks for helping on https://review.openstack.org/#/c/332470/
15:11:39 <cmspence> :)  We are almost there!
15:11:51 <jimbaker> sulo, i think this is something we should work on together so we can minimize the branch carryover
15:13:17 <jimbaker> obviously delete all closed branches; but presumably best to also do early removals as well. i don't know about best transitional practice - just wanted to put it out there
15:13:22 <jimbaker> sarob, o/
15:13:34 <jimbaker> rainya, o/
15:13:52 <rainya> jimbaker, o/
15:13:55 <jimbaker> sarob, we were just discussing https://review.openstack.org/#/c/332470/
15:14:10 <jimbaker> and what we can do to cleanup accordingly
15:14:40 <jimbaker> i'm just going to suggest that sulo and i take that as an action item
15:15:44 <jimbaker> i assume sulo is good with that :)
15:16:22 <jimbaker> #action jimbaker sulo cleanup github branches in prep for move over to openstack infra
15:16:24 <sulo> jimbaker: 10-4 on branch. I can take care of it
15:16:31 <jimbaker> cool
15:17:32 <jimbaker> #topic FLT005 acceptance criteria
15:17:46 <jimbaker> https://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/fleet-management.html
15:18:27 <jimbaker> kencjohnston and KrishR from OSIC have asked that we detail out the acceptance criteria for FLT005
15:19:30 <jimbaker> so to make this concrete: if we are focused on the OSA security role audit, what will that look like, from an operator experience?
15:20:35 <jimbaker> i think the team knows what we are doing from a developer perspective, it's just connecting up the operator specifics
15:21:09 <jimbaker> and this can be based against using the CLI, which is probably primary; but also thinking about what a horizon integration could look like
15:21:49 <sulo> Ok sounds good
15:21:54 <jimbaker> example: an operator can select a cabinet/cell/etc, to apply the OSA security role audit
15:22:06 <jimbaker> can configure specifics in terms of variables
15:22:13 <jimbaker> etc
15:22:55 <jimbaker> sulo, so i will continue working with OSIC on this definition
15:23:09 <sulo> Ok
15:23:37 <jimbaker> cmspence, sigmavirus, given that this should focus first on CLI, we will want to work together on these specifics as well
15:24:26 <sigmavirus> okay jimbaker
15:24:27 <cmspence> +1 agreed
15:25:54 <jimbaker> #topic inventory modeling discussion
15:27:06 <jimbaker> we are currently trying to wrap some of the inventory specifics for phase 2 work
15:27:52 <jimbaker> sulo has an outstanding PR to add device tree support, so that cabinet -> host -> container can be modeled using a tree of devices
15:28:31 <sulo> yeah so I'll add a few test later. It should be good to merge
15:28:33 <jimbaker> it looks like i almost have the variable table refactoring done, which proved to be surprisingly tricky
15:29:59 <jimbaker> ideally, we will see virtualized variable and device DAG support in our inventory, but neither is necessary for FLT005, so we may defer
15:30:11 <sulo> Yeah
15:31:09 <sulo> Let's get this phase done with... we can rework that in later
15:31:16 <jimbaker> but doing so for barcelona makes a lot of sense - the DAG stuff will support oneops integration; and virtualized variables brings in the inventory fabric
15:31:29 <jimbaker> sulo, agreed
15:31:36 <sulo> I think we might have a better understanding of what is needed too
15:31:47 <sulo> I mean what more is needed
15:32:11 <jimbaker> sulo, right, much as we have seen to date in terms of thinking of an inventory fabric
15:32:23 <jimbaker> but more specifics as we get there
15:32:25 <sulo> yeah
15:32:43 <jimbaker> clearly, the more important thing here is getting real workflows going
15:33:24 <jimbaker> so let's talk about that now
15:33:28 <jimbaker> #topic taskflow
15:33:36 <sulo> Yeah so I have some of that in the works like mentioned last time
15:33:48 <sulo> but not enough to PR yet
15:34:00 <sulo> will be this week
15:34:13 <jimbaker> sulo, sounds good. but enough for us to discuss with taskflow upstream re container support, for example
15:34:32 <sulo> yeah it's related
15:34:59 <sulo> I think we might have simple task flow
15:35:12 <jimbaker> (let me point out this friday's meeting on july 22
15:35:30 <sulo> and add containers as we move forward
15:35:31 <jimbaker> which will be on taskflow container support)
15:35:53 <jimbaker> sulo, agreed: we can always assume we have all dependencies on the workers for now
15:36:04 <jimbaker> and then get the same behavior once we have container support
15:36:32 <sulo> yeah
15:36:40 <jimbaker> so this simplifies our dev plans significantly
15:37:25 <jimbaker> sulo, this week, let me suggest we start splitting out some of the high level aspects of the workflow gen, such as task gen
15:37:46 <jimbaker> of the workflow *work*
15:38:06 <jimbaker> so we can get past research
15:38:36 <_sarob> o/
15:38:38 <sulo> +1
15:38:58 <sulo> I'll discuss some of these in next Dev meeting
15:39:12 <jimbaker> sulo, cool
15:39:19 <jimbaker> sarob, o/
15:39:25 <sarob> jimbaker: hey
15:39:35 <sulo> just wanted to get some examples to discuss
15:39:38 <sarob> another meet conflict
15:39:45 <jimbaker> sarob, no worries
15:40:11 <rainya> I'm about to lose my wifi (en route to SJC)
15:40:12 <jimbaker> sarob, we were just wrapping our discussion of taskflow work, which is a key piece of phase 2
15:40:26 <jimbaker> rainya, no worries, thanks for joining us
15:40:40 <jimbaker> sarob, good to discuss oneops now?
15:40:53 <sarob> jimbaker: sure
15:40:59 <jimbaker> #topic oneops
15:41:11 <sarob> get my email eariler?
15:41:17 <jimbaker> sarob, yes, and responded! :)
15:41:17 <sarob> earlier
15:42:04 <jimbaker> sarob, do you think you will have some of the developers who will be working on this at the craton/operators midcycle?
15:42:30 <jimbaker> that could be a good target to plan against
15:42:48 <sarob> thats what i am driving towards, yes
15:43:04 <jimbaker> on our end, we continue to discuss schema changes that will help make this work easier
15:43:32 <jimbaker> basically by making our device support work in a similar fashion to oneops' CIs
15:43:45 <sarob> sounds good
15:44:29 <sulo> I have notes on integration points. Haven't had a chance to put that in the etherpad yet
15:44:34 <jimbaker> cool. schema integration seems to be the natural way to do this, so we will continue down that path
15:45:04 <jimbaker> once your team is ready, we can start looking at doing the underlying model support with sqlalchemy, and connecting up to current oneops
15:45:19 <jimbaker> which will help move this transition on the oneops side
15:45:29 <jimbaker> sulo, sounds like an action item for you :)
15:45:29 <sarob> okay
15:45:50 <sulo> ok
15:46:07 <sarob> im flying out to AR, so I need to jump off
15:46:23 <sarob> anything else for me?
15:46:27 <jimbaker> sarob, thanks for popping in - we will discuss more later
15:46:33 <sarob> roger roger
15:46:34 <jimbaker> sarob, i think we are good
15:46:35 <sarob> 5x5
15:46:38 <jimbaker> have a good flight
15:46:42 <sarob> thx!
15:46:46 * sarob out
15:47:25 <jimbaker> #topic horizon integration
15:47:58 <jimbaker> see for example https://cloud.githubusercontent.com/assets/160446/16780656/d216c66e-4834-11e6-8a9d-c15f5798cc81.png
15:48:45 <jimbaker> so this is just a high level description - we expect panels in horizon to interact with inventory, workflows
15:49:37 <jimbaker> Tamayo is working on some high level sketches
15:50:01 <jimbaker> cmspence, is this something you can help facilitate with respect to FLT005?
15:50:21 <cmspence> yes, I can work with them on this
15:50:44 <jimbaker> cmspence, you probably also want to work mhayden on the audit specifics of the OSA security role
15:50:45 <cmspence> is FLT005 a first priority wrt this?
15:51:00 <cmspence> or should they get the basics of just displaying inventory?
15:51:05 <jimbaker> cmspence, we want to use a specific user story so that we have specifics
15:51:22 <jimbaker> cmspence, but displaying inventory is a key piece
15:51:26 <cmspence> something like FLT002
15:51:28 <cmspence> ok
15:52:10 <jimbaker> cmspence, FLT002 is more involved in terms of integration
15:52:38 <jimbaker> we chose FLT005 because it aligns best with phase 2 work on audit workflows
15:52:46 <cmspence> +1 makes sense
15:53:25 <jimbaker> cmspence, so from an inventory perspective, we need to select the specific inventory; as well as drill down in any audit results before AND after the audit
15:53:39 <jimbaker> (using craton's variables as the source of truth here)
15:53:51 <cmspence> jimbaker: ok
15:54:31 <jimbaker> cmspence, also this is pretty tightly tied to the same UX that would be seen from a CLI perspective
15:54:51 <jimbaker> which makes perfect sense of course - they are just driving the same REST APIs
15:55:34 <cmspence> jimbaker: sulo other than just digging into the code, do we have any documentation on the available REST APIs?  We were being asked for that by the OSIC Horizon folks
15:55:50 <jimbaker> #action cmspence facilitates horizon storyboarding with respect to FLT005
15:56:03 <turvey> cmspence: I've got script to dump some of the craton inventory.  I'll pass it along
15:56:04 <jimbaker> cmspence, so we are using swagger to document
15:56:24 <cmspence> jimbaker turvey thanks
15:56:26 <sulo> cmspence: yeah
15:56:30 <jimbaker> but yeah, moving the docs up a notch is definitely something we all have to do :)
15:56:40 <jimbaker> 2 minute warning!
15:56:50 <jimbaker> #topic further questions?
15:57:07 <sulo> docs are a part of rest api swagger docs
15:57:18 <sulo> need to generate though
15:57:35 <jimbaker> i highly recommend pointing against our swagger api docs with the swagger editor
15:57:54 <jimbaker> we do have an  outstanding issue to start generating actual docs with that
15:58:09 <jimbaker> ok, need to wrap here!
15:58:30 <jimbaker> please move over to #craton for any further questions
15:58:35 <jimbaker> #endmeeting