15:01:06 <jimbaker> #startmeeting craton
15:01:06 <openstack> Meeting started Mon Aug 15 15:01:06 2016 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:09 <openstack> The meeting name has been set to 'craton'
15:01:22 <cmspence> o/
15:01:42 <Zucan> o/
15:02:21 <jimbaker> cmspence, Zucan o/
15:02:41 <jimbaker> #topic roll call
15:03:07 <jimbaker> cmspence, how were things while i was gone last week on vacation?
15:03:29 <syed_> o/
15:03:46 <jimbaker> syed_, hi
15:03:52 <syed_> hi jim
15:03:58 <syed_> i hope you are doing good
15:04:35 <cmspence> jimbaker: good, I was at the castle with syed_ and jovon working with them to get their development environments working and ready to jump into development
15:04:36 <jimbaker> yes, still working on timezone adjustment, but otherwise, fine
15:04:45 <jimbaker> cmspence, good to hear!
15:06:15 <jimbaker> cmspence, is turvey back this week?
15:06:43 <jimbaker> Mitschke is out on vacation
15:06:54 <cmspence> jimbaker:  I don't think so, I think he's out until NY
15:07:32 <sigmavirus> o/
15:07:40 <jimbaker> cmspence, no problem. Mitschke set up a shared calendar for us to track vacation, travel - we will want to have Zucan and syed_ to join that
15:08:06 <jimbaker> it's just a google cal
15:08:11 <jimbaker> sigmavirus, hi
15:08:16 <Zucan> Sure
15:08:27 <syed_> Sounds good
15:08:53 <jimbaker> ok, i think we can get going for today's meeting. hopefully sulo will join us later
15:09:27 <jimbaker> #topic action items
15:09:48 <jimbaker> so i just wanted to review last week's action items - http://eavesdrop.openstack.org/meetings/craton/2016/craton.2016-08-08-15.01.html
15:10:27 <jimbaker> cmspence, you mentioned the status on working with horizon devs with your trip last week to the castle
15:10:34 <jimbaker> any further updates on that?
15:11:00 <jimbaker> also updates on the breaking up of the CLI tasks?
15:11:38 <cmspence> jimbaker: They have a personal repo here: https://github.com/ediardo/craton-ui.  Review to move it into infra is here: https://review.openstack.org/#/c/354274/1 and I have a demo video I'll post a link to when I can find it
15:12:11 <cmspence> They were able to use sulo's data that he set up last week and should be making more progress this week
15:12:29 <jimbaker> cmspence, thanks, i look forward to seeing that
15:12:41 <jimbaker> rainya, hi
15:13:26 <jimbaker> cmspence, how are they consuming inventory data? did you make progress on the python client?
15:13:38 <cmspence> jimbaker: craton-dashboard demo: https://www.youtube.com/watch?v=7degc9OgcV8&feature=youtu.be
15:15:02 <cmspence> jimbaker: yes, making slow progress (due to lack of +2s).  Worked with sulo to get a couple reviews merged.  put a couple more out to get 1 entity complete and will work with syed_ and jovon (and sigmavirus depending on his availability) to get work done on the rest of the entities
15:15:45 <jimbaker> cmspence, ok, that sounds like a need for me to do some reviewing
15:16:11 <sigmavirus> I might be able to squeeze some reviews in
15:16:27 <sigmavirus> This week should be a bit slower than recent ones
15:16:29 <jimbaker> cmspence, please use #craton to alert me to these reviews, esp priorities - easy to miss
15:16:29 <Zucan> I will see what I can do to help review too
15:16:34 <sulo> o/
15:16:38 <jimbaker> sulo, hey
15:16:39 <cmspence> jimbaker:  will do
15:16:51 <jimbaker> sulo, you have perfect timing
15:17:27 <sulo> ohh horizon plugin looks nice/promising :)
15:17:28 <jimbaker> next up in the action items i was reviewing (http://eavesdrop.openstack.org/meetings/craton/2016/craton.2016-08-08-15.01.html)
15:17:45 <sulo> cool .. i think both action items for me are done ...
15:17:46 <jimbaker> was the stuff you were working on
15:17:53 <sulo> review up in gerrit
15:17:59 <jimbaker> nice
15:18:24 <jimbaker> ok, once again, i know what i'm working on this week now that i'm back from vacation - reviews
15:18:33 <jimbaker> which is awesome
15:19:18 <sulo> cmspence: why no data on the demo? ediardo still working with the setup i assume ?
15:19:58 <cmspence> sulo, that was his demo video from before he got it connected to data (August 5)
15:20:04 <jimbaker> cmspence, ahh
15:20:09 <sulo> gotcha, cool
15:20:11 <cmspence> I'll ask him for another with data
15:20:16 <jimbaker> and also we have some reviews to complete re the python client api
15:20:53 <jimbaker> so that's for me, sigmavirus, and sulo to get some progress on
15:21:03 <rainya> jimbaker, o/ and hihi
15:21:14 <jimbaker> rainya, hi!
15:21:29 <jimbaker> we were just discussing the first gui demo, using horizon integration
15:21:47 <jimbaker> still very much wip, but also very nice to see this getting outlined
15:22:03 <rainya> indeed!
15:22:31 <jimbaker> cmspence, so either my audio needs to be fixed, or the next demo should have some narration
15:22:50 <Zucan> the demo is mimed.
15:22:58 <cmspence> jimbaker: yes I don't think any audio on that demo
15:23:05 <jimbaker> Zucan, :)
15:23:45 <ediardo> hey
15:23:52 <jimbaker> ediardo, hi
15:23:56 <ediardo> Hi!
15:24:32 <ediardo> well, that video is soooo last week!
15:24:55 <jimbaker> so to conclude: last week's action items are all complete
15:25:10 <jimbaker> #topic midcycle meetup
15:25:25 <ediardo> There has been lots of rework on this plugin and looking forward to play with the data this week
15:25:41 <jimbaker> ediardo, yeah, completely understood. and looking forward to it!
15:25:54 <jimbaker> and also quite relevant to the midcycle meetup
15:25:58 <ediardo> We tried curling the api and looks good, thank you!
15:27:26 <jimbaker> ediardo, we are seeing a common point in a project, where stuff just comes together
15:27:35 <jimbaker> (which is much better than the opposite...)
15:27:50 <cmspence> jimbaker: just 3 of us going to midcycle?
15:27:51 <ediardo> Ane that is??
15:27:59 <jimbaker> cmspence, turvey, and i will be attending the midcycle
15:28:21 <jimbaker> i believe that's the full list of attendees
15:28:53 <jimbaker> ediardo, i'm speaking of integration
15:29:30 <jimbaker> so we have two days of craton specific sprinting, which we will do at openstack east
15:29:37 <jimbaker> plus two days of meeting with operators
15:29:54 <jimbaker> for the later: we have one working group session in the schedule
15:30:25 <jimbaker> obviously we will use that a starting point for interested operators
15:30:27 <lcastell> o/ folks
15:30:46 <palendae> I assume the operators midcycle isn't going to have video conferencing?
15:31:16 <jimbaker> palendae, that would be my assumption
15:31:55 <jimbaker> openstack in person meetings almost always are "in person only"
15:33:14 <jimbaker> cmspence, anyway our action item is to prep for next week's midcycle, just so we have very clear messaging about what we are doing
15:33:38 <palendae> As an outsider, that would be valuable
15:33:44 <Zucan> Should we log some action items for meetbot?
15:33:58 <Zucan> 1) shared google calendar; 2) prep for midcycle?
15:36:43 <jimbaker> Zucan, sounds good
15:37:04 <jimbaker> #action jimbaker works with Mitschke to get everyone on the google share calendar
15:37:34 <jimbaker> "everyone" here means people actively working on craton, or would like to
15:38:16 <jimbaker> #action jimbaker, cmspence drive midcycle prep, including horizon demo
15:38:38 <jimbaker> i think that captures what we discussed
15:38:54 <Zucan> agreed
15:39:25 <jimbaker> let's move on
15:39:37 <jimbaker> #topic open issues
15:39:58 <jimbaker> sulo, any highlights of work you are doing this week?
15:40:48 <sulo> well, much of it is pending the project structure change (pr in gerrit) but re: midcycle .. after chatting with soem folks in community
15:41:05 <sulo> have asked to get a scrrencase .. so illbe preparing one for midcycle
15:41:19 <sulo> eventhough i wont be there ;)
15:41:38 <jimbaker> sulo, a screencast is especially helpful if you are no there :)
15:41:43 <jimbaker> not
15:41:53 <sulo> yeah .. agreed that is a good idea
15:42:12 <sulo> also
15:42:22 <sulo> folks please check out LP for issue
15:42:42 <sulo> https://bugs.launchpad.net/craton
15:42:54 <sulo> and for BP
15:42:55 <jimbaker> sulo, i spent some time on the plane yesterday going the language we use to describe craton
15:43:26 <jimbaker> sulo, +100, it's an awkward interface, but we need to be looking at that tracker
15:43:42 <sulo> jimbaker: cool, i think we need to work on our docs quite a lot
15:43:49 <jimbaker> sulo, yeah, so much so
15:44:06 <sulo> question that i am getting more and more is"where is the doc? "
15:44:23 <jimbaker> sulo, it doesn't help to say in "our heads" ? ;)
15:44:27 <sulo> and its not complete so if anyone want to help out there is a great way to get started too :)
15:44:32 <sulo> jimbaker: yeah
15:44:42 <sulo> well i've been passing RTD
15:44:44 <Zucan> I have a question... so, what are the cases where we refer to this project as "Fleet Management" and when do we refer to it as "Craton"?
15:44:50 <sulo> but its not complete ..
15:45:36 <sulo> Zucan: Craton is the project name .. but is fleet management of openstack based cloud i guess is a good way to look at it
15:45:37 <cmspence> craton: neutron :: fleet management: networking
15:45:59 <Zucan> ok, that makes sense.
15:46:07 <palendae> What fleet is it managing?
15:46:19 <palendae> The infrastructure of your openstack cloud?
15:46:28 <sulo> palendae: this is control plane infrastructure
15:46:35 <palendae> Ok
15:46:38 <sulo> not instances (vm)
15:47:11 <palendae> Seems like relying on things on top of the control plane to manage the control plane is a little awkward
15:48:03 <jimbaker> sulo, so on the plane, i was specifically working on the docs around workflows. i think what is in RTD is sort of useful for inventory, and could be readily added to by others
15:48:05 <jimbaker> but workflows is definitely are in yours and my heads at this point. we will get this changed. this week sounds good to me
15:48:07 <jimbaker> cmspence, good analogy
15:48:13 <jimbaker> palendae, so the way i think about it is that fleet management is about the same set of ops to your fleet in a systematic way
15:48:21 <jimbaker> about DOING the same set of ops
15:48:24 <sulo> palendae: not a fan of openstack on openstack :P ?
15:48:45 <palendae> sulo, Not especially
15:48:57 <jimbaker> palendae, in particular, we have a working implementation at rackspace that craton is consciously following
15:49:08 <jimbaker> as a version 2
15:49:11 <sulo> palendae: but tbh we've been careful not to get tied to any cp services
15:49:14 <sulo> including auth
15:49:25 <palendae> sulo, What about this horizon dashboard?
15:49:41 <sulo> palendae: you dont have to use it .. everything is though cli/api
15:49:44 <jimbaker> palendae, all optional
15:50:07 <sulo> the UI part though plugin is optional
15:50:27 <sulo> same with keystone for auth
15:50:29 <jimbaker> worth mentioning this diagram: https://cloud.githubusercontent.com/assets/160446/16780656/d216c66e-4834-11e6-8a9d-c15f5798cc81.png
15:50:44 <jimbaker> (someone, namely jimbaker, should add this to the read the docs...)
15:50:54 <palendae> jimbaker, Yeah, jcannavale sent that to me last week
15:50:59 <jimbaker> sounds good
15:51:08 <sulo> palendae: so the idea is to be able to host it outside of the CP plane, but be albe to do action on it
15:51:12 <jimbaker> so keystone, barbican, horizon are all optional
15:51:44 <jimbaker> so far these are the three openstack services we can see as being useful to integrate directly with craton
15:52:16 <jimbaker> in addition, other services like neutron, cinder, and nova can be useful to add information about what is happening with respect to hosts/devices
15:52:30 <sulo> anyway should move though other items here .. as we are running out of time
15:52:53 <jimbaker> sulo, thanks, yes, let's move that to a follow up discussion in #craton
15:54:39 <jimbaker> cmspence, any other work this week you want to highlight?
15:55:14 <jimbaker> sulo, i will really try to get the var refactoring in this week
15:55:29 <jimbaker> (too long delayed... and it's just alembic)
15:55:30 <cmspence> just making a strong effort to complete as much crud for python/cli inventory entities
15:55:42 <sulo> jimbaker: yes pls, few items dependent on that patch
15:56:17 <jimbaker> sulo, thanks for making that case re prioritization
15:56:29 <jimbaker> *easy to get distracted on other things*
15:56:30 <jimbaker> :)
15:56:49 <sulo> jimbaker: np, i think one item to discuss here is project structure
15:56:59 <sulo> re: https://review.openstack.org/#/c/354649/
15:57:01 <jimbaker> cmspence, i think the one ask here is to look at the docs aspect of that tork
15:57:02 <sulo> point to note
15:57:16 <sulo> 1) single api endpoint for both inventory and workflow
15:57:32 <sulo> 2) versioning will probably follow and will release cycle later on
15:57:33 <jimbaker> sulo, right, some nice cleanup here
15:58:06 <jimbaker> so we had discussed this in a dev call iirc and it made perfect sense
15:58:12 <sulo> jimbaker: yeah, so if we all agree, i can follow up with workflow patches
15:58:36 <jimbaker> sulo, yes
15:58:43 <syed_> Also guys, i am working over the API document as well and will be putting it up soon.
15:58:57 <jimbaker> we are basically removing some early project struct cruft, before we knew what we were really doing :)
15:58:59 <sulo> few items from my side needs that patch ... also important to get this done before the midcycle break .. i need this for my screencase ;)
15:59:11 <sulo> syed_: ah yes .. thanks!
15:59:21 <jimbaker> sulo, understood
15:59:25 <syed_> Have moved the Developer Install guide document and made some changes on it, its in review. Will be moving it to github openstack repo
15:59:29 <jimbaker> ok, we are coming up to the end of this meeting
15:59:38 <syed_> so that we have install guide up there for the people who wanna play with craton
15:59:42 <jimbaker> and we need to move all follow up discussion to #craton
15:59:48 <jimbaker> thanks everyone!
15:59:51 <jimbaker> #endmeeting