15:03:08 <jimbaker> #startmeeting craton
15:03:09 <openstack> Minutes:        http://eavesdrop.openstack.org/meetings/kuryr/2016/kuryr.2016-09-12-14.02.html
15:03:10 <openstack> Minutes (text): http://eavesdrop.openstack.org/meetings/kuryr/2016/kuryr.2016-09-12-14.02.txt
15:03:11 <openstack> Log:            http://eavesdrop.openstack.org/meetings/kuryr/2016/kuryr.2016-09-12-14.02.log.html
15:03:12 <openstack> Meeting started Mon Sep 12 15:03:08 2016 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:15 <openstack> The meeting name has been set to 'craton'
15:03:30 <jimbaker> #topic roll call
15:03:42 <chrisspencer> o/
15:03:47 <sulo> o/
15:03:48 <jimbaker> and general chit chat while we wait for everybody to be here
15:04:51 <sigmavirus> o/
15:04:52 <jimbaker> hi everyone. between travel, vacation, and a holiday, it's been 4 weeks since i was last on this meeting
15:05:04 <jimbaker> so glad to be back
15:05:04 <sigmavirus> jimbaker you've missed a lot
15:05:26 <jimbaker> it can be a challenge with monday meetings, or monday anything
15:06:54 <jimbaker> anyway, let's get started!
15:07:39 <jimbaker> #topic development progress
15:09:12 <jimbaker> turvey, o/
15:09:16 <turvey> o/
15:09:22 <jovon> hi everyone
15:09:29 <jimbaker> jovon, o/
15:09:59 <jimbaker> so glad is everyone here, let's get started on discussing dev progress. one key aspect: making sure everyone is unblocked
15:10:33 <jimbaker> a couple of things that i would start with
15:11:04 <jimbaker> 1. we have a lot of reviews to be done, so it's really important to understand prioritization if you are blocked on a review
15:12:10 <jimbaker> 2. perhaps the biggest challenge for a reviewer is understanding what is being presented
15:12:27 <syed_> o/
15:12:31 <sigmavirus> the second biggest is *why*
15:12:47 <sigmavirus> and the *why* should be answered in your commit message, if it isn't, please update your message ;)
15:13:03 <jimbaker> sigmavirus, right, detail is extremely important
15:13:22 <sigmavirus> a launchpad bug is good for discussion and context, but the why still needs to be in your message :)
15:13:54 <syed_> Agreed
15:14:25 <jimbaker> another context: why do we need this change, explained with code. so this means tests
15:14:57 <jimbaker> i think are unit tests have been mostly ok, but i'm seeing problems in functional testing - how the pieces fit together
15:15:19 <jimbaker> as a reviewer, this is the most important thing for me. otherwise, it's pretty easy
15:17:00 <jimbaker> so on the client side, seeing cratonclient exercised through building out, configuring, and querying the inventory is extremely important. also it will find bugs
15:17:47 <jimbaker> likewise on the rest api - as we are adding resources, we need to try this out, especially cases like duplicates, bad data, etc
15:18:32 <jimbaker> so those can be blockers for me, and i would like for us to address them
15:19:22 <jimbaker> chrisspencer, sulo - you have the most outstanding reviews. any thoughts here?
15:20:31 <jimbaker> also, in general, going forward, i want a chance at each meeting to call out blockers and especially speed bumps - what might be slowing us down
15:21:24 <sulo> +1 for more tests
15:21:32 <sulo> or functional tests i guess
15:22:24 <jimbaker> sulo, yeah, it's the #1 speed bump right now for us imho. plus also getting everyone able to run stuff end-to-end, especially debugging end-to-end
15:22:29 <chrisspencer> jimbaker. just trying to catch back up.  I agree we need to get through these reviews (some have been outstanding for > 1 month).  I'm not sure what is really left on some of the earlier reviews (have +2 and +1 verification).  But I would have to look at each individually.  Also not sure what % time I will be dedicating to this team as I get pulled off
15:22:48 <jimbaker> chrisspencer, yeah, so here's what i recommend for your case
15:23:29 <jimbaker> please roll up all of your changes into one overall change. you can put that in some fork
15:23:48 <jimbaker> and provide an extension of that test-cc.py script i put on gist
15:24:19 <sigmavirus> chrisspencer: you had said you wanted to block some changes on the conclusion to one of the other changes, that one should be good to go (and I think is already merged) can you update the rest?
15:24:35 <chrisspencer> sigmavirus: yup will do
15:24:36 <jimbaker> i'm ok with the basic approach you have been using. i'm sure we can improve, and i hope to see sigmavirus provide input/code here
15:24:38 <chrisspencer> jimbaker:  ack
15:24:55 <jimbaker> chrisspencer, https://gist.github.com/jimbaker/df47cabfefa6d6985af9029449b589df
15:25:00 <sigmavirus> I'll try to get some review in today, but I'm out the rest of the week (as a head's up)
15:25:40 <jimbaker> sigmavirus, fair enough. separately on #craton, let's start planning to have a meeting time that works for you for discussing cratonclient
15:26:53 <jimbaker> chrisspencer, i just want to have some confidence in the code. i haven't had a chance to go and extend test_cc.py for the other pieces, so i'm just seeing if you have time to do so
15:27:27 <jimbaker> once we have that, we can start building the functional testing in earnest
15:27:30 <chrisspencer> jimbaker: I will work with syed_ and jovon on that
15:27:39 <syed_> sounds good to me
15:27:47 <syed_> functional testing i need some help
15:27:51 <jimbaker> +1
15:27:53 <syed_> i will ping jim/sulo up for that
15:28:08 <syed_> we need it really soon so that we can verify everything is in place
15:29:06 <jovon> +1
15:29:40 <jimbaker> syed_, i'm a big fan of exploratory coding. let me try an API out in the console. iterate over it to build understanding
15:30:00 <syed_> sounds good to me jim
15:30:27 <jimbaker> then take those results, start building up a script that captures what i worked on - don't want to keep typing up the same stuff over and over again, and i don't want to rely on command history
15:30:33 <jimbaker> that's test_cc.py right now
15:30:46 <jimbaker> next: formalize into functional tests
15:31:16 <syed_> +1
15:31:40 <jimbaker> syed_, and certainly count me in as we move into that formalization to help out
15:32:15 <syed_> thank you jim
15:32:24 <jimbaker> jovon, were you able to generate the docs including the rest api changes you made?
15:33:10 <jimbaker> turvey, just want to see the same thing - i like looking at the .rst, but it's easier to see what has been done by looking at generated docs, much like running tox
15:33:23 <jovon> I have to 2 html schema from red and  local tox
15:33:49 <jovon> but no official link yet . it will be up momentarily
15:33:54 <jimbaker> jovon, thanks!
15:33:59 <turvey> jimbaker, Yep-- I added a link to a readthedocs page in my original review that shows a rendering of the changes
15:34:13 <jimbaker> turvey, awesome, that's going to be very helpful
15:34:35 <jimbaker> other blockers/speed bumps for people?
15:36:27 <syed_> rather then the db migration, i guess rest for me is going okay
15:36:49 <syed_> working over client side of the code for cells, once the region gets merged
15:37:05 <jimbaker> syed_, yeah, i would just suggest we hold off on you working on the migration scripts - they are as tricky as they get
15:37:23 <syed_> i am able to convert them, but facing a minor issue
15:37:34 <jimbaker> even simple changes seem to be not so simple
15:37:45 <syed_> haha agreed :)
15:38:29 <sulo> syed_: whats the problem with that patch, you should have everything you need now ?
15:39:16 <jimbaker> meanwhile, let me capture action items
15:40:04 <jimbaker> #agreed jimbaker will discuss dev blockers, speed bumps at each dev meeting going forward
15:41:09 <syed_> https://www.irccloud.com/pastebin/Cz4qvvGg/
15:41:23 <syed_> https://gist.github.com/ahsan518/4c9fc46896bd4ba801b8b1a12de7a6bb
15:41:29 <jimbaker> #action jimbaker works with syed_ on formalizing functional testing for cratonclient, after some exploratory testing code is written
15:42:00 <syed_> so when i try to run inventory, i get this error which is in pastebin, AttributeError: 'tuple' object has no attribute '_set_parent_with_dispatch'
15:42:01 <jimbaker> chrisspencer, this formalized functional testing will not block your changes landing btw - we will do it after the fact
15:42:11 <chrisspencer> jimbaker: sounds good
15:42:17 <syed_> +1
15:42:58 <jimbaker> syed_, so that's a typically non helpful alembic error
15:43:16 <syed_> i see
15:43:16 <jimbaker> which is even more nonhelpful than sqlalchemy's errors
15:44:02 <jimbaker> syed_, so i would start with a diff here
15:44:19 <jimbaker> but alembic - it's not easy, that's for sure
15:44:38 <syed_> hmm ..
15:45:17 <jimbaker> syed_, again - i don't want this to take up any more time for the time being. we need to fix this, but we can triage it past barcelona
15:45:33 <syed_> makes sense
15:45:55 <jimbaker> cool
15:47:22 <jimbaker> since i didn't see anything else raised about blockers, i assume we are generally good here and it's been discussed sufficiently
15:47:42 <jimbaker> for today
15:48:22 <jimbaker> #topic openstack ansible
15:48:50 <jimbaker> sulo, any updates here on support? i assume you are waiting on the network modeling to land
15:49:21 <sulo> yeah i need to get the patches i have to go in first
15:49:26 <sulo> then i have the next bunch ready
15:49:44 <sulo> which includes ansible-inventory endpoint
15:50:48 <jimbaker> right. and we will need to add cratonclient support for that endpoint
15:52:51 <jimbaker> sulo, one question for you with respect to ansible support here: my assumption is that should be trivial, because the cratonclient will just act as a dynamic inventory script; and that's just json
15:52:58 <jimbaker> anything i'm missing?
15:53:19 <sulo> will need a separate script that will use the client
15:53:59 <sulo> but yeah its just something that calls the api to get the json and return that
15:54:03 <jimbaker> sure, that's the worker code - it's retrieving variables, setting variables, running ansible playbooks with that inventory
15:55:54 <jimbaker> also fwiw the worker is mostly ansible, not OSA - the key part for OSA is the specific inventory modeling; any imports to that model; and proper JSON generation
15:56:52 <jimbaker> let's wrap this up now
15:56:59 <jimbaker> #topic other questions?
15:58:43 <jimbaker> let's move discussion to #craton
15:58:46 <jimbaker> thanks everyone!
15:58:53 <syed_> thanks guys
15:59:30 <jimbaker> #endmeeting