15:00:07 <jimbaker> #startmeeting craton
15:00:08 <openstack> Meeting started Mon Dec 12 15:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'craton'
15:01:21 <jimbaker> sigmavirus, sulo, toan, o/
15:01:47 <jimbaker> git-harry, o/
15:03:42 <sigmavirus> o/
15:04:26 <sigmavirus> How goes it, jimbaker ?
15:05:03 <jimbaker> sigmavirus, it is going very well, thanks. i had a nice weekend of hiking, some inside bouldering, and first attempt at slacklining
15:06:09 <jimbaker> by next weekend, the snow depth should get high enough to start opening up a lot of skiing, just in time for vacation :)
15:06:19 <jimbaker> sigmavirus, yourself?
15:06:40 <sigmavirus> Can't complain
15:06:41 <jimbaker> and thanks for your spec review on url design
15:07:08 <jimbaker> Syed__, hi
15:08:50 <sigmavirus> jimbaker: just trying to get something written down around that. We seem to be doing whatever strikes us as preferable at the moment, and I'd like that to stop because we seem to burn dev cycles that way
15:09:51 <jimbaker> sigmavirus, i thought we had reached agreement based on what git-harry had proposed. (as in, keep it flat.) but writing it down is definitely the best
15:10:12 <jimbaker> sulo, are you around?
15:11:28 <sigmavirus> jimbaker: you reached consensus in an unrecorded meeting without git-harry and myself (who seem to be the only people with differing opinions) so no justification was documented. Just the decision, in a gerrit comment, was written down somewhere
15:11:54 <Syed__> hi jim
15:11:54 <sigmavirus> I'm relitigating this only so we can document our justifications
15:12:21 <jimbaker> sigmavirus, sure, and i have no problem with the religitation
15:13:27 <sigmavirus> I'm not as concerned with what we choose, so long as we can all agree on why :)
15:15:11 <jimbaker> sigmavirus, i was always uncomfortable with the region_id being required. relaxing that constraint seemed to make a lot of sense. there is a natural hierarchy in terms of DC layout, but it's not necessary how one wants to get at things
15:15:32 <sigmavirus> jimbaker: let's keep the reasoning on the spec?
15:15:50 <sigmavirus> #link https://review.openstack.org/409281
15:15:51 <jimbaker> sigmavirus, sure
15:16:21 <jimbaker> and it can be done async as well, which is good considering we are missing git-harry, sulo this moment
15:16:27 <sigmavirus> #info That link is to a specification that will explain our choice of URL structure/semantics. Please review and contribute to the design and discussion
15:16:31 <sigmavirus> jimbaker: right
15:16:38 <sigmavirus> This is why I like gerrit specs :)
15:16:47 <git-harry> I'm here
15:17:12 <jimbaker> sigmavirus, better process is a good thing
15:18:00 <jimbaker> #topic week planning
15:18:12 <jimbaker> i will go first
15:19:19 <jimbaker> i have 3 blueprints i'm working on. rbac is more or less complete, but needs to move into the new gerrit review spec process. i also have some supporting code for implementing scoped role assignments, which is the key piece of the modeling that is craton specific
15:19:44 <jimbaker> the other blueprints are for secrets and virtualized variables
15:21:22 <jimbaker> re supporting code, i have done a bit of work also cleaning up the alembic migration so it has a more parallel implementation to the model code in models.py, which i think is important for helping keep things consistent/understandable
15:21:39 <jimbaker> so that's what i'm working on. i have no blockers
15:22:09 <Syed__> Cool.
15:22:14 <Syed__> I will go next
15:22:21 <jimbaker> Syed__, thanks
15:22:39 <Syed__> i have an review out there for network unit tests, whenever you guys get time kindly review that
15:23:11 <Syed__> will take more bugs from launchpad this week,
15:23:57 <Syed__> jimbaker: regarding rbac
15:24:27 <jimbaker> ?
15:24:47 <Syed__> are we able to get oslo.policy rules set up in rbac, or is this more or less regarding enforcing key rules for accessibility
15:26:03 <jimbaker> Syed__, so my expectation is that oslo.policy provides the logic that actually makes usable the scoped role assignments. nothing i'm doing should conflict
15:26:30 <Syed__> cool
15:26:44 <Syed__> waiting for that to be in the queue :)
15:26:47 <jimbaker> unfortunately that is some serious handwaving. the real answer is
15:27:16 <jimbaker> to demonstrate some appropriate integrating rules from oslo.policy
15:27:21 <Syed__> hmm
15:27:34 <Syed__> will be looking into it in depth
15:27:52 <Syed__> thats all from my side
15:28:09 <jimbaker> remember: the whole point of the scoped role assignments is to keep in the database what should be in the db; and to minimize the overhead of setting up by using our exisitng support for scoping
15:28:25 <jimbaker> Syed__, thanks
15:28:36 <jimbaker> sigmavirus, you want to go next?
15:31:49 <jimbaker> or we can just keep this meeting short
15:32:03 <jimbaker> git-harry, any updates on your side?
15:32:36 <sigmavirus> sorry, had a heavy package arrive
15:32:59 <sigmavirus> not many updates on my side. I'll be pressing folks for justification on the URL spec and working on caching & client stuff
15:33:45 <jimbaker> sigmavirus, sounds good. such discussion will sharpen our implementation
15:33:49 <git-harry> a lot of what I was doing is now blocked by the url spec, there are several dependant patches. I'm not going to try and unwind them, I'll just wait for the outcome of that spec.
15:34:14 <git-harry> I'll probably dig up something else to do in the meantime.
15:34:21 <jimbaker> git-harry, ok, so we need to conclude soon that discussion
15:35:00 <jimbaker> sigmavirus, i assume the spec + review is capturing the impact on the client, especially paging?
15:36:45 <jimbaker> in the meantime, i will dive into the discussion
15:37:01 <jimbaker> looks like we can have an early end for today's meeting. but first
15:37:58 <jimbaker> git-harry, sigmavirus, will you be around on dec 19? we will not have a meeting on dec 26 regardless
15:38:09 <git-harry> I won't
15:38:58 <jimbaker> ok, then let's cancel dec 19 as well
15:38:59 <sigmavirus> jimbaker: I think I will
15:39:02 <sigmavirus> wfm
15:39:08 <sigmavirus> jimbaker: want me to send that to the ML?
15:39:15 <jimbaker> sigmavirus, sounds good
15:39:27 <sigmavirus> #action sigmavirus to send message to openstack-dev cancelling next two meetings
15:39:38 <jimbaker> so today is the last irc meeting of the year. happy holidays everyone!
15:39:58 <sigmavirus> Happy New Year, y'all!
15:40:05 <jimbaker> please take a look at the url spec discussion, and weigh in. especially if you have questions - i know i do!
15:40:26 <jimbaker> #endmeeting