#openstack-meeting: crossproject

Meeting started by thingee at 21:00:58 UTC (full logs).

Meeting summary

    1. Agenda: https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting (thingee, 21:01:09)

  1. review past action items (thingee, 21:02:32)
    1. https://review.openstack.org/#/c/223011/ (johnthetubaguy, 21:03:12)
    2. https://review.openstack.org/#/c/223011/ (thingee, 21:03:36)
    3. https://wiki.openstack.org/wiki/StringFreeze (johnthetubaguy, 21:04:09)
    4. ACTION: ttx to review string freeze to Common Cycle with milestones doc update (thingee, 21:04:28)
    5. http://lists.openstack.org/pipermail/openstack-dev/2015-September/073576.html (thingee, 21:05:48)
    6. https://review.openstack.org/#/c/207467/ (thingee, 21:05:58)
    7. base feature deprecation policy discussed being wrapped in last TC meeting (thingee, 21:07:01)
    8. ACTION: ttx to propose new patch set for base feature deprecation policy (thingee, 21:07:18)

  2. Team announcements (horizontal, vertical, diagonal) (thingee, 21:09:23)
    1. http://docs.openstack.org/releases/ (ttx, 21:10:22)
    2. For release management goal is to start tagging RC1s early next week (thingee, 21:10:41)
    3. projects must wrap up the remaining FFEs in the coming days and start bruning their RC bugs lists (ttx, 21:11:09)
    4. we now have a website clearly describing deliverables in each release cycle, with version numbers and all (thingee, 21:11:10)
    5. http://docs.openstack.org/releases/ (thingee, 21:11:18)
    6. projects must wrap up the remaining FFEs in the coming days and start bruning their RC bugs lists (thingee, 21:11:45)

  3. Centralized Code Coverage Index/Stats (thingee, 21:15:21)
    1. https://review.openstack.org/#/c/221494/ (thingee, 21:15:39)
    2. working prototype available (thingee, 21:17:53)
    3. http://demo.ronaldbradford.com/cover/ (thingee, 21:17:59)
    4. https://review.openstack.org/214207 (fungi, 21:18:48)
    5. next step is posting stats to graphite and being able to show graphs over time (thingee, 21:20:41)
    6. http://git.openstack.org/cgit/openstack-infra/project-config/tree/zuul/layout.yaml (rbradfor, 21:21:35)
    7. http://git.openstack.org/cgit/openstack-infra/project-config/tree/zuul/layout.yaml (thingee, 21:21:44)
    8. waiting for patch to land to fix post gate checks (thingee, 21:26:02)
    9. #link https://review.openstack.org/214207 (thingee, 21:26:04)
    10. Question is, should the default {project}-coverage be non-voting always, and you need to override that for voting. Thats outside of this spec scope but something to promote more projects listed. (thingee, 21:26:39)

  4. Return request ID to caller (thingee, 21:28:56)
    1. https://review.openstack.org/#/c/156508/ (thingee, 21:29:07)
    2. currently has one +2. will be placed on the docket for final approval with TC next week assuming it continues consensual trends (thingee, 21:33:19)

  5. Refactoring testr and tox (thingee, 21:34:07)
    1. https://review.openstack.org/#/c/218070/ (thingee, 21:34:12)
    2. good thoughts in today's meeting with this, we'll bring this up next week again (thingee, 21:48:35)
    3. ACTION: lifeless to follow through with another iteration (thingee, 21:48:48)

  6. open discussion (thingee, 21:49:04)
    1. http://lists.openstack.org/pipermail/openstack-dev/2015-September/074126.html (kfox1111, 21:49:27)
    2. http://lists.openstack.org/pipermail/openstack-dev/2015-September/074126.html (thingee, 21:49:34)
    3. https://review.openstack.org/#/c/222293/ (kfox1111, 21:50:11)
    4. Instance Users for Cloud Interaction - sometimes instance need to interact with cloud serivces (thingee, 21:51:26)
    5. spec was moved from nova spec to cross project (thingee, 21:51:50)
    6. https://review.openstack.org/#/c/222293/ (thingee, 21:51:52)
    7. original nova spec comments should be addressed in cross project spec (thingee, 21:52:44)
    8. https://review.openstack.org/#/c/186617 (thingee, 21:52:46)
    9. instance users for cloud interaction is proposed to cross project sessions at the summit (thingee, 21:54:57)
    10. glance contributors please read discussion with dhellmann's priority proposal (thingee, 21:59:28)
    11. http://lists.openstack.org/pipermail/openstack-dev/2015-September/074360.html (thingee, 21:59:30)


Meeting ended at 22:00:20 UTC (full logs).

Action items

  1. ttx to review string freeze to Common Cycle with milestones doc update
  2. ttx to propose new patch set for base feature deprecation policy
  3. lifeless to follow through with another iteration


Action items, by person

  1. lifeless
    1. lifeless to follow through with another iteration
  2. ttx
    1. ttx to review string freeze to Common Cycle with milestones doc update
    2. ttx to propose new patch set for base feature deprecation policy


People present (lines said)

  1. thingee (90)
  2. lifeless (35)
  3. ttx (34)
  4. rbradfor (31)
  5. johnthetubaguy (17)
  6. jroll (15)
  7. kfox1111 (14)
  8. bknudson (14)
  9. fungi (13)
  10. tpatil (10)
  11. jokke_ (9)
  12. clarkb (7)
  13. dhellmann (6)
  14. openstack (5)
  15. redrobot (4)
  16. Rockyg (4)
  17. mestery (3)
  18. j^2 (2)
  19. david-lyle (2)
  20. annegentle (2)
  21. docaedo (1)
  22. SheenaG (1)
  23. TravT (1)
  24. gordc (1)
  25. EmilienM (1)
  26. Piet (1)
  27. kzaitsev_mb (1)
  28. stevebaker (1)
  29. smcginnis (1)
  30. russellb (1)
  31. loquacities (1)


Generated by MeetBot 0.1.4.