18:02:38 <sputnik13> #startmeeting cue
18:02:38 <openstack> Meeting started Tue Apr 28 18:02:38 2015 UTC and is due to finish in 60 minutes.  The chair is sputnik13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:42 <openstack> The meeting name has been set to 'cue'
18:03:16 <davideagnello> hello everyone
18:03:20 <sputnik13> goooooooood morning!
18:03:29 <abitha> good morning :)
18:03:46 <sputnik13> everyone here?
18:03:55 <danielallegood> hi!
18:03:56 <davideagnello> +1
18:04:10 <sputnik13> esmute?
18:04:24 <esmute> Oh hai
18:04:25 <esmute> meeting
18:05:11 <sputnik13> yup, meeting, we kind of skipped last week since no one was available...  so let's start with actions from the week before, and I don't think we have anything specific on the agenda
18:05:25 <sputnik13> so we'll do open discussion afterward
18:05:29 <sputnik13> sound good?
18:05:34 <davideagnello> yup
18:05:45 <sputnik13> #topic integration testing approach
18:06:36 <sputnik13> davideagnello and esmute you each had actions to do sample tests in rally and tempest respectively and come to a decision on which of the two to use
18:06:38 <davideagnello> we have been reviewing Tempest and Rally test frameworks for use in Cue's Integration and Scenario test coverage
18:06:39 <esmute> http://eavesdrop.openstack.org/meetings/cue/2015/cue.2015-04-14-18.07.txt
18:06:49 <esmute> that was the action items from last meeting
18:06:57 <sputnik13> http://eavesdrop.openstack.org/meetings/cue/2015/cue.2015-04-14-18.07.html
18:07:01 <sputnik13> :)
18:07:33 * sputnik13 is dying from the suspense
18:07:35 <davideagnello> we have decided to use Tempest for integration tests and rally for scenario tests with rally launching both integration and scenario tests
18:07:57 <sputnik13> particular reasons?
18:08:09 <davideagnello> Tempest tests will be interfacing directly to cue through the REST API
18:08:42 <esmute> tempest allows you to build test that are part of the common python testing framework.... like testools and unittests
18:09:14 <davideagnello> Rally provides a straight forward and powerful way to run overall scenario tests, run benchmarks
18:09:15 <esmute> which mean that they provide all the functionalities and tooling that you'd expect in a testing framework...
18:09:34 <esmute> but the most compelling reason is the maturity of tempest for integration/api tests
18:09:46 <esmute> since all openstack projects uses them for testing,
18:10:14 <davideagnello> Rally makes use of the service's client
18:10:22 <esmute> i have put up a patch that will great a base int test and tests for create/list/get/delete
18:10:26 <esmute> https://review.openstack.org/#/c/177984/
18:10:36 <esmute> please review it when you get a chance
18:11:18 <esmute> tests can be run by using testr or nosetests.. but i have also added a run_tests.py script that will create the env and run the test for you
18:11:19 <davideagnello> https://review.openstack.org/#/c/175524/ this patch covers Rally integration into Cue and a e2e scenario test which creates, verifies and deletes a cluster
18:11:40 <esmute> this script will be used by the devstack-vm-gate (future) to run our tests
18:12:32 <esmute> We choose rally for sceneraio tests... davideagnello has been looking at them mainly..
18:12:53 <esmute> davideagnello: can you give us an update of rally in scenario testing?
18:13:05 <davideagnello> running the current Rally scenario test in Cue's devstack is as easy as:  1. source your openstack credentials in devstack 2. running them with:  run_rally_scenarios.sh
18:13:39 <davideagnello> esmute: ^
18:13:55 <sputnik13> #link https://review.openstack.org/#/c/177984/
18:14:05 <sputnik13> #link https://review.openstack.org/#/c/175524/
18:14:28 <sputnik13> so these are patches for integration test using tempest and scenario test using rally respectively
18:14:29 <sputnik13> ?
18:14:41 <esmute> sputnik13: yes..
18:15:09 <esmute> once the int-tests go in, we can start running int tests....
18:15:11 <sputnik13> ok, do we understand how to launch these as part of a gate in CI?
18:15:29 <sputnik13> esmute: you're referring to tempest exclusively, yes?
18:15:30 <esmute> next will be to hook it up with devstack-vm gate so that they are run everything we check in
18:15:50 <esmute> sputnik13: yes.. ask davideagnello for rally and scenario tests :P
18:16:22 <davideagnello> Rally scenario can be executed directly through a simple script
18:17:03 <sputnik13> davideagnello: is there a plan to run rally scenario tests as part of a ci-gate?
18:17:15 <davideagnello> I am currently not familiar with the CI framework, will be looking at how to add them there
18:17:24 <davideagnello> sputnik13: yes
18:17:55 <sputnik13> ok
18:17:56 <esmute> davideagnello: we can have scripts that can be run by the gate thru hooks..
18:18:16 <esmute> so if you/rally has a script that runs all tests, we can use this
18:18:18 <sputnik13> #action davideagnello investigate how to run rally tests in CI gate
18:18:59 <davideagnello> sounds good :)
18:19:42 <sputnik13> and esmute you're going to be adding the integration for running the tempest tests in CI?
18:20:02 <esmute> yes
18:20:05 <sputnik13> #action esmute enable automatic tempest testing for all cue project repos
18:21:08 <sputnik13> #agreed using both tempest and rally for testing but for different types of tests (integration and scenario respectively)
18:21:41 <sputnik13> btw, when providing information, you should use the info command to add information for the minutes
18:21:44 <sputnik13> https://wiki.debian.org/MeetBot
18:21:59 <sputnik13> it's fine for today, let's try and do that in future meetings
18:22:29 <sputnik13> anything more on the testing approach?
18:23:04 <davideagnello> time to write integration and scenario tests now!
18:23:26 <sputnik13> action davideagnello to write all integration and scenario tests
18:23:28 <sputnik13> :-D
18:23:35 <davideagnello> hahaha
18:23:41 <sputnik13> alright, going once
18:23:46 <sputnik13> going twice
18:23:55 <sputnik13> aannnddd
18:23:57 <sputnik13> #topic cue stickers and t-shirt
18:24:27 <davideagnello> do we have updated samples?
18:24:48 <sputnik13> I do, one sec while I find it
18:25:58 <sputnik13> #link http://snag.gy/ihaRb.jpg
18:26:27 <davideagnello> looks nice
18:26:40 <sputnik13> the final will be a little different, the top portion of the bottom part of the letter needs to be lightened as per vipul's feedback
18:27:07 <davideagnello> do we have a sample that has the word Cue at the bottom in a straight horizontal line?
18:27:09 <sputnik13> my friend was confused about which part to lighten, but other than that it's ready to go
18:27:10 <abitha> nice!
18:27:36 <sputnik13> no, with the word straight the whole image looks a bit off
18:27:42 <esmute> is the shirt black?
18:27:49 <davideagnello> oh ok
18:27:57 <sputnik13> I think this logo really works best on its own without any wording
18:28:07 <sputnik13> but the concern was that no one would know what it was for
18:28:16 <sputnik13> esmute: no it's a hot pink
18:28:18 <esmute> i like it...
18:28:19 <sputnik13> :-D
18:28:31 <davideagnello> yeah true
18:28:31 <abitha> the white background is only for the sticker right?
18:28:41 <sputnik13> it's hot pink and it has sparkly rhinestones all over it
18:28:47 <esmute> sputnik13: as long as i can wear it outside of my bedroom :P
18:28:55 <sputnik13> hahahah
18:29:17 <sputnik13> esmute: we haven't made the t-shirts yet, we need everyone's sizes
18:29:33 <sputnik13> and we have until the end of the week to pick colors
18:29:53 <esmute> can you send a surveymonkey link with the choices?
18:30:21 <sputnik13> uh, no, too much work, we're not making t-shirts for 100s of people
18:30:46 <sputnik13> it's just a few of us let's just take a vote in the main channel later
18:30:54 <esmute> i'd like a low cut women's shirt just the way you described it for me wifey :)
18:31:11 <sputnik13> hmm, let's talk to vipul about that :-P
18:31:18 <esmute> ok
18:31:28 <sputnik13> you know you can always take a shirt and modify it ;)
18:32:00 <sputnik13> that's where are with the sticker and t-shirt
18:32:47 <sputnik13> questions? are we good?
18:32:59 <sputnik13> going once
18:33:01 <sputnik13> going twice
18:33:12 <sputnik13> aaannnddd we're good
18:33:31 <sputnik13> #topic open discussion
18:34:08 <sputnik13> any other questions, concerns, interesting tidbits?
18:34:52 <esmute> Pacquiao vs Mayweather this Saturday :)
18:35:02 <sputnik13> boxing?
18:35:16 <esmute> yup.. fight of the century
18:35:23 <esmute> or so they say
18:35:30 <sputnik13> until the next one
18:35:32 <sputnik13> ;)
18:35:46 <sputnik13> this century hasn't been very long either, we're in year 15 :)
18:35:55 <sputnik13> media hype ftw
18:36:14 <sputnik13> actually...  danielallegood
18:36:33 <sputnik13> did you have a chance to look in to the sqlalchemy problem you were having?
18:36:47 <sputnik13> with version always returning None?
18:36:52 <danielallegood> No not yet.
18:37:36 <sputnik13> ok, I think that would be good to follow up on and get some closure to...  if it's a sqlalchemy bug it would be good to get it filed
18:38:10 <sputnik13> http://www.sqlalchemy.org/support.html#irc
18:38:23 <sputnik13> ^ says they're at #sqlalchemy
18:38:25 <danielallegood> Ok, I'll spend some time on it today
18:38:57 <sputnik13> yeah, don't spend a ton of time on it, just drop in the channel and see if anyone knows of it
18:39:11 <sputnik13> raise your irc aptitude a bit ;)
18:39:48 <sputnik13> any other topics?
18:40:02 <sputnik13> has anyone been to the tulip festival?
18:40:13 <sputnik13> the skagit valley tulip festival
18:40:27 <sputnik13> totally not worth it imho, but there's a brewery there...  great bbq
18:40:32 <sputnik13> :)
18:40:49 <sputnik13> http://www.skagitbrew.com
18:41:00 <abitha> I didnt visit this year..
18:41:11 <sputnik13> totally recommended if you're in the area, it's on the way up to vancouver
18:41:21 <sputnik13> and they have bbq chicken too ;)
18:41:30 <abitha> :)
18:42:06 <esmute> sputnik13: you went too late.
18:42:26 <esmute> it is nice between end of march and beginning of april
18:43:03 <sputnik13> oh, it makes that much of a difference?
18:43:28 <sputnik13> maybe we'll go again for bbq and shopping next beginning of next april then :)
18:43:36 <abitha> ya. it used to have acres of flowers during the beginning of april
18:43:47 <sputnik13> I was a bit disappointed with the outlets up that way
18:44:06 <sputnik13> ah ok, there were very few flowers when we were there
18:44:45 <esmute> you see miles and fields of tulips all different colors
18:44:48 <esmute> its nice :)
18:45:05 <sputnik13> hmmm, ok, we'll give it another shot next year :)
18:45:32 <sputnik13> if you go up, you should stop at the brewery for bbq, it was really good
18:45:55 <sputnik13> ok, if there's no other topics should we end the meeting?
18:46:20 <sputnik13> going once
18:46:29 <sputnik13> going twice
18:46:34 <sputnik13> #endmeeting