18:02:21 <sputnik13> #startmeeting cue
18:02:21 <openstack> Meeting started Mon Jun  8 18:02:21 2015 UTC and is due to finish in 60 minutes.  The chair is sputnik13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:25 <openstack> The meeting name has been set to 'cue'
18:02:31 <sputnik13> role call, sound off
18:02:33 <sputnik13> 1
18:02:36 <vipul> o/
18:02:53 <davideagnello> hello!
18:02:55 <abitha> hello
18:03:51 <sputnik13> you guys are horrible at this, sound off one two three four, etc
18:03:52 <sputnik13> :-P
18:04:01 <sputnik13> where's dkalleg ?
18:05:02 <vipul> sputnik13: :p didn't know we were playign that game
18:05:59 <sputnik13> dkalleg is indisposed I guess, let's start the meeting!
18:06:12 <sputnik13> we have... dun dun duuuuunnnnn
18:06:14 <sputnik13> agenda!
18:06:17 <sputnik13> https://wiki.openstack.org/wiki/Meetings/Cue
18:06:40 <sputnik13> our next meeting is no longer in the past
18:06:41 <sputnik13> :)
18:06:50 <davideagnello> nice
18:07:13 <vipul> thx for updating that
18:07:15 <sputnik13> #topic Open Action Items
18:07:23 <sputnik13> http://eavesdrop.openstack.org/meetings/cue/2015/cue.2015-06-01-18.01.html
18:07:58 <sputnik13> vipul no problem, I might get it done sooner than 12 hours before the meeting for next week ;)
18:08:13 <sputnik13> davideagnello you first
18:08:40 <davideagnello> ok, so Rally job is currently in review
18:08:58 <davideagnello> https://review.openstack.org/#/c/187620/
18:09:13 <sputnik13> #info davideagnello to look into getting Rally gate job added
18:09:18 <davideagnello> the CI job was created by Sergey Skripnick
18:09:27 <sputnik13> #link https://review.openstack.org/#/c/187620/
18:09:48 <sputnik13> who's sergey?
18:09:55 <sputnik13> I thought Boris was the rally guy
18:10:09 <davideagnello> looks like it passed jenkins tests and waiting to be merged in
18:10:20 <davideagnello> I am not sure
18:10:35 <sputnik13> well, I'm not one to look the gift horse in the mouth
18:10:55 <dkalleg> sorry, hi
18:11:04 <davideagnello> haha yes
18:11:16 <dkalleg> 2
18:11:22 <sputnik13> see, dkalleg gets is
18:11:27 <sputnik13> s/is/it
18:11:52 <sputnik13> fashionably late though he may be
18:12:12 <sputnik13> ok, so we're just waiting for it to merge?
18:12:21 <davideagnello> so at this point who would we talk to in order to get this added?
18:12:26 <davideagnello> sputnik13: yes
18:12:31 <sputnik13> added as in what
18:12:36 <davideagnello> merged
18:12:41 <vipul> talk to someone in #openstack-infra
18:12:48 <sputnik13> hmm, I don't know, maybe camp out at #openstack-infra
18:12:52 <sputnik13> yeah, what vipul  said
18:12:55 <davideagnello> ok
18:13:10 <sputnik13> you like the great outdoors, go camping :)
18:13:26 <vipul> this should be straight forward, it's an experimental check -- should be merged if we ask
18:13:28 <dkalleg> *crickets*
18:14:22 <sputnik13> davideagnello once that's merged do we need changes to our repo?
18:14:36 <davideagnello> sputnik13: we shouldn't have to
18:14:40 <sputnik13> ok
18:14:46 <sputnik13> #action davideagnello to follow up on rally job merge
18:15:01 <sputnik13> next topic?
18:15:34 <sputnik13> #topic esmute to making tempest rabbit gate job voting
18:16:10 <davideagnello> it's not voting yet, but the test looks stable
18:16:20 <sputnik13> being that esmute is out and someone (me) neglected to follow up with him, let's get status on this next week
18:16:23 <vipul> davideagnello: does it? i haven't seen it pass that often
18:16:30 <sputnik13> davideagnello: define "stable"
18:16:31 <vipul> maybe i am looking at the wrong patches
18:17:04 <davideagnello> in the last four outstanding patches, the test are passing
18:17:26 <davideagnello> total runtime is around 40 min
18:17:34 <sputnik13> no no, what we're looking for are consistently passing
18:17:57 <davideagnello> ok, over how many iterations?
18:18:05 <sputnik13> #link https://review.openstack.org/#/c/187273/6
18:18:12 <sputnik13> that's where we're trying to track it right?
18:18:37 <sputnik13> of the last 4 attempts 2 failed
18:18:52 <sputnik13> I'm not sure how that coincides with the rabbit stability patch being merged
18:19:03 <ekarlso> o/
18:19:06 <ekarlso> just peeking in  )
18:19:07 <sputnik13> but it doesn't seem stable at this point
18:19:12 <sputnik13> ekarlso welcome
18:19:18 <davideagnello> when was your cloud config fix merged in?
18:19:48 <davideagnello> seems to be since the port delete and oscloud config changes where made
18:20:05 <sputnik13> 6/3
18:20:27 <sputnik13> so the 2 failures could have been before the merge and the 2 successes were definitely after the change
18:20:55 <sputnik13> but 1 day of tests following a fix doesn't seem to match the bar we agreed to
18:21:09 <sputnik13> which was about 1 week of testing to ensure it's stable
18:21:20 <davideagnello> I agree, we should give it more time, but it is looking better
18:21:37 <sputnik13> it's definitely looking better, agree 100% there :)
18:22:06 <sputnik13> I think we should continue to run rechecks this week and check on this again next week
18:22:47 <sputnik13> I think that patch might need to be rebased as well
18:22:54 <sputnik13> not positive
18:23:07 <davideagnello> ok, will get it updated
18:23:27 <sputnik13> #startvote postpone decision on tempest gate until 6/15
18:23:28 <openstack> Unable to parse vote topic and options.
18:23:33 <sputnik13> bleh
18:23:47 <davideagnello> lol
18:24:08 <vipul> you need to provide options :P
18:24:22 <sputnik13> like how
18:24:35 <vipul> #startvote Should we vote now? Yes, No, Maybe
18:24:36 <openstack> Only the meeting chair may start a vote.
18:24:37 <sputnik13> ah I see it
18:24:49 <vipul> #link http://docs.openstack.org/infra/system-config/irc.html#voting
18:24:58 <sputnik13> #startvote Postpone decision on tempest gate until 6/15? Yes, No
18:24:59 <openstack> Begin voting on: Postpone decision on tempest gate until 6/15? Valid vote options are Yes, No.
18:25:00 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:25:06 <sputnik13> #vote Yes
18:25:09 <vipul> #vote yes
18:25:16 <davideagnello> #vote yes
18:25:22 <vipul> i wonder if it's case sensitive
18:25:32 <sputnik13> we'll find out in a bit
18:25:38 * sputnik13 prods abitha and dkalleg
18:25:41 <sputnik13> vote
18:25:47 <dkalleg> #vote Yes
18:25:49 <abitha> #vote yes
18:25:55 <sputnik13> #endvote
18:25:56 <openstack> Voted on "Postpone decision on tempest gate until 6/15?" Results are
18:25:57 <openstack> Yes (5): dkalleg, vipul, sputnik13, davideagnello, abitha
18:26:05 <vipul> w00t
18:26:10 <vipul> landslide
18:26:12 <sputnik13> ok, cool, it's like all official like
18:26:14 <sputnik13> :-D
18:26:32 <sputnik13> ok, should we go on to the next topic?
18:26:41 <vipul> +1
18:26:51 <davideagnello> just got notice from openstack-infra that they would like a Cue core to review and +1 patch before they merge
18:27:01 <sputnik13> #agreed follow up on tempest gate status 6/15 and decide whether to make it voting
18:27:03 <davideagnello> for rally ci job
18:27:24 <sputnik13> davideagnello: ok, action for vipul and me
18:27:40 <sputnik13> #action vipul and sputnik13 to review https://review.openstack.org/#/c/187620/ and +1 it
18:28:05 <sputnik13> #topic sputnik13 vipul davideagnello esmute start classifying undecided bugs
18:28:29 <sputnik13> I checked undecided for bugs last night and at least as of last night there were no undecided bugs so that's good
18:29:04 <vipul> so that means everything reported is an actual bug
18:29:19 <davideagnello> I see three which don't seem to be classified
18:29:23 <sputnik13> hmm, wait there's 3 that are undecided still
18:29:28 <davideagnello> https://bugs.launchpad.net/cue
18:29:32 <sputnik13> yeah
18:29:40 <sputnik13> there's something wrong with the filter I used I guess
18:29:42 <sputnik13> user error
18:30:21 <sputnik13> #action esmute to classify https://bugs.launchpad.net/cue/+bug/1439329 and https://bugs.launchpad.net/cue/+bug/1439330
18:30:22 <openstack> Launchpad bug 1439329 in Cue "Cluster goes to ERROR when creating it with flavor passed by name" [Undecided,New]
18:30:23 <openstack> Launchpad bug 1439330 in Cue "Cannot delete cluster by name" [Undecided,New]
18:30:45 <sputnik13> #action sputnik13 to harass josh barry to classify https://bugs.launchpad.net/cue/+bug/1450931
18:30:46 <openstack> Launchpad bug 1450931 in Cue "Readme doc link incorrect" [Undecided,New]
18:30:57 <sputnik13> actually that last one is probably just low
18:31:06 <sputnik13> I'll follow up
18:32:12 <sputnik13> next topic
18:32:14 <sputnik13> ?
18:32:49 <sputnik13> #topic blueprints
18:33:13 <sputnik13> we have an agreement to create more blueprints to better document the features that are being worked on
18:33:34 <sputnik13> #link https://blueprints.launchpad.net/cue
18:33:47 <sputnik13> Thanks davideagnello for entering some of the blueprints
18:34:18 <davideagnello> np, they are a start.  we might want to add more as we see fit to each
18:34:30 <sputnik13> +1
18:34:43 <sputnik13> we should add more detail to each as we find more detail
18:35:14 <davideagnello> agreed
18:35:15 <sputnik13> I will be looking in to kafka for an "intro to kafka" thing I'm going to be doing next week, so I will take that one on
18:35:31 <sputnik13> #action sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:36:04 <sputnik13> can someone add some detail to https://blueprints.launchpad.net/cue/+spec/rally-scenario-tests
18:36:11 <sputnik13> based on what we have and what's in process?
18:36:19 <davideagnello> I can do that one
18:36:45 <sputnik13> davideagnello can you also add a linke to the API in the v1-api blueprint?
18:37:19 <sputnik13> #action davideagnello to add detail to https://blueprints.launchpad.net/cue/+spec/rally-scenario-tests based on existing rally tests and gate testing things in process
18:37:38 <sputnik13> #action davideagnello to add link and information to v1 API in https://blueprints.launchpad.net/cue/+spec/v1-api
18:37:53 <sputnik13> the others we can fill in details as we start tackling them
18:38:36 <sputnik13> next on the agenda is/are bugs, should we go on or are there other things related to blueprints we need to discuss?
18:38:40 <davideagnello> sputnik13: ok
18:38:53 <davideagnello> sputnik13: to the API read the docs?
18:39:15 <sputnik13> davideagnello yup, and as I recall there was a wiki page that was created a while back describing the API as well wasn't there?
18:39:27 <sputnik13> a link to that would be good too for posterity
18:39:31 <davideagnello> yes, created that one a while back
18:39:34 <davideagnello> ok
18:40:27 <sputnik13> we have 20 minutes left and I would like to leave some time in the end for open discussion, so let's move on if there aren't other things to discuss regarding blueprint
18:40:40 <sputnik13> going once
18:40:44 <sputnik13> going twice
18:40:47 <davideagnello> I think that's all regarding blueprints, we should discuss which bugs
18:40:56 <sputnik13> cool
18:40:58 <davideagnello> should be resolved next
18:41:14 <sputnik13> #topic bugs
18:41:23 <sputnik13> #link https://bugs.launchpad.net/cue/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.importance%3Alist=CRITICAL&field.importance%3Alist=HIGH&field.importance%3Alist=MEDIUM&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_comb
18:41:23 <sputnik13> inator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
18:41:31 <sputnik13> woah that doesn't work
18:42:12 <sputnik13> #link http://bit.ly/1MChDwJ
18:43:11 <sputnik13> vipul and I have the ongoing action to triage/disposition bugs, but I feel like a bug should not stay in the New state for any longer than a week
18:43:26 <davideagnello> I think our current failure in reverting a flow on create is something that should be addressed
18:43:26 <sputnik13> especially if they're critical, high, or medium
18:43:50 <sputnik13> so I'd like to make sure we get the highest ones triaged and assigned
18:44:08 <sputnik13> some of these actually need to be recategorized as far as importance
18:44:22 <davideagnello> yes
18:44:22 <sputnik13> as they don't follow the definition we agreed to
18:44:34 <abitha> nic argument should be a list is already fixed. why is it still showing new?
18:45:06 <sputnik13> abitha: status is changed when someone goes and changes it
18:45:20 <sputnik13> when you commit things in gerrit, gerrit goes and updates the status for you
18:45:33 <sputnik13> perhaps the bug wasn't properly referenced in the patch?
18:45:35 <abitha> oh ok.
18:46:04 <abitha> it is listed as partial-bug as the other half is fixed by the client
18:46:11 <sputnik13> abitha: since you know where it was fixed, can you go update that?
18:46:18 <sputnik13> ok
18:46:29 <sputnik13> does the client say closes or partial-bug?
18:46:33 <abitha> should I change the bug from partial to closes bug?
18:46:39 <sputnik13> I think at least one change needs to say closes bug
18:46:49 <sputnik13> but if the change was already merged I'm not sure you can update the commit message
18:46:50 <abitha> oh ok. I will change and close this one
18:47:11 <abitha> if thats the case can I close it manually?
18:47:20 <sputnik13> so if the changes were already merged, just go ahead and change the status to fix committed and reference the changes (if they're not in the history already)
18:47:36 <abitha> ok .will do
18:47:48 <sputnik13> I only see one message from gerrit in the history, so you might have to add a link to the other one
18:48:05 <abitha> sure
18:48:53 <sputnik13> davideagnello: do you see the bug that states rollback isn't happening?
18:49:57 <abitha> actually client patch already has closes-bug. but don't know why it wasn't linked correctly?
18:49:57 <davideagnello> sputnik13: I don't see that one
18:50:49 <sputnik13> davideagnello: I think I might have been conflating that bug with others like https://bugs.launchpad.net/cue/+bug/1452958 https://bugs.launchpad.net/cue/+bug/1452959 https://bugs.launchpad.net/cue/+bug/1452990
18:50:51 <openstack> Launchpad bug 1452958 in Cue "cluster does not change to ERROR state when VM does not go ACTIVE" [High,New]
18:50:51 <sputnik13> in my mind
18:50:52 <openstack> Launchpad bug 1452959 in Cue "cluster does not ERROR on missing broker metadata" [High,New]
18:50:53 <openstack> Launchpad bug 1452990 in Cue "resources not cleaned up when deleting a cluster in BUILDING state" [Medium,New]
18:51:15 <sputnik13> so we might have to file it as a distinct bug
18:51:31 <sputnik13> we should look in to it further
18:51:36 <sputnik13> I agree it needs to be resolved soon
18:52:02 <davideagnello> yes, those look like the results of a rollback not working
18:52:10 <sputnik13> we can't go through all of the bugs during the meeting, can everyone go through the bugs they filed and make sure they're currently classified correct?
18:52:27 <sputnik13> davideagnello: I disagree a bit, some of those should trigger the rollback
18:53:02 <sputnik13> no wait, nevermind you're right
18:53:10 <sputnik13> they're probably all related to the rollback not happening
18:53:18 <sputnik13> we set ERROR status at the end of a rollback right?
18:53:24 <davideagnello> yup, that's what I meant
18:53:27 <davideagnello> yes we do
18:53:32 <sputnik13> yeah, you're right
18:53:48 <davideagnello> if the rollback reaches the first task :)
18:53:58 <sputnik13> we need a way to reproduce the lack of rollback, I think I know how to do that
18:54:12 <sputnik13> I'll reproduce the error and file a new bug
18:54:28 <davideagnello> ok, how do you trigger that behavior?
18:54:35 <davideagnello> make a task implicitly fail?
18:54:49 <sputnik13> #action sputnik13 reproduce bug that fails to rollback a cluster create and file a bug with the details
18:55:09 <sputnik13> davideagnello based on what I saw in the rally tests, running out of resources seems to trigger this
18:55:20 <sputnik13> so I'm going to just create clusters until it fails
18:55:33 <sputnik13> and make sure it does that reliably
18:55:45 <davideagnello> ok, makes sense
18:56:12 <sputnik13> #action vipul davideagnello esmute abitha dkalleg to check that existing bugs have the correct classification
18:56:53 <sputnik13> the action last week was to make sure there were no Undecided bugs but several bugs that were already classified had improper classifications
18:57:27 <sputnik13> we have 3 minutes left in the meeting :(
18:57:53 <sputnik13> so in future meetings I'm hoping we can discuss the critical/high/medium bugs, but I don't think we have a clear picture of what those are right now
18:58:00 <sputnik13> given there are some bugs that are mis-classified
18:59:28 <sputnik13> questions? concerns? other topics?
18:59:34 <davideagnello> ok, agreed
18:59:44 <sputnik13> #topic Open Discussion
19:00:07 <sputnik13> who's sick of the sun?
19:00:08 <sputnik13> :)
19:00:16 <sputnik13> so hot this past weekend
19:00:30 <sputnik13> it was actually cooler in San Diego than Seattle
19:00:54 <sputnik13> my wife actually started getting excited at the prospect of rain next week
19:00:54 <sputnik13> :)
19:00:55 <dkalleg> That doesn't make it hot :-P You want hot go check out Virginia in the summer.
19:01:13 <dkalleg> actually, I think Abitha might trump us all
19:01:22 <hogepodge> can we wrap up for the next meeting?
19:01:37 <sputnik13> alrighty, thanks everyone
19:01:39 <sputnik13> #endmeeting