18:00:53 <vipuls> #startmeeting cue
18:00:54 <openstack> Meeting started Mon Jun 22 18:00:53 2015 UTC and is due to finish in 60 minutes.  The chair is vipuls. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:57 <openstack> The meeting name has been set to 'cue'
18:01:04 <vipuls> roll call..
18:01:07 <vipuls> o/
18:01:14 <esmute__> o/
18:01:15 <dkalleg> o/
18:01:19 <davideagnello> hello
18:01:23 <abitha> hello
18:01:45 <vipuls> ok nice.. let's get started
18:02:00 <vipuls> sputnik is interviewing someone .. wont' be here
18:02:06 <vipuls> #link https://wiki.openstack.org/wiki/Meetings/Cue
18:02:14 <vipuls> #topic Action Items
18:02:21 <vipuls> #link http://eavesdrop.openstack.org/meetings/cue/2015/cue.2015-06-15-18.02.html
18:02:25 <harlowja> oh is https://github.com/openstack/cue in yet?
18:02:32 <harlowja> oops, sorry, will ask later
18:02:37 <vipuls> harlowja: we shall see tomorrow ;)
18:02:39 <harlowja> k
18:02:56 <vipuls> davideagnello to follow up on rally job merge, work with Sergey to fix job and ensure it runs on some patches
18:03:09 <davideagnello> yes
18:03:23 <davideagnello> we uploaded a new patch fixing the issue related to the error we saw last week
18:03:36 <davideagnello> the job is now failing at another point further in the process
18:03:50 <vipuls> is it running tests yet? or still setup issues?
18:04:14 <davideagnello> it's not running the tests yet, it is looking for files in a location called:  rally-plot/**
18:04:46 <esmute__> davideagnello: what errors are you seeing?
18:05:06 <davideagnello> this was as of last thursday, trying to get information from the rally group on what this means as it's not something I was able to find in their CI gate job documentation
18:05:18 <davideagnello> No file(s) found: rally-plot/**
18:05:48 <davideagnello> ‘rally-plot/extra/index.html’ doesn’t match anything: even ‘rally-plot’ doesn’t exist
18:05:52 <vipuls> davideagnello: that may not be the error actually..
18:05:53 <davideagnello> it then just fails
18:06:02 <vipuls> that's just a side effect of the real failure
18:06:04 <vipuls> http://logs.openstack.org/59/191959/1/experimental/gate-cue-integrate-dsvm-rally/184e871/console.html.gz
18:06:21 <vipuls> #link http://logs.openstack.org/59/191959/1/experimental/gate-cue-integrate-dsvm-rally/184e871/console.html.gz#_2015-06-18_17_54_35_647
18:06:25 <vipuls> ^ is the real error
18:07:12 <davideagnello> ok, I am looking into this.  Since Thursday last week I haven't had time to look into this problem
18:07:18 <esmute__> davideagnello: lets work together on this since i did something similar for integration test
18:07:42 <davideagnello> esmute__: sounds good, thanks
18:07:55 <vipuls> esmute__: davideagnello : the ball's back in our court.. job seems to have set up correctly, missing things in the cue repo
18:08:24 <vipuls> #action esmute__ and davideagnello to fix the rally gate job and get rally tests running
18:08:43 <davideagnello> vipuls: let's pull this in into planning
18:09:07 <vipuls> davideagnello: feel free to bring it up during planning meeting
18:09:24 <davideagnello> ok
18:10:03 <vipuls> next couple of actions are for sputnik13, we'll go through them, if anyone has an update please chime in
18:10:04 <vipuls> sputnik13 to classify https://bugs.launchpad.net/cue/+bug/1450931 and talk with Josh about classifying submitted bugs
18:10:05 <openstack> Launchpad bug 1450931 in Cue "Readme doc link incorrect" [Undecided,New]
18:10:34 <vipuls> oh this one Josh barry fixed already
18:10:54 <vipuls> #action vipuls to link Josh's patch with correct bug number
18:11:08 <vipuls> sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:11:28 <vipuls> looks like that still needs some details :)
18:11:34 <vipuls> #action sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:11:55 <vipuls> ok next up..
18:11:56 <vipuls> davideagnello to add link and information to v1 API in https://blueprints.launchpad.net/cue/+spec/v1-api
18:12:07 <davideagnello> that's done
18:12:34 <vipuls> nice
18:12:57 <vipuls> sputnik13 to track release of new taskflow version and ensure https://review.openstack.org/#/c/190081/ is merged
18:13:34 <vipuls> harlowja: taskflow just released right?
18:13:59 <harlowja> should have, although i think https://review.openstack.org/#/c/192343/ is in the pipeline
18:14:11 <harlowja> although i think cue isn't yet (?) blocking on global-requirements
18:14:20 <vipuls> d'oh yea.. we're fine for now..
18:14:34 <harlowja> k, unsure how that works going forward when joining 'openstack' namespace
18:14:48 <vipuls> Hopefully that merges by then ;)
18:14:50 <harlowja> ya
18:14:57 <harlowja> never know how long it will take, ha
18:15:19 <vipuls> ok cool.. so we'll consider that action closed
18:15:26 <vipuls> esmute to rebase https://review.openstack.org/#/c/187273/ then run a minimum of 20 rechecks on it by 6/22
18:15:34 <vipuls> esmute__: how's the tempest job looking?
18:15:46 <harlowja> minumum of 20 rechecks, lol
18:15:52 <esmute__> Did many rechecks!
18:15:54 <harlowja> why only 20, why not 200
18:16:19 <vipuls> cuz esmute__ would quit
18:16:23 <harlowja> :)
18:16:32 <esmute__> it failed 3/20.. and the failure was the same.. The cluster didnt go active becasue of a crash in rabbit
18:17:00 <esmute__> It seems there is a race condition that prevents the node from accessing the db.
18:17:06 <esmute__> i created this bug https://bugs.launchpad.net/cue/+bug/1467045
18:17:07 <openstack> Launchpad bug 1467045 in Cue "Rabbitmq cluster dont become active because of error 'tables_not_present'" [Medium,New]
18:17:27 <esmute__> Openstack-infra has a similar issue. https://review.openstack.org/#/c/173222/
18:17:59 <esmute__> I spoke to sputnik13.. To resolve this issue would be to bootstrap the first node and then create the other ones
18:18:34 <esmute__> anyways.. i think 3/20 is fairly consistent to promote the job to voting
18:18:43 <esmute__> what are you thoughts?
18:18:43 <vipuls> esmute__: hmm ok.. that will be an interesting fix given that we just use rabbitmq.conf to configure the cluster
18:19:27 <esmute__> vipuls: we will have to modify the flow in this case
18:19:40 <esmute__> so that the first one gets bootstrap
18:19:55 <esmute__> currently, we are creating all node in parallel at the same time
18:20:06 <vipuls> esmute__: Ok -- we should probably raise that as a high priority issue
18:20:22 <esmute__> ok.
18:20:24 <vipuls> let's vote
18:20:39 <vipuls> #startvote Should we make tempest gate voting? Yes, No, Maybe
18:20:40 <openstack> Begin voting on: Should we make tempest gate voting? Valid vote options are Yes, No, Maybe.
18:20:42 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:20:42 <esmute__> but do you think the gate is good enough to making voting?
18:20:51 <esmute__> #vote Yes
18:21:25 <esmute__> #vote Yes
18:21:33 <esmute__> #vote of course Yes
18:21:34 <openstack> esmute__: of course Yes is not a valid option. Valid options are Yes, No, Maybe.
18:21:34 <esmute__> #vote Yes
18:21:36 <vipuls> everyone else abstaining ;)
18:21:45 <vipuls> davideagnello: abitha dkalleg
18:21:56 <esmute__> i spend the whole weekending doing recheck every hour
18:22:02 <davideagnello> nope
18:22:05 <dkalleg> #vote Maybe
18:22:05 <esmute__> weekend*
18:22:17 <vipuls> damn shouldn't have put maybe in
18:22:24 <abitha> #vote Yes
18:22:26 <dkalleg> haha
18:22:32 <esmute__> so what is the concern?
18:22:40 <dkalleg> It's not perfect.
18:22:44 <dkalleg> It should be.
18:22:53 <esmute__> dkalleg: it is not perfect because of a bug
18:22:55 <davideagnello> worst case we would have to run recheck sometimes, but will give us a good safety net when it caches real issues with checkins
18:22:56 <dkalleg> We're going to grow to rely on it
18:23:12 <esmute__> by the way, cue-coverage and gate-cue-python27 failed more often :p
18:23:25 <dkalleg> I'd be comfortable adding the gate now if the bug becomes a high prio.
18:23:42 <dkalleg> with fix eta < a week or two
18:24:00 <vipuls> esmute__: do you plan to take this on?
18:24:14 <esmute__> what is 'this'?
18:24:20 <vipuls> the 'fix'
18:24:24 <vipuls> :)
18:24:35 <esmute__> i spoke to sputnik13... it is not a simple fix..
18:24:57 <esmute__> we can talk about it first
18:25:09 <vipuls> ok let's hold off making it voting
18:25:13 <vipuls> #vote No
18:25:17 <esmute__> guys... from 20 run, it failed 3 times.
18:25:21 <vipuls> #endvote
18:25:21 <openstack> Voted on "Should we make tempest gate voting?" Results are
18:25:23 <openstack> Maybe (1): dkalleg
18:25:24 <openstack> Yes (2): esmute__, abitha
18:25:25 <openstack> No (1): vipuls
18:25:34 <esmute__> majority wins?
18:25:34 <davideagnello> #vote yes
18:25:37 <vipuls> damn Yes still won ;)
18:25:43 <vipuls> ok you win
18:25:49 <vipuls> democracy and all
18:25:49 <davideagnello> :)
18:25:51 <esmute__> im putting a patch to make it voting
18:26:20 <vipuls> esmute__: let's talk about this before next meeting -- we need to have a plan to fix the actual bug
18:26:33 <esmute__> vipuls: sounds good.
18:26:56 <vipuls> Ok that's it for action items
18:27:11 <vipuls> #topic Big Tent submission
18:27:37 <vipuls> Ok so the submission is still being discussed..
18:27:39 <vipuls> #link https://review.openstack.org/#/c/191173/
18:28:03 <vipuls> there is a TC meeting tomorrow where I assume they will say yay or nay (or maybe)
18:28:08 <vipuls> the meeting is 1pm PST
18:28:14 <vipuls> s/PST/PDT
18:28:20 <esmute__> vipuls: is the meeting on irc?
18:28:25 <vipuls> yessir
18:28:34 <davideagnello> cool
18:28:37 <dkalleg> exciting!
18:28:42 <esmute__> #openstack-meeting?
18:29:08 <vipuls> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:29:16 <vipuls> yep looks like openstack-meeting
18:29:40 <vipuls> i got some new comments that i need to address on that patch
18:30:29 <vipuls> if no questions.. we'll move on
18:31:10 <vipuls> #topic Bug scrub
18:31:17 <esmute__> vipuls: i gotta go to a dr appt
18:31:31 <vipuls> i've been in/out last couple of these irc meetings.. do we have any bugs to discuss?
18:31:52 <vipuls> esmute__: OK later
18:32:31 <davideagnello> vipuls: should we go over the bugs marked as critical?
18:32:45 <vipuls> it looks like there is only 1 bug that's undecided.. and that one already has a patch up
18:33:06 <davideagnello> ok
18:33:17 <vipuls> davideagnello: so there is one critical bug that isn't fixed.. https://bugs.launchpad.net/cue/+bug/1466609
18:33:18 <openstack> Launchpad bug 1466609 in Cue "user supplied network is not validated before attaching" [Critical,New]
18:33:47 <vipuls> we can talk about this one if we want?
18:34:15 <davideagnello> vipuls: yes, what kind of verification should Cue be doing in this case?
18:35:03 <vipuls> So the issue is a user can supply an arbitrary network_id to attach to their cluster, even if they don't own the network
18:35:10 <vipuls> we will happily attach a port from that network
18:35:22 <davideagnello> ok
18:35:39 <vipuls> this is probably not a security issue yet.. but it will be when we allow the user to attach ports from multiple networks
18:36:19 <vipuls> they could supply a network owned by another tenant, a network that they have access to, and potentially get to resources owned by the other tenant
18:36:33 <vipuls> a simple check for now would be to validate they own the network
18:37:13 <vipuls> make sense?
18:37:19 <davideagnello> ok, that makes sense.  we should have this check
18:37:54 <vipuls> alright any other bugs to discuss?
18:38:36 <vipuls> going once..
18:39:14 <vipuls> #topic Open Discussion
18:40:09 <vipuls> anyone have anything they want to bring up?
18:40:30 <vipuls> weekend escapades... why the greens at the US Open suck...
18:41:16 <davideagnello> oh yeah, what was up with that?  mostly complaints?
18:41:40 <vipuls> well the grass is brown..
18:42:23 <vipuls> ok.. man this is a tough crowd :)
18:42:52 <dkalleg> why was the grass brown?
18:43:01 <davideagnello> one of the next things that we should be looking to add to Cue is accurate status checking correct?
18:43:31 <vipuls> dkalleg: i'm not privy to that kinda info.. ;)
18:43:41 <abitha> vipuls:  what will happen after tomorrow's big tent meeting?
18:44:01 <vipuls> davideagnello: yes.. our cluster status is inaccurate currently.. we just report that the port is up
18:44:09 <vipuls> we need to actually check that things are clustered
18:44:23 <vipuls> dkalleg: has been doing some research on this already.. so hopefully he can report more
18:44:35 <davideagnello> vipuls: ok
18:44:43 <vipuls> abitha: good question.. so we if get into the big tent..
18:44:55 <vipuls> then one of the things is our code moves from stackforge -> openstack
18:45:20 <vipuls> so there'll be some things probably breaking like our devstack scripts, etc. we'll need to fix
18:45:24 <abitha> is it based on voting?
18:45:44 <vipuls> yes, as long as the TC members give up vote.. we're good..
18:45:47 <vipuls> so far no down votes
18:45:56 <vipuls> votes are on that patch i linked
18:46:01 <abitha> oh thats nice
18:46:38 <davideagnello> awesome!
18:47:21 <vipuls> ok.. thx folks
18:47:24 <vipuls> #endmeeting