18:01:00 <sputnik13> #startmeeting cue
18:01:01 <openstack> Meeting started Mon Jul 13 18:01:00 2015 UTC and is due to finish in 60 minutes.  The chair is sputnik13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:06 <openstack> The meeting name has been set to 'cue'
18:01:27 <davideagnello> here
18:01:33 <sputnik13> o/
18:01:36 <dkalleg> o/
18:02:30 * sputnik13 pokes vipul and abitha
18:02:48 <abitha> here here
18:03:07 <vipul> o/
18:03:59 <sputnik13> #topic Action Items
18:04:13 <sputnik13> #info http://eavesdrop.openstack.org/meetings/cue/2015/cue.2015-06-29-18.02.html
18:04:34 <sputnik13> #info AI #1 davideagnello to follow up on merge of https://review.openstack.org/#/c/195991/ and https://review.openstack.org/#/c/195992/
18:04:55 <sputnik13> it looks like the first merged but the second didn't
18:05:13 <davideagnello> first was merged, we then found a couple more issues with the gate job
18:05:14 <sputnik13> it's still WIP
18:05:33 <davideagnello> Sergey set it as WIP last week
18:06:03 <sputnik13> any idea what's wrong with ti?
18:06:07 <sputnik13> s/ti/it
18:06:10 <davideagnello> my latest fix was merged a couple of days ago, issue with CI gate job in reference to a rally script was wrong
18:06:46 <davideagnello> I have ran with the latest changes, it looks like it's now trying to run our tests but their is a failure on importing the correct rally libraries
18:06:55 <vipul> latest failure: http://logs.openstack.org/92/195992/1/experimental/gate-cue-integrate-dsvm-rally/cd8c54a/console.html#_2015-07-13_05_53_30_532
18:06:58 <davideagnello> as of today, looking into what is required
18:07:03 <vipul> it's trying to run a .yaml scenario
18:07:06 <vipul> which doesn't make sense..
18:07:38 <sputnik13> typo?
18:07:46 <sputnik13> or incorrect use of variable expansion?
18:08:15 <davideagnello> possibly, I will followup with Rally group while looking into it
18:08:30 <sputnik13> ok
18:08:56 <sputnik13> #action davideagnello to follow up on https://review.openstack.org/#/c/195992/1 getting merged to enable rally gate job
18:09:34 <sputnik13> #info AI #2 sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:10:35 <sputnik13> not yet done, will start filling in today in addition to researching auth mechanisms for Kafka and QPID
18:10:51 <sputnik13> expect to have it done this week
18:11:11 <davideagnello> ok
18:11:51 <sputnik13> #action sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:12:02 <sputnik13> kicking the can a little further :)
18:12:30 <sputnik13> #info AI #3 esmute__ to follow up with patch (https://review.openstack.org/#/c/194324/) and ensure it gets merged
18:12:43 <sputnik13> it looks like the patch merged so we'll mark this done
18:13:07 <sputnik13> #info https://review.openstack.org/#/c/194324/ merged as of 2015/06/30
18:13:33 <sputnik13> ok, that's it for Action Items, any questions? concerns?
18:13:49 <sputnik13> go on to discussion topics?
18:13:54 <davideagnello> yup
18:14:06 * sputnik13 pokes abitha dkalleg and vipul
18:14:20 <vipul> nope i'm good
18:14:21 <abitha> yes
18:14:23 <dkalleg> No topics from me
18:14:48 <sputnik13> Impromptu discussion topic, vipul and I were talking about moving the meeting
18:14:52 <sputnik13> or making it every other week
18:15:15 <vipul> Let's find some time that's not monday
18:15:40 <sputnik13> which day of the week works best?
18:15:52 <vipul> i got a topic about making rally voting.. if we can actually ever do that
18:16:02 <vipul> but i'll wait for my turn
18:16:06 <sputnik13> ok :)
18:16:44 <sputnik13> seems like 11 on tuesday is fairly open
18:16:51 <sputnik13> as far as openstack meeting rooms
18:17:29 <vipul> ok i'm good with that
18:17:31 <sputnik13> or afternoon around 4pm pacific is open for all the days
18:17:42 <sputnik13> didn't we used to have it on tuesday anyway?
18:17:55 <vipul> we did...
18:18:07 <sputnik13> I forget why we moved to Monday, seemed like a good idea at the time
18:18:16 <abitha> but we have our sprint planning from 10-12 every other week right? should we move that then?
18:19:01 <vipul> abitha: sputnik13 i think we should do everything (except cue meeting) mondays
18:19:07 <vipul> closeout, retro, planning
18:19:24 <sputnik13> right, that's the plan going forward
18:19:29 <abitha> okay
18:20:14 <vipul> are we on open discussions?
18:20:24 <vipul> maybe topic change sputnik13
18:20:30 <sputnik13> ohhh
18:20:30 <sputnik13> yes
18:20:39 <sputnik13> #topic Discussion: New meeting time
18:20:56 <sputnik13> #startvote move meeting to tuesday, yes or no?
18:20:57 <openstack> Begin voting on: move meeting to tuesday, yes or no? Valid vote options are Yes, No.
18:20:58 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:21:06 <sputnik13> #vote yes
18:21:12 <abitha> #vote yes
18:21:26 <davideagnello> #vote yes
18:21:30 <vipul> #vote yes
18:21:30 <dkalleg> #vote yes
18:21:35 <sputnik13> #endvote
18:21:36 <openstack> Voted on "move meeting to tuesday, yes or no?" Results are
18:21:51 <sputnik13> the suspense is killing me
18:21:59 * sputnik13 pokes openstack
18:22:17 <sputnik13> ok, I'll call it it's unanimous
18:22:37 <sputnik13> #agreed moving meeting to Tuesday 11am pacific time
18:23:01 <sputnik13> #topic Discussion: make rally gate voting?
18:23:35 <sputnik13> vipul want to kick it off?
18:23:40 <vipul> Yea should we?  The issue is there is a dependency to cueclient
18:24:00 <vipul> so when we make an api change.. which goes into openstack/cue.. we need a corresponding client change
18:24:12 <vipul> (if we want the scenario tests to be part of the api change0
18:24:53 <vipul> and not knowing enough about the cross-project dependency 'feature' i don't know if we can make two patches dependent across repos and if the gates will actually pull the right patchsets
18:25:47 <davideagnello> a good example is the end_point rename to endpoint in our api
18:25:57 <sputnik13> well, we can make the two patches dependent across repos, but the order of the merge needs to be correct
18:26:08 <davideagnello> if we had a rally voting test, we would have to override it in order to get it merged
18:26:40 <vipul> right.. the rally tests woudl fail unless gerrit is smart enough to pull the right cue client change
18:27:37 <sputnik13> ah right, because gerrit would need to use the dependent patch
18:27:43 <sputnik13> while running the tests
18:27:46 <davideagnello> yup
18:27:49 <sputnik13> fair point
18:28:04 <vipul> so we need to confirm this before we make voting..
18:28:14 <sputnik13> perhaps it's something to follow up on with infra?
18:28:25 <vipul> sounds like an action
18:28:36 <sputnik13> indeed
18:28:48 <sputnik13> davideagnello?
18:29:15 <sputnik13> can you follow up on that as part of the rally stuff?
18:29:22 <davideagnello> ok
18:29:42 <sputnik13> I christen thee The Rally Expert
18:29:45 <sputnik13> :)
18:30:16 <davideagnello> hahaha ok, will followup and find what we would require
18:31:07 <sputnik13> #action davideagnello to investigate whether Gerrit jobs can pull cross-repo dependent patches as part of a gate (e.g. Rally)
18:32:15 <sputnik13> #info when a change is required in both cue and python-cueclient, the rally job on cue may fail until python-cueclient is merged, unless Gerrit can handle pulling the appropriate version automatically
18:32:40 <sputnik13> vipul: so if gerrit doesn't do this, do we keep it non-voting until it can?
18:33:12 <vipul> i would think so
18:33:13 <sputnik13> generally, changes that have dependencies like these are not that frequent
18:33:24 <vipul> but it's painful when you have them
18:33:54 <vipul> requires a lot of coordination.. and making sure the client goes in first, etc.
18:33:56 <sputnik13> right, but there is a workaround, get the client merged then cue
18:34:11 <vipul> then rechecks... hours lost
18:34:24 <sputnik13> although depending on the time lapsed between the two, there is a window where there are incompatible versions in the wild
18:34:49 <vipul> let's see how other projects are handling it too.. if they actually vote
18:35:15 <sputnik13> ok
18:35:31 <davideagnello> last time I checked, I don't think they did.  will check again
18:35:46 <vipul> ok thx
18:35:47 <sputnik13> #action davideagnello to investigate whether other openstack projects' rally gates are voting
18:36:57 <vipul> moving on?
18:37:02 <sputnik13> yup
18:37:08 <sputnik13> other topics?
18:37:18 <vipul> we are in openstack now
18:37:19 <sputnik13> if not next is bug triage
18:37:37 <sputnik13> #topic Cue is openstack/cue
18:37:40 <sputnik13> woo hooo
18:37:43 <vipul> yay!
18:38:01 <davideagnello> nice!
18:38:05 <vipul> things aren't that smooth yet.. cuz of the mock library issues
18:38:06 <sputnik13> we're milking every last drop from this event ;)
18:38:10 <vipul> tests are failing
18:38:15 <sputnik13> vipul passing now
18:38:20 <vipul> cueclient failing
18:38:23 <sputnik13> or they should be
18:38:23 <sputnik13> oh
18:38:30 <sputnik13> doh
18:38:34 <sputnik13> I'll look at that
18:39:02 <vipul> the nice thing is all open patches got retargeted
18:39:22 <sputnik13> yup, and stackforge/cue redirects to openstack/cue
18:39:38 <sputnik13> but we probably should repoint our repos at some point
18:40:04 <vipul> Yep, add a new remote
18:40:05 <sputnik13> not urgent though given the auto redirect
18:40:19 <vipul> but patches like https://review.openstack.org/#/c/195992/1/tests/gate_hook.sh davideagnello need to be updated
18:40:30 <sputnik13> don't you have to reset the upstream remote for each branch?
18:40:30 <vipul> from stackforge/cue-dashboard to openstack/cue-dashboard
18:40:56 <vipul> if you have local branches.. yes
18:41:32 <sputnik13> we have a few places where we reference stackforge, I'll get a patch up fixing those
18:41:41 <davideagnello> ok
18:41:45 <vipul> also do a grep on docs
18:41:47 <sputnik13> it's mostly in doc and contrib
18:41:59 <sputnik13> yeah, did grep -r at root
18:42:13 <vipul> k.. i'm going to move the docs to docs.o.o soon
18:42:14 <sputnik13> dashboard is still stackforge
18:42:22 <vipul> cue-dashboard?
18:42:30 <sputnik13> did you get the message from jonathan?
18:42:30 <sputnik13> err kial
18:42:33 <sputnik13> not jonathan
18:42:43 <sputnik13> about not getting rid of rtfd
18:43:00 <sputnik13> making it point to docs.o.o instead because someone grabbed his rtfd page
18:43:01 <vipul> oh yea.. saw that.. good things is ekarlso owns that
18:43:08 <sputnik13> ok
18:43:21 <vipul> so we can put up a redirect link or something and keep holding on to it
18:43:30 <sputnik13> k
18:43:42 <vipul> dashboard is also openstack btw.. https://github.com/openstack/cue-dashboard
18:44:16 <sputnik13> ah sweet, but is that the right thing?
18:44:36 <vipul> sounds like we might have a hard time getting it into proper horizon.. so for now i guess it is
18:44:38 <sputnik13> or should it become part of horizon
18:44:44 <sputnik13> right
18:45:09 <davideagnello> why would we have a hard time getting into horizon?
18:45:33 <vipul> sounds like that team doesn't want to take more dashboards in
18:45:44 <vipul> which makes sense.. given they have a plugin model
18:45:45 <sputnik13> word is they're quite overloaded and not willing to take in changes
18:46:06 <vipul> devstack will probably be a similar battle
18:46:06 <sputnik13> right, taking it in to their repo would mean they're taking responsibility
18:46:32 <davideagnello> ah ok
18:47:12 <sputnik13> isn't an overarching answer for how to address this now that the big tent makes it possible for more projects to join?
18:47:32 <sputnik13> shared "things" like devstack and horizon
18:47:59 <vipul> i don't think there is an answer.. it's more likely pushback
18:48:17 <vipul> take extensions out of tree..
18:48:40 <sputnik13> but that also means changes like the keystone v3 change in devstack can break other projects without those projects knowing about it until after the fact
18:49:08 <vipul> yep.. but the other approach doesn't scale either
18:49:21 <vipul> at least you'd know quickly enough cuz gates start to fail
18:49:51 <sputnik13> well, when you have lots of dependencies it always limits scalability
18:50:25 <vipul> btw i've added https://bugs.launchpad.net/python-cueclient/+bug/1473454
18:50:25 <openstack> Launchpad bug 1473454 in Trove "New mock release(1.1.0) broke unit/function tests" [High,In progress] - Assigned to Nikhil Manchanda (slicknik)
18:50:30 <sputnik13> would be nice for the information to be proactively disseminated though
18:51:01 <vipul> yes it would :)
18:51:36 <sputnik13> huh I didn't know Nikhil was SlickNik
18:51:50 <sputnik13> have we segway'd to bugs?
18:52:07 <vipul> we got 8 mins
18:52:16 <vipul> i've assigend that to you..
18:52:21 <sputnik13> yay
18:52:25 <vipul> since you are fixing tests ;)
18:52:30 <sputnik13> Trove patch :)
18:52:40 <vipul> nope.. cueclient patch
18:52:46 <sputnik13> oh doh
18:52:56 <sputnik13> ok
18:53:18 <sputnik13> #topic Bugz
18:53:51 <sputnik13> #link https://bugs.launchpad.net/cue/+bug/1425131
18:53:51 <openstack> Launchpad bug 1425131 in Cue "Incorporate standardized logging" [High,New]
18:54:01 <sputnik13> is that a high priority bug?
18:54:25 <vipul> No.. imo
18:54:38 <sputnik13> I think it's probably more a wishlist...  I think it needs more description as well
18:54:40 <vipul> run it in debug all day!
18:55:18 <sputnik13> davideagnello can you add more detail to that?  are you saying we should classify the log messages differently?
18:55:42 <sputnik13> don't need to explain here, please add more detail to the bug...  will reclassify as wishlist for now
18:55:53 <sputnik13> objections?  good? next bug?
18:55:53 <davideagnello> ok
18:56:40 <sputnik13> #info reclassified as wishlist
18:56:47 <sputnik13> #link https://bugs.launchpad.net/cue/+bug/1429304
18:56:47 <openstack> Launchpad bug 1429304 in Cue "Error 400 Bad Request when adding a limit to the cluster list URL" [High,New] - Assigned to Steve Leon (steve-leon)
18:57:17 <sputnik13> Is this still an issue?
18:57:19 <vipul> sputnik13: so how is our panel working
18:57:41 <sputnik13> not sure, I think Steve may have worked around it by not sending the limit
18:58:38 <sputnik13> I'd say this is Medium since we do not have current failure
18:58:48 <vipul> yea we need to add pagination to the api
18:58:51 <vipul> that will fix this
18:58:54 <davideagnello> looks like a feature
18:59:07 <davideagnello> which the api currently doesn't support
18:59:13 <sputnik13> davideagnello: I agree it is a feature
18:59:30 <sputnik13> if the dashboard isn't broken perhaps it's not a bug
18:59:37 <sputnik13> vipul?
18:59:41 * sputnik13 pokes abitha dkalleg
19:00:02 <vipul> yea i would change the status to unconfirmed or something as well
19:00:07 <sputnik13> we have 1 minute left, let's agree on what to do with this before we close
19:00:11 <vipul> incomplete
19:00:37 <sputnik13> there is no unconfirmed state
19:00:44 <sputnik13> ok, leave it at high?
19:00:47 <davideagnello> non-voting rally jobs in:  designate, neutron, murano, mistral and zaqar
19:00:47 <vipul> incomplete
19:00:51 <vipul> medium
19:01:01 <sputnik13> ok
19:01:10 <vipul> thanks davideagnello so maybe it's something we punt down the road
19:01:13 <vipul> making it voting that is
19:01:14 <davideagnello> wishlist?
19:01:23 <davideagnello> vipul: ok
19:01:33 <sputnik13> someone should follow up on this
19:01:40 <davideagnello> on?
19:01:43 <sputnik13> the bug
19:01:50 <sputnik13> I'll follow up on it or get steve to look at it
19:01:57 <davideagnello> ok
19:02:04 <sputnik13> #action sputnik13 to follow up on confirming https://bugs.launchpad.net/cue/+bug/1429304
19:02:04 <openstack> Launchpad bug 1429304 in Cue "Error 400 Bad Request when adding a limit to the cluster list URL" [Medium,Incomplete] - Assigned to Steve Leon (steve-leon)
19:02:10 <sputnik13> ok that's time
19:02:21 <sputnik13> meetings will be Tuesday starting next week
19:02:24 <sputnik13> thanks everyone
19:02:30 <sputnik13> #endmeeting