18:01:53 <sputnik13> #startmeeting cue
18:01:54 <openstack> Meeting started Tue Sep 22 18:01:53 2015 UTC and is due to finish in 60 minutes.  The chair is sputnik13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:57 <openstack> The meeting name has been set to 'cue'
18:02:07 <sputnik13> role call
18:02:08 <sputnik13> o/
18:02:12 <dkalleg> o/
18:02:15 <abitha> o/
18:02:35 <vipul> o/
18:02:43 <vipul> s/role/roll
18:02:45 <vipul> ;)
18:02:59 <sputnik13> pfff, nitpicker :-P
18:03:33 * sputnik13 pokes davideagnello
18:03:44 <sputnik13> where's esmute
18:03:53 <davideagnello> o/
18:04:10 <sputnik13> ok, action items
18:04:15 <sputnik13> #topic Action Items
18:04:35 <sputnik13> #note AI #1 davideag_ to continue developing https://blueprints.launchpad.net/cue/+spec/multi-broker-support
18:05:33 <sputnik13> see no update on the BP since the last meeting, is there a goal for what we want to have done in the BP prior to the summit?
18:05:41 <davideagnello> yes, not much progress on this since last week.  I have started breaking down the different areas that require more background information.
18:06:15 <davideagnello> sputnik13: we want a design proposal for the summit
18:06:19 <vipul> Yea we should nail this down by the summit and present there
18:06:26 <sputnik13> ok, thinking it would be good to have concrete things we need decisions or discussions on at the summit rather than it being open ended
18:06:48 <sputnik13> ok, so given that we have about a month to nail things down
18:06:49 <davideagnello> sputnik13: that's right
18:07:13 <davideagnello> will put aside more time near the end of this week
18:07:15 <sputnik13> saying just so we keep it in perspective :)
18:07:23 <sputnik13> ok, sounds good
18:07:29 <sputnik13> #action davideag_ to continue developing https://blueprints.launchpad.net/cue/+spec/multi-broker-support
18:07:50 <sputnik13> next action...
18:07:56 <esmute> o/
18:07:59 <sputnik13> #note AI #2 sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:08:06 <sputnik13> welcome esmute :)
18:08:23 <esmute> Sorry for the tardiness :(
18:08:49 <sputnik13> no work on the kafka front once again...  kicking that can down the road...  I also need to step that up since it will probably provide useful information for the multi broker support
18:08:57 <sputnik13> #action sputnik13 to fill in details for https://blueprints.launchpad.net/cue/+spec/kafka
18:09:15 <davideagnello> sputnik13: yes, will be asking you very shortly :)
18:09:33 <sputnik13> esmute no worries, don't do it again!! ;)
18:09:42 <sputnik13> #note AI #3 vipul sputnik13 to file cross-project summit discussion on service VMs
18:09:53 <sputnik13> vipul you already did this yes?
18:10:06 <vipul> one sec.. have an update
18:10:08 <esmute> its sad we didnt get the talk accepted.. otherwise, we would have more urgency in getting this done
18:10:37 <vipul> #link https://review.openstack.org/#/c/203880/
18:10:38 <sputnik13> esmute: yes, so sad...  especially given how much free time we have ;)
18:10:51 <vipul> so Bruno submitted a nova-spec about this
18:11:09 <sputnik13> who is bruno
18:11:15 <vipul> catalyst
18:11:28 <sputnik13> oh that bruno
18:11:33 <sputnik13> the one we met
18:11:35 <sputnik13> ?
18:11:56 <vipul> yes..
18:12:02 <vipul> added a bunch of people as reviewers
18:12:07 <sputnik13> cool
18:12:21 <vipul> so we need to follow this one istead of filing yet another session
18:12:34 <sputnik13> we just need a room for the discussion then, is that something we need to push or is there someone organizing things like these?
18:12:51 <vipul> this will probably be a nova session
18:13:13 <sputnik13> ok, makes more sense anyway since they're the ones that need to get it done right
18:14:34 <esmute> vi oscon
18:14:44 <sputnik13> next action...
18:14:50 <esmute> oops
18:14:50 <sputnik13> esmute: wrong window :-P
18:15:00 <vipul> opening oscon?
18:15:05 <vipul> nice.. i need to have files like that
18:15:23 <sputnik13> #note AI #4 dkalleg to provide details in https://blueprints.launchpad.net/cue/+spec/status regarding more accurate rabbitmq status check
18:15:35 <esmute> yeah.. we need to change the host... Its been too long in portland :p
18:15:52 <dkalleg> I still need to do some research here.  Will work on prioritizing this.
18:16:03 <sputnik13> ok
18:16:38 <sputnik13> I think we're pushing that out post 1.0, is that correct vipul ?
18:17:04 <sputnik13> we were targeting a 1.0 release for Mitaka iirc
18:17:20 <vipul> We shoudl prioritize it for M.. won't get into L
18:17:26 <vipul> too late for L
18:17:33 <sputnik13> isn't L out?
18:17:38 <vipul> nope
18:17:43 <vipul> Liberty 3 is
18:17:51 <vipul> liberty final should happen next month
18:17:51 <sputnik13> is there a L4?
18:17:54 <sputnik13> ok
18:18:06 <sputnik13> so we're trying to get a 1.0 for L4
18:18:24 <vipul> Yea probably won't make it into that then
18:18:25 <sputnik13> but ongoing status should be post 1.0
18:18:46 <vipul> We should do a release.. and call that 1.0 since it's production ready..
18:19:00 <vipul> and it's unlikely that we can get more things in at this point
18:19:09 <sputnik13> so...  I think the point is the priority for ongoing status is lower than we thought it was last week
18:19:42 <vipul> Yea .. should figure out how we want to solve it though..
18:20:08 <sputnik13> agreed, but priority is still less
18:20:58 <sputnik13> so...  no need to rush it this month
18:21:09 <vipul> that's fine
18:21:39 <sputnik13> ok, that's it for past actions
18:21:41 <sputnik13> #action dkalleg to provide details in https://blueprints.launchpad.net/cue/+spec/status regarding more accurate rabbitmq status check
18:22:08 <sputnik13> any discussion topics?
18:22:13 <sputnik13> #topic Open Discussion
18:22:59 <davideagnello> security groups for broker VM ports
18:23:21 <sputnik13> link?
18:23:31 <davideagnello> new BP #link https://blueprints.launchpad.net/cue/+spec/broker-security-groups
18:24:16 <sputnik13> makes sense to me
18:24:36 <davideagnello> post beta feature?
18:24:42 <sputnik13> post 1.0
18:24:49 <sputnik13> what beta
18:24:53 <sputnik13> :)
18:25:38 <sputnik13> technically we're supposed to approve a BP aren't we
18:26:03 <sputnik13> does this BP need more or is it good to approve?
18:26:15 <vipul> I think this is straight forward.. we can target for M
18:26:29 <sputnik13> it's not an API change, it's a backend change, so just code and configuration
18:26:30 <davideagnello> whoops, yes post 1.0
18:26:49 <sputnik13> cool
18:27:03 <sputnik13> I mean, agreed, target M
18:27:29 <sputnik13> we need to define series so we can target things to series
18:27:43 <sputnik13> #action sputnik13 or vipul to define series in launchpad
18:28:10 <sputnik13> #note https://blueprints.launchpad.net/cue/+spec/broker-security-groups approved for M series
18:28:20 <sputnik13> anything else on this?  other topics?
18:28:56 <sputnik13> if there's nothing else we should move on to bugs
18:29:25 <sputnik13> the silence is deafening
18:29:39 <davideagnello> post 1.0 are we looking to target additional broker support first?
18:30:11 <sputnik13> yes, post 1.0, but I think we need a fleshed out design before we can say what release we would target
18:30:33 <sputnik13> so "post 1.0" could be 2.0, 3.0, 4.0, x.x
18:32:03 * sputnik13 taps on the mic
18:32:06 <sputnik13> hello?
18:32:10 <sputnik13> is this thing on?
18:32:29 <davideagnello> ok
18:32:34 <dkalleg> o/
18:32:39 <vipul> nothing else from me
18:32:45 <sputnik13> ok, bugs
18:32:49 <davideagnello> yes
18:33:03 <sputnik13> #topic Bugs
18:33:10 <sputnik13> no new bugs since last week
18:33:19 <sputnik13> #note No new bugs
18:33:40 <sputnik13> 2 open bugs
18:33:48 <sputnik13> https://bugs.launchpad.net/cue/+bug/1466609
18:33:49 <openstack> Launchpad bug 1466609 in Cue "user supplied network is not validated before attaching" [High,In progress] - Assigned to Min Pae (sputnik13)
18:34:15 <sputnik13> fix has been submitted, just needs unit tests before it's ready to review
18:35:14 <sputnik13> still in progress, will be done asap
18:35:47 <sputnik13> oops
18:35:50 <sputnik13> #link https://bugs.launchpad.net/cue/+bug/1466609
18:35:51 <openstack> Launchpad bug 1466609 in Cue "user supplied network is not validated before attaching" [High,In progress] - Assigned to Min Pae (sputnik13)
18:36:03 <sputnik13> ok, next open bug
18:36:08 <sputnik13> ?
18:36:23 <sputnik13> #link https://bugs.launchpad.net/cue/+bug/1426103
18:36:23 <openstack> Launchpad bug 1426103 in Cue "Validate UUID API parameter's at API layer instead of DB interface" [Medium,Confirmed] - Assigned to Abitha Palaniappan (abitha-palaniappan)
18:36:49 <abitha> havent started on it yet.
18:36:52 <sputnik13> ok
18:37:29 <sputnik13> would be great if we can get it in to 1.0, but not high priority
18:37:45 <abitha> ok will start on it soon
18:37:57 <sputnik13> cool
18:38:03 <sputnik13> that's it for bugs
18:38:33 <sputnik13> should we call it?
18:38:45 <sputnik13> end it early for a change? :)
18:38:51 <vipul> yep i'm good
18:38:57 <dkalleg> ha
18:39:03 <dkalleg> Nothing more from me.
18:39:22 <sputnik13> k, meeting adjourned
18:39:26 <sputnik13> #endmeeting