08:00:18 <huzhj> #startmeeting daisycloud
08:00:19 <openstack> Meeting started Fri Aug 12 08:00:18 2016 UTC and is due to finish in 60 minutes. The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:23 <openstack> The meeting name has been set to 'daisycloud'
08:00:37 <huzhj> #topic Roll Call
08:00:51 <kongwei> #info kongwei
08:01:05 <huzhj> #info Zhijiang
08:02:32 <huzhj> aha, only a few people
08:03:06 <huzhj> @kongwei , please take the chair for a while for me, I will BRB in minutes.
08:03:15 <kongwei> ok
08:06:06 <luyao> #info luyao
08:06:18 <kongwei> hi
08:07:18 <luyao> hi
08:08:37 <Sunjing> #info sunjing
08:09:58 <kongwei> #topic the first release
08:10:31 <huzhj> I am back
08:10:37 <huzhj> #topic Daisy Demo and doc
08:10:42 <kongwei> ok
08:11:39 <huzhj> Seems I should fire a spcific command something like chair... to give chair to other, otherwise, only I can issue command like topic...
08:11:50 <kongwei> we will get a demo version
08:12:02 <kongwei> yes
08:12:17 <kongwei> i can not change topic
08:13:17 <huzhj> #info we have athe demo version online for donload
08:13:22 <huzhj> #undo
08:13:24 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f5bbf1afd10>
08:13:42 <huzhj> #info we have athe demo version online for public download
08:14:34 <luyao> welcome zhuzeyu
08:14:45 <Zhuzeyu> thank you
08:14:55 <huzhj> #link http://www.daisycloud.org/static/files/installdaisy_el7_noarch.bin
08:15:35 <kongwei> great
08:15:47 <luyao> good
08:16:24 <huzhj> #this is only a demo version which do not support barematel discovery currently , user must install OS on all to-be-deplyed hosts before hand
08:16:34 <huzhj> #info this is only a demo version which do not support barematel discovery currently , user must install OS on all to-be-deplyed hosts before hand
08:17:16 <huzhj> #info The corresponding document will avaliable next week
08:18:11 <zhouya> great
08:19:42 <huzhj> #info Zhijiang will send email to OpenStack and OPNFV to announce the release event
08:20:19 <huzhj> #topic Ironic status update
08:20:53 <huzhj> @luyao anything intresting about ironic from your side?
08:22:07 <luyao> I am studying how deploy os with ironic。
08:22:24 <huzhj> #info Daisy uses ironic as the baremetal discovery and OS ochestrating tool
08:23:14 <huzhj> Good!
08:23:24 <luyao> maybe we should add ironic interface to fullfill the fuction of deploy centos
08:23:35 <huzhj> #info Yao will work on ironic related things
08:24:55 <huzhj> Hope the latest version of the ironic meets our requirements
08:25:21 <luyao> yes
08:27:01 <huzhj> I do not know if there is any website which publish the detail changelog of ironic from K to Mitaka. We need do some research on the changelog to find out which new things can benifit us
08:27:27 <huzhj> only a hope :0
08:27:30 <huzhj> :
08:27:33 <huzhj> :)
08:27:46 <zhouya> yes
08:28:01 <Sunjing> We can check ironic no of new version.
08:28:18 <Sunjing> ironic bp
08:29:05 <huzhj> As we know there are some other projects like what we are doing. They are trying to use ironic to deploy OS.
08:30:14 <huzhj> OK, if no further progress to report about ironic , we's better go to the next topic
08:30:26 <huzhj> #topic Get backend type by calling host_get_all function
08:30:31 <zhouya> you mean we can learn from them?
08:30:41 <huzhj> Yes @zhouya
08:30:56 <luyao> If M can not fullfill our need,we can add new interface to do it
08:31:10 <huzhj> Yes, agree @luyao
08:31:11 <zhouya> OK
08:31:49 <Julien-zte> #info Julien
08:32:05 <huzhj> OK, @zhouya so you are working one the host_get_all() function rectifing?
08:32:13 <zhouya> yes
08:32:16 <zhouya> we
08:32:41 <huzhj> What do you think about the idea of providing bakcend info through that API?
08:32:53 <zhouya> I add a interface in host-detail
08:32:53 <luyao> welcome julien
08:32:58 <huzhj> Is it a correct way we should go ?
08:33:15 <kongwei> welcome Julien-zte
08:33:31 <huzhj> Hi @ChrisPriceAB_ and Hi @Julien-zte
08:33:31 <Sunjing> welcome julien
08:33:32 <zhouya> I think it's the right thing we should do
08:33:35 <Julien-zte> huzhj you can use chair command to let other has the priority
08:33:52 <zhouya> welcome
08:34:02 <Zhuzeyu> welcome
08:34:04 <huzhj> Yes Julien, thanks
08:34:11 <Julien-zte> thanks everyone
08:34:44 <Julien-zte> what's current topic
08:35:00 <Julien-zte> Get backend type by calling host_get_all function?
08:35:12 <huzhj> About How to identify backend in our code.
08:35:14 <huzhj> yes
08:35:21 <Julien-zte> what's the backend?
08:35:47 <zhouya> the backend of kolla,tecs and zenic
08:35:55 <huzhj> As you know, we will suport alot of disctrbuted system to deploy, we call each of them as a specific backend
08:36:15 <Julien-zte> distribution is more fit :)
08:36:25 <huzhj> yep :)
08:36:31 <zhouya> and I will still work on the code of multi backend type
08:36:49 <Julien-zte> great
08:37:11 <Julien-zte> whtat distribution does we expect to support? centos , ubuntu? and other?
08:37:27 <huzhj> we expect all of them :)
08:37:44 <Julien-zte> in the next release, I do think centos + ubuntu is enough
08:37:48 <zhouya> and now is CentOS
08:37:50 <huzhj> we have just released the demo for centos7
08:37:52 <Julien-zte> even we can choose only one
08:38:12 <Julien-zte> where can I check / download the demo?
08:38:36 <huzhj> http://www.daisycloud.org/static/files/installdaisy_el7_noarch.bin
08:38:43 <Sunjing> www.daisycloud.org
08:38:45 <huzhj> That is the previrous topic
08:39:01 <Julien-zte> It will ben meaningful in OPNFV, for we can support multiple release version. currently in OPNFV, one installer choose only distribution
08:39:07 <huzhj> The related document will be avaliable next week.
08:39:11 <Julien-zte> Ubuntu is mostly used.
08:39:22 <huzhj> Acctually I can send the doc offline to you
08:39:43 <huzhj> Yes.
08:39:46 <Julien-zte> fantastic
08:39:53 <Julien-zte> thanks huzhj
08:40:06 <huzhj> at your service:)
08:40:27 <huzhj> So can we move to next topic now?
08:40:38 <Julien-zte> ok
08:40:40 <zhouya> OK
08:40:43 <huzhj> #info Ya will work on the host_get_all rectify things
08:40:56 <huzhj> @topic Related status update
08:41:01 <huzhj> sorry
08:41:10 <huzhj> #topic Daisy4nfv Related status update
08:42:30 <huzhj> I discussed with @kongwei about the relationship between escalator and installer
08:43:13 <huzhj> We also realized that Escalator may need to be located at the north bond of VNFM
08:43:27 <huzhj> such as tacker or something
08:44:42 <huzhj> Because when you do upgrading , there may a sequencial activities among escalator , VNFM and the installer
08:45:51 <huzhj> First, escalator call into VNFM to let it to do VM change over, then, escalator call installer to do upgrading
08:46:20 <huzhj> So we can treate escalator as the very top level scheduler
08:46:23 <zhouya> includes the installer itself?
08:46:33 <huzhj> may be @zhouya
08:47:04 <zhouya> fantastic
08:47:06 <huzhj> At the summit, I declared a so called DaaS modle
08:47:26 <Julien-zte> maybe we will have some integration with tacker
08:48:11 <Julien-zte> in this release, we can mainly focus on implementation of Daisy and documents/or basic support of escalator
08:48:20 <Julien-zte> can we support them both in Release D?
08:48:28 <huzhj> Agree, But now I did not dive so deep into VNFM
08:48:37 <Julien-zte> I'm think of over workload
08:48:55 <Julien-zte> team in Shanghai can give some assistance
08:49:13 <Julien-zte> we are formiliar with MANO including VNFM
08:49:30 <huzhj> Greate, that will be so great:)
08:49:41 <Julien-zte> not familiar with Tacker
08:49:59 <Julien-zte> but mayny a new team member is good at tacker
08:50:11 <Julien-zte> mayny -> maybe
08:50:57 <Julien-zte> let's push forward these items.
08:51:21 <Julien-zte> #info huzhj, I think we'd better use jira.opnfv.org to manage our requirements
08:51:33 <huzhj> I hope we need more concentration on the relationship between escalator and installer , thus, do not think of vm change over things, that may be more easily for us to finish in release D
08:51:41 <Julien-zte> then anyone can check our working items
08:51:57 <huzhj> @julien-zte will do that
08:52:23 <Julien-zte> can not get it for " do not think of vm change over things"
08:52:23 <huzhj> #info Zhijiang will update work items for opnfv in jira
08:52:37 <Julien-zte> change info to action
08:52:46 <huzhj> #undo
08:52:47 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f5bbf1af290>
08:52:54 <huzhj> #action Zhijiang will update work items for opnfv in jira
08:53:58 <huzhj> I mean as the frist phase , let just simply do not care about vm change over, os that there is no need for escalator to talk to VNFM
08:54:47 <huzhj> and I think , if we do not upgrade some critical service such as libvert. then there is also no need to do VM change over
08:55:18 <Julien-zte> sorry, what is "VM change over" ?
08:55:20 <Julien-zte> migration?
08:55:27 <huzhj> but taht is really a small , non common upgrade use case :)
08:55:47 <huzhj> Not migration exactly
08:55:58 <huzhj> I mean the HA change over
08:56:02 <Julien-zte> no background information
08:56:11 <huzhj> Let discuss it offline
08:56:14 <huzhj> OK?
08:56:14 <Julien-zte> can I check these states in some docs?
08:56:20 <Julien-zte> good
08:56:40 <huzhj> I think @kongwei are working on a document on that
08:57:13 <Julien-zte> no questions for this
08:57:34 <huzhj> #info Wei is working on a document about more detail upgrading requirements for escalator
08:57:47 <kongwei> yes
08:57:50 <Julien-zte> great
08:58:23 <huzhj> anything for daisy4nfv?
08:58:55 <huzhj> Oh , just FYI , the meeting log and minutes link can be found at https://wiki.opnfv.org/display/meetings/Meetings
08:59:43 <huzhj> #info the meeting log and minutes link can be found at https://wiki.opnfv.org/display/meetings/Meetings
09:00:01 <luyao> ok,thank s~
09:00:52 <Sunjing> Get it
09:01:16 <huzhj> seems we have finished with all topics. anything intresting before call it a meeting :)
09:02:20 <zhouya> do we have some docs about opnfv?
09:02:22 <huzhj> intresting -> interesting
09:02:57 <huzhj> some docs for on boarding?
09:03:38 <zhouya> learn about esclastor
09:04:01 <zhouya> escalator
09:04:01 <huzhj> basically they are all located at http://artifacts.opnfv.org/opnfvdocs
09:04:37 <zhouya> OK,it will be a great help
09:04:38 <huzhj> but the url redirect to google storage ...
09:04:52 <huzhj> not easy to get
09:04:59 <huzhj> :(
09:05:14 <zhouya> OK,I see
09:05:15 <huzhj> you can also check out the wiki.opnfv.org
09:05:26 <zhouya> thank you
09:05:54 <huzhj> there are quiet a lot description about projects on their man page.
09:06:17 <zhouya> got it
09:06:44 <huzhj> for escalator https://wiki.opnfv.org/display/escalator
09:07:21 <huzhj> wow we are running out of time
09:07:33 <kongwei> :)
09:07:39 <huzhj> let's call it a meeting
09:07:44 <luyao> yes
09:07:47 <huzhj> bye
09:07:48 <Sunjing> ok
09:07:52 <luyao> bye
09:07:54 <kongwei> bye
09:07:56 <Zhuzeyu> bye
09:08:01 <huzhj> have a good weekend
09:08:07 <huzhj> #endmeeting