08:00:41 <huzhj> #startmeeting daisycloud
08:00:42 <openstack> Meeting started Fri Aug 19 08:00:41 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:46 <openstack> The meeting name has been set to 'daisycloud'
08:01:08 <huzhj> Agenda for this meeting
08:01:15 <huzhj> 1) Roll Call
08:01:15 <huzhj> 2) OPNFV CI Evolution Study Progress
08:01:15 <huzhj> 3) Bare Metal Deployment(PXE/IPMI) Status Update
08:01:15 <huzhj> 4) Bare Metal Related DB Deployment Status Update
08:01:15 <huzhj> 5) Bifrost/Ironic Integration
08:01:15 <huzhj> 6) New Kolla Images
08:01:23 <kongwei> #kongwei
08:01:25 <huzhj> #topic Roll Call
08:01:32 <huzhj> #info Zhijiang
08:01:47 <kongwei> #info kongwei
08:01:47 <zhouya> #info zhouya
08:02:00 <zhuzeyu> #info zhuzeyu
08:02:51 <huzhj> I think Yao and Jing are facing network problem
08:03:06 <huzhj> Hi Yao
08:03:17 <zhuzeyu> welcome
08:03:20 <huzhj> So you are using cell phone ?
08:03:22 <luyao> #info luyao
08:03:32 <luyao> yes
08:04:23 <huzhj> are you using bluetooth keyboard, or Jing? Is it easy to use?
08:04:49 <luyao> have not do it
08:05:21 <luyao> actually I dont konw how to use
08:05:33 <huzhj> Me too...
08:05:37 <huzhj> Me either
08:05:58 <luyao> use bluetools?
08:06:20 <huzhj> yes, never got it connected with my cell phone
08:06:33 <huzhj> hah
08:07:03 <huzhj> so the next topic is OPNFV CI Evolution Study Progress, but we havn't got Jing
08:07:31 <huzhj> So I would like to skip that topic, any idea?
08:07:39 <zhouya> OK
08:07:48 <kongwei> ok
08:07:48 <luyao> ok
08:07:57 <zhuzeyu> ok
08:08:03 <huzhj> #topic Bare Metal Deployment(PXE/IPMI) Status Update
08:08:30 <huzhj> @luyao anything related to this topic from your side?
08:09:02 <huzhj> Hi @Sunjing
08:09:06 <Sunjing> Sorry for late.
08:09:23 <huzhj> No problem
08:09:31 <luyao> now I can use daisy code To build
08:09:53 <luyao> sorry
08:10:25 <luyao> use daisy to build pxe and install centos and get intall progress
08:11:06 <zhouya> great
08:11:21 <luyao> but because of the script error of get progress,I
08:11:45 <huzhj> #info Yao said Now we can use daisy to utilize and install centos and get intall progress
08:11:52 <luyao> need to modify get progress script to get actual centos install progress
08:12:26 <huzhj> Where is that script located? the pxe_serverxxxx.rpm ?
08:12:39 <luyao> yes
08:12:45 <luyao> but it not in daisy code
08:12:57 <luyao> jist a rpm release
08:13:50 <huzhj> Well that rpm should be converted to code and splited into pieces I think
08:14:04 <luyao> yes I think do
08:14:09 <luyao> so
08:14:46 <huzhj> store rpm is NOT good for opensource, so we need a new BP for doing that
08:15:42 <huzhj> #action Zhijiang will add a new BP for Kill pxe rpm and spliting it into several parts
08:16:28 <huzhj> This should be the first step , I mean the clean up step before we move on
08:16:57 <luyao> yes
08:18:05 <huzhj> @luyao we also need a API list to make further work more clear.
08:18:40 <huzhj> such as enroll , inspect, deploy, progress check,,
08:18:44 <luyao> ironic-api?
08:19:19 <huzhj> exactly, the API used by daisy for doing target host enroll , inspect, deploy, progress check,,
08:19:39 <luyao> daisy code have api to get progress of centos
08:20:42 <huzhj> OK, right , getting progress is seems not a functionaility provided by ironic
08:21:14 <luyao> ok
08:22:16 <huzhj> So except for that, I think other API that daisy used to deploy OS may all can be provided by ironic.
08:22:39 <huzhj> But we know we can do all the stuff all by daisy itself
08:23:16 <luyao> yes we can use ironic to do it later
08:23:26 <huzhj> after split the pxe rpm, the next step will be deleting ironic
08:23:48 <luyao> yes
08:25:17 <huzhj> And we also need  database  migration to move data to daisy db
08:25:28 <huzhj> and that is the next topic
08:25:53 <huzhj> #topic Bare Metal Related DB Deployment Status Update
08:26:19 <huzhj> @Ya Are you working on this topic?
08:26:26 <zhouya> yes
08:27:17 <zhouya> we can modify model.py fileto add ironic data
08:27:36 <huzhj> Do you have plan to modify the db table design?
08:27:46 <zhouya> and use Daisy API interface to get these datas
08:27:52 <huzhj> for example, add some fields to a table or create a new table?
08:28:14 <zhouya> we do not have to add new table
08:28:48 <huzhj> Good
08:28:51 <zhouya> we can just add these data to host table
08:29:26 <zhouya> and we modify the api.py file to read these data from db
08:29:53 <huzhj> So what fields do you plan to add to that table?
08:30:14 <zhouya> the very first thing we should do is to know which data we should put in Daisy db
08:30:59 <zhouya> such as cpu,disk,memory PCI
08:31:16 <huzhj> cpu, disk, memory, pci, ..... forget
08:31:46 <huzhj> Well let's talk aboute is offline through email
08:32:15 <zhouya> and I nok
08:32:20 <zhouya> OK
08:32:21 <huzhj> #info Ya is working one ading some new fields to host table in daisy db
08:33:16 <huzhj> #action, Zhijiang will provide which fields should be added to taht table
08:33:28 <huzhj> any thing else?
08:33:59 <zhouya> no
08:34:15 <huzhj> Great, next topic
08:35:10 <huzhj> Hi Jing are you there? do you have any thing about the OPNFV CI Evolution ??
08:35:39 <Sunjing> I have learned the basic workflow of opnfv CI.
08:35:55 <huzhj> Greate
08:36:12 <huzhj> #info Jing is learning about the new CI workflow.
08:36:46 <huzhj> Do you have any question or problems during the study?
08:36:50 <Sunjing> I have some issues for julien.but he is not coming today.
08:37:35 <huzhj> OK, next week , let's send your questions to opnvf mailing list
08:37:37 <Sunjing> I will send anemail for the issues to him.
08:38:20 <huzhj> OK
08:38:33 <huzhj> How about send them to the OPNFV mail list?
08:38:53 <zhouya> #agree
08:39:28 <Sunjing> In fact,I am not that clearly about CI yet,just begin to study two days.
08:39:45 <huzhj> Becasue julien may be not the right person to answer your question about CI stuff
08:40:20 <Sunjing> ok,I will send an email to Opnfv Mail list.
08:40:51 <huzhj> #topic OPNFV CI Evolution Study Progress
08:41:29 <huzhj> #action questions about CI Evolution will send to julien or OPNFV mail list
08:41:42 <huzhj> OK, next topic
08:41:52 <huzhj> #topic Bifrost/Ironic Integration
08:42:03 <huzhj> I thinks that belongs to me
08:42:20 <huzhj> I have learned a little about bifrost
08:42:56 <huzhj> it is just a bunch of ansible script on handling ironic to deploy bare metal, very amazing
08:43:38 <luyao> we can use it later if it is useful!
08:43:43 <huzhj> it basically uses three ansible modules to utilize ironic
08:43:51 <luyao> amazing
08:44:39 <huzhj> os_ironic: for Enrolling nodes into ironic, os_ironic_inspect: for introspection(discovery), and os_ironic_node for install OS
08:45:05 <zhouya> if we can move to bifrost,we can also get rid of ironic
08:45:05 <huzhj> #info bifrost basically uses three ansible modules to utilize ironic: os_ironic: for Enrolling nodes into ironic, os_ironic_inspect: for introspection(discovery), and os_ironic_node for install OS
08:45:18 <huzhj> not exactly Ya
08:45:27 <huzhj> bifrost needs ironic
08:45:39 <zhouya> OK,I see
08:45:54 <huzhj> actually , biforst is an way about how to use ironic
08:46:21 <luyao> good
08:46:49 <huzhj> we need a mapping between our PXE/IPMI usage and bifrost function
08:47:05 <huzhj> I think bifrost really got what we need
08:47:17 <Sunjing> Daisy will use ironic via biforst?
08:47:52 <huzhj> @Sunjing that is a way really need to think about
08:48:13 <zhouya> if so we can shield the exact usage of ironic
08:48:18 <huzhj> But it depends on wether bifrost meets our requirements
08:49:10 <huzhj> #info Zhijiang will provide a mapping between daisy bare metal requirements and bifrost API
08:49:12 <Sunjing> sounds great!
08:49:27 <huzhj> undo
08:49:30 <huzhj> #undo
08:49:31 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f5bc0498bd0>
08:49:47 <huzhj> #info Zhijiang will provide a mapping between daisy bare metal discovery and deployment requirements and bifrost API
08:50:38 <huzhj> #info About those thress ansible modules , we can get detail info from below links
08:50:41 <huzhj> #link http://docs.ansible.com/ansible/os_ironic_module.html
08:50:51 <huzhj> #link https://docs.ansible.com/ansible/os_ironic_inspect_module.html
08:51:06 <huzhj> #link http://docs.ansible.com/ansible/os_ironic_node_module.html
08:51:57 <huzhj> OK, do you guys have any further auestion about bisfrost? or we are about to move to the next topic
08:52:04 <huzhj> :)
08:52:41 <Sunjing> ok,I will study the docs with links above.
08:53:14 <Sunjing> onthing more for me.
08:53:30 <huzhj> Greate,  Jing, Thanks :)
08:53:33 <zhouya> the same to me
08:54:02 <huzhj> Great! @zhouya
08:55:01 <huzhj> OK for the next topic , let me check the build & upload result  , I will brb
08:56:40 <huzhj> I am back
08:56:56 <huzhj> #topic New Kolla Images
08:57:17 <Sunjing> Waiting for the result
08:57:19 <huzhj> #info I have built a new image
08:57:25 <huzhj> successfully
08:57:42 <zhouya> excellient
08:58:02 <zhouya> excellent
08:58:19 <Sunjing> wonderful
08:58:47 <huzhj> same version as before , 2.0.3 . But it should have the latest django package which is 1.8.14
08:59:07 <huzhj> Hope it can resolve the login problem
08:59:18 <huzhj> I have uploaded it to the ftp server
08:59:26 <huzhj> but with a different name
09:00:04 <huzhj> it is registry-2.0.3-2.tgz
09:00:14 <zhouya> hope it can work
09:00:27 <huzhj> it has a -2 subfix than the prev version
09:00:38 <Sunjing> we can use the new images to deploy next time.
09:00:59 <huzhj> So if you would like to try it ,do not forget to change the name in your daisy config file
09:01:33 <zhouya> OK
09:01:47 <Sunjing> Ok
09:01:53 <huzhj> #info the new image is regisry-2.0.3-2.tgz  and the old one is coexisted
09:02:37 <huzhj> Well that is all for today's discuss. Anything else for today?
09:03:31 <zhouya> nothing from my side
09:03:53 <luyao> no else
09:04:19 <zhuzeyu> no
09:04:28 <Sunjing> nothing
09:04:38 <huzhj> OK, Time to wrap up. :)
09:05:01 <huzhj> I think kongwei is still on the vacation
09:05:23 <zhouya> yes
09:05:32 <huzhj> Bye
09:05:38 <huzhj> have a nice weekend
09:05:45 <zhuzeyu> bye
09:05:59 <zhouya> bye
09:06:04 <Sunjing> bye
09:06:16 <huzhj> #endmeeting