#openstack-meeting: daisycloud

Meeting started by huzhj at 08:00:49 UTC (full logs).

Meeting summary

  1. Roll Call (huzhj, 08:01:13)
    1. kongwei (kongwei, 08:01:22)
    2. Zhijiang (huzhj, 08:01:32)
    3. zhuzeyu (zhuzeyu, 08:02:47)
    4. luyao (luyao, 08:04:29)
    5. zhouya (zhouya, 08:04:56)

  2. OPNFV CI Evolution Study Progress (huzhj, 08:05:12)
    1. Wei done some wiki page update for daisycloud CI documentation ,at https://wiki.openstack.org/wiki/Daisy#Example_of_Daisy_CI_Environmen (huzhj, 08:08:50)

  3. Bare Metal Deployment(PXE/IPMI) Status Update (huzhj, 08:15:36)
    1. @luyao said we can deploy bare metal include pxe server build and get progress (huzhj, 08:17:51)

  4. Bare Metal Related DB Development Status Update (huzhj, 08:21:23)
    1. @zhouya is working on comparing data format between ironic and daisy (huzhj, 08:26:35)

  5. Bifrost/Ironic Integration (does ironic provide all data we need) (huzhj, 08:31:08)
    1. http://docs.openstack.org/developer/ironic-inspector/install.html (huzhj, 08:35:15)
    2. we can get the pre built ironic-agent.kernel and ironic-agent.initramfs at http://tarballs.openstack.org/ironic-python-agent/tinyipa/files/ (huzhj, 08:35:31)
    3. the data collection ability inside the ironic-agent.initramfs is pluggable. (huzhj, 08:37:37)
    4. extra_hardware and pci_devices plugins' code can be found at: http://git.openstack.org/cgit/openstack/ironic-python-agent/tree/ironic_python_agent/inspector.py (huzhj, 08:38:56)
    5. extra_hardware and pci_devices plugin(collect_extra_hardware() and collect_pci_devices_info()) can help us to get more hardware info about PCI,cpu,network.... etc. by using /sys/bus/pci/devices file and hardware-detect(from python-hardware-detect package) command. (huzhj, 08:40:18)
    6. So we need to find out if those already existed plugins suit for us to get what we need. (huzhj, 08:42:13)
    7. If they do, then there is no need for us to modify the repbuilt ironic-agent.initramfs. (huzhj, 08:42:32)
    8. But if they don't, then we need to actually DIY the ironic-agent.initramfs. (huzhj, 08:43:02)
    9. We can uses dib do create one according to http://docs.openstack.org/developer/ironic-inspector/install.html, simply like follows: (huzhj, 08:43:32)
    10. yum install diskimage-builder (huzhj, 08:43:52)
    11. disk-image-create ironic-agent centos -o ironic-agent (huzhj, 08:43:56)
    12. before running the last comand, we can modify the ironic_python_agent/inspector.py to collect what we need. (huzhj, 08:44:08)
    13. May be that is a contribution point to the ironic project. (huzhj, 08:44:48)
    14. ACTION: @huzhj will evaluate if the collect_extra_hardware() and collect_pci_devices_info() is suit for daisy to get what it needs. (huzhj, 08:46:58)


Meeting ended at 08:53:06 UTC (full logs).

Action items

  1. @huzhj will evaluate if the collect_extra_hardware() and collect_pci_devices_info() is suit for daisy to get what it needs.


Action items, by person

  1. huzhj
    1. @huzhj will evaluate if the collect_extra_hardware() and collect_pci_devices_info() is suit for daisy to get what it needs.


People present (lines said)

  1. huzhj (92)
  2. zhouya (27)
  3. luyao (12)
  4. kongwei (6)
  5. openstack (3)
  6. zhuzeyu (2)


Generated by MeetBot 0.1.4.