08:00:09 <huzhj> #startmeeting daisycloud
08:00:10 <openstack> Meeting started Fri Sep  2 08:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:13 <openstack> The meeting name has been set to 'daisycloud'
08:00:30 <huzhj> Agenda for IRC meeting 0800UTC Sep. 2 2016
08:00:48 <huzhj> https://thepb.in/p/y8h6P8GrxkVhO
08:00:59 <fdc> Uff
08:01:07 <huzhj> wow, my list hasc been changed into a url...
08:01:27 <huzhj> #topic Roll Call
08:01:30 <fdc> Its impossible
08:01:35 <fdc> Mah
08:01:46 <zhouya> #info zhouya
08:02:05 <huzhj> hi Ya
08:02:21 <huzhj> how is your day
08:02:34 <zhouya> great
08:02:41 <luyao> #info luyao
08:02:54 <kongwei> #info kongwei
08:02:59 <huzhj> #info Zhijiang
08:03:25 <huzhj> good!
08:03:39 <fdc> -_-
08:03:45 <huzhj> #topic Unit Test
08:04:03 <fdc> Bye
08:04:22 <huzhj> well we need unit test asap
08:04:39 <kongwei> yes
08:05:15 <huzhj> But I my opinion, the first thing first is deleting useless code as much as possible
08:05:25 <huzhj> So I commited a patch
08:05:35 <huzhj> https://review.openstack.org/#/c/364098/4
08:05:49 <huzhj> #info Zhijiang post a patch to clean useless code
08:05:52 <huzhj> #link https://review.openstack.org/#/c/364098/4
08:06:39 <luyao> Good
08:06:45 <huzhj> besides, I will temperary delete the code for the hardware management (hwm)
08:07:20 <zhouya> if we fonot use this we could delete it
08:07:20 <huzhj> because hwm code interfered our arch
08:08:16 <huzhj> it make the daisy-registry module rely on the daisyclient module, up side down
08:09:36 <huzhj> we need to re think a new method to implement hwm interface in a good way. sush as introducing a new client module, called hwmclient
08:09:42 <zhouya> we can reconstructe these code
08:10:02 <huzhj> So currently, let's just delete it, what do you think?
08:10:15 <zhouya> #agree
08:10:25 <luyao> Agree
08:10:51 <huzhj> I think that is essensial to the unit test .
08:11:10 <kongwei> ok
08:11:20 <zeyu> great
08:11:29 <huzhj> #action Zhijiang will delete hwm code temperary.
08:11:50 <huzhj> OK, anything else about unit test?
08:13:00 <huzhj> since we have three python modules in one code repo, I do not know if it is suitable for us to use the common unit test frameworkk directly
08:13:52 <huzhj> may be we need something like dispatcher to dispatch unit test task from root directory to the subdir
08:14:11 <zhouya> we can get a referance of inner Daisy
08:14:27 <huzhj> Yes, indeed
08:15:20 <huzhj> anything else before we move to the next topic?
08:15:44 <zhouya> no
08:16:13 <kongwei> nothing
08:16:14 <luyao> no
08:16:32 <huzhj> I set unit test as the first topic becasue it is really important:)
08:16:38 <zhuzeyu> nothing
08:16:39 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:17:28 <huzhj> I can not get in touch with Jing. So, nothing for this topic I think.
08:18:03 <huzhj> I will try to contact her later
08:18:11 <zhouya> OK
08:18:27 <huzhj> #topic Bare Metal Deployment(PXE/IPMI) Status Update
08:19:15 <huzhj> @luyao anything for this topic from your side?
08:19:59 <luyao> I have push code to daisycloud,now we can success install os
08:20:14 <huzhj> Good!
08:20:15 <luyao> but need to +2
08:20:33 <huzhj> #info @luyao has ush code to daisycloud
08:20:35 <zhouya> sounds great
08:20:59 <huzhj> I did't +2 becasue the tempest was broken. But now
08:21:06 <huzhj> it got fixed
08:21:21 <luyao> need to recheck?
08:21:31 <huzhj> Yes
08:21:47 <luyao> ok ,I will do it now
08:23:06 <huzhj> @luyao, what about ironic ? can we delete it after merging your code?
08:24:11 <luyao> yes ,now we dont need ironic
08:24:24 <luyao> to build pxe and ipmi
08:25:51 <huzhj> OK, if you would like to do that do not forget to delete the dependences settings in the rpm spec.
08:26:33 <huzhj> also, do not forget to delete ironic's install process and uninstall process
08:26:33 <luyao> ok ,I forget,I will modify after merge
08:26:46 <huzhj> Thanks!
08:26:51 <luyao> ok
08:27:15 <huzhj> #action @luyao will do ironic cleanup
08:27:56 <huzhj> OK, anything else? @luyao
08:28:00 <luyao> no
08:28:04 <huzhj> Good!
08:28:09 <luyao> that is all
08:28:10 <huzhj> #topic Bare Metal Related DB Development Status Update
08:28:53 <huzhj> @zhouya, are you working on this?
08:29:00 <zhouya> I just push a commit to gerrit
08:29:04 <zhouya> yes
08:29:41 <zhouya> and the physical-node can t find problem has been fixed
08:30:28 <zhouya> the data type has changed from string to dict
08:30:29 <huzhj> #info @zhouya fixed physical-node table accessable problem
08:30:58 <huzhj> #link https://review.openstack.org/#/c/364711/
08:31:07 <huzhj> is this the related patch
08:31:10 <zhouya> but this commit should be merged after change ID I963fed
08:31:26 <zhouya> yes
08:31:49 <zhouya> this is the releated link
08:32:11 <huzhj> OK, can you add  dependance on gerrit for this?
08:32:40 <zhouya> OK
08:33:30 <huzhj> I am not very familiar with that function of gerrit, is it called follow-up?
08:34:13 <zhouya> the topic section can change these commit into one
08:34:59 <zhouya> and can remind all people which patch this commit is for
08:35:36 <huzhj> Good, that's realy helpful
08:35:55 <huzhj> and , another thing comes to my mind.
08:36:25 <huzhj> @zhouya , when you are working on db stuffs , could you please help to see this patch:
08:36:30 <huzhj> #link https://review.openstack.org/#/c/364445/
08:36:51 <zhouya> OK
08:36:52 <huzhj> It is a patch commited by others
08:36:59 <huzhj> related to db
08:37:42 <huzhj> But please see the comment I left for that patch.
08:38:08 <huzhj> We kind of can not adapt that patch currently
08:38:44 <zhouya> I think I should know the attemption of this patch
08:39:14 <huzhj> because some module that patch introduced to daisy does not have related distro package, such as rpm, and only have pip package , os it is not suit for us to use.
08:39:44 <huzhj> Yes, all we need to do is knowing the attemption of this patch, at present
08:39:49 <huzhj> Thanks
08:40:03 <zhouya> add a tenacity rpm?
08:40:08 <huzhj> #action @zhouya will dive into https://review.openstack.org/#/c/364445/
08:40:22 <huzhj> No , that is not our job
08:40:26 <zhouya> I will work on this
08:40:54 <huzhj> Good! Anything else about db?
08:41:00 <zhouya> no
08:41:12 <huzhj> #topic Bifrost/Ironic Integration
08:41:42 <huzhj> As a OpenStack installer, daisycloud-core project has a requirement.
08:42:02 <huzhj> When there are more than one baremetal in a cluster which have the same hardware characteristic. Then only one of then need to be described and configured, and the others can be add into cluster without any human intervention.
08:42:23 <huzhj> So daisycloud-core needs to collect some detail hardware info, such as numa info
08:43:21 <huzhj> I found that  When collecting pci devices info by using collect_pci_devices_info() function ,  ironic-python-agent  only collect vender id and device id.
08:43:37 <huzhj> for example cat /sys/bus/pci/devices/0000\:00\:03.0/vendor
08:43:42 <huzhj> cat /sys/bus/pci/devices/0000\:00\:03.0/device
08:44:00 <huzhj> But we need more about num id
08:44:17 <huzhj> that will be: cat /sys/bus/pci/devices/0000\:00\:03.0/numa_node  as example
08:44:28 <huzhj> cat /sys/bus/pci/devices/0000\:00\:03.0/numa_node
08:44:28 <huzhj> -1
08:44:33 <huzhj> we need the last one
08:45:03 <huzhj> So I proposed a bp for ironic, https://blueprints.launchpad.net/ironic-python-agent/+spec/get-pci-device-numa-node
08:45:58 <huzhj> #info Zhijiang proposed a bp for ironic to get more pci device info (NUMA node) for the homogenious nodes recognization module of daisy
08:46:48 <huzhj> #action further contact to the ironic team is needed for that bp.
08:47:07 <huzhj> OK , that is all for this topic.
08:48:18 <huzhj> OK, we have been through all the topics , anything else that I forgot?
08:48:57 <luyao> no
08:49:03 <zhuzeyu> no
08:49:07 <zhouya> nothing I think
08:49:37 <huzhj> any plan for the weekend you guys? :)
08:50:32 <luyao> sleep^_^
08:51:07 <zhuzeyu> 0.0
08:51:10 <huzhj> :D
08:51:12 <zhouya> go outside with some friends
08:51:30 <zhuzeyu> sports
08:51:33 <huzhj> Nice weather
08:51:34 <zhouya> weather is great these days
08:51:51 <luyao> 啊
08:52:00 <zhuzeyu> 0.0
08:53:38 <huzhj> I will acommpany my parents to see the house and discuss decoration things,
08:53:49 <huzhj> hehe
08:53:57 <zhouya> sounds sweet
08:54:37 <huzhj> decoration is really a bigger, more complex project than daisy :/
08:54:57 <zhouya> Ithink so
08:55:47 <luyao> yes,Ithink so。I just finish my decoration
08:56:41 <huzhj> Good, upload a spec or design doc on this for us, hehe
08:57:37 <huzhj> I @kongwei, anything else from your side?
08:58:22 <kongwei> i will do something about unit test
08:58:44 <huzhj> I think Wei and Zeyu are busy with CI, node pool stuffs.
08:59:10 <kongwei> i will try ut on our ci env
08:59:14 <kongwei> yes
09:00:11 <huzhj> Good!
09:00:18 <huzhj> OK, time to warp up.
09:00:32 <kongwei> yes
09:00:34 <kongwei> bye
09:00:36 <huzhj> bye
09:00:46 <zhuzeyu> bye
09:00:54 <huzhj> #endmeeting