08:01:08 <huzhj> #startmeeting daisycloud
08:01:10 <openstack> Meeting started Fri Sep  9 08:01:08 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:13 <openstack> The meeting name has been set to 'daisycloud'
08:01:32 <huzhj> today'  agenda
08:01:50 <huzhj> https://thepb.in/p/xGhmpJZMErpfM
08:01:59 <huzhj> 1) Roll Call
08:01:59 <huzhj> 2) Unit Test Progress
08:01:59 <huzhj> 3) Bifrost/Ironic Integration
08:01:59 <huzhj> 4) OPNFV: Daisy4nfv CI Framework Progress
08:01:59 <huzhj> 5) Bare Metal Deployment(PXE/IPMI) Status Update
08:02:00 <huzhj> 6) Bare Metal Related DB Development Status Update
08:02:12 <huzhj> #topic Roll Call
08:02:18 <huzhj> #info Zhijiang
08:02:24 <zhuzeyu> #info zhuzeyu
08:02:34 <zhouya> #zhouya
08:02:42 <zhouya> #info zhouya
08:06:05 <huzhj> hi kongwei, are you there?
08:06:14 <kongwei> yes
08:07:54 <huzhj> please #info kongwei
08:08:09 <kongwei> #info kongwei
08:08:10 <Sun> #info sunjing
08:08:36 <huzhj> #topic Unit Test Progress
08:09:50 <huzhj> For UT, I have delete a lot of unused glance code , hope that will ease us to do UT
08:10:15 <huzhj> hwm still not delete yet. I need more time on this.
08:10:25 <kongwei> i think we can get UT report next week.
08:10:41 <huzhj> Great!
08:11:12 <huzhj> #info next week @kongwei will work on UT report framework.
08:11:19 <kongwei> UT will be exec after flake8
08:11:30 <huzhj> #undo
08:11:31 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f23bdb4b210>
08:11:33 <huzhj> #action  next week @kongwei will work on UT report framework.
08:11:58 <huzhj> #action hwm code will be delete by @huzhj next week.
08:12:04 <huzhj> Good
08:12:53 <huzhj> nothing for this topic I think.
08:13:03 <huzhj> #topic Bifrost/Ironic Integration
08:13:15 <huzhj> #link https://blueprints.launchpad.net/ironic-python-agent/+spec/get-pci-device-numa-node
08:13:32 <huzhj> Hi Ya, I think you are working on this BP above?
08:14:02 <zhouya> yes
08:14:33 <zhouya> I just wrote the email to Jim eollenhagen
08:14:44 <zhouya> who is the ptl of ironic
08:14:57 <huzhj> But we found that there is no even one BP existed in that project launchpad. I do not think they utilize BP to tracking their work...
08:15:06 <huzhj> Good
08:15:10 <zhouya> I looking forward for his reply
08:15:27 <huzhj> #info @zhouya is contacting PTLof ironic
08:15:37 <zhouya> this is the only one BP on the launchpad
08:16:46 <huzhj> yes
08:17:16 <zhouya> If Jim think it is proper for US to accomplish,Iwill do the code writing
08:17:41 <huzhj> Just wait for the reply.  I don't know, may be they arrange their BP some other place?
08:18:13 <huzhj> for example , the ironic project? instead of the ironic-...agent project?
08:19:02 <zhouya> so strange
08:20:25 <huzhj> OK, just keep waiting. or maybe joining to the ironic irc meeting is a benefit.
08:20:52 <zhouya> OK,Iwill keep in touch with ironic
08:21:04 <huzhj> OK, next topic?
08:21:21 <zhouya> OK
08:21:26 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:21:53 <huzhj> Hi Jing , anything interesting on this topic?
08:22:10 <huzhj> I saw you have sent a patch to releng
08:22:40 <Sun> I have commit the verify framework to relent.
08:22:54 <huzhj> Good
08:23:18 <Sun> The PTL of relent have reviewed .
08:23:32 <huzhj> #info @Sun has commited the verify job framework to releng repo.
08:23:39 <Sun> PTL of releng
08:23:54 <huzhj> What about the POD , which one should we use ?
08:24:21 <Sun> I recommit the code according the reviews advice.
08:25:02 <Sun> Maybe daisy4nfv CI can use ate-pod2 now.
08:25:20 <huzhj> Could you please send us the url to your code
08:25:31 <Sun> ok
08:28:32 <Sun> https://gerrit.opnfv.org/Gerrit/#/c/20629/
08:28:50 <huzhj> #link https://gerrit.opnfv.org/Gerrit/#/c/20629/
08:29:27 <huzhj> I can not open it
08:30:10 <zhuzeyu> I also can not open
08:30:13 <Sun> Sorry
08:30:19 <zhouya> The same as me
08:30:34 <huzhj> #link https://gerrit.opnfv.org/gerrit/#/c/20629/
08:30:38 <Sun> please change the Gerrit to gerrit
08:30:49 <huzhj> Got it
08:30:58 <huzhj> Yes, PTL is Fatih
08:31:12 <huzhj> a nice guy.
08:31:34 <Sun> I agree that much.
08:31:39 <huzhj> helped me a lot when I study releng jjb code.
08:32:31 <Sun> so fortunate
08:32:50 <huzhj> So next step I think we may be able to test our bare metal deplyment on zte-pod2?
08:33:24 <huzhj> What do you think @luyao
08:33:39 <luyao> good
08:33:41 <Sun> this pod is for virtual deployment.
08:34:04 <luyao> where zte-pod2
08:34:49 <Sun> when the whole test jobs are up,we may use other pods for bare metal deploy.
08:34:57 <huzhj> I think we can get guidance from Zhifeng
08:35:45 <huzhj> @Sun could you please try to contact with Zhifeng and get some detail info about how to use that POD?
08:36:00 <Sun> I will email her for this issue.
08:36:05 <kongwei> pod2 at shanghai
08:36:10 <huzhj> Thanks
08:36:16 <Sun> ok
08:36:30 <huzhj> #action @Sun will try to contact with Zhifeng and get some detail info about how to use zte-pod2 POD
08:37:21 <huzhj> I think virtual deployment is not enough
08:37:33 <huzhj> we need baremetal.
08:38:06 <huzhj> in the near future
08:38:28 <Sun> Bare metal deployment jobs run when daily phase.
08:39:11 <huzhj> Yes, then we also need daily job frame work.
08:39:51 <Sun> ok.I will learn about how to use pod.
08:40:56 <huzhj> After successfully merge the verify/merge job , is there any technical difficulties for us to implement the daily job?
08:41:29 <huzhj> such as access the google storage?
08:42:24 <huzhj> Or may be we can temprary pass the stoage accessing.
08:42:43 <Sun> yes.There are some issue for daily job framework.I am not sure now.
08:43:07 <huzhj> Good, let's find out the issues first.
08:43:39 <huzhj> OK, any other things for this topic?
08:43:40 <Sun> How to upload and download Isi from google story is import one.
08:43:50 <Sun> iso
08:44:30 <huzhj> Yes, hope zte-pod2 has the abbility to break the GFW
08:44:31 <Sun> Nothing for me
08:44:36 <huzhj> OK
08:44:42 <huzhj> #topic Bare Metal Deployment(PXE/IPMI) Status Update
08:45:12 <huzhj> Hey , @luyao. I have merged your patch about kicking out ironic.
08:45:27 <luyao> I see,thanks!
08:45:28 <huzhj> But, now our tempest test failed all the time.
08:45:47 <huzhj> It infinitly loop
08:45:50 <luyao> I find the reason
08:46:17 <huzhj> You mean you have found out the reason?
08:46:18 <luyao> because I delete install ironicclient,API,
08:46:23 <luyao> yes
08:46:24 <huzhj> Great!
08:46:41 <huzhj> #info kicking out ironic patches are merged.
08:46:50 <luyao> ironic-discover code use ironicclient and api and so one
08:46:53 <luyao> on
08:47:13 <huzhj> #info @luyao have found out the reason why tempest failed on discovery after merge patches.
08:47:48 <huzhj> Good. I think we can finally solve it next week.
08:47:56 <luyao> so,if sure just need ironicdiscover ,I will modify ironicdiscover code to solve this pronlem
08:48:37 <huzhj> may be some test code shuold also be fixed
08:49:22 <huzhj> I think the next step for us is test Daisy's auto-scaling function
08:49:56 <huzhj> thus , discover and deploy new nodes automatically.
08:50:18 <huzhj> that is the key feature of daisy.
08:50:21 <luyao> yes
08:50:44 <zhouya> exactly
08:51:16 <huzhj> OK. for time reason. shall we move to the last topic?
08:51:37 <luyao> ok
08:51:49 <huzhj> #topic Bare Metal Related DB Development Status Update
08:52:51 <huzhj> @zhouya, what about the db access api progress? I think @luyao is waiting for your output:)
08:53:48 <zhouya> We now can get information from Daisy dB
08:54:23 <luyao> have merged?
08:54:29 <zhouya> no
08:55:06 <luyao> we can test again after merge
08:55:14 <zhouya> OK
08:56:10 <zhouya> I will test this with luyao later
08:57:10 <huzhj> @zhouya could you provide the url to your code ?
08:57:45 <zhouya> I will find it
08:58:48 <zhouya> review.OpenStack.org/#/c/361083
09:00:09 <zhouya> OpenStack to openstack
09:00:13 <zhouya> sorry
09:00:35 <huzhj> #link https://review.openstack.org/#/c/361083
09:00:42 <huzhj> already merged
09:01:14 <huzhj> #info @zhouya has merged the API code which  @luyao can use.
09:01:22 <huzhj> Great!
09:01:35 <luyao> good
09:01:38 <zhouya> sorry I did not get the status
09:01:38 <huzhj> OK, we are running out of  time .
09:01:57 <huzhj> It is OK
09:02:14 <huzhj> So, I think it is time to call it a meeting
09:02:22 <zhouya> OK
09:02:24 <huzhj> have a nice weekend every one
09:02:42 <luyao> you too
09:02:50 <zhouya> OK
09:02:57 <huzhj> thank you. bye
09:03:27 <huzhj> #endmeeting