08:00:48 <huzhj> #startmeeting daisycloud
08:00:49 <openstack> Meeting started Fri Sep 30 08:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:52 <openstack> The meeting name has been set to 'daisycloud'
08:01:22 <huzhj> #topic Roll Call
08:01:30 <zhouya> #zhouya
08:01:31 <huzhj> #info ZHijiang
08:01:38 <zhouya> #info zhouya
08:01:46 <huzhj> #undo
08:01:47 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f66f512d190>
08:01:59 <huzhj> #info Zhijiang
08:02:09 <huzhj> Hi @zhouya
08:02:22 <zhouya> Hi boss
08:04:34 <huzhj> Seems few people come today
08:04:47 <zhouya> absolutely
08:05:22 <zhouya> maybe they are busy with their works
08:05:46 <huzhj> Or prepare for the vacation:)
08:05:50 <huzhj> Any way
08:05:58 <huzhj> #topic Core Code Abstraction
08:06:46 <huzhj> @zhouya, I am looking at your code about the os installer abstraction layer
08:06:49 <huzhj> https://review.openstack.org/#/c/372867/31/code/daisy/daisy/api/v1/install.py
08:06:55 <zhouya> yes
08:07:34 <zhouya> I need a little modify of this commit
08:07:36 <huzhj> I do not know what the exact meaning of the condition if 'deployment_interface' in install_meta:
08:08:09 <huzhj> why the function return if it is true?
08:08:27 <zhouya> Neither do I
08:08:37 <huzhj> why not go ahead to do the installer?
08:08:46 <huzhj> why not go ahead to do the installation?
08:09:10 <zhouya> I think it is related to cluster-install
08:09:55 <huzhj> And I thought it is suppoosed to install the OS right? But why the comment says Install "TECS to a cluster"?
08:10:27 <zhouya> I do not think this place need to do this judge
08:11:24 <huzhj> pxe_server_build related to pxe sequence, I think Yao know it
08:11:27 <zhouya> And the pxe-server-build should not put here
08:11:57 <huzhj> Where do you think it should be moved to?
08:12:04 <zhouya> Maybe I should get help from Yao
08:12:30 <huzhj> Good
08:12:33 <zhouya> I think it should move to pxe/install.py
08:13:21 <zhouya> But I think it is better to discuss this with Yao
08:13:49 <huzhj> #action @zhouya will investigate the purpose of the pxe_server_build() in install_cluster().
08:14:51 <huzhj> OK, any other things about this topic?
08:15:03 <zhouya> no
08:15:17 <huzhj> #topic Bifrost/Ironic Integration
08:16:55 <huzhj> @zhouya I saw your patch still hanging there. May be you should move step forward to push the core members of ironic? what do you think?
08:17:26 <zhouya> I send a email to ironic team
08:18:02 <zhouya> And this afternoon,John give me some advice
08:19:06 <zhouya> I just modify the code,and,I will get some advice from other ironic teams
08:20:40 <huzhj> Good. For this kind of things, I think  if we don't push them, they won't merge it.
08:20:56 <zhouya> Yes
08:21:12 <huzhj> Or may be they are busy with newton release.
08:21:48 <zhouya> and I will contact frequently with ironic team s
08:22:01 <huzhj> Thanks
08:22:24 <huzhj> #action @zhouya will keep contact with ironic team
08:22:54 <huzhj> OK, shall we move to the next topic?
08:22:59 <zhouya> OK
08:23:21 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:24:11 <huzhj> since we can not reach Jing, so I do not think we have anything about this.
08:24:31 <huzhj> #topic Bare Metal Deployment(PXE/IPMI) demo2 doc and artifact
08:25:04 <huzhj> #info The demo2 is out
08:25:17 <zhouya> congratulations
08:25:29 <huzhj> #info you can get from repo by cloning and swtiching to tag 1.2.0
08:26:43 <zhouya> great
08:27:30 <huzhj> #action @huzhj will create a document on how to do baremetal deployment for this demo.
08:28:26 <huzhj> I am still waiting for Yao to send me the cli howto.
08:28:51 <huzhj> I am not very familiar with daisy cli :)
08:29:18 <zhouya> I think she will work out it
08:29:24 <zhouya> soon
08:32:54 <huzhj> Good , I have just  got her email.
08:33:30 <zhouya> great
08:37:11 <huzhj> OK, we'd better upload her script to gerrit to review it. I will do this for her, cuz she will not avaliable next two weeks
08:37:28 <zhouya> OK
08:40:13 <huzhj> Basically she uses template, it is a convenient way  to docommand line  auto deployment.
08:40:34 <huzhj> It is also helpful for Jing to deploy OPNFV pod.
08:40:34 <zhouya> exactly
08:41:02 <huzhj> OK, nothing for this topic
08:42:59 <huzhj> OK we have gone through all topics for today
08:43:02 <huzhj> What else could be discussed?
08:43:22 <zhouya> nothing from me
08:44:17 <huzhj> OK, let's wrap up.
08:44:24 <zhouya> OK
08:44:43 <huzhj> Have a good national day vacation!
08:44:56 <zhouya> T和 same to you
08:45:18 <zhouya> The same to you
08:45:29 <huzhj> @zhouya will you stay at Nanjing or go back home for this vacation?
08:46:00 <zhouya> today and tomorrow will have traffic jam
08:46:14 <huzhj> exactly
08:46:19 <zhouya> So I will go home 10.2
08:46:41 <huzhj> goood choice
08:47:01 <huzhj> :)
08:47:25 <huzhj> #endmeeting