08:00:14 <huzhj> #startmeeting daisycloud
08:00:15 <openstack> Meeting started Fri Nov  4 08:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:18 <openstack> The meeting name has been set to 'daisycloud'
08:00:37 <huzhj> #topic Roll Call
08:01:01 <zhuzeyu> #info zhuzeyu
08:01:05 <zhouya> #info zhouya
08:01:23 <luyao> #info luyao
08:02:04 <huzhj> #topic OPNFV: Escalator Support
08:03:06 <huzhj> FYI Escalator wants to be deployed by Daisy in OPNFV release D
08:03:15 <huzhj> #info Escalator wants to be deployed by Daisy in OPNFV release D
08:03:30 <huzhj> still no code from escalator
08:03:49 <zhouya> Be deployed by Daisy or call daisy to upgrade openstack?
08:04:02 <huzhj> Both @zhouya
08:04:29 <zhouya> OK
08:04:32 <zhouya> so
08:04:55 <huzhj> as a installer ,daisy need to deploy everything. but as a south bond API, daisy also need to be able to be called by escalator
08:05:57 <zhouya> so now we need daisy framework?
08:06:00 <huzhj> #info Daisy shall provide client code to escalator so that it can call into daisy api.
08:06:10 <huzhj> yes
08:06:20 <zhouya> OK,I see
08:06:42 <huzhj> something just like providerclient that you work on currently
08:07:00 <zhouya> yes
08:08:08 <huzhj> how to impl escalator side code is still a question,
08:08:21 <huzhj> need to discuss with kongwei.
08:08:35 <zhouya> agree
08:08:50 <huzhj> basically, escalator is a service that running all the time
08:09:04 <huzhj> like daisy api
08:09:33 <huzhj> Hi kongwei
08:09:51 <kongwei> hi huzhj
08:10:24 <huzhj> what the escalator will be look like
08:10:30 <huzhj> a service ?
08:10:38 <kongwei> yes
08:10:54 <huzhj> OK
08:10:59 <kongwei> escalator is a service
08:11:19 <huzhj> it need to be packaged into rpm so that daisy can deploy it
08:11:33 <huzhj> where to deploy it? on jump server?
08:11:43 <luyao> daisy install escalator rpm
08:11:46 <luyao> ?
08:11:50 <kongwei2> we can use cli to send command to escalator
08:11:54 <huzhj> yes luyao
08:12:19 <kongwei2> escalator can be installed on jump server.
08:12:25 <huzhj> OK, escalator  = cli + service + rpm
08:13:00 <huzhj> how cli communicate with service ?
08:13:02 <kongwei2> i think the escalator_cli is a rpm, and the service is another rpm
08:13:22 <kongwei2> it should be restful
08:13:52 <kongwei2> but we wiil get the escalator_client package
08:14:00 <kongwei2> just like daisy
08:14:17 <huzhj> Then it will complex enough . escalator  = rpm(cli + escalatorclient) + rpm(service)
08:14:28 <kongwei2> yes
08:15:12 <huzhj> David ask, are we confident that Daisy will be able to successfully complete integration with CI in time(He means MS3 = 20161130) to support the Escalator project
08:15:23 <huzhj> I have already forward that mail to you
08:15:48 <kongwei2> ok, thanks
08:16:15 <huzhj> I am confident that Daisy will be able to successfully complete integration with CI in time, but not confident to support Escalator...
08:16:29 <kongwei2> yes
08:17:12 <huzhj> a lot of work to do hehe...
08:17:34 <huzhj> any other thing related with this topic?
08:17:46 <zhouya> no
08:17:49 <luyao> no
08:17:54 <huzhj> #info escalator  = rpm(cli + escalatorclient) + rpm(service)
08:18:03 <kongwei2> we would try our best to do it. but there is not enough time
08:18:11 <kongwei2> no
08:18:19 <zhuzeyu> no
08:19:01 <huzhj> let alone the escalator CI
08:19:35 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:20:21 <huzhj> Jing went to the dentist :)
08:20:43 <huzhj> So , @zhuzeyu, anything from your side ?
08:21:45 <zhuzeyu> i am still studying yml
08:22:07 <huzhj> Good
08:22:14 <zhuzeyu> jjb Job Template
08:23:00 <huzhj> It is a little bit complex, especially when opnfv releng added a bunch of plugins ..
08:23:52 <zhuzeyu> i find daisy verify job also has some step unrealized
08:24:08 <zhuzeyu> basic and deploy
08:24:16 <huzhj> Yes, deply/smoketest
08:24:28 <huzhj> basic is not improtant
08:25:00 <huzhj> we are stuck at building step now becasue the enviroment has some problem
08:25:43 <huzhj> still waiting infra team to help us to cleanup the $WORKSPACE
08:25:43 <zhuzeyu> So do we have to add basic to merge job?
08:26:09 <huzhj> Yes, just add it . but it can be a dummy job
08:26:22 <zhuzeyu> i see
08:26:48 <huzhj> @luyao what about the virtual deployment ?
08:27:03 <huzhj> everything went well so far?
08:28:05 <luyao> we now success deploy virtual manual
08:28:21 <luyao> and can auto deploy with template
08:28:34 <luyao> but if we use yml
08:29:06 <luyao> I still write python file to support common config file
08:29:26 <huzhj> how long will that work take?
08:29:52 <luyao> I think next week I can finish it
08:30:30 <huzhj> Good!
08:31:08 <huzhj> @luyao besides, If you have time, could you please start working on daisycloud-core support newton OpenStack?
08:31:34 <luyao> yes, I can do it
08:31:57 <luyao> I think msybe not big change
08:32:08 <huzhj> One thing I am not sure now is if daisycloud-core can be built / can run on newton
08:32:48 <luyao> yes, need test
08:32:56 <huzhj> notice us through mail if you have any problem
08:33:07 <luyao> yes
08:34:03 <huzhj> #action @luyao will start working on daisycloud-core support newton OpenStack after common config file support is finished
08:34:24 <huzhj> OK, shall we go to next topic ?
08:34:28 <luyao> yes
08:34:44 <huzhj> #topic Core Code Abstraction
08:35:05 <huzhj> @zhouya, what about the status of the API extension framework
08:35:42 <zhouya> I just commit the change to gerrit
08:35:58 <zhouya> and the unittest need to be modified
08:36:37 <zhouya> so I think we need another test file name like test_hwm_hosts.py to test the extention of hwm
08:37:18 <huzhj> no hwm related test currently?
08:37:39 <zhouya> we already have the test
08:37:53 <huzhj> but need to move into a new file?
08:37:56 <zhouya> But they are in the test_hosts.py file
08:38:02 <huzhj> got it
08:38:14 <zhouya> yes,need to move into a new file.
08:38:36 <huzhj> Great, hwm will be the first example to fit into this frameworkl
08:38:48 <zhouya> exactly
08:38:55 <luyao> good
08:38:56 <luyao> !
08:39:00 <huzhj> #info API extension framework doner
08:39:04 <huzhj> #undo
08:39:05 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7fac553faf50>
08:39:08 <huzhj> #info API extension framework done
08:39:57 <huzhj> @zhouya has the framework PS been sent to daisycloud-core?
08:40:15 <zhouya> no
08:40:26 <zhouya> I have just tested in daisy
08:40:36 <huzhj> You can send it first ot see if it break tempest or not.
08:41:08 <huzhj> another benifit is other can see your work and review it
08:41:14 <zhouya> first of all , It needs to pass the unittest,and next it will run the tempest
08:41:27 <huzhj> YEs
08:41:48 <zhouya> yes,and I will send a PS to daisycloud-core
08:42:17 <huzhj> Yes I mean send it to daisycloud-core to let the community t oreview your work
08:42:35 <zhouya> OK ,got it
08:43:19 <huzhj> Great. Now we have basically 5 extensible submodule in daisy
08:43:45 <huzhj> API/DB/BMDeploy/DSDeploy/CC
08:43:46 <zhouya> since we have delete the hwm code in daisycloud-core,I have to find which we have deleted,and add it to daisycloud-core
08:44:22 <huzhj> You mean which we deleted by mistake?
08:44:42 <zhouya> yes,and also the hwm code
08:45:40 <huzhj> also the hwm code ?
08:45:49 <zhouya> the router
08:46:25 <huzhj> you will add hwm code to back to daisycloud-core ? I don't think that is really what you mean
08:47:28 <zhouya> no
08:47:39 <huzhj> hwm code as extension should always stay outside of core as much as possible
08:47:50 <zhouya> OK,I see
08:49:15 <huzhj> maybe currently we can not manage to wipe all hwm code, for example, code in the pxe (if host_meta has hwm_id)
08:49:30 <huzhj> due to lack of time
08:49:45 <huzhj> but in future, all will be wipe out.
08:49:52 <zhouya> great
08:50:41 <luyao> good
08:50:46 <huzhj> OK, anything else for this topic?
08:50:51 <zhouya> no
08:50:54 <luyao> no
08:50:55 <zhuzeyu_> no
08:51:35 <huzhj> another thing
08:51:54 <huzhj> #info we still lack of a example of DB extension
08:52:44 <zhouya> yes
08:53:06 <kongwei2> no
08:53:19 <huzhj> OK, time to wrap up, let's call it a meeting.
08:53:24 <kongwei2> bye
08:53:27 <huzhj> bye everyone
08:53:29 <luyao> bye
08:53:51 <huzhj> #endmeeting