08:00:35 <huzhj> #startmeeting daisycloud
08:00:35 <openstack> Meeting started Fri Nov 11 08:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:39 <openstack> The meeting name has been set to 'daisycloud'
08:01:09 <huzhj> #topic Roll Call
08:01:19 <huzhj> #info Zhijiang
08:01:20 <zhouya1> #info zhouya
08:01:38 <zhuzeyu> #info zhuzeyu
08:02:58 <kongwei> hi
08:03:04 <huzhj> today's topic
08:03:18 <kongwei> #info kongwei
08:03:18 <huzhj> 1) Roll Call
08:03:18 <huzhj> 2) OPNFV: Escalator Support
08:03:18 <huzhj> 3) OPNFV: CI Progress
08:03:18 <huzhj> 4) Core Code Abstraction
08:03:18 <huzhj> 5) Newton
08:03:33 <huzhj> Do we need to add any other topic?
08:04:03 <huzhj> #topic OPNFV: Escalator Support
08:04:43 <kongwei> we need pod for functest
08:06:09 <huzhj> do not know how to fire a ticket for POD
08:06:25 <SunJing> #
08:07:01 <kongwei> do we can use daisy ci env?
08:07:48 <huzhj> Not quite sure. But hope we can ,
08:08:07 <kongwei_> yes
08:08:28 <huzhj> waht about other function projects?
08:09:07 <kongwei_> no more info about others
08:09:39 <huzhj> Can we use releng/releng/jjb/kvmfornfv/kvmfornfv.yml as example?
08:10:28 <kongwei_> the escalator need one installer.
08:11:04 <kongwei_> the others do not neet them
08:11:53 <huzhj> I think maybe every function project need installer to deploy them into a functional openstack env before test them. Hope I am wrong
08:12:46 <kongwei_> yes
08:14:07 <huzhj> A quick look as the kvm code, i found that the do not need to be deployed into a functional openstack env before test them
08:14:17 <kongwei_> fengxiaowei tell me the functest can be run at the env which was already deployed installer..
08:14:22 <huzhj> I mean a quick look at the kvm jjb code
08:14:42 <kongwei_> yes. I will look it.
08:14:58 <huzhj> Maybe kvm is special
08:15:18 <huzhj> kvm located at the south of openstack
08:15:38 <huzhj> Maybe we need to find a example which located at the north
08:17:03 <huzhj> #info Need to figure out if escalator need POD.
08:18:22 <huzhj> netready/netready.yml is even more simpler than kvm
08:19:39 <huzhj> netready/netready.yml does not have daily job
08:19:50 <huzhj> really confused me
08:20:00 <kongwei_> only weekly?
08:21:11 <huzhj> no , only verify/merge
08:21:20 <huzhj> I got one dovetail/dovetail-ci-jobs.yml
08:21:53 <huzhj> dovetail/dovetail-ci-jobs.yml is more complex than others, it seems has some installer aware code
08:22:24 <huzhj> Let's discuss more about it offline OK?
08:22:48 <kongwei_> ok
08:23:55 <huzhj> For MS3, maybe escalator does not have enough time to do test with a real installer
08:24:51 <huzhj> #topic OPNFV: CI Progress
08:25:26 <zhuzeyu> I
08:25:33 <huzhj> @zhuzeyu isworking on impl. merge jjb
08:25:54 <huzhj> everything went well?
08:25:59 <zhuzeyu> I just commit merge job to releng
08:26:14 <zhuzeyu> and jenkins already +1
08:26:29 <zhuzeyu> https://gerrit.opnfv.org/gerrit/#/c/24221/
08:26:38 <huzhj> did not got your notice, maybe you need to add rviewer
08:27:04 <zhuzeyu> i add just now
08:27:17 <huzhj> Oh, yes
08:29:45 <zhuzeyu> are you here?
08:29:51 <zhouya> yes
08:29:58 <huzhj> @zhuzeyu, you can also add feng.xiaowei
08:30:34 <huzhj> OK, let's review the code after the meeting.
08:30:43 <zhuzeyu> ok ,i add this name just now
08:31:33 <huzhj> Anyone/Anything else for this topic?
08:32:22 <huzhj> #info @zhuzeyu proposed a PS to impl. the merge job for daisy4nfv
08:32:36 <huzhj> #info #link https://gerrit.opnfv.org/gerrit/#/c/24221/
08:34:44 <huzhj> One problem I would like to add
08:34:49 <huzhj> #link https://gerrit.opnfv.org/gerrit/#/c/24211/1/deploy/config/vm_environment/zte-virtual1/template.json
08:34:59 <huzhj> Our config file is too complex
08:35:08 <luyao2> yes
08:35:09 <huzhj> need to be strip
08:35:28 <zhuzeyu> agree
08:37:13 <huzhj> I asked wu.wei for help, still not got ack
08:38:01 <huzhj> #info need to figure out which part of the json file can be wipe out from our template
08:39:32 <huzhj> @luyao2 do you think we should use that complex config for the time being?
08:40:07 <huzhj> If we can wait, then we can go with it.
08:40:18 <huzhj> If we can NOT wait, then we can go with it.
08:40:39 <huzhj> and strip it in future
08:40:40 <luyao2> we can use it just now ,and do the simplify in the same time
08:40:50 <huzhj> Good
08:41:12 <huzhj> OK, then I will merge https://gerrit.opnfv.org/gerrit/#/c/24211
08:41:25 <luyao2> besides, if we use genesis config,maybe we do not need use daisy template function
08:42:25 <huzhj> I think we do not need use daisy template function even without  genesis config file.
08:43:08 <luyao2> yes,I  can do it
08:43:11 <huzhj> it is not the benifit we take from  genesis config file  that can help us get rid of the template  function
08:43:34 <luyao2> agree
08:44:13 <huzhj> it is the daisy itself that support another config method , is that waht you mean?
08:45:01 <luyao2> no ,I can just use interface such as add-cluster,update-host, role-update to do it
08:45:56 <huzhj> Got it. Seems that is the right way we should take
08:46:40 <huzhj> In that way we can totally get ride of template?
08:46:59 <luyao2> I think so,but also need a template to provide needed para
08:47:39 <huzhj> So how can one get that template?
08:48:04 <luyao2> network.yml and deploy.YML?
08:49:38 <huzhj> let's define some terms for clearer discuss . network.yml and deploy.YML are not template, they are config file
08:49:58 <luyao2> oh thanks,I got it
08:50:23 <huzhj> So, again, In that way we can totally get ride of template?
08:50:43 <luyao2> yes,template funciton will be get rid
08:50:48 <huzhj> Good
08:51:18 <huzhj> @luyao, could you please propose a PS (patch set) to illustrate thi new way?
08:51:22 <luyao2> and I already do  something
08:51:36 <luyao2> yes
08:51:37 <huzhj> Good:)
08:52:32 <huzhj> #action @luyao2 will propose a PS (patch set) to illustrate a new way to setup a cluster instead of using template.
08:52:53 <huzhj> OK, no more time, let's move forward
08:52:57 <huzhj> #topic Core Code Abstraction
08:54:05 <huzhj> @zhouya, anything about this from your side?
08:54:18 <huzhj> We lost zhouya?
08:54:37 <zhouya1> I am here
08:54:59 <huzhj> Aha, bad network
08:55:09 <zhouya1> I just do the core code abstraction
08:55:25 <huzhj> it seems almost done?
08:55:59 <zhouya1> yes,but we have some flake8 err to be deal with
08:56:32 <zhouya1> and also the tempest is not work again
08:56:44 <huzhj> bad network
08:57:14 <huzhj> #info core code abstraction stuck at flake8 err. need to deal with
08:57:57 <zhouya1> and when I finish this work we can have a more clear abstraction of our code.
08:58:12 <huzhj> Great
08:58:19 <zhouya1> First of all I will deal with the flake8 errs
08:58:57 <huzhj> that will open up a door to encourage more plugin to be added into daisy
08:59:09 <zhouya1> exactly
08:59:33 <huzhj> we need a document to discribe how to implement plugins.
08:59:50 <zhouya1> yes
08:59:56 <huzhj> #info we need a document to discribe how to implement plugins. such as new API/ API extension...
09:00:03 <huzhj> OK, any thing else?
09:00:31 <luyao2> no
09:00:40 <huzhj> Time is up, let's talk Newton  offline
09:00:53 <huzhj> bye everyone
09:00:57 <luyao2> bye
09:01:01 <zhouya1> byes
09:01:02 <huzhj> Have a nice wekend
09:01:03 <zhouya1> bye
09:01:14 <huzhj> #endmeeting