08:00:16 <huzhj> #startmeeting daisycloud
08:00:17 <openstack> Meeting started Fri Nov 18 08:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:20 <openstack> The meeting name has been set to 'daisycloud'
08:00:35 <huzhj> #topic Roll Call
08:00:44 <huzhj> #info Zhijiang
08:00:50 <Zeyu> #info zeyu
08:00:56 <luyao> #info luyao
08:01:27 <huzhj> #topic OPNFV: Escalator Support
08:01:48 <zhouya> #info zhouya
08:02:50 <huzhj> We are not only integrating escalator but also implenting escalator now :)
08:03:30 <luyao> good
08:03:32 <huzhj> sunjing: any statue update for this topic?
08:03:47 <huzhj> zhouya: also from your side
08:04:01 <huzhj> Do we have kongwei connected?
08:04:33 <sunjing> I have beginned to implement the escalator frame from daisy.
08:04:37 <huzhj> #info daisy team not only integrating escalator but also implenting escalator now
08:04:42 <zhouya> Sorry, kongwei is not in at the moment.
08:05:13 <huzhj> sunjing: Good
08:05:17 <sunjing> Now the escalator service is up.
08:05:32 <zhouya> I just read the code try to modify spec file and build a escalatorclient rpm
08:05:42 <huzhj> sunjing: as intaller we need to know how to intall escalator
08:06:07 <huzhj> zhouya: you mean you have got the latest code from sunjing?
08:07:17 <sunjing> Next step ,I will try to work on the interface about how to call escalator for upgrade openstack.
08:07:36 <zhouya> no,I just read the code myself
08:07:37 <huzhj> I havn't got the code, sunjing, could you please release it as early as possible?
08:07:51 <huzhj> so taht we can review
08:08:26 <huzhj> sunjing: please contact kongwei on what api need to be done
08:08:46 <huzhj> I do not think we need to impl upgrading api for this phase
08:08:51 <sunjing> OK,there ara still some issue need to be modify.I will commit the code after the modify  asap.
08:09:03 <zhouya> great
08:09:35 <zhouya> and we can query the version now?
08:09:40 <huzhj> #info sunjing meet kongwei to discuss what api should be done for D release
08:09:44 <sunjing> To huzhj: OK. I will contact kongwei .
08:09:47 <zhouya> pbr problem has solved?
08:10:31 <huzhj> zhouya: query version is an easy api, we can do it first
08:10:40 <sunjing> We avoid the pbr problom.
08:10:46 <zhouya> yes
08:11:24 <zhouya> we now first query the escalator version or openstack version?
08:11:51 <huzhj> zhouya: escalator to call into daisy to query the  openstack version
08:12:04 <sunjing> we need talk about these with kongwei,maybe.
08:12:46 <huzhj> So the next thing we need to do is to impl the api in daisy
08:13:04 <zhouya> exactly
08:13:11 <sunjing> escalator will call installer other than the opposite?
08:13:39 <huzhj> sunjing: yes, escalator call installer
08:13:42 <zhouya> @sunjing you mean installer call escalator?
08:13:51 <huzhj> escalator sits on the top of installers
08:13:55 <sunjing> OK.I got it.
08:14:10 <zhouya> OK
08:14:17 <huzhj> but escalator itself have to be installer by installer
08:14:26 <huzhj> but escalator itself have to be installed by installer
08:14:47 <sunjing> sounds odd
08:14:50 <huzhj> Get version from inside a container is not easy
08:15:10 <huzhj> Zeyu , are you there?
08:15:16 <Zeyu> yes
08:16:02 <huzhj> Since you are working on kolla , may be you can ask them how to get openstack component version our from a running container or image
08:16:30 <huzhj> you know , the version info is wrapped by the container
08:17:00 <Zeyu> maybe i can send email to the ptl of kolla to ask this quesstion
08:17:00 <huzhj> not easy to get them
08:17:12 <zhouya> the version cann't mapped to the outside of container?
08:17:51 <huzhj> great. beware there are two type of versions
08:18:07 <huzhj> one: version in a image, two: version in a running container
08:18:24 <Zeyu> what do we need
08:18:30 <huzhj> two is easy, for example , we can get it by calling docker exec...
08:18:35 <huzhj> one is hard .
08:18:48 <zhouya> yes,if so,we can get the version from docker exec.
08:18:51 <huzhj> Zeyu: we may need them all
08:19:07 <Zeyu> ok
08:19:23 <huzhj> just like rpm
08:19:55 <huzhj> no matter before or after installing a rpm , we can get its version
08:20:25 <huzhj> So I think kolla image need the same character
08:20:38 <Zeyu> this is a new feature
08:20:46 <huzhj> totallu
08:20:48 <huzhj> totally
08:21:29 <huzhj> #action Zeyu will send email to kolla team about the how to get openstack component version our from a running container or a static image
08:22:10 <huzhj> For support escalator, if we can not wait for this new feature, then we can first make a fake one.
08:22:43 <zhouya> maybe fire a BP to kolla
08:23:00 <huzhj> Yes
08:23:17 <huzhj> OK, anything else for this topic?
08:23:32 <Zeyu> no
08:23:33 <sunjing> no
08:23:38 <zhouya> no
08:23:48 <huzhj> #topic OPNFV: CI Progress
08:24:16 <huzhj> luyao and Zeyu , what is new from your side about this?
08:25:01 <luyao> now  I can use common config to deploy nodes auto
08:25:19 <luyao> by call deploy.sh
08:25:22 <Zeyu> i commit the deploy job to OPNFV releng
08:25:52 <Zeyu> based on luyao's script
08:26:42 <huzhj> Good, so i think the rest thing is adding the virtual env to jenkins.
08:26:56 <luyao> yes
08:27:10 <huzhj> This is an urgent task. as well as adding the bare metal env
08:27:31 <Zeyu> you give me some advice about the deploy job, i have modified it
08:28:16 <huzhj> zeyu: you mean this one:? https://gerrit.opnfv.org/gerrit/#/c/24459/
08:29:09 <huzhj> #info Zeyu commit the deploy job to OPNFV releng
08:29:11 <Zeyu> yes
08:29:43 <huzhj> #info luyao confirm that we now can use common config file to deploy virtual nodes automatically
08:29:51 <huzhj> Zeyu: I have +1
08:30:44 <Zeyu> I read the eamil sent by you about the functest, it seem that the functest job only runs in verify stage
08:31:05 <huzhj> Sorry Zeyu, I think you are also working on escalator jjb which belongs to the prev topic.
08:32:39 <huzhj> Yes, functest smoke test can be run on both verify and merge. We Just choose one for time being. in future, if the time for deploy/test is not too long then we can consider run them on both phase.
08:33:22 <Zeyu> but JOSE say that FUNCTEST_SUITE_NAME is only used by verify jobs in CI
08:34:14 <huzhj> I guess his "verify" include both verify / merge
08:34:32 <huzhj> that is generalized verify
08:34:37 <Zeyu> ok ,i konw
08:35:25 <Zeyu> escalator jjb is still in modification, i am not sure about step
08:35:53 <Zeyu> such as  virtual deploy
08:36:04 <huzhj> Zeyu: OK, let's talk about escaltor jjb offline. I can help
08:36:15 <Zeyu> thanks
08:37:04 <huzhj> luyao: could you please send email to Zhihui about adding virtual env to OPNFV after  a successful deplyment?
08:37:50 <huzhj> We can show her the successful deployed env, the config file and the deply script.
08:38:09 <huzhj> To let her know taht we are ready
08:38:47 <huzhj> #action Zhijiang and Zeyu will working on impl jjb for escalator
08:38:55 <luyao> yes
08:39:02 <huzhj> Great
08:39:13 <huzhj> #action luyao will send email to Zhihui about adding virtual env to OPNFV after  a successful deplyment
08:39:14 <luyao> I will sed email right now
08:39:21 <huzhj> Great
08:39:27 <huzhj> OK, anything else?
08:39:39 <zhouya> no
08:40:07 <Zeyu> no
08:40:33 <huzhj> #topic Core Code Abstraction
08:41:39 <huzhj> zhouya: Seems the CCA is done right?
08:41:45 <zhouya> yes
08:41:56 <zhouya> the core code abstraction is ok
08:41:56 <huzhj> Excellent
08:42:15 <luyao> good
08:42:17 <huzhj> I saw a new feature comes in
08:42:24 <zhouya> tempest and rebot has passed
08:42:27 <huzhj> config file auto backup
08:42:28 <zhouya> yes
08:42:36 <zhouya> daisy config file suto backup
08:42:41 <zhouya> auto backup
08:42:58 <zhouya> I have contact qilongzhao to modify this
08:43:08 <huzhj> Such task can be run by cron/logrotate sevice though.
08:43:19 <zhouya> and he will modify the code to kick out the code from API layer
08:43:32 <huzhj> The only reason they need it in daisy seems is to probide API
08:43:48 <huzhj> provide API
08:44:02 <zhouya> yes
08:44:09 <huzhj> Good
08:44:54 <huzhj> Let him commit code by him self. zhouya, do not be the proxy :)
08:45:03 <zhouya> yes
08:45:50 <zhouya> all Teamers of daisy need to understand the process of new core code CI
08:46:02 <huzhj> If currently he has problem about contributing code youcan help him
08:46:09 <zhouya> And next they will commit core code to opensource
08:46:10 <huzhj> Yes
08:46:47 <huzhj> Anything else?
08:46:52 <zhouya> no
08:47:06 <huzhj> #topic Newton
08:47:35 <huzhj> One thing comes to my mind , we need a CI environment dedicated to Newton
08:47:46 <zhouya> yes
08:48:36 <huzhj> If we are lake of env, then may be we need a script to switch infrastructrure
08:49:33 <huzhj> #info we need a CI environment dedicated to Newton  or need a script to switch infrastructrure
08:50:39 <huzhj> If nothing else , then that is all for today
08:50:54 <huzhj> Let's warp up
08:51:14 <huzhj> wrap up
08:51:37 <zhouya> OK
08:51:43 <huzhj> Bye, guys
08:51:50 <zhouya> bye
08:52:23 <luyao> by
08:52:28 <sunjing> bye
08:53:41 <huzhj> #endmeeting