08:00:25 <huzhj> #startmeeting daisycloud
08:00:26 <openstack> Meeting started Fri Nov 25 08:00:25 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:29 <openstack> The meeting name has been set to 'daisycloud'
08:00:44 <kongwei> hi
08:00:46 <huzhj> Today's topics
08:01:01 <huzhj> 1) Roll Call
08:01:01 <huzhj> 2) OPNFV: CI Progress
08:01:01 <huzhj> 3) OPNFV: Escalator Support
08:01:01 <huzhj> 4) nominate Ya to be daisycloud-core core reviewer.
08:01:01 <huzhj> 5) Newton
08:01:10 <huzhj> #topic Roll Call
08:01:32 <huzhj> #info Zhijiang Hu
08:01:53 <kongwei> #info kongwei
08:04:03 <huzhj> seems we lost other guys
08:04:24 <huzhj> I will contact them offline right away
08:04:44 <huzhj> brb
08:05:14 <kongwei> OK
08:07:07 <huzhj> kongwei: let's get start on OPNFV: Escalator Support, we can not get contact with others
08:07:29 <huzhj> #topic OPNFV: Escalator Support
08:07:58 <kongwei> OK
08:08:21 <kongwei> sunjing and zhouya post code
08:08:41 <kongwei> we are in code review
08:09:04 <huzhj> #info we are in code review for escalator framework and client
08:09:08 <huzhj> Good
08:09:09 <kongwei> i post three jira for work
08:09:19 <zhouya> #info zhouya
08:09:39 <kongwei> zhuzeyu post ci code
08:10:03 <kongwei> they have good progress
08:10:12 <kongwei> hi zhouya
08:10:21 <huzhj> Yes I saw Zeyu's work, but Aric replied that we should complete the build sctript first.
08:11:10 <kongwei> yes
08:12:18 <huzhj> sunjing: Are you working on impl. the build script? Since I saw Escalator now can do pip install
08:13:10 <huzhj> #info we should complete the build sctript before merge releng jjb code
08:13:43 <huzhj> BTW, Jie just made a test case spec yesterday.
08:13:55 <huzhj> #info Jie just made a test case spec yesterday.
08:14:06 <huzhj> #link https://wiki.opnfv.org/display/escalator/Escalator+Test+Cases
08:14:18 <zhouya> great
08:14:18 <sunjing> Yes.I am working on build script and reviewer's comments.
08:15:27 <huzhj> sunjing: So after you got the script merged, could you please contact Zeyu to move his progress forward?
08:15:31 <sunjing> I will commit build script after the frame been in the hit repo.
08:15:40 <huzhj> Good
08:16:20 <huzhj> Only Jie can commit the code? Do we have other commiter?
08:16:44 <sunjing> ok,I will contract with zeyu about CI issues.
08:16:57 <huzhj> I think we need to ask Jie for extend the number of commiter member
08:17:27 <zhouya> we only have jie one commiter
08:17:27 <sunjing> good propose
08:17:54 <huzhj> kongwei: Have you read Jie's test case spce?
08:18:10 <huzhj> I think it is kind of blur.
08:18:27 <huzhj> especially for which we need to do in Danube release.
08:19:00 <kongwei> i have read it
08:19:08 <huzhj> Julien & Jie has some discuss on that wiki page, I haven't dive into it.
08:20:24 <huzhj> I think the discuss is a little bit high level for us.
08:20:46 <kongwei> yes
08:21:20 <kongwei> but i think we should join them
08:21:57 <zhouya> yes
08:22:18 <huzhj> Yes. OK, let's join the discuss for the escalator test case over OPNFV community
08:22:57 <huzhj> Julien noticed that this discussion should be as open as possible.
08:23:43 <zhouya> we should let other s know our progress
08:23:56 <huzhj> #info The test case need more OPEN discuss
08:24:08 <zhouya> so,discuss in community is neccessary
08:24:13 <huzhj> yes
08:24:39 <huzhj> zhouya & sunjing , do we have any problem during the coding?
08:25:48 <huzhj> And is there any other issues on this topic?
08:25:55 <zhouya> we do not have enough repo
08:26:02 <sunjing> Thanks for
08:27:01 <huzhj> zhouya, you mean we need to split the repo as two. one is for the service another for client?
08:27:08 <zhouya> so,we just make two dir in escalator
08:27:09 <sunjing> To shouts:Escalator and client code are in one repo.
08:27:25 <zhouya> yes
08:27:39 <zhouya> we now just do it this way
08:27:42 <sunjing> sorry,to Zhou ya
08:28:08 <huzhj> Yes this may be an issue.
08:28:27 <huzhj> But let's keep it as what it is for the time being
08:28:33 <zhouya> OK
08:29:33 <huzhj> For we'd better spend time on the first prio things. you know we are now lack of time:)
08:29:56 <sunjing> got it
08:30:18 <huzhj> I will keep a record of the repo spliting things for future follow up
08:30:53 <huzhj> Besides, we can also take other OPNFV projects' example
08:31:18 <huzhj> See how they deal with this kind of problem
08:32:07 <zhouya> good idea
08:32:23 <huzhj> #info we need to split the repo as two. one is for the service another for client, keep it as what it is for the time being, keep a record of the repo spliting things for future follow up
08:33:01 <huzhj> OK, shall we move on the the next topic?
08:33:16 <zhouya> OK
08:33:32 <luyao3> ok
08:33:56 <huzhj> #topic OPNFV: Daisy & Escalator CI Progress
08:34:46 <huzhj> I beleive we have some good progress from Yao
08:35:01 <luyao3> Now
08:35:58 <luyao4> we
08:36:04 <luyao4> can
08:36:20 <huzhj> luyao4: you are on cell phone ?
08:36:26 <luyao4> yes
08:36:28 <luyao4> sorry
08:36:57 <luyao4> now can use daisy to deploy virtual os
08:37:08 <huzhj> No thank you for participate us in such a worse network condition
08:37:23 <luyao4> so sorry~
08:37:40 <huzhj> luyao4: let's update your progress offline
08:37:50 <luyao4> yes
08:38:10 <huzhj> From my side I see that Yao has just proposed a patch
08:38:24 <luyao4> yes
08:38:32 <huzhj> https://review.openstack.org/#/c/402024/
08:38:36 <huzhj> #link https://review.openstack.org/#/c/402024/
08:38:53 <huzhj> A patch for daisy to support kvm node deployment
08:39:02 <zhouya> conflict with other commit
08:39:09 <luyao4> it can solve daisy deploy os of virtual to support opnfv
08:39:23 <huzhj> The idea is that , we basically follow the sequence of baremetal deployment for kvm node.
08:39:32 <luyao4> i will solve the conflict
08:39:36 <huzhj> But skip the IPMI command
08:40:04 <luyao4> yes
08:40:28 <huzhj> leave the power/bootsequence task to the outer deploy script
08:41:03 <huzhj> The the outer depoly script can use virsh commands to replce IPMI command
08:41:25 <zhouya> sounds great
08:41:34 <luyao4> next step IWill modify deploy script to support deploy vm
08:42:04 <sunjing> Nice job
08:42:44 <huzhj> Let's wait Yao's final build script proposed to OPNFV repo to get the whole picture about this new work flow
08:43:44 <huzhj> #info A patch for daisy to support kvm node deployment , The idea is that , we basically follow the sequence of baremetal deployment for kvm node bskip the IPMI command and leave the power/bootsequence task to the outer deploy script
08:43:51 <huzhj> #info Then the outer depoly script can use virsh commands to replce IPMI command
08:44:29 <huzhj> Another thing is that now we can build and start kvm machine from scratch
08:44:35 <huzhj> #info now we can build and start kvm machine from scratch
08:44:40 <luyao4> good
08:45:08 <huzhj> #info By using virsh xml config file.
08:45:19 <huzhj> #action Yao is working on that
08:45:51 <huzhj> luyao4: OK that is all I know about the progress, is ther anything I missed
08:46:17 <luyao4> xml have merged?
08:46:46 <luyao4> maybe we can merge then I can use test
08:47:24 <huzhj> No, I just proxy you to describe the progress
08:48:10 <luyao4> sorry ,now can create vm from xml
08:48:23 <huzhj> Greate.
08:48:58 <huzhj> And the xml will be stored in OPNFV repo.
08:49:20 <huzhj> Good, anything else about this topic?
08:49:25 <luyao4> no
08:49:47 <huzhj> #topic nominate Ya to be daisycloud-core core reviewer.
08:50:15 <huzhj> I sent a email about this but no one give me ack
08:50:33 <huzhj> So shall we vote on IRC?
08:50:57 <huzhj> agree : +1, disagree -1,
08:50:57 <zhouya> didn ot get the email
08:51:59 <huzhj> Allright, so let's vote now
08:52:01 <huzhj> +1
08:52:30 <huzhj> Oh, Let me resend the email content on IRC
08:52:49 <huzhj> Ya started to work on Daisycloud-core since the beginning of the project
08:52:50 <huzhj> and he has made significant contribution to project in last three months
08:52:50 <huzhj> including adding Kolla backend, implementing extensible framework, etc.
08:52:50 <huzhj> The most important work is introducing extensible framework to
08:52:50 <huzhj> daisycloud-core, it makes our product a more open design to adapt more new
08:52:50 <huzhj> technology such as bifrost, HWM, and any other third-party plugins.
08:52:50 <huzhj> I have had a nice talk with him offline and he expressed willing to
08:52:51 <huzhj> contribute more to daisycloud-core project and I believe he will make a
08:52:51 <huzhj> great addition to the core review team.
08:55:50 <luyao4> good
08:56:02 <sunjing> +1
08:56:26 <huzhj> luyao4 so you vote +1 :
08:56:28 <huzhj> :)
08:57:05 <huzhj> #vote
08:57:11 <huzhj> #undo
08:57:13 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7fbb93c47250>
08:57:44 <huzhj> #topic Nominate Ya to be daisycloud-core core reviewer
08:58:09 <huzhj> OK, so we got the majority vote
08:58:23 <huzhj> Congres, zhouya
08:58:32 <zhouya> thanks
08:58:36 <kongwei> sorry
08:58:46 <kongwei> zhouya +1
08:59:09 <huzhj> Thanks kongwei, I will add zhouya to the core member list later
08:59:14 <zhouya> and I will keep on working with all contribute rs
08:59:46 <huzhj> zhouya: Thank you
08:59:53 <huzhj> OK, we are running out of time
08:59:54 <kongwei> Congres, zhouya
09:00:01 <sunjing> congratulations
09:00:01 <kongwei> yes
09:00:03 <zhouya> thanks wei
09:00:06 <kongwei> bye
09:00:14 <huzhj> Let's call it a meeting
09:00:15 <huzhj> Bye
09:00:21 <huzhj> have a nice weekend
09:00:23 <zhouya> bye
09:00:42 <huzhj> #endmeeting