08:03:21 <huzhj> #startmeeting daisycloud
08:03:22 <openstack> Meeting started Fri Jan 13 08:03:21 2017 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:03:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:03:25 <openstack> The meeting name has been set to 'daisycloud'
08:03:39 <huzhj> Today topics:
08:03:53 <huzhj> 1) Roll Call
08:03:54 <huzhj> 2) OPNFV: Daisy CI Progress
08:03:54 <huzhj> 3) OPNFV: Daisy Support Escalator
08:03:54 <huzhj> 4) OpenStack: Kolla Image Versioning
08:03:54 <huzhj> 5) AoB
08:04:01 <huzhj> #topic Roll Call
08:04:14 <huzhj> #info Zhijiang
08:04:37 <zhuzeyu> #info zhuzeyu
08:05:29 <luyao1> #info luyao
08:05:58 <huzhj> #topic OPNFV: Daisy CI Progress
08:06:50 <huzhj> Alex contributed a lot of PS these days.
08:07:53 <huzhj> Please DO review them if we have time, some of the PS is really valuable
08:08:04 <luyao1> ok
08:08:21 <zhuzeyu> OK,it is a good idea
08:08:24 <huzhj> For example:  https://gerrit.opnfv.org/gerrit/#/c/26785/
08:09:45 <luyao1> ssh-keygen is better
08:11:07 <zhuzeyu> Code like this is very simple and userful
08:11:44 <huzhj> Yes
08:11:59 <zhuzeyu> Can this realize the expected function?
08:13:10 <huzhj> I think so.
08:14:25 <zhuzeyu> I will test its function after meeting
08:14:28 <huzhj> Old code is fussy, wordy, tremble
08:14:37 <huzhj> Good
08:15:06 <huzhj> Another PS is https://gerrit.opnfv.org/gerrit/#/c/26913/
08:16:09 <huzhj> It makes the local(jenkins slave) and remote (jump server) arguments more readble to us
08:16:38 <huzhj> Anything else about this topic?
08:17:01 <luyao1> good
08:17:03 <luyao1> no
08:17:17 <zhuzeyu> yes, nice work
08:17:24 <huzhj> #topic OPNFV: Daisy Support Escalator
08:17:47 <huzhj> Anything about Daisy support Escalator or Escalator itself?
08:19:13 <sunjing> I am working on get cluster list from daisy for escalator right now.
08:19:55 <huzhj> sunjing you mean you are working on the Daisy side or the Escalator side?
08:20:18 <sunjing> I am working on escalator side.
08:20:29 <sunjing> get cluster list from daisy
08:20:36 <huzhj> #info sunjing is working on getting cluster list from daisy for escalator .
08:20:56 <sunjing> It is in coding phase now.
08:21:07 <huzhj> Good, does Daisy fully support this function currently?
08:22:06 <sunjing> Yes,daisy has fully supported this now.
08:22:28 <sunjing> There is no need for modify daisy side.
08:22:34 <huzhj> Good
08:23:51 <sunjing> One thing more,the function"Add a new installer daisy adapter to modules directory" has been merge.
08:24:00 <sunjing> merged
08:24:10 <huzhj> Great
08:24:16 <sunjing> https://gerrit.opnfv.org/gerrit/#/c/26595/
08:24:32 <huzhj> #info function"Add a new installer daisy adapter to modules directory" has been merged https://gerrit.opnfv.org/gerrit/#/c/26595/
08:25:15 <sunjing> But it is just a frame,I will realize that lator.
08:25:48 <huzhj> OK, I will add a JIRA for this task
08:26:02 <sunjing> Thanks.
08:26:28 <huzhj> #action huzhj to add a JIRA task for "Add a new installer daisy adapter to modules directory" implementation
08:27:00 <huzhj> Anything else?
08:27:14 <sunjing> nothing for me
08:27:18 <zhuzeyu> no
08:27:57 <huzhj> zhuzeyu, I saw your PS https://gerrit.opnfv.org/gerrit/#/c/26851/ about how to install config file by using python setup.py
08:28:07 <huzhj> It is a good idea
08:28:31 <huzhj> Seems can replace almost all the task which RPM can provide.
08:28:42 <zhuzeyu> yes,When use pip install tarball, there is no configuration file in /etc/eacalator
08:29:00 <zhuzeyu> this patchset can solve this problem
08:29:09 <luyao1> good
08:29:27 <sunjing> agree
08:29:28 <huzhj> But I believe RPM has its own advantage
08:29:51 <zhuzeyu> yes
08:29:54 <huzhj> Basically, RPM is platform specific
08:30:17 <huzhj> It knows deeply about the RPM based OS such as CentOS/RHEL
08:30:37 <huzhj> Just like apt to the ubuntu
08:31:58 <huzhj> So I think there may be a boundary which is used to decide which task should be done by setup.py,  and which should be done by RPM
08:32:32 <huzhj> We need to make this boundary clear
08:32:38 <zhuzeyu> I agree with you
08:33:16 <huzhj> probably, read other projects rpm spec can help
08:33:35 <zhuzeyu> Does escalator need to support ubuntu?
08:33:35 <luyao1> good idea
08:34:11 <huzhj> zhuzeyu, yes, probably
08:34:42 <huzhj> At setup.py level, it should not see the difference between RPM based OS and apt based OS
08:35:48 <zhuzeyu> ok, we can add Makefile in escalator to generate RPM
08:36:25 <huzhj> Agree
08:36:41 <huzhj> #info zhuzeyu said we can add Makefile in escalator to generate RPM
08:37:19 <huzhj> OK, anything else about this topic?
08:37:30 <zhuzeyu> no
08:37:57 <luyao1> no
08:38:01 <huzhj> #topic OpenStack: Kolla Image Versioning
08:38:37 <zhuzeyu> I am working on geting version of openstack componment in remote docker container by using ansible
08:39:21 <zhuzeyu> I use 'docker exec ...' to query version of componment  in docker
08:39:47 <zhuzeyu> It seems that it is not a good idea
08:40:11 <huzhj> what is the problem?
08:40:49 <zhuzeyu> There is no output in screen
08:41:17 <zhuzeyu> the error is that input device is not a TTY
08:42:23 <zhuzeyu> Recently ,I attempt to use custom module of ansible to query version
08:42:23 <huzhj> and you can not run with argument, such as ,"-it"?
08:42:31 <zhuzeyu> yes
08:42:46 <zhuzeyu> it will work without "-it"
08:43:23 <zhuzeyu> but if we don't use "-it", we can not see the result
08:43:48 <huzhj> it works without "-it" only?
08:44:45 <zhuzeyu> yes
08:45:22 <zhuzeyu> It is mainly because "-t"
08:45:40 <huzhj> Do you think impl. ansible can solve the peoblem ?
08:46:25 <zhuzeyu> I don't find a solution
08:46:36 <huzhj> sorry : Do you think impl. ansible  module can solve the peoblem ?
08:46:39 <huzhj> OK
08:46:57 <zhuzeyu> now ,i am working on this
08:46:58 <huzhj> Or we may get such info from container metadata?
08:47:46 <zhuzeyu> I test the using method of ansible custom module today
08:47:49 <huzhj> I mean, when kolla build these images, it store some sort of metadata to the image, then after it running as a container, we can get metadata from container
08:47:59 <huzhj> OK
08:48:10 <huzhj> Try your method first.
08:48:44 <zhuzeyu> ok ,we can discuss it offline
08:49:22 <huzhj> The metadata method is just my $0.02 , I am not sure if docker image has such metadata framework or not.
08:49:25 <huzhj> OK
08:50:05 <zhuzeyu> I am not sure about this
08:50:26 <huzhj> #info zhuzeyu is working on getting component version out from container by using ansible module
08:51:06 <huzhj> #info huzhj suggest using image metadata  method which may or may not supported by docker image
08:52:01 <huzhj> OK, About the Kolla image statical version, I have modified the version file format in Daisy kolla image tarball
08:52:42 <huzhj> Now it includes not only the git version but also the git tag such as 3.0.2 and build date
08:53:24 <zhuzeyu> It is really a good idea,we need this information
08:53:25 <huzhj> I think it is helpful for luyao  to impl the version management in daisy
08:54:15 <zhuzeyu> yes
08:54:40 <huzhj> The git tag will be used to decide which image group version should be deployed.
08:55:27 <huzhj> #info huzhj have modified the version file format in Daisy kolla image tarball
08:55:27 <huzhj> Now it includes not only the git version but also the git tag such as 3.0.2 and build date
08:55:33 <huzhj> #info Now it includes not only the git version but also the git tag such as 3.0.2 and build date
08:56:04 <huzhj> #info The git tag will be used to decide which image group version should be deployed after choosing a specific tarball
08:56:42 <huzhj> #info git tag can also be used to implement the version upgrading
08:57:00 <huzhj> For example we can upgrade from 3.0.2 to 3.0.3
08:57:19 <huzhj> OK, anything else about this topic?
08:57:25 <zhuzeyu> no
08:57:33 <luyao1> no
08:58:01 <huzhj> #topic AoB
08:59:13 <huzhj> any other business?
08:59:23 <Qiming> hi, is there a IRC channel for daisycloud?
08:59:35 <Qiming> searched channel list for daisy but found nothing
08:59:54 <zhuzeyu> yes ,it is
08:59:56 <huzhj> Qiming, yes, it is for daisy
09:00:16 <huzhj> where you found the channel list?
09:00:41 <Qiming> you can list the channels or search for channels from IRC client
09:01:06 <Qiming> tried daisy or daisycloud or openstack-daisy ...
09:01:10 <Qiming> all empty, :)
09:01:13 <huzhj> most projects share the same channel
09:01:38 <huzhj> OpenStack suggest most projects share the same channel , thus openstack-meeting
09:01:50 <Qiming> this channel is for meeting only
09:01:58 <Qiming> I mean a project specific channel
09:02:08 <Qiming> sounds like you don't have one
09:02:21 <huzhj> We now do not have project spec channel
09:02:29 <Qiming> i see
09:03:09 <huzhj> prev we have one (daisycloud-core), but not used now
09:03:32 <huzhj> If you have any question to discuss please feel free to send email to me
09:03:36 <huzhj> :)
09:03:42 <huzhj> We are runing out of time
09:03:51 <huzhj> #endmeeting