07:59:31 <huzhj> #startmeeting daisycloud
07:59:32 <openstack> Meeting started Fri Feb 10 07:59:31 2017 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:59:35 <openstack> The meeting name has been set to 'daisycloud'
07:59:50 <huzhj> #topic Roll Call
08:00:00 <huzhj> #info Zhijiang
08:00:06 <zhuzeyu> #info zhuzeyu
08:01:24 <huzhj> Today's topics:
08:01:39 <zhouya> #info zhouya
08:01:45 <huzhj> 1) Roll Call
08:01:45 <huzhj> 2) OPNFV: Release Postpone Discuss
08:01:46 <huzhj> 3) OPNFV: BM/BM Deployment & Functest Integration
08:01:46 <huzhj> 4) OpenStack: Core Code Definition Wind Up
08:03:21 <huzhj> Hi all. Let's wait julien and kongwei
08:03:32 <zhouya> ok
08:03:38 <huzhj> Hi Julien-zte
08:03:51 <Julien-zte> #info Julien
08:03:52 <zhuzeyu> no problem
08:03:59 <Julien-zte> hi huzhj
08:03:59 <huzhj> Hello kongwei
08:04:08 <huzhj> OK, let's get startedx
08:04:08 <kongwei> hi
08:04:27 <huzhj> #topic OPNFV: Release Postpone Discuss
08:04:43 <Julien-zte> what's the main issues now?
08:04:58 <Julien-zte> what we must finished before we can release?
08:05:02 <huzhj> I am considering this topic and sorting out tasks remained for Danube.
08:05:21 <Julien-zte> can you show the link
08:05:32 <huzhj> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=111&projectKey=DAISY&view=planning&selectedIssue=DAISY-16
08:05:58 <huzhj> I have  sorted out the tasks remain in JIRA
08:06:29 <Julien-zte> what's the progress for each of them
08:06:48 <huzhj> We really have more to do, expecially integrate with functest yardstrick and deal potential issues
08:06:55 <Julien-zte> can we review these tasks for the progress now
08:07:01 <huzhj> OK
08:07:33 <huzhj> https://jira.opnfv.org/browse/DAISY-13   --- deploy to vm in verify job
08:08:01 <huzhj> I saw Alex post a virtual pod proposal to helpdesk
08:08:14 <huzhj> but still hasn't got response?
08:08:40 <Julien-zte> I have got it done
08:09:18 <Julien-zte> #info I leave a msg in review: https://gerrit.opnfv.org/gerrit/#/c/28073/
08:09:39 <Julien-zte> #info Alex request to add a new slave node has been finished offline
08:09:50 <Julien-zte> I work with Aric and get it done
08:09:59 <Julien-zte> zte-virtual1 has been online
08:10:13 <huzhj> Great!
08:11:19 <huzhj> Then the deploy job should be enabled
08:11:19 <Julien-zte> https://build.opnfv.org/ci/computer/zte-virtual1/
08:11:29 <Julien-zte> yes, I have add it !
08:11:40 <Julien-zte> it will be triggered when new patch got merged
08:12:34 <Julien-zte> we can set this task resolved
08:12:40 <Julien-zte> is it ok?
08:12:42 <huzhj> I have just merged https://gerrit.opnfv.org/gerrit/#/c/28059/
08:12:45 <huzhj> Yes
08:13:56 <Julien-zte> https://build.opnfv.org/ci/view/daisy/job/daisy4nfv-merge-master/
08:14:01 <Julien-zte> jobs has been triggered
08:14:22 <Julien-zte> whether it can finished correctly or not. but we can fix it
08:14:37 <Julien-zte> let's move on to next?
08:14:46 <huzhj> OK, the next
08:14:47 <huzhj> #link https://jira.opnfv.org/browse/DAISY-30
08:14:55 <huzhj> BM deployment
08:15:19 <huzhj> I think Ya is working on this and have PS
08:15:23 <Julien-zte> pod2 is added for daisy baremetal also in 28073
08:15:32 <zhouya> I am
08:15:45 <Julien-zte> #info what's the current status for deployment?
08:15:45 <zhouya> I am work on the debug of BM deployment
08:16:03 <huzhj> team - feel free to #info your comments as you think is appropriate
08:16:19 <Julien-zte> how long  do you estimate it will take?
08:16:19 <zhouya> I have commit on https://gerrit.opnfv.org/gerrit/#/c/28347/
08:16:40 <zhouya> but I have to debug it till it can work
08:16:50 <zhouya> Maybe another week
08:16:53 <Julien-zte> agree! how long it will take
08:17:03 <Julien-zte> we shall consider the risks
08:17:18 <zhouya> yes
08:18:09 <zhihui> @zhouya, if you meet envrioment issue, you can contact me.
08:18:22 <zhouya> ok,thank you @zhihui
08:18:29 <huzhj> zhouya do we have any risks currently?
08:18:31 <Julien-zte> what's current status?
08:18:31 <Julien-zte> os finished?
08:18:45 <zhouya> I haven't deploy 5 nodes.
08:19:11 <zhouya> yesterday,I just can ping 192.168.1.106
08:19:13 <zhihui> Have you booted a daisy vm?
08:19:20 <zhouya> yes
08:19:25 <zhouya> I booted a daisy vm
08:19:36 <zhouya> with 10.20.11.2 network
08:19:48 <zhouya> And I will change this to 10.20.7.2
08:20:01 <zhihui> Good.
08:20:22 <Julien-zte> does the daisy vm work now?
08:20:32 <zhouya> yes,it can work
08:20:40 <zhihui> So next step is to discover nodes?
08:20:43 <Julien-zte> #info daisy vm has been deployed and it works now
08:20:52 <zhouya> but I don't know if the vm can find host from pxe.
08:21:01 <huzhj> Julien-zte  https://build.opnfv.org/ci/view/daisy/job/daisy4nfv-merge-build-master/47/console
08:21:11 <huzhj> seems build job failed
08:21:20 <zhouya> I will test the host find later.
08:21:28 <Julien-zte> we shall fix all the ci error in the weekend
08:21:39 <huzhj> thanks
08:22:05 <Julien-zte> but I don't know what affects, maybe I need team help
08:22:24 <huzhj> we will also take a look
08:22:36 <Julien-zte> #action Julien-zte fix ci errors
08:23:09 <Julien-zte> huzhij can you add me the op's priority
08:23:18 <huzhj> zhouya , we know that you also work on other project, how many percentage of time can you spend on daisy4nfv?
08:23:24 <Julien-zte> huzhj can you add me the op's priority
08:24:04 <zhouya> maybe I must take 1 day or 2 for the other project
08:24:10 <huzhj> julien-zte op's priority  of what?
08:24:25 <Julien-zte> admin
08:25:13 <zhouya> and maybe the BM deployment task will be delay.
08:26:43 <huzhj> zhouya So man power seems is still a risk
08:26:55 <zhouya> yes
08:28:29 <huzhj> Julien-zte you mean the meeting admin ? sure
08:28:37 <Julien-zte> yes
08:29:22 <Julien-zte> #chair Julien-zte
08:29:36 <huzhj> #chair Julien-zte
08:29:37 <openstack> Current chairs: Julien-zte huzhj
08:29:45 <Julien-zte> it's ok now
08:29:57 <huzhj> I can not Open https://wiki.opnfv.org/display/SWREL/Milestone+Compliance+for+Danube
08:29:57 <Julien-zte> let's continue
08:30:06 <huzhj> is anybody can open it?
08:30:15 <Julien-zte> Yes I can
08:30:38 <zhuzeyu> I can open it
08:30:39 <huzhj> OK, that is the MS timeline.
08:30:41 <Julien-zte> #info no report and Missing Functest integration
08:31:00 <huzhj> Let's move to next item?
08:31:25 <Julien-zte> huzhj, the report only from Jenkins jobs
08:31:41 <Julien-zte> if we can provide jenkins work correctly, it will paas
08:32:20 <huzhj> Got it
08:32:33 <Julien-zte> we 'd finish baremetal deployment and integrate with functest
08:32:34 <huzhj> David is expecting the report from daisy
08:32:49 <Julien-zte> and the integration with functest can be finished offline
08:33:05 <Julien-zte> do you have another evironment which can be used for test integration?
08:33:10 <huzhj> merge job seems need to integrate with functest too , right?
08:33:29 <Julien-zte> yes, after we have tested
08:33:44 <Julien-zte> integrate with functest in daily jobs not merged jobs
08:33:53 <huzhj> For BM , no we dont have
08:34:07 <Julien-zte> I can assign another member to work in integration.
08:34:31 <Julien-zte> any other env baremetal in ZTE ?
08:34:42 <huzhj> So https://jira.opnfv.org/browse/DAISY-16 (Daisy4NFV call into functest smoke test during gerrit verify/merge process) can be remove from todo list?
08:35:02 <Julien-zte> yes, please
08:35:07 <Julien-zte> it will take too much time
08:35:18 <Julien-zte> I don't think anyother installer project perform this
08:35:24 <Julien-zte> zhihui, do you know
08:35:34 <Julien-zte> I think it is a daisy /periodic job
08:35:42 <Julien-zte> daisy->daily
08:35:49 <zhuzeyu> it seems that functest is only used by verify jobs in CI
08:36:31 <Julien-zte> functest is triggered by daisy ci jobs: deploy, test and get the result
08:36:42 <Julien-zte> test procedure including: yardstick and functest
08:36:59 <Julien-zte> when we finish integration, I will add the steps in Jenkins
08:37:12 <Julien-zte> I add a test step in daisy job
08:37:46 <huzhj> So the next one is https://jira.opnfv.org/browse/DAISY-31   (https://jira.opnfv.org/browse/DAISY-31)
08:37:57 <huzhj> Call into functest smoke test on zte-pod2 in daily jobs
08:38:17 <Julien-zte> I think we should postpone till deployment finished
08:38:25 <huzhj> yes
08:38:36 <huzhj> it depends on bm deployment
08:38:39 <Julien-zte> and we'd better test offline
08:38:51 <Julien-zte> if we have other envs
08:39:14 <Julien-zte> or , we can use virtual env for test
08:40:08 <huzhj> We do not have env in Nanjing for bm test.  I still havent got any local env dedicated for daisy4nfv
08:40:31 <Julien-zte> what a pity:(
08:41:12 <huzhj> ;/
08:42:32 <huzhj> Next item is scenario related
08:42:38 <huzhj> https://jira.opnfv.org/browse/DAISY-8 and https://jira.opnfv.org/browse/DAISY-9
08:43:05 <Julien-z_> #info let's focus on baremetal deployment first
08:43:05 <huzhj> Thus, we need to find out how to call correct functest/yardstrick test suit
08:43:48 <Julien-z_> huzhj, we have a functest committer who can help use  to achive
08:44:11 <huzhj> OK, keep focus on BM deployment topic, i am just sorting out all the to do items :)
08:44:31 <Julien-z_> good
08:44:42 <Julien-z_> no issues about baremetal?
08:45:24 <Julien-z_> zhouya, if there is any issue, contact us for help
08:46:05 <Julien-z_> #info cancel DAISY-16 it is not necessary
08:46:07 <zhouya> we just have to change a little code in deploy.sh to satify BM deployment
08:46:20 <Julien-z_> then change it
08:46:35 <zhouya> If I have any problem of BM deployment,I will contact.Thank you.
08:46:56 <Julien-z_> huzhj, let's move on to next
08:47:36 <Julien-z_> lower priority for DAISY-10
08:47:51 <Julien-z_> I think it is import for daisy not integrate with escalator
08:48:06 <huzhj> OK, next item may be only my own concern:  https://jira.opnfv.org/browse/DAISY-35
08:48:14 <huzhj> Make zte-pod2 a CI POD, not Development POD
08:48:14 <Julien-z_> the target is to release
08:48:34 <huzhj> Yes, I will not mention any escalator related items
08:49:02 <Julien-z_> don't care about this
08:49:31 <Julien-z_> when all the jobs begin stable, we can apply for CI pods, for now, it is not necessary.
08:49:37 <huzhj> Got it
08:49:44 <Julien-z_> all the PODs for installer will begin CI pods.
08:49:57 <Julien-z_> I have discussed with the INFRA WG multiple times.
08:50:29 <Julien-z_> for now, our PODs have been stable without network issue, when we finish the jobs. it will become
08:50:36 <Julien-z_> I will discuss with them
08:50:38 <huzhj> OK , if that is not the case, then I have only one itme left,  #link https://jira.opnfv.org/browse/DAISY-36   --- Release Documentation
08:51:05 <huzhj> I have done with some initial docs
08:51:21 <Julien-z_> #info don't care about DAISY-35 where it is a CI pod
08:51:31 <Julien-z_> it's a huge job for documents
08:51:44 <huzhj> #info initial doc work https://gerrit.opnfv.org/gerrit/#/c/28169/
08:51:47 <huzhj> Yes
08:52:08 <huzhj> Daivd noticed that we need to do doc as early as possible
08:52:13 <Julien-z_> please add JIRA: DAISY-36 into your commit msg, then we can tracker it in Jira
08:52:26 <huzhj> the idea is to force most of the learning process for documentation earlier in the release, in order to reduce confusion and delay toward the end of the release, as we had with Colorado
08:52:35 <Julien-z_> #action team learn to write correct commit-msg in OPNFV
08:52:58 <Julien-z_> agree
08:53:04 <huzhj> My fault, already merged
08:53:21 <huzhj> I will try to rectify it
08:53:39 <Julien-z_> for the latter reviews
08:54:14 <Julien-z_> what about rst knowledge for documents of team?
08:54:16 <huzhj> Will do
08:54:32 <huzhj> Only basic
08:54:40 <huzhj> basic knowledge
08:54:49 <Julien-z_> got it
08:55:06 <Julien-z_> if required, we can provide some training for rst
08:55:16 <Julien-z_> let's move to next
08:55:20 <huzhj> expecially do not have the knwledg for the conveting tools
08:55:36 <huzhj> Thanks, that will be greate help
08:56:01 <huzhj> I do not have any items left
08:56:35 <Julien-z_> I have move DAISY-25, 26, 27, 29 to "Done" status
08:56:41 <huzhj> May be not thought all the way through
08:56:53 <Julien-z_> any questions for these tasks?
08:57:12 <Julien-z_> what about DAISY-21?
08:57:50 <Julien-z_> huzhj, any other topics?
08:57:55 <huzhj> 21 is easy, I have confirm with Jose
08:58:00 <huzhj> relative easy
08:58:11 <huzhj> I have confirm with Jose what we should do after deploy
08:58:21 <Julien-z_> OK
08:58:42 <huzhj> OK, we are running out of time...
08:58:53 <huzhj> #topic OPNFV: BM/BM Deployment & Functest Integration
08:59:06 <Julien-z_> #from the discussion, most important is deployment on pod2
08:59:06 <huzhj> I think we have already done with this topic
08:59:16 <Julien-z_> #info from the discussion, most important is deployment on pod2
08:59:29 <Julien-z_> #info we shall add more resources into this tasks
08:59:31 <zhuzeyu> :wq
08:59:37 <Julien-z_> thanks!
08:59:40 <zhouya> ok
08:59:44 <huzhj> #topic OpenStack: Core Code Definition Wind Up
09:00:13 <huzhj> This topic belongs to Yao, but we do not have her online.
09:00:30 <huzhj> zhouya, do you have any thing about this topic?
09:01:03 <huzhj> This is the last topic for today
09:01:31 <zhouya> maybe yao has accomplish all the core code definition
09:01:43 <huzhj> Good.
09:01:59 <zhouya> and we can just use all the core code from stable/mitaka branch of diasycloud-core
09:02:22 <huzhj> OK, Iwill confirm that with Yao offline
09:02:38 <zhouya> next step is to change the script to copy and replace all the core code
09:02:52 <huzhj> Yes
09:03:26 <huzhj> Anything else or let's call it a meeting.
09:03:32 <zhouya> no
09:04:03 <huzhj> Good, Thanks guys. Have a good weekend!
09:04:08 <huzhj> Bye
09:04:10 <zhuzeyu> bye
09:04:11 <zhouya> The same to you
09:04:14 <kongwei> bye
09:04:18 <huzhj> #endmeeting