08:24:17 <alexyang> #startmeeting daisycloud
08:24:18 <zhouya> and when pxe reboot,the node can't find.
08:24:18 <openstack> Meeting started Fri Feb 24 08:24:17 2017 UTC and is due to finish in 60 minutes.  The chair is alexyang. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:24:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:24:21 <openstack> The meeting name has been set to 'daisycloud'
08:24:38 <zhouya> I have send yangyang a email about this.
08:25:42 <Julien-zte_> #info Julien
08:25:47 <Julien-zte_> #nick Julien-zte
08:25:48 <zhouya> #info zhouya
08:25:51 <alexyang> #info alexyang
08:26:56 <Julien-zte_> hi zhouya, what's progress about the baremetal deployment on ZTE pod2
08:27:36 <zhouya> we can deploy our daisy of multinode on ZTE pod2
08:27:49 <Julien-zte_> successfully?
08:27:49 <alexyang> good
08:27:56 <zhouya> But we still have some code to fix.
08:28:21 <zhouya> https://gerrit.opnfv.org/gerrit/#/c/28347/
08:28:26 <zhouya> this is the commit
08:28:37 <Julien-zte_> if the pod can be deployed successfully, we'd active the pod into Jenkins
08:29:03 <Julien-zte_> it has been merged
08:29:13 <zhouya> we still need to move network.yml and deploy.yml to lab dir.
08:29:54 <zhouya> I am testing the network.yml file you gave me.
08:29:56 <alexyang> those yaml files should be provided in securedlab?
08:30:19 <Julien-zte_> I think artifacts.opnfv.org/daisy/opnfv-2017-02-24_06-58-33.bin  bas included this patch
08:30:34 <zhouya> And I have a common on the network.yml file you gave me.
08:30:38 <Julien-zte_> #info zhouya has finished most the deployment on pod2
08:31:43 <Julien-zte_> one question zhouya, the daisy ip is "10.20.7.2" or "10.20.7.3"
08:31:54 <zhouya> 10.20.7.3
08:31:57 <Julien-zte_> I will update the info in securedlab today
08:32:11 <Julien-zte_> #action Julien update the daisyip from 10.20.7.2 to 10.20.7.3
08:32:23 <zhouya> I thought the 10.20.7.2 is used by fuel
08:32:44 <Julien-zte_> fuel and daisy only has one alive
08:32:57 <alexyang> the fuel vm has been destroyed
08:32:59 <Julien-zte_> daisy can also use 10.20.7.2
08:33:13 <alexyang> i think any ip is ok
08:33:18 <Julien-zte_> but it is a better choice
08:33:30 <zhouya> OK
08:33:30 <Julien-zte_> zhouya anything else
08:33:55 <Julien-zte_> #info virtual job has been added in Jenkins server.
08:34:12 <Julien-zte_> we would look and see the result
08:34:20 <zhouya> It seems alexyang has solve the daisy.xml can't start problem.
08:34:43 <zhouya> Another thing about the admin_openrc.sh file
08:35:26 <zhouya> When we deploy the all_in_one ,the file is in /etc/kolla/ dir
08:36:06 <zhouya> and I will modify daisy code to make admin_openrc.sh file generates into daisy node
08:36:43 <zhouya> Nothing from my side.
08:37:22 <Julien-zte_> thanks zhouya
08:37:42 <Julien-zte_> #info zhouya will submit a new patch to put adin_openrc.sh in daisy node
08:38:06 <Julien-zte_> I will trigger the virtual deployment for verification
08:38:16 <Julien-zte_> alexyang any other issues
08:38:35 <alexyang> zhouya, did you try deploy by jenkins script?
08:38:55 <zhouya> no
08:39:05 <zhouya> I just use deploy.sh
08:39:10 <Julien-zte_> zhouya, can you send an email or have discuss with zhijiang, more time in reivew and fast the merge progress
08:39:25 <zhouya> ok
08:39:47 <Julien-zte_> zhouya, in the later, we 'd use jenkins's script for deploy
08:39:47 <zhouya> I will send a email to him.
08:39:55 <Julien-zte_> hi huzhj
08:40:08 <zhouya> OK,I will change it to jenkins's script
08:40:12 <huzhj> hi Julien
08:40:22 <huzhj> sorry , busy with other issues
08:40:28 <Julien-zte_> we just discuss the progress of baremetal
08:40:31 <Julien-zte_> nearly done
08:40:46 <Julien-zte_> I think we can finish the first step by MS7
08:40:56 <Julien-zte_> and finish integration with functest
08:40:59 <huzhj> Greate. For the lf-build1 job slot problem, Aric has increaed slot no to 3
08:41:21 <Julien-zte_> I find it. but I think there is still some issue
08:41:34 <Julien-zte_> I don't have time for this today
08:41:39 <huzhj> #info For the lf-build1 job slot problem, Aric has increaed slot no to 3
08:42:23 <huzhj> Thanks Julien-zte_, I have seen the daily jobs have been merged
08:42:25 <Julien-zte_> #info the remain is 'zte-pod' is offlinine
08:42:34 <Julien-zte_> which blocks the remain issues
08:42:53 <huzhj> network problem ?:)
08:43:03 <Julien-zte_> #info I clean tens of queued daisy-deploy-daily-master   jobs
08:43:17 <Julien-zte_> huzhj no, it is reserved for zhouya's test
08:43:31 <Julien-zte_> when it is finished, it will be online
08:43:54 <huzhj> Got it
08:43:59 <Julien-zte_> it's easy and it only takes seconds to connect to the Jenkins server
08:44:36 <Julien-zte_> we just talk about, can you put some time in review and fast the merge procedure
08:45:11 <huzhj> Sure. Sorry for the delay
08:45:27 <Julien-zte_> #info I add a new group in opnfv: daisy-reviewers
08:45:46 <Julien-zte_> I think everyone of you are in the group. next time you can add reviewers using this group
08:45:48 <zhouya> great
08:46:11 <Julien-zte_> #info jenkins-zte has been approved
08:46:25 <Julien-zte_> #info daisy will use jenkins-zte account for ci and deloyment
08:46:46 <Julien-zte_> do you update the public key in the gerrit?
08:46:56 <Julien-zte_> if no, please
08:47:50 <Julien-zte_> zhongjun has submitted his patch for daisy
08:47:57 <Julien-zte_> welcome zhongjun to join daisy
08:48:08 <huzhj> Welcome, zhongjun
08:48:18 <zhouya> welcome.zhongjun
08:48:42 <huzhj> #action update the public key in the gerrit
08:49:12 <huzhj> Where can I get the public key?
08:49:38 <Julien-zte_> the member working in integration rely on your patch for adding the openrc in daisy server
08:49:50 <Julien-zte_> it ssh public key, public not private:)
08:49:54 <alexyang> https://gerrit.opnfv.org/gerrit/#/settings/ssh-keys
08:50:25 <Julien-zte_> I have sent an email, please have a check
08:50:59 <huzhj> OK, I will check my mail later
08:51:14 <zhongjun> think you!
08:51:39 <Julien-zte_> #info zhijiang, currently, we don't have test codes in repo
08:51:59 <Julien-zte_> I think we 'd better add test codes after finishing the initial steps
08:52:20 <Julien-zte_> I premote to use tox+pytest, what's your opinion
08:52:21 <zhouya> #agree
08:52:55 <huzhj> Julien-zte_ test code need tox, yes, thus, need a complete python project to be setup
08:53:04 <Julien-zte_> there are several testframeworks for choice
08:53:14 <huzhj> Just like what we did for escalator
08:53:20 <Julien-zte_> tox can support bash together
08:53:41 <huzhj> We have already used tox in upstream daisy
08:53:50 <huzhj> so no tech problem
08:53:59 <Julien-zte_> we have used the pytest in qtip which save lots of work comparing to other tools
08:54:09 <huzhj> Great
08:54:28 <Julien-zte_> we can do some training for daisy team
08:54:37 <huzhj> any docs/PS/url are welcome:)
08:54:53 <huzhj> That will be a greate help
08:55:01 <Julien-zte_> #action Julien provide docs/url about pytest
08:55:14 <alexyang> http://docs.pytest.org/en/latest/
08:55:20 <Julien-zte_> what's used in upstream?
08:55:24 <huzhj> Thanks alexyang
08:55:28 <Julien-zte_> testr , nosetest or ?
08:55:51 <huzhj> both of them.  testr for unit test.   nosetest for tempest
08:56:04 <Julien-zte_> OK, understood
08:56:24 <Julien-zte_> compare with unit test, we can save 80% code lines
08:56:35 <Julien-zte_> impressive
08:56:56 <huzhj> awesome
08:57:32 <Julien-zte_> Ok, no other issue from me
08:57:48 <Julien-zte_> alexyng, anything else
08:57:54 <alexyang> no more
08:58:03 <Julien-zte_> zhongjun anything to ask ?
08:58:17 <zhongjun> no more
08:58:20 <huzhj> Feel free to discuss
08:58:29 <huzhj> Or send email
08:58:36 <Julien-zte_> thanks alexyang for present the meeting
08:58:50 <Julien-zte_> great work, this week
08:58:53 <huzhj> Thank you alexyang
08:59:27 <huzhj> If no other issues, then let's wrap this up
08:59:33 <Julien-zte_> thanks team! you're awesome
08:59:43 <huzhj> Have a good weekend guys!
08:59:47 <alexyang> ok, let's end the meeting
08:59:59 <Julien-zte_> ok
09:00:01 <alexyang> #endmeeting