08:00:26 <huzhj> #startmeeting daisycloud
08:00:27 <openstack> Meeting started Fri Mar  3 08:00:26 2017 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:30 <openstack> The meeting name has been set to 'daisycloud'
08:00:37 <huzhj> #topic Roll Call
08:00:50 <huzhj> #info Zhijiang
08:05:25 <huzhj> #topic OPNFV: BM/BM Deployment & Functest Integration
08:05:59 <huzhj> #undo
08:06:00 <openstack> Removing item from minutes: #topic OPNFV: BM/BM Deployment & Functest Integration
08:06:06 <huzhj> #topic OPNFV: VM/BM Deployment & Functest Integration
08:07:01 <huzhj> Let's wait Ya , he is coming
08:07:20 <kongwei> OK
08:07:20 <huzhj> Hi kongwei
08:07:26 <kongwei> hi
08:07:38 <huzhj> Next topic is about daisy support escalator
08:07:49 <kongwei> yes
08:07:58 <huzhj> I only have two topic today
08:08:08 <huzhj> feel free to add AoB
08:08:18 <huzhj> Hi zhouya
08:08:20 <kongwei> good
08:08:29 <kongwei> hi zhouya
08:08:33 <zhouya> #info zhouya
08:08:34 <zhouya> hi
08:08:43 <huzhj> Any updates of this topic
08:08:47 <kongwei> #info kongwei
08:09:06 <alexyang> #info alexyang
08:09:13 <huzhj> Can you see the current topic title over your IRC client?
08:09:19 <huzhj> Hi alexyang
08:09:47 <huzhj> anyway , let me retype it , OPNFV: BM/BM Deployment & Functest Integration
08:09:47 <alexyang> hi
08:09:49 <zhouya> hi alexyang
08:10:05 <huzhj> opps, OPNFV: VM/BM Deployment & Functest Integration
08:10:16 <zhouya> Oh,I am  testing the BM Deployment
08:10:50 <zhouya> And now I am deploying the openstack
08:11:15 <huzhj> do we have any problem , seems kolla precheck have problem?
08:11:16 <zhouya> Seems ok after I change the globals.yml
08:11:31 <huzhj> Great, what is the PS?
08:11:41 <huzhj> can you provide the URL?
08:11:42 <zhouya> I think I have solve the problem
08:11:52 <huzhj> Greate Job:)!
08:12:10 <huzhj> Did you use the tagged version?
08:12:16 <zhouya> The problem we met is we have VLan
08:12:20 <huzhj> or the latest version from git?
08:12:27 <huzhj> well
08:12:40 <zhouya> no ,I just used the opnfv-2017-02-22_06-58-35.bin
08:13:00 <huzhj> OK, nearly the same
08:13:19 <huzhj> nearly the same as the tagged version
08:13:25 <zhouya> In the globals.yml file,we use the interface without .vlanid
08:13:29 <zhouya> so we can
08:13:40 <zhouya> so we can't get the vlan of interface
08:14:13 <zhouya> But after I change the interface storage_interface: ens12f1
08:14:18 <huzhj> So this is our config error?
08:14:31 <zhouya> to storage_interface: ens12f1.172, it seems ok of kolla prechecks
08:14:39 <zhouya> Yes ,It is our config error
08:14:51 <alexyang> where can find the globals.yml?
08:14:53 <huzhj> Good
08:15:03 <huzhj> precheck sometime over tested
08:15:20 <zhouya> cd /etc/kolla
08:15:26 <alexyang> ok
08:15:29 <zhouya> It is the config of kolla
08:15:56 <zhouya> and we just use the interface,so the prechecks process can't find the ip on one interface with vlan
08:16:05 <zhouya> we should add .vlanid behind
08:16:54 <huzhj> when you said so the prechecks process can't find the ip on one interface with vlan, did you really mean "so the prechecks process can't find the ip on one interface withOUT vlan" ?
08:17:30 <zhouya> yes
08:17:33 <huzhj> OK
08:18:27 <zhouya> we do not get the mistake when we deploy the openstack with virtual deploy. because we use only one interface,and the interface has ip on it
08:18:30 <zhouya> Kolla
08:18:55 <zhouya> kolla needs we have ip on each interface except the external interface.
08:19:43 <zhouya> So,I think we should change our code of daisy to have this change in generate the kolla config file /etc/kolla/globals.yml
08:21:11 <huzhj> how about just pass the correct vlan virtual interface such as eth0.100 to daisy? i think there is no need to change /etc/kolla/globals.yml  generator
08:22:16 <huzhj> Or you mean our  /etc/kolla/globals.yml  generator  can not accept vlan virtual interface such as eth0.100 currently ?
08:23:26 <zhouya> yes
08:23:48 <huzhj> and alexyang, any thing related from you side? Did you got the tagged version of daisy and did it work correctly for you:)?
08:24:33 <alexyang> virtual deploy failed yesterday
08:24:39 <alexyang> but success today
08:24:40 <huzhj> zhouya: OK, i see, let's create a PS to illustrate your thought
08:25:00 <alexyang> it seems not very stable
08:25:04 <huzhj> intermittent problem.......
08:25:28 <huzhj> did you collected any log?
08:25:58 <alexyang> i have send email, zhouya have debug it ?
08:26:09 <zhouya> the management ip hasn't assigned
08:26:48 <zhouya> Seems it is not happen everytime
08:26:58 <huzhj> zhouya, the tagged version DID include the PS about prevent losing IP, that is https://review.openstack.org/#/c/423738/
08:27:06 <zhouya> But I see the commit of zhanghui has merged in daisycloud-core
08:27:11 <huzhj> Yes
08:27:30 <zhouya> absolutely
08:28:04 <huzhj> Let's dive into this problem more deeply offline
08:28:14 <huzhj> Time for the next topic
08:28:28 <huzhj> OK?
08:28:30 <zhouya> ok,I will trace this problem
08:28:39 <zhouya> ok
08:28:41 <huzhj> Thanks
08:29:02 <huzhj> #topic OPNFV: Escalator Support
08:29:04 <Julien-zte> hi
08:29:11 <zhouya> hi julien
08:29:13 <huzhj> hi Julien-zte
08:29:15 <Julien-zte> currently docker service is not stable enough
08:29:18 <Julien-zte> #info Julien
08:29:34 <Julien-zte> registry-1.docker.io usually failed
08:29:36 <huzhj> docker service to the daisy build?
08:29:47 <Julien-zte> I don't know it is affected by amazon S3
08:29:55 <huzhj> Got it
08:29:59 <Julien-zte> integration with functest
08:30:11 <Julien-zte> diasy has trigger the integration job
08:30:19 <Julien-zte> after deployment finished
08:30:39 <Julien-zte> I'm considering setting up a docker cache service in our lab
08:30:49 <Julien-zte> I'm investigating the https issue
08:31:07 <Julien-zte> if it can be resolved, the docker registry service can be easy replaced
08:32:18 <huzhj> Julien-zte , so you mean the docker service unstable problem obstruced our integration  to functest?
08:32:32 <Julien-zte> yes, actually it is
08:32:50 <Julien-zte> we can not pull the image correctly
08:33:04 <huzhj> I see, functest test suit folded in container.
08:33:24 <huzhj> #info the docker service unstable problem obstruced our integration  to functest?
08:33:30 <huzhj> #undo
08:33:30 <openstack> Removing item from minutes: #info the docker service unstable problem obstruced our integration  to functest?
08:33:34 <huzhj> #info the docker service unstable problem obstruced our integration  to functest
08:35:14 <huzhj> Julien-zte
08:35:14 <huzhj> Julien-zte thanks for the information, can we go on for this topic?
08:35:21 <huzhj> current topic
08:36:01 <huzhj> Escalator Support, I think kongwei has a quite a bit of info to share
08:36:03 <Julien-zte> yes
08:36:10 <huzhj> Thanks
08:36:13 <Julien-zte> yes please
08:36:28 <Julien-zte> is kongwei online
08:36:35 <huzhj> Hi kongwei , are you still there?
08:36:41 <kongwei> yes
08:37:17 <kongwei> we have two question need to be discuss today
08:38:08 <kongwei> the first is how to get version info from kolla
08:38:35 <kongwei> zhouya said it can be merged
08:38:48 <kongwei> hi zhouya
08:38:52 <zhouya> yes
08:38:59 <Julien-zte> I don't get what you means? what version?
08:39:08 <Julien-zte> openstack version of kolla?
08:39:15 <zhouya> the version of openstack
08:39:17 <Julien-zte> can we use branch?
08:39:20 <zhouya> yes
08:39:57 <huzhj> Julien-zte what branch? openstack branch like newton,mitaka?
08:40:00 <zhouya> I think zeyu knows this well
08:40:08 <Julien-zte> yes, I mean the branch
08:40:21 <zhuzeyu> hi
08:40:26 <kongwei> the version of openstack
08:40:27 <zhouya> hi zeyu
08:40:31 <kongwei> what tome can you finished it? zhouya
08:40:32 <huzhj> Currently we only support using kolla to deploy newton
08:40:39 <huzhj> zeyu is not on line
08:41:12 <zhouya> we can get the version of openstack from kolla
08:41:26 <kongwei> we talk about it yesterday
08:41:38 <Julien-zte> for escalator I think we can fixed to use newton for now
08:41:41 <zhuzeyu> kolla can get the version of openstack componments
08:41:44 <kongwei> zhouya said it is his job
08:41:44 <Julien-zte> is it ok? kongwei
08:42:00 <zhouya> yes
08:42:34 <Julien-zte> zhouya when will you implement kongwei 's requirement
08:42:45 <Julien-zte> in Danube?
08:42:47 <kongwei> Julien-zte: if we only use branch name, we can not test the upgrade function
08:42:54 <zhouya> we can use kolla to get the version of openstack
08:42:59 <zhouya> zeyu will show the code
08:43:19 <Julien-zte> I think daisy has its own version flag
08:43:28 <kongwei> yes
08:43:35 <zhouya> yes ,daisy has own version flage
08:43:53 <huzhj> actually, we are using kolla images version flag. such as 3.0.1 3.0.2
08:44:04 <huzhj> and kolla support upgrade from 3.0.1 to 3.0.2
08:44:10 <huzhj> 3 means newton
08:44:19 <zhouya> Danube will be okjulien-zte
08:44:42 <kongwei> yes huzhj
08:44:53 <zhouya> and we can implement this requirement by Danube of escalator
08:45:08 <Julien-zte> the upgrade work-items shall be excuted by installer itself or by escalator?
08:45:26 <kongwei> by installer
08:45:27 <Julien-zte> the first release code frozen line is by March 10th, zhouya
08:45:54 <huzhj> Julien-zte, yes, I got the frozen line notice from David
08:45:58 <zhouya> oops,Then the time is too tense.
08:46:13 <huzhj> I will create a branch Danube before that date
08:46:20 <Julien-zte> the lucky things are : there are danube 2.0 and 3.0
08:46:49 <Julien-zte> shall we can finish this by the deadline of 2.0?
08:47:08 <Julien-zte> maybe a month after 1.0
08:47:59 <zhouya> cd /kolla/tools/version-check.py
08:48:18 <zhouya> we can use kolla to get the version of each container
08:48:25 <zhouya> by use python version-check.py
08:48:54 <Julien-zte> #info escalator can use kolla 'version-check.py' to get the version of each container
08:48:54 <zhouya> so the problem is what we need to get ,the version of openstack or the version of each container
08:49:35 <kongwei> no
08:50:19 <huzhj> IMHO, the granularity of  version of openstack or the version of each container is too  fine.
08:50:37 <kongwei> we need the version of the openstack that cluster is running
08:50:37 <huzhj> Sorry  IMHO, the granularity of  version of each container is too  fine.
08:50:47 <huzhj> Agree, kongwei
08:50:47 <zhouya> ok ,I see
08:51:11 <kongwei> such as the version flag
08:51:13 <zhouya> then we can get the version of opensatck by danube2.0
08:51:27 <huzhj> Good
08:51:43 <zhouya> and the version is 3.0.3
08:51:49 <zhouya> or 3.0.2
08:52:02 <kongwei> zhouya: yes
08:52:05 <zhouya> right? kongwe
08:52:11 <zhouya> ok,I see
08:52:18 <huzhj> Daisy is just like a version manager and GUI for Kolla
08:52:30 <kongwei> yes
08:52:31 <Julien-zte> #info escalator can get the openstack version in danube 2.0
08:52:45 <zhouya> When I finished the BM deploy of daisy ,I will commit the code to escalator.
08:52:52 <Julien-zte> my question is that the api between installer and escalator have been defined yet?
08:53:10 <Julien-zte> thanks zhouya, good work
08:54:49 <Julien-zte> shall be go to next question, kongwei
08:54:58 <zhouya> ok from my side
08:54:59 <kongwei> yes
08:55:14 <kongwei> the api were defined.
08:56:26 <Julien-zte> what's the next question?
08:56:35 <kongwei> next topic:changes on gerrit
08:56:50 <kongwei> sunjing are you here?
08:57:18 <kongwei> the change 27535 was blocked
08:57:25 <huzhj> I am afraid sunjing is not here
08:57:35 <kongwei> oh
08:58:27 <Julien-zte> 27535? are you sure?
08:58:28 <huzhj> https://gerrit.opnfv.org/gerrit/#/c/27535/ ?
08:58:48 <Julien-zte> it is from dovetail?
08:58:56 <Julien-zte> what's the relationship with escalator?
08:59:53 <kongwei> huzhj,the jira 34 was blocked too
09:00:26 <kongwei> these are jobs of escalator
09:00:35 <Julien-zte> all the patchset in escalator have been dealed with
09:00:40 <Julien-zte> can you specifiy which job?
09:01:08 <Julien-zte> 27535, I think it is not relevant with escalator
09:01:32 <huzhj> kongwei, OK, if there is any job that were blocked, please let me know
09:01:47 <huzhj> I will try to find out why
09:01:52 <kongwei> it is escalator's change
09:02:06 <kongwei> Ok
09:02:29 <Julien-zte> #link https://gerrit.opnfv.org/gerrit/#/c/27535/
09:02:36 <Julien-zte> kongwei, have a look at this link
09:02:43 <kongwei> Yes
09:03:08 <Julien-zte> I find nothing in patch relevant
09:03:55 <kongwei> The ci failure
09:04:12 <alexyang> https://gerrit.opnfv.org/gerrit/#/c/27353/
09:04:14 <kongwei> 27353
09:04:18 <huzhj> kongwei, can you please double check the PS number 27535 is right?
09:04:23 <huzhj> OK
09:04:35 <kongwei> Sorry
09:05:16 <kongwei> Huh just
09:05:17 <Julien-zte> oh, it's the lint issue
09:05:23 <Julien-zte> I think it is easy fixed
09:06:00 <kongwei> Yes. I think sunjing would resolve it
09:06:35 <huzhj> OK,
09:06:43 <kongwei> Huzhj I have nothing else to talk about
09:06:50 <kongwei> Thank you
09:06:50 <Julien-zte> I find a CI issue
09:06:59 <huzhj> #action huzhj to ask sunjing for help to make 27353 move forward
09:07:08 <Julien-zte> no docker file build from escalator
09:07:09 <Julien-zte> I will check the build job
09:07:18 <Julien-zte> no docker image build and push
09:07:26 <huzhj> Thanks Julien-zte
09:07:57 <huzhj> #action Julien-zte will try to check the docker build job  of escalator
09:08:00 <Julien-zte> kongwei, shall I add a new tag in build.opnv.org for escalator
09:08:47 <huzhj> Julien-zte, it seems only the PTL has the tagging permission
09:09:08 <Julien-zte> not tag the version
09:09:15 <Julien-zte> add new "web-tag" for converging escalator's jobs
09:09:17 <kongwei> What is the tag's effect
09:09:20 <Julien-zte> easy to view and check
09:09:26 <Julien-zte> just like daisy
09:09:37 <kongwei> Oh, yes. Thank you
09:11:14 <huzhj> OK, shall we wrap this up? timed out...
09:11:22 <zhouya> ok
09:11:38 <kongwei> Ok
09:12:15 <huzhj> Thanks everyone, thanks for the greate jobs, and have a good weekend!
09:12:29 <huzhj> #endmeeting