07:58:12 <huzhj> #startmeeting daisycloud
07:58:12 <openstack> Meeting started Fri Mar 24 07:58:12 2017 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:58:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:58:15 <openstack> The meeting name has been set to 'daisycloud'
07:58:47 <huzhj> #topic roll call
07:59:22 <zhouya> #info zhouya
07:59:43 <huzhj> #info Zhijiang
08:02:22 <huzhj> (huzhj) Iam on my cell phone, my desktop internet access right has been expired... So I will be slow for todays meeting...
08:03:17 <huzhj> #topic opnfv:vn/bm  deployment and functest integration
08:04:24 <huzhj> Hi zhouya  any update about this topic?
08:05:06 <zhouya> I was check the host and pxe update interface problem
08:05:13 <huzhj> Please add info command if needed
08:05:46 <zhouya> the config file is wrong for our deploy in zte lab
08:06:18 <zhouya> I have sent a E-mail to julien to modify this
08:06:53 <huzhj> Got it .  why he still use the old one?
08:07:27 <zhouya> After change the config file of deploy.yml and network.yml , it Will be OK
08:08:21 <zhouya> I think maybe julien forgot to change the files.
08:08:53 <huzhj> OK
08:09:46 <zhouya> And I think senera is working on functest integration
08:11:35 <huzhj> Let's speed up a little bit on BM deployment progress. I think Ceph Cinder support is less imortant than this.
08:13:07 <huzhj> When it comes to Ceph Cinder support. Do we have the spec done?
08:13:10 <zhouya> OK, I think first of all we should guarantee the right deployment of BM deploy.
08:13:30 <huzhj> Yes,
08:13:40 <huzhj> Hi Alex
08:13:40 <zhouya> Yes
08:13:58 <alexyang> Hi All
08:14:06 <zhouya> Hi Alex
08:14:55 <zhouya> I am coding on ceph cinder support
08:15:08 <huzhj> @alexyang I am thinking of nominate you to be core reviewer to speed up patch merge process
08:15:31 <zhouya> #agree
08:15:47 <huzhj> Are you willing to be core memver of Daisy?: D
08:16:09 <alexyang> yes, thank you very much
08:16:16 <huzhj> Sorry for my buggy typing. I am on my cell phone
08:16:55 <huzhj> Thanks alex and I will send a patch to fo it in gerrit
08:18:01 <huzhj> #action huzhj will send a ps to nominating alex as core member
08:18:10 <huzhj> Hi zhongjun
08:18:25 <zhongjun> HI zhijiang
08:18:28 <Julien-zte> #info Julien
08:18:35 <SerenaFeng> #info SerenaFeng
08:18:38 <alexyang> #info alexyang
08:18:52 <SerenaFeng> #info SerenaFeng
08:18:57 <huzhj> Hi julien and serena
08:19:00 <Julien-zte> what's the topic
08:19:07 <Julien-zte> hi @huzhij
08:19:14 <SerenaFeng> hi
08:19:26 <zhouya> opnfv:vn/bm  deployment and functest integration (Meeting topic: daisycloud)
08:19:38 <huzhj> Topic is vm bm depliyment and functest integration
08:19:42 <Julien-zte> hi SerenaFeng, what about current status of functest integration
08:19:43 <SerenaFeng> the integration is almost done
08:20:01 <SerenaFeng> but there are some problems
08:20:10 <Julien-zte> baremetal will tested after we can finish the baremetal deployment
08:20:13 <huzhj> Great job Serena , thanks
08:20:13 <SerenaFeng> 1) cinder is not supported
08:20:17 <SerenaFeng> so rally cannot be executed
08:20:39 <SerenaFeng> and about adding a new field network_name in network.yaml
08:20:39 <Julien-zte> #info huzhj, what about current cinder status
08:21:12 <huzhj> Cinder is on its way, and will be speed up if bn deployment is stable. Zhouya is working in that
08:21:12 <Julien-zte> #info network_name in network.yaml has been added in securedlab, and someting to be done in upstream
08:21:12 <SerenaFeng> I will submit a patch in daisy OpenStack to support it
08:21:48 <Julien-zte> #info Zhouya is working on Cinder, and it will be provided after baremetal deployment is stable
08:22:04 <zhouya> I am coding on cinder support, and I think I need environment to debug the code
08:22:11 <huzhj> Thanks for contributing directly to upstream "
08:22:16 <Julien-zte> #info SerenaFeng will submit a patch in daisy OpenStack to support it
08:22:42 <Julien-zte> Alex has enabled POD2 online
08:23:05 <Julien-zte> From todays' Job status, virtual deployment is still no stable
08:23:08 <zhouya> Great
08:23:11 <SerenaFeng> and about the virtual deployment
08:23:13 <Julien-zte> block for hours
08:23:19 <SerenaFeng> now it is a all-in-one mode
08:23:32 <Julien-zte> last time, I suggest to reboot it when no response after 3-5 minutes
08:23:42 <SerenaFeng> in the community, it is actually 4-5 nodes
08:24:00 <Julien-zte> Shall we deploy a virtual pod with 3-5 nodes?
08:24:14 <Julien-zte> we can use zte-virtual2 to test.
08:24:27 <zhouya> We should support multinode in virtual deployment as well
08:24:35 <SerenaFeng> if we want to support virtual-pod in the community, it should be deployed as the community does
08:24:36 <Julien-zte> huzhj, what's your opinion?
08:24:45 <huzhj> No tech problem
08:24:54 <huzhj> Agree
08:25:07 <zhouya> Agree
08:25:14 <huzhj> What is the priority
08:25:15 <Julien-zte> who can work for this?
08:25:23 <Julien-zte> after the baremetal
08:25:42 <Julien-zte> currently, all the installers are working through issues
08:26:16 <huzhj> I will try to ask luyao2 for doing this
08:26:22 <huzhj> Hi luyao2
08:26:25 <SerenaFeng> Julien-zte virtual will fail definitely,  before my upstream patch is submitted and merged :)
08:26:48 <huzhj> She is the expert at vm deployment:(
08:26:55 <huzhj> :)
08:27:06 <Julien-zte> it's failed only on integration with functest
08:27:11 <Julien-zte> currently, it deployed fialed
08:27:36 <Julien-zte> I don't think it is the same issue
08:27:58 <zhouya> Vm deployment or BM deployment?
08:28:13 <SerenaFeng> if the fail related to network_name?
08:28:18 <Julien-zte> vm deployment fail
08:28:23 <Julien-zte> SerenaFeng
08:28:24 <Julien-zte> no
08:28:25 <zhouya> Yes
08:28:26 <SerenaFeng> ok, then
08:29:12 <Julien-zte> any other new topics?
08:29:13 <huzhj> For multi node vm deploy @julien, what is the role of each node? Same as bm?
08:29:22 <Julien-zte> Agree
08:29:36 <zhouya> If you want to add network name in network.yml, I think, the update of cluster establish Will failed
08:29:38 <Julien-zte> just without ceph
08:29:52 <huzhj> Ok, next topic?
08:30:09 <Julien-zte> let's move on next topic
08:30:13 <SerenaFeng> one controller with mongo, the other three compute with cinder
08:30:36 <SerenaFeng> that's one of fuel deployment
08:30:42 <Julien-zte> for virtual pod, mongo is necessary?
08:30:56 <Julien-zte> ok, we can use as a reference
08:31:02 <huzhj> Yes
08:31:29 <huzhj> Let see if the kolla default config also match the requirement:-)
08:31:44 <SerenaFeng> zhouya, I will submit a patch to fix the update of cluster establish
08:32:01 <zhouya> OK, thank you
08:32:11 <huzhj> #topic version management
08:32:38 <huzhj> Luyao is working on this but se is not online
08:32:55 <huzhj> As I know it is almost done
08:33:14 <huzhj> Oh and sunjing is working on the UI
08:33:54 <Julien-zte> what's the version management?
08:34:02 <Julien-zte> multiple openstack version?
08:34:06 <huzhj> So after we support version management we can choose which version to deploy even upgrade the vim
08:34:12 <huzhj> Yes
08:34:27 <Julien-zte> great feature.
08:34:36 <huzhj> That is a requirement from Escalator also
08:35:10 <Julien-zte> #info Daisy will support multiple version and can choose which to use and upgrade.
08:35:37 <huzhj> Since we do not have Luyao online I eill follow the status offline with Yao
08:35:53 <Julien-zte> I'm interested in this whether we can demo in Beijin summit
08:36:41 <huzhj> I hope so
08:37:19 <Julien-zte> Can we discuss about OPNFV Beijin summit?
08:37:20 <huzhj> Also I want to demo aother feature . multicast version file distribution
08:37:36 <huzhj> Sure
08:37:41 <Julien-zte> what's the plan and CFP ?
08:37:58 <Julien-zte> what's the plan then?
08:38:02 <SerenaFeng> the deadline is 27th next Monday
08:38:05 <huzhj> No other topic today . so please go ahead
08:38:31 <SerenaFeng> do we have any proposal for CFP?
08:38:43 <SerenaFeng> daisy and escalator
08:38:46 <Julien-zte> I do hope Daisy can give a presentation and let the community know it can work.
08:39:02 <Julien-zte> even David postpone the release to E
08:39:13 <Julien-zte> and do some demos then
08:39:14 <huzhj> Cfp is still in scratch.kongwei asked me if I can add he as co speaker to talk about escalator . I agreed
08:39:22 <SerenaFeng> will we have a booth there?
08:39:37 <Julien-zte> of course SeneraFeng, I think
08:40:22 <huzhj> Julien do yo have any suggestion on faisys presentation
08:40:23 <SerenaFeng> will we demo daisy or escalator in the booth?
08:40:37 <Julien-zte> how many topics from Daisy?
08:40:45 <huzhj> One
08:40:58 <Julien-zte> what's the topic for daisy?
08:41:02 <huzhj> Upgrading
08:41:20 <huzhj> Using kolla and multicast engine
08:41:39 <Julien-zte> it is mainly for escalator, and I think we should focus on daisy itself in the first release.
08:41:41 <huzhj> To meet the smooth and fast upgrade requirement
08:41:43 <SerenaFeng> Upgrading is for escalator
08:42:13 <SerenaFeng> I think we should have a presentation for daisy only
08:42:14 <huzhj> Agree
08:42:33 <Julien-zte> upgrade is only a feature from daisy
08:42:38 <huzhj> Serena ,Agree
08:43:11 <Julien-zte> and maybe some discussions
08:43:38 <Julien-zte> OK, I'm glad that daisy will have a presentation in summit.
08:43:50 <Julien-zte> let's mov on next topic
08:44:13 <SerenaFeng> I think we should prepare at least one design summit and one OPNFV summit
08:44:27 <SerenaFeng> there are two kinds of summit in Beijing Summit
08:44:44 <SerenaFeng> summit -> session
08:45:17 <Julien-zte> thanks SerenaFeng, a good remind
08:45:20 <huzhj> i mainly focus on opnfv summit cauz it had more wide audience
08:45:42 <SerenaFeng> design summit mainly focus on what we have done
08:45:43 <Julien-zte> we'd prepare something in design summit
08:46:00 <Julien-zte> what we want to do instead of have done?
08:46:13 <SerenaFeng> and opnfv summit mainly focus on the big vision, roadmap
08:46:43 <Julien-zte> and demos in summit
08:46:48 <SerenaFeng> yes
08:46:53 <huzhj> IMHO the difference is about audience
08:47:23 <Julien-zte> yes
08:47:33 <Julien-zte> we can use neary the same presentation
08:48:00 <Julien-zte> that's ok for summit? anything else?
08:48:38 <SerenaFeng> just pay attention to the deadline
08:48:51 <SerenaFeng> 27th
08:49:06 <Julien-zte> got it
08:49:10 <huzhj> Err changed serena
08:49:24 <huzhj> Changr to 4 10
08:49:34 <SerenaFeng> proposal?
08:49:39 <huzhj> Yes
08:49:44 <huzhj> Cfp
08:50:02 <Julien-zte> can you cc us the email? we think it is 37 march
08:50:13 <huzhj> #topic multicast
08:50:13 <SerenaFeng> that's good new
08:50:15 <Julien-zte> can you cc us the email? we think it is 27 march
08:50:19 <huzhj> Sure
08:51:12 <huzhj> Have Sent a email to julien
08:51:38 <huzhj> I am working on multicast tool
08:51:53 <huzhj> It is my old job:)
08:52:16 <huzhj> Since TIPC
08:52:42 <huzhj> But this time I do not want to use TIP C for reasons
08:53:05 <huzhj> I will make an ether pad page to describe the spec
08:53:11 <Julien-zte> when will you submit it into gerrit?
08:53:19 <Julien-zte> ok
08:53:54 <huzhj> Julien it may not suit for opnfv cide repo i would like to make it another project
08:54:09 <huzhj> It will be written in C
08:54:24 <Julien-zte> in openstack?
08:54:36 <huzhj> No sure
08:54:46 <Julien-zte> I think any code is acceptable in OPNFV, in openstack , mainly in python and go
08:54:49 <huzhj> May be a new project on github
08:55:10 <huzhj> That is good news
08:55:20 <Julien-zte> zhuzhj, I received the CFP deadline extension email for I switch to gmail for the community emails
08:55:29 <huzhj> Then i will try submit to opnfv
08:56:14 <huzhj> Yes extended to 4 10
08:56:32 <Julien-zte> will you demo in the summit for the multicast feature?
08:56:55 <Julien-zte> #info CFP of Beijin Summit extended to 10th Apr.
08:57:08 <huzhj> Yes I think it can be done before summit
08:57:24 <Julien-zte> fantastic:)_
08:57:47 <SerenaFeng> great!
08:57:50 <Julien-zte> and I want to add another topic
08:57:59 <Julien-zte> #topic new committers
08:58:34 <huzhj> Yes julien i have just asked alex to be core before you came to meeting
08:58:45 <alexyang> :)
08:58:47 <Julien-zte> http://stackalytics.com/?metric=commits&project_type=opnfv-group&release=all&module=daisy
08:58:52 <Julien-zte> it is great!
08:58:52 <huzhj> And he was kinely accepted
08:59:03 <huzhj> Kindly
08:59:24 <Julien-zte> from the contribution list, I would premote Alex as a new committer for his continous contribution in daisy.
08:59:45 <Julien-zte> thanks huzhj, and Alex
08:59:55 <huzhj> Great job alex
09:00:03 <alexyang> thank you
09:00:24 <Julien-zte> another topic is test
09:00:38 <Julien-zte> SerenaFeng, can you add a test framework for daisy?
09:00:49 <SerenaFeng> about what?
09:00:50 <Julien-zte> huzhj, I think the shortage in daisy is test and CI jobs
09:01:24 <SerenaFeng> unittest?
09:01:32 <Julien-zte> yes , unitest
09:01:46 <Julien-zte> I suggest to use pytest for daisy
09:01:54 <Julien-zte> what's your opinion
09:02:02 <SerenaFeng> but lots of code is in bash
09:02:28 <Julien-zte> we can start from python.
09:02:32 <huzhj> I am not familiar with pytest. But I have no other choice currently
09:02:34 <SerenaFeng> it is maybe impossible to use pytest to unittest bash
09:02:42 <Julien-zte> I don't think test for these bash scripts
09:02:48 <SerenaFeng> we can start with pytest
09:02:58 <SerenaFeng> and refactor the exited code to python
09:03:02 <huzhj> Because the unittest frame work in upstream daisy is so big and iutdated
09:03:07 <SerenaFeng> bash is too ugly to manage a project
09:03:09 <Julien-zte> good work SerenaFeng
09:03:35 <Julien-zte> add the framework and alexyang can continue on this area.
09:03:42 <SerenaFeng> ok
09:04:08 <alexyang> ok
09:04:14 <SerenaFeng> #action SerenaFeng add a test framework
09:04:25 <Julien-zte> OK
09:04:31 <Julien-zte> that's all from my side
09:04:41 <SerenaFeng> huzhj pytest is great
09:04:44 <huzhj> Thanks Serena
09:04:48 <SerenaFeng> we don't need other options :)
09:05:06 <Julien-zte> SerenaFeng has done a great work in recently weeks in daisy!
09:05:32 <SerenaFeng> and you said will reward me with an apple :)
09:05:39 <huzhj> Yes ! Indeed
09:05:42 <Julien-zte> cc to huzhj:)
09:05:51 <Julien-zte> an real apple
09:06:34 <SerenaFeng> yes, with a bite flag
09:06:34 <Julien-zte> ok, that's all
09:06:49 <huzhj> :D
09:06:54 <huzhj> Thanks all
09:07:06 <huzhj> Let us wrap this uo
09:07:08 <huzhj> Up
09:07:23 <huzhj> #endmeeting