07:59:17 <huzhj> #startmeeting daisycloud
07:59:18 <openstack> Meeting started Fri Apr  7 07:59:17 2017 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:59:21 <openstack> The meeting name has been set to 'daisycloud'
07:59:28 <huzhj> #topic Roll Call
08:00:02 <huzhj> #info Zhijiang
08:00:57 <alexyang> #info alexyang
08:02:55 <huzhj> Let's wait other to come
08:04:17 <zhouya> #info zhouya
08:04:53 <sunjing> #sunjing
08:05:13 <huzhj> OK let's get started
08:05:23 <huzhj> #topic OPNFV: VM/BM Deployment & Functest Integration
08:06:39 <huzhj> sunjing please use #info sunjing  to ack the roll call, thanks
08:06:47 <luyao1> #info luyao
08:07:39 <sunjing> Sorry,i will use that next time.
08:08:01 <sunjing> #info sunjing
08:08:14 <huzhj> any update for this topic?
08:09:06 <zhouya> I am testing the mutinode deploy on virtual env
08:09:23 <zhouya> And just need some time to see the result
08:09:54 <huzhj> Great, so the config file for the multinode vm is done?
08:10:26 <zhouya> I just reference the bm deployment deploy.yml
08:10:42 <zhouya> And also launch 5 nodes.
08:11:09 <zhouya> 3 controller nodes and 2 computer nodes
08:12:30 <zhouya> maybe we can use much more nodes to deploy with if the storage of virtual env is enouth.
08:12:45 <huzhj> #info zhouya is testing the mutinode deploy on virtual env, uses bm deployment deploy.yml  as reference
08:13:20 <huzhj> why we need more?
08:13:31 <zhouya> just for test.
08:13:58 <huzhj> OK, for the further multicast test?
08:13:59 <zhouya> And maybe this can used on multicast test.
08:14:03 <zhouya> yes
08:14:08 <huzhj> Good
08:14:39 <huzhj> for CI, 5 is enough , also need to confirm with serna
08:14:43 <huzhj> serena
08:15:29 <zhouya> ok
08:16:22 <huzhj> anything else for this topic?
08:16:30 <zhouya> I will contact  serena and discuss how many nodes we need to test in virtual deploy.
08:16:36 <zhouya> nothing from my side.
08:16:43 <huzhj> #info zhouya will contact  serena and discuss how many nodes we need to test in virtual deploy
08:17:02 <huzhj> alexyang, anything else from your side?
08:18:02 <alexyang> nothing from my side now
08:18:52 <huzhj> alexyang, the core reviewer proposing sequence seems stuck. I can not contact with some of the core member, seems other projects also have the same problem, such as https://gerrit.opnfv.org/gerrit/#/c/29999/, I will try to remove some inactive Committers if nothing else we can do
08:19:23 <huzhj> let's move on
08:19:46 <huzhj> #topic Cinder/Ceph support
08:20:08 <huzhj> I saw we have a good progress on this topic, zhouya
08:20:45 <zhouya> the test result seems great.
08:21:48 <zhouya> And we can use the LVM or CEPH backend to boot vm from volume.
08:22:06 <huzhj> good, what about the live migration?
08:22:42 <zhouya> the live migration is ok with ceph backend just as yesterday do.
08:23:15 <zhouya> but the live migration seems not very well when we do not use ceph backend.
08:23:39 <huzhj> I know kongwei has dived more deeper in live migration
08:24:07 <zhouya> And I will still try on test the live migration without ceph backend and discuss this with kong.
08:24:18 <kongwei> :)
08:24:28 <huzhj> Great
08:24:52 <huzhj> #info we can use the LVM or CEPH backend to boot vm from volume,  live migration is ok with ceph backend.
08:24:57 <kongwei> We can discuss it later @zhouya
08:25:27 <zhouya> thank you for your help.
08:25:55 <huzhj> #info  ceph support can now fulfill the requirement of functest. but need further confirm with Serena
08:27:00 <zhouya> exactly, I will spare some time to learn from Serena of how to integrate this to functest with Serena.
08:28:05 <huzhj> #action zhouya will confirm with Serena to see if the current support of Cinder/Ceph can fulfill the requirement of functest
08:28:14 <huzhj> Great work!
08:28:22 <huzhj> anything else for this topic?
08:28:31 <zhouya> no
08:28:53 <huzhj> #topic Daisy as Kolla Image Version Manager
08:30:36 <huzhj> Hi, luyao1
08:31:03 <luyao2> hi
08:31:54 <huzhj> Hi luyao2, do we support fallback to a old version?
08:32:04 <huzhj> if the new version is failed
08:32:50 <luyao2> inner daisy maybe support it
08:34:10 <luyao2> for daisycloud,we support version manage to choose the version
08:34:31 <luyao2> if one version failed,we can choose another
08:34:49 <huzhj> Yes, but what is the differences between choose a old version  and fallback ?
08:35:29 <luyao2> sorry,I don‘t know,and need study for it
08:35:49 <huzhj> Good, let's find out
08:36:29 <huzhj> First need to know if Kolla support fallback
08:37:03 <luyao2> YES
08:37:13 <luyao2> I will
08:37:28 <luyao2> ask for meizhifang and inner daisy for it
08:38:09 <luyao2> kolla maybe just suppout upgrade?
08:38:52 <zhouya> also maybe we could make attempts to uninstall openstack without uninstall the os or delete all host and deploy from the beginning.
08:39:02 <huzhj> If fallback need to have the old and new version exist in the registry simultaneously, then we will do more work, since currently we have only one version in the registry server
08:40:10 <luyao2> yes
08:41:09 <huzhj> #info If fallback need to have the old and new version exist in the registry simultaneously, then we will do more work, since currently we have only one version in the registry server
08:41:11 <huzhj> OK,
08:41:21 <huzhj> anything else for this topic?
08:42:06 <luyao2> no,I will do understand fallback offline
08:42:09 <zhouya> no
08:42:58 <huzhj> fallback or rollback, correct me if I use a wrong word...
08:43:07 <huzhj> #topic Multicast Image Distribution
08:44:15 <huzhj> #info coding is done. usable, but have not do  integration into Daisy
08:44:20 <huzhj> #link https://gerrit.opnfv.org/gerrit/#/c/33093/
08:44:27 <luyao2> http://10.42.5.115/check_doc/97/163697/5/check/check-daisy-doc-publish/a8aac71/daisy/FeatureSpecification/VersionBack/versionback.md.html we can see it for help
08:44:54 <huzhj> luyao2, that is dead link for the Open Community
08:45:26 <luyao2> sorry
08:47:05 <zhouya> https://gerrit.opnfv.org/gerrit/#/c/33093/  so these code will wrap into a rpm package?
08:47:18 <huzhj> Yes, just
08:47:33 <huzhj> just run ./autoconf && ./configure && make rpm
08:47:50 <huzhj> then rpm will appear in x86_64 sub dir
08:48:45 <zhouya> and we just install this after daisy install?
08:49:13 <huzhj> Yes, Install on daisy server as well as all target hosts
08:50:27 <huzhj> OK, that is all for this topic
08:50:45 <huzhj> #topic AoB
08:58:09 <huzhj> OK, let's call it a meeting
08:58:34 <huzhj> Thanks all!
08:58:41 <huzhj> #endmeeting