08:00:10 <huzhj> #startmeeting daisycloud
08:00:10 <openstack> Meeting started Fri Jun 30 08:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:13 <openstack> The meeting name has been set to 'daisycloud'
08:00:24 <huzhj> #topic Roll call
08:00:32 <zhouya_> #info zhouya
08:00:36 <huzhj> #info Zhijiang
08:01:35 <huzhj> Today's topic bashing
08:01:38 <huzhj> 1.ODL L2/L3 Integration  2.Scenario in JJB 3.Documentation task 4.AoB
08:03:41 <huzhj> #topic ODL L2/L3 Integration
08:04:24 <huzhj> zhouya_ maybe we can start to test ODL L2/L3 intgetration from now on
08:04:57 <huzhj> #info ODL L2/L3 is ready in code
08:05:20 <zhouya_> yes, I have started the test of ODL L3
08:06:05 <huzhj> Great.
08:06:11 <zhouya_> And serena and AlexYang have work on the intergation on functest of odl
08:07:06 <huzhj> FIP shoud work properly
08:07:10 <zhouya_> Maybe later we can get the information from them.
08:07:37 <zhouya_> Yes,FIP can work properly on both bm env and vm env.
08:08:18 <huzhj> But currently I encountered a problem that after restart controller, and restart vm, the vm can not get IP from DHCP any more
08:08:47 <huzhj> Have already send this issue to ODL community but got no answer yet
08:09:44 <zhouya_> each time it will fail when restart vm?
08:10:08 <huzhj> not restart vm, restart controller
08:10:11 <zhouya_> Except ODL community can feedback soon.
08:10:19 <huzhj> Yes
08:10:37 <zhouya_> Expect ODL community can feedback soon.
08:10:41 <huzhj> but this issue seems do not prevent us from passing functest
08:11:18 <zhouya_> great
08:13:55 <huzhj> Anything else on this topic?
08:14:16 <zhouya_> no
08:14:25 <huzhj> #topic Scenario in JJB
08:15:13 <huzhj> There is a weird thing about this topic
08:15:22 <huzhj> If you look at #link https://build.opnfv.org/ci/job/daisy-os-nosdn-nofeature-noha-virtual-daily-master/
08:16:16 <huzhj> you can see that Scenario: ​os-odl_l3-nofeature-​ha is passed to this job
08:16:17 <zhouya_> Seems the ci env havn't run the  os-odl_l3-nofeature-noha scenario?
08:16:47 <huzhj> but this job is only for os-nosdn-nofeature-noha
08:17:51 <zhouya_> Is there some place we can change?https://build.opnfv.org/ci/job/daisy-os-nosdn-nofeature-noha-virtual-daily-master/239/
08:18:00 <huzhj> and this is the very first time we saw ​os-odl_l3 scenario running on this job
08:18:28 <alexyang> #info alexyang
08:18:55 <huzhj> Maybe caused by manuall operation?
08:19:00 <huzhj> Hi alexyang
08:19:03 <alexyang> yes
08:19:18 <alexyang> that job is triggered manually
08:19:28 <huzhj> :D
08:19:41 <zhouya_> hi alex
08:19:45 <alexyang> hi
08:20:07 <huzhj> no wonder
08:20:23 <zhouya_> https://build.opnfv.org/ci/job/daisy-os-nosdn-nofeature-noha-virtual-daily-master/239/parameters/
08:20:49 <zhouya_> the parameters have change the scenario to odl_l3
08:21:18 <alexyang> You can find "Started by user zhifeng.jiang" in the console log
08:21:36 <huzhj> Got it alexyang
08:22:22 <huzhj> anything else for odl scenario?
08:22:54 <alexyang> we will discuss with serena and julien about how to add another deployment job with odl scenario
08:23:15 <huzhj> Thanks alexyang
08:23:32 <huzhj> #action alexyang will discuss with serena and julien about how to add another deployment job with odl scenario
08:24:48 <huzhj> OK,  for HA related scenarios, which were failed before, I think we can give it another try after finishing ODL works
08:25:23 <zhouya_> agree
08:25:25 <huzhj> the HA problem may be caused by rally test in functest, just may be
08:26:27 <huzhj> So the solution is to split the keepalived heartbeat traffic out from API netplane
08:26:52 <huzhj> currently, Kolla does not have this ability
08:27:05 <huzhj> So maybe we can fire a BP to Kolla
08:27:58 <zhouya_> greate
08:28:10 <huzhj> anything else?
08:28:13 <zhouya_> But we have to test this before.
08:28:14 <zhouya_> no
08:28:24 <huzhj> yes
08:28:41 <huzhj> #topic Documentation task
08:29:29 <huzhj> I registered a Jira ticket about documentation work related to E release
08:29:35 <huzhj> #link https://jira.opnfv.org/browse/DAISY-36
08:30:31 <huzhj> All tasks that I know for a release is kept as a record in that jira ticket
08:31:18 <huzhj> So if I miss something, please help to supplement
08:31:38 <huzhj> #action
08:31:41 <huzhj> #undo
08:31:42 <openstack> Removing item from minutes: #action
08:32:04 <huzhj> #action I will take the documentation action mainly.
08:33:34 <huzhj> OK , I think that is all for today
08:33:38 <huzhj> #topic AoB
08:34:21 <zhouya_> As for the lost of  SDN_CONTROLLER_IP in admin_openrc
08:35:28 <huzhj> what is SDN_CONTROLLER_IP for?
08:35:42 <zhouya_> I think we should add some extra template in kolla-ansible code kolla-ansible/ansible/roles/common/templates/admin-openrc.sh.j2
08:36:03 <zhouya_> This is just for the functest of odl
08:36:20 <zhouya_> maybe can have another function?alexyang?
08:36:58 <alexyang> functest odl testcase need this
08:37:35 <huzhj> So the name "SDN_CONTROLLER_IP" is defined by functest project?
08:38:19 <huzhj> If that is the case, I think we'd better not add it to kolla-ansible/ansible/roles/common/templates/admin-openrc.sh.j2 zhouya_
08:38:33 <alexyang> yes, but functest get the openrc from the installer
08:38:48 <alexyang> and functest need acccess SDN_CONTROLLER_IP:8080
08:39:05 <huzhj> understand
08:39:40 <huzhj> maybe we can append it into admin-openrc after kolla post action
08:40:01 <zhouya_> agree
08:40:13 <zhouya_> and this work will be done by daisy?
08:40:22 <huzhj> and for the port, it maybe not 8080, i hope functest does not hardcode it
08:41:02 <alexyang> i can check with serena
08:42:18 <huzhj> zhouya_ can you share the global.yml so that we can see which port number is configured bu kolla?
08:42:36 <zhouya_> ok
08:43:06 <zhouya_> [root@daisy ~]# cat /etc/kolla/globals.yml  docker_namespace: kolla docker_registry: 10.20.11.2:4000 enable_ceph: 'yes' enable_cinder: 'yes' enable_opendaylight: 'yes' enable_opendaylight_l3: 'yes' enable_opendaylight_legacy_netvirt_conntrack: 'no' enable_opendaylight_qos: 'no' kolla_external_vip_interface: ens3 kolla_internal_vip_address: 10.20.11.11 network_interface: ens3 neutron_external_interface: ens8 neutron_plugi
08:43:42 <zhouya_> opendaylight_features: odl-mdsal-apidocs,odl-netvirt-openstack opendaylight_l3_service_plugin: odl-router_v2 opendaylight_leader_ip_address: 10.20.11.6 opendaylight_mechanism_driver: opendaylight_v2 opendaylight_restconf_port: '8087' openstack_release: 4.0.2 storage_interface: ens3 tunnel_interface: ens3
08:43:46 <zhouya_> 8087?
08:43:58 <huzhj> https://github.com/huzhijiang/kolla-ansible/blob/stable/ocata/etc/kolla/globals.yml#L125
08:43:58 <huzhj> Yes, knid of 8087
08:44:02 <huzhj> #link https://github.com/huzhijiang/kolla-ansible/blob/stable/ocata/etc/kolla/globals.yml#L125
08:45:00 <huzhj> This is for port mainly used for getting info out from ODL
08:45:05 <huzhj> for example: curl -u admin:admin http://10.20.11.10:8087/controller/nb/v2/neutron/networks
08:45:29 <huzhj> So I thinks this is the port number that functest may use
08:46:07 <huzhj> when it comes to 8080, this number is something like a web server's port.
08:46:12 <zhouya_> so the admin_openrc.sh will need to add this?
08:46:31 <huzhj> I dont think functest need to access ODL GUI
08:46:47 <huzhj> actually we do not install ODL GUI
08:48:26 <huzhj> zhouya_, add what?
08:48:33 <alexyang> you can refer opnfv/functest/functest/opnfv_tests/sdn/odl/odl.py
08:48:58 <zhouya_> add the SDN_CONTROLLER_IP
08:49:31 <alexyang> there are kwargs['odlwebport'] and kwargs['odlrestconfport']
08:49:42 <alexyang> hardcoded
08:50:55 <huzhj> alexyang, please see https://gerrit.opnfv.org/gerrit/gitweb?p=functest.git;a=blob;f=functest/opnfv_tests/sdn/odl/odl.py;h=67bf66e3484de40f1a7e07137f1ec18dddd64659;hb=refs/heads/master#l228
08:51:19 <huzhj> it is a hardcode, but depending on installer it choose
08:51:47 <alexyang> yes
08:52:57 <huzhj> well, seems functest really needs to access to ODL WEB portal?
08:53:58 <huzhj> please see https://gerrit.opnfv.org/gerrit/gitweb?p=functest.git;a=blob;f=functest/opnfv_tests/sdn/odl/odl.py;h=67bf66e3484de40f1a7e07137f1ec18dddd64659;hb=refs/heads/master#l238
08:54:15 <huzhj> can we just go through the "else" brunch?
08:54:21 <huzhj> branch?
08:54:57 <huzhj> in "else" branch, odlwebport is not used
08:55:25 <huzhj> oh sorry, it will use the default value kwargs['odlwebport'] = '8080'
08:55:34 <alexyang> yes
08:55:44 <alexyang> there is a default value
08:57:16 <huzhj> we use ODL from http://cbs.centos.org/repos/nfv7-opendaylight-6-candidate/x86_64/os/Packages/opendaylight-6.1.0-0.1.20170627rel1887.el7.noarch.rpm
08:57:44 <huzhj> still do not know if it include WEB GUI module or not
08:57:52 <huzhj> I will check it
08:58:08 <huzhj> OK, time is up, let's wrap this up.
08:58:15 <zhouya_> ok
08:58:18 <alexyang> ok
08:58:18 <huzhj> have a good weekend
08:58:22 <huzhj> bye
08:58:25 <zhouya_> same to you
08:58:27 <zhouya_> bye
08:58:29 <alexyang> bye
08:59:05 <huzhj> #endmeeting