13:02:49 <IgorYozhikov> #startmeeting deb_packaging
13:02:50 <openstack> Meeting started Mon Sep  5 13:02:49 2016 UTC and is due to finish in 60 minutes.  The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:54 <openstack> The meeting name has been set to 'deb_packaging'
13:03:04 <IgorYozhikov> #chair   IgorYozhikov zigo tlbr mordred
13:03:05 <openstack> Warning: Nick not in channel: mordred
13:03:06 <openstack> Current chairs: IgorYozhikov mordred tlbr zigo
13:03:38 <zigo> #link https://etherpad.openstack.org/p/openstack-deb-packaging
13:04:02 <zigo> #topic Stackalitycs status
13:04:22 <zigo> I have no news from Ilya about it.
13:04:31 <zigo> Though he knows already what needs to be done.
13:04:41 <zigo> It'd be nice to have it fixed before the elections for PTL start.
13:04:52 <tlbr> Did he provide any ETA ?
13:04:54 <zigo> He's in Moscow office, right?
13:05:00 <tlbr> No, Saratov.
13:05:01 <zigo> He said last week ...
13:05:04 <zigo> Ah...
13:05:10 <zigo> Daniil is where?
13:05:20 <zigo> Do we have anyone near him to beat him hard? :)
13:05:41 <tlbr> He doesn't feel well today. =\
13:05:51 <zigo> :/
13:05:53 <IgorYozhikov> zigo, Daniil on sick leave
13:05:55 <tlbr> mivanov is also away
13:06:15 <tlbr> So we don't anyone from there for now.
13:06:18 <zigo> So, the only way is to ping Ilya by email then.
13:06:28 <tlbr> No the only way.
13:06:28 <zigo> I'll do that.
13:06:32 <tlbr> Slack is ok.
13:06:56 <zigo> #action zigo to ping Ilya about Stackalytics needed update for packaging-deb
13:07:07 <zigo> Next topic?
13:07:21 <zigo> #topic project status
13:07:39 <zigo> We got almost all of Oslo packages built on infra.
13:07:56 <IgorYozhikov> zigo, it is awesome
13:08:28 <strigazi> where can these packages be found?
13:08:34 <zigo> oslo.cache and oslo.db are missing, because we need deb-alembic to be approved as new gerrit repo by the infra team, and we need tag push ACL for pushing new versions of dogpile.cache
13:08:49 <zigo> The rest should build ok (a few are remaining to trigger)
13:08:50 <IgorYozhikov> https://review.openstack.org/#/c/365477/1
13:09:05 <zigo> Yup, that's the one.
13:09:21 <zigo> #link https://review.openstack.org/365477
13:09:39 <tlbr> strigazi, http://mirror.regionone.osic-cloud1.openstack.org/debian-openstack/
13:09:44 <strigazi> thx
13:10:01 <zigo> strigazi: That's *one* of the URLs, there's in fact one repo per cloud that infra uses.
13:10:21 <strigazi> ok
13:10:22 <IgorYozhikov> zigo, are we going to push tags manually or through existing in ifra mechanism?
13:10:23 <zigo> You also shall remember that these are only for testing purposes, what counts at the end is what we upload to distros.
13:10:47 <zigo> IgorYozhikov: The thing that I am not clear with is if we can push non-signed upstream tags.
13:11:10 <zigo> IgorYozhikov: For example, alembic has rel_0_6_2, we need to push a 0.6.2 label on top.
13:11:17 <zigo> None of them are in gerrit.
13:11:29 <zigo> I'm not sure how this will work, but it's very important we clear that up.
13:11:40 <zigo> IgorYozhikov: Any suggestion / thoughts about it?
13:11:48 <IgorYozhikov> zigo, u r now about git-buildpackage structure right?
13:11:57 <zigo> Yup.
13:12:04 <zigo> Using git tag workflow.
13:12:06 <IgorYozhikov> i c, now it's clear
13:12:16 <zigo> No package uploaded to gerrit is using pristine tar.
13:12:33 <zigo> Probably, if we have the ACL, that's enough.
13:12:38 <zigo> I'd say, we'll see, no? :)
13:13:00 <IgorYozhikov> we could try
13:13:45 <zigo> Also, nearly all of the packages in deb-auto-backports are built too.
13:13:55 <zigo> We can just build the remaining as we need them.
13:14:31 <zigo> #topic canonical server team contribution
13:14:55 <zigo> It looks like it should be possible to have James Page change his mind, according to the discussion on the Alioth list.
13:14:56 <IgorYozhikov> wow, really, canonical will join us?
13:15:21 <zigo> Let me find the link of the thread...
13:15:38 <zigo> #link http://lists.alioth.debian.org/pipermail/openstack-devel/2016-September/018098.html
13:16:26 <zigo> We need to define a clear workflow for uploads in Debian, and explicit the fact that we consider infra deb repo as non-official testing only repo.
13:16:31 <IgorYozhikov> ah, I've seen this
13:16:35 <zigo> Meaning someone needs to write in the install-guide.
13:16:53 <zigo> So far, I've been the only contributor to the install-guide in the team.
13:16:59 <zigo> Anyone up for the task?
13:17:15 <zigo> It'd be really nice if we could show to the doc guys that I wont be the only contributor.
13:17:41 <zigo> They've been very vocal over the years that it shouldn't be the case.
13:17:50 <zigo> IgorYozhikov: tlbr: Do you have time for that?
13:18:01 <tlbr> I can do that, but we need to discuss it.
13:18:12 <tlbr> To have a clear vision.
13:18:32 <zigo> tlbr: What do you need to know?
13:18:36 <IgorYozhikov> zigo, good point, also we need to start with filling up of wiki space
13:19:05 <strigazi> zigo: you mean the debconf install-guide?
13:19:07 <tlbr> zigo, for example get commits from Alioth, not everyone uses Gerrit for it.
13:19:14 <zigo> #action tlbr to commit in the install-guide about the fact OpenStack infra repo are *not* for production use, but testing only.
13:19:27 <zigo> strigazi: Both the debconf one and the non-interactive one.
13:19:49 <zigo> tlbr: This has nothing to do with Alioth, as as far as I'm concerned, Alioth git repo will die.
13:20:35 <zigo> tlbr: It's about OpenStack infra debian repository vs distribution (ie: Debian Sid/testing & Ubuntu Xenial + UCA or the latest Ubuntu).
13:20:40 <tlbr> zigo, well, we still need ongoing changes from it.
13:20:40 <IgorYozhikov> zigo, let's tlbr prepare a draft
13:20:47 <IgorYozhikov> after that we will review it
13:20:52 <IgorYozhikov> and post on wiki
13:21:00 <zigo> tlbr: Feel free to start a WIP patch first...
13:21:26 <tlbr> zigo, okay
13:21:42 <tlbr> IgorYozhikov, ok, will do
13:21:46 <zigo> Do you guys see anything else that could ease Canonical's team to join our effort?
13:21:48 <IgorYozhikov> cool
13:22:02 <zigo> +decision
13:22:13 <tlbr> What do they actually need ?
13:22:48 <zigo> So far, James only expressed 2 concerns: 1/ that we should explicitely be vocal that users should use distribution repositories
13:22:53 <zigo> I very much agree with this
13:23:11 <zigo> and 2/ that we should have all the PKG OpenStack team to agree on the move to Gerrit
13:23:23 <zigo> I really think both are workable.
13:23:35 <tlbr> I don't see any blockers.
13:23:37 <zigo> For 2/, I believe it's already the case that everyone agrees.
13:23:50 <IgorYozhikov> yep
13:24:02 <zigo> But maybe there are more things we could do to make them comfortable?
13:24:07 <IgorYozhikov> that was initially decided
13:24:11 <strigazi> I think 2 will increase contributions from projects
13:24:12 <zigo> If you have any idea, please shoot ...
13:24:36 <zigo> strigazi: That's indeed my hope as well.
13:24:37 <tlbr> Provide them with documentation if required.
13:24:55 <zigo> Shall we set the topic to building contributor's guide? :)
13:24:56 <IgorYozhikov> zigo, without any input from them - we can only guess
13:25:08 <zigo> #topic documenting contribution to packaging-deb
13:25:10 <tlbr> I guess so :)
13:25:10 <IgorYozhikov> agree
13:25:24 <zigo> I'll stop typing, IgorYozhikov, you have the con ... :P
13:25:42 <IgorYozhikov> zigo, ok
13:26:22 <IgorYozhikov> I suppose to prepare a contributions guide and post it here - https://wiki.openstack.org/wiki/DEB-packaging
13:26:55 <IgorYozhikov> I believe that this is a good place to store it
13:27:14 <zigo> What content shall we set there?
13:27:15 <IgorYozhikov> I'll prepare initial page for it
13:27:28 <zigo> Things are too obvious for me, I don't think I'd be the good person to write in there.
13:27:45 <zigo> Though ideas could be taken from: http://openstack.alioth.debian.org/
13:27:46 <IgorYozhikov> I think, that at 1st - how to update already exiting projects
13:27:47 <zigo> #link http://openstack.alioth.debian.org/
13:28:13 <tlbr> I don't think that is very obvious that users should have enough rights to push merge commits :)
13:28:19 <IgorYozhikov> 2nd - style
13:28:28 <IgorYozhikov> with examples
13:28:45 <zigo> tlbr: I agree, we should document the fact that only packaging core group has this right.
13:29:04 <IgorYozhikov> ie - how should resulting package specification looks like
13:29:17 <tlbr> zigo, at leat we may specify that it could be changed in future.
13:29:23 <tlbr> *least
13:29:55 <zigo> It should be all but a guide on how to do actual packaging. There's enough docs about that in Debian. We could point to existing packages already in production within the packaging-deb project, as well as the packaging-tutorial package in Debian, if contributors need to know.
13:30:34 <zigo> Maybe we should also explain what the git-buildpackage tag based workflow is, no?
13:30:49 <zigo> That page here http://openstack.alioth.debian.org/ has such details.
13:30:54 <IgorYozhikov> so future doc need to be filled up with links to already existing documentation
13:31:00 <zigo> But it's outdated, and should be reviewed.
13:31:07 <zigo> Yup.
13:31:12 <tlbr> Just specify that we use git-buildpackage, it should be enough.
13:31:51 <zigo> tlbr: And the fact we generate tarballs out of upstream git tags too (ie: we don't use pristine-tar).
13:32:04 <tlbr> zigo, yeap, good idea
13:32:16 <zigo> IgorYozhikov: You're up for the task, right?
13:32:28 <IgorYozhikov> I can try
13:33:11 <zigo> #action IgorYozhikov to write contributor guide, explaining the git-buildpackage tag based workflow, how pushing tags & merge commit work (ie: only from core group), plus links to existing Debian packaging docs
13:33:12 <IgorYozhikov> zigo, assign an AI on me
13:33:16 <IgorYozhikov> ah, ok
13:33:41 <zigo> Next item?
13:33:45 <strigazi> IgorYozhikov If you need feedback from a new contributor count me in
13:34:08 <IgorYozhikov> strigazi, thanx
13:34:08 <zigo> strigazi: Nice, you're very much welcome to help!
13:34:28 <zigo> #topic todo list for next week
13:34:51 <zigo> So, remaining to do before we build services, is building all the python*client
13:35:12 <IgorYozhikov> agree here, same we are going to do in downstream
13:35:19 <zigo> I attempted building python-keystoneclient, and it needs tempest, which is currently stuck with a failed download
13:35:32 <zigo> Though it should normally work...
13:35:54 <zigo> Then we'll need to build cross-project libs like os-brick, neutron-lib and such.
13:35:57 <IgorYozhikov> I saw, and about tempest
13:36:08 <zigo> Yeah, that's *very* annoying.
13:36:13 <IgorYozhikov> do we really need it for unit tests?
13:36:23 <zigo> It's due to the fact that the Debian mirror from infra is unsigned.
13:36:31 <zigo> Meaning we can't use it with sbuild-createchroot.
13:36:42 <zigo> Hopefully, they will fix it and use a *real* ftp-sync script.
13:36:48 <zigo> Though currently, we have to deal with what we have.
13:37:12 <zigo> tempest is a build dependency of *many* things, since it now replaces tempest-list.
13:37:28 <zigo> It's possible we'll need to remove temporarily some build-dependency of tempest so that it can build...
13:37:31 <IgorYozhikov> zigo, I saw a similar test reqs in *murano*
13:37:32 <zigo> The usual drill you know.
13:37:44 <zigo> I'm really not worried.
13:38:05 <tlbr> Anything else to discuss ?
13:38:17 <IgorYozhikov> and dev team told me that tempest needed only 4 functional testing
13:38:19 <zigo> Once we've build everything, we should attempt to upgrade all to Newton b3 (all is currently Newton b2...).
13:38:19 <IgorYozhikov> not unit
13:38:31 <IgorYozhikov> that's why I'm asking
13:38:35 <zigo> Yeah, another topic! :)
13:38:41 <tlbr> :)
13:38:42 <zigo> #topic removal of duplicate repo
13:39:28 <zigo> #link https://review.openstack.org/362732
13:39:53 <tlbr> I don't think that we should remove it at this moment
13:39:54 <zigo> tlbr: Can you take care of that one?
13:39:58 <zigo> Why?
13:40:35 <tlbr> I'm not sure, if python- prefixes could be an issue when we will use zuul-cloner
13:40:53 <tlbr> Because Debian name differs =\
13:40:57 <zigo> It isn't, as much as I can tell.
13:41:06 <tlbr> Well, I'm not sure
13:41:14 <zigo> What issue do you forsee exactly?
13:41:15 <tlbr> It need further investigation
13:41:40 <zigo> tlbr: So are you suggesting we just wait, and deal with the deletion later?
13:41:55 <zigo> I don't really mind if we do that...
13:42:21 <tlbr> zigo, lets postpone it for now, please. :)
13:42:25 <zigo> Ok
13:42:54 <zigo> #action We will *not* remove duplicate repositories for now, it's postpone for at least a week
13:43:06 <zigo> #topic open discussion
13:43:31 <zigo> strigazi: IgorYozhikov: tlbr: Anything else you'd like to discuss?
13:43:41 <tlbr> zigo, are you picking new changes from Alioth ?
13:43:53 <tlbr> or we don't need it at all at this moment
13:43:58 <tlbr> and can discuss it later
13:44:01 <zigo> tlbr: I'll do that manually, that's implicitely part of Newton b3 move.
13:44:18 <zigo> tlbr: I'm not sure how to detect these changes though.
13:44:27 <tlbr> zigo, by squashing commits into one ?
13:44:29 <zigo> tlbr: Are you suggesting some kind of automation ? :)
13:44:42 <tlbr> zigo, yes, sure we need it
13:44:51 <zigo> tlbr: Yeah, no choice, because we must do "merge commit" with the new upstream version ...
13:45:07 <strigazi> About the build of clients, is python-magnumclient going to be included?
13:45:12 <tlbr> zigo, that is my only concern for now :)
13:45:18 <zigo> The merge commit must contain the merge of the new tag, AND the necessary packaging change in a single commit.
13:45:28 <zigo> strigazi: Yes, it will.
13:46:02 <zigo> strigazi: Everything that is over here will be in upstream OpenStack infra at some point: https://qa.debian.org/developer.php?login=openstack-devel@lists.alioth.debian.org
13:46:29 <zigo> tlbr: Will you write the automation script to detect changes between alioth and Gerrit?
13:46:42 <zigo> IMO, it should only detect changes in the debian folder, that's enough.
13:47:17 <tlbr> strigazi, Heat requires it https://github.com/openstack/heat/blob/master/requirements.txt#L42. We will do it for sure
13:47:30 <tlbr> zigo, at least I may try to do that
13:47:38 <zigo> Cool.
13:47:39 <tlbr> zigo, as a new job ?
13:47:50 <tlbr> I mean, periodic job
13:47:55 <zigo> tlbr: Just a shell script, which you can drop anywhere, that's IMO fine.
13:48:03 <tlbr> zigo, ok, will do
13:48:05 <zigo> We will only need it for the time of the migration, IMO.
13:48:19 <tlbr> Agree :)
13:48:27 <zigo> #action tlbr to write a script to check inconsistency between alioth and gerrit, so we wont forget changes pushed to alioth
13:48:35 <IgorYozhikov> zigo, what are your plans for summit, r u going to be in Barcelona?
13:48:36 <zigo> I think we're done here, no?
13:48:53 <tlbr> yeap, thank you for your time!
13:48:57 <zigo> IgorYozhikov: Definitively going yes. I need to open a ticket @mirantis for that.
13:49:21 <zigo> It's close from where I live anyway. We may even drive to it, not sure about it yet.
13:49:51 <IgorYozhikov> ok, rpm-packaging colleagues want to discuss "build machine"
13:49:54 <zigo> Ok, let's close the meeting then, let's chat in #openstack-pkg. strigazi you're of course welcome there.
13:50:03 <zigo> IgorYozhikov: At the summit?
13:50:07 <IgorYozhikov> yep
13:50:12 <strigazi> cool
13:50:15 <zigo> What does "build machine" means ?
13:50:28 <IgorYozhikov> I asked him about that on previous week
13:50:38 <IgorYozhikov> package builder on infra
13:50:46 <zigo> Ah, right.
13:51:01 <zigo> Well, they can look how we've done with openstack-pkg-tools and what's in project-config.
13:51:09 <zigo> I'm not sure how we can advise better than this.
13:51:26 <IgorYozhikov> :)
13:51:29 <zigo> Also, probably we'll move pkgos-infra-install-sbuild to diskimage-builder somehow.
13:51:40 <IgorYozhikov> so, we have 9 mins to go
13:51:42 <zigo> It really takes too much time to setup sbuild on each build.
13:51:50 <zigo> IgorYozhikov: Yes, but we're done, no? :)
13:52:06 <IgorYozhikov> looks like it there are no objections
13:52:14 <IgorYozhikov> or topics :)
13:52:24 <IgorYozhikov> s/it/if/
13:52:26 <zigo> Thanks everyone!
13:52:28 <zigo> #endmeeting