13:01:58 <zigo> #startmeeting deb_packaging
13:02:00 <openstack> Meeting started Mon Sep 12 13:01:58 2016 UTC and is due to finish in 60 minutes.  The chair is zigo. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:03 <openstack> The meeting name has been set to 'deb_packaging'
13:02:09 <zigo> ping  IgorYozhikov zigo tlbr mordred jamespage ddellav coreycb zul onovy strigazi
13:02:14 <zigo> Please raise your hand!
13:02:22 <tlbr> o/
13:02:26 <zigo> o/
13:02:46 <strigazi> o/
13:03:16 <ddellav> o/
13:03:53 <zigo> ddellav: James Page and Corey aren't comming?
13:04:13 <ddellav> zigo: I haven't heard anything from them either way.
13:04:24 <zigo> Ok, let's start then.
13:04:40 <zigo> #link Agenda at: https://etherpad.openstack.org/p/openstack-deb-packaging
13:04:53 <zigo> #topic Project current status
13:05:15 <zigo> So, most of 3rd party libs are there, and oslo as well.
13:05:27 <zigo> All of oslo has been uploaded to Experimental with latest change from Alioth.
13:05:43 <tlbr> I've seen you started adding Keystone.
13:05:52 <zigo> I fixed the VCS URLs for most of oslo, forgot a few at the begining, and that's the only ones that are done.
13:05:55 <tlbr> Looks like it builds successfully.
13:05:57 <zigo> All the others will need patch for it.
13:06:11 <zigo> Yup, Keystone is the 1st one to be completely built, though that's only Newton B2.
13:06:32 <tlbr> Ah, got it. Are you planning to update it ?
13:06:40 <zigo> Now, we needed openstacksdk to have half of the client to build, and the project-config patch containing it just got approved.
13:06:44 <zigo> It will be merged soon.
13:06:49 <tlbr> Ok.
13:07:12 <zigo> tlbr: We need to finish boostraping all the other projects first, but that will be next item on the list, yes.
13:07:48 <zigo> Remaining python-*client to build: heat, ironic, ironic-inspector, manila, sahara, senlin, watcher, zaqar.
13:07:56 <onovy> o/
13:07:58 <zigo> None were uploaded to Debian, this will have to be done.
13:08:06 <zigo> Any question?
13:08:22 <zigo> ddellav: Do you know if the python-*client are up-to-date in Alioth?
13:08:30 <tlbr> Have you uploaded all the clients ?
13:08:38 <zigo> ddellav: I mean, same version of upper-constraints.txt ?
13:08:41 <zigo> tlbr: Nop.
13:08:44 <zigo> None of them.
13:08:52 <zigo> Maybe Canonical did a bit, I didn't check yet.
13:08:54 <ddellav> zigo as far as i know they are as of last week, thats the last time we did a pass on them
13:09:04 <tlbr> zigo, ok, i'll start to upload it today.
13:09:25 <zigo> ddellav: Super cool, I'll work on it next.
13:09:33 <zigo> Then it should be ok to start building services.
13:09:49 <zigo> ddellav: What about 3rd party libs?
13:09:57 <onovy> swift + swiftclient are uploaded to debian and in alioth git. don't know if gerrit is in sync
13:10:06 <zigo> ddellav: Is there some of them stuck in git.debian.org, or where the updates you did uploaded to Debian Experimental?
13:10:28 <ddellav> zigo we synced everything to global requirements. However I do not know if everything was uploaded to alioth. I only updated the packages and passed them to corey
13:10:39 <zigo> onovy: I believe these will need a project-config patch, you'll have to check, but probably they don't have gerrit repo yet.
13:11:25 <zigo> tlbr: Do you think your check script will be available soon?
13:11:42 <tlbr> zigo, https://github.com/iudovichenko/deb-pkg-scripts
13:11:47 <zigo> FYI, tlbr wrote a script to check if there's some diff between alioth and Gerrit.
13:11:49 <tlbr> git_diff.sh in there
13:11:50 <zigo> Ah, cool ! :)
13:12:14 <tlbr> :) if you have any concerns please let me know.
13:12:17 <zigo> #link Check diff between Alioth and Gerrit: https://github.com/iudovichenko/deb-pkg-scripts/blob/master/git_diff.sh
13:12:42 <zigo> #topic Stackalitycs status
13:12:48 <zigo> tlbr: Any update from Ilya ?
13:12:56 <zigo> He didn't reply to my email...
13:12:59 <tlbr> zigo, no updates yet.
13:13:02 <zigo> :/
13:13:15 <tlbr> I've started to work on adding custom branches to it config.
13:13:18 <zigo> tlbr: Could you work on it yourself, or it's too much dealing with Stackalytics internals?
13:13:52 <tlbr> zigo, well, it is not a simple task. I haven't worked with it before. But anyway, I can ask Ilya to help me with that.
13:14:09 <zigo> tlbr: Ok, please keep us up-to-date.
13:14:11 <tlbr> I just changes its config. :)
13:14:14 <tlbr> zigo, Ok.
13:14:38 <zigo> tlbr: That's not what Ilya wrote. He said it needs some new code to be able to ignore the non-packaging branches.
13:14:50 <zigo> Anyway, moving on...
13:14:51 <zigo> #topic Canonical participation in packaging-deb
13:14:55 <tlbr> zigo, oh, ok.
13:15:04 <tlbr> May be I will find some traces to do that.
13:15:10 <zigo> ddellav: What's the current state of your thoughts? Can we count on you guys?
13:15:24 <tlbr> :)
13:15:57 <zigo> We'd really love to, and I'd make everything to make you feel comfortable...
13:16:06 <zigo> (but that, you know already, probably...)
13:16:07 <tlbr> ddellav, it'd be really great!
13:16:53 <ddellav> zigo i read the email thread you guys posted to openstack-dev, I do think your points have some merit and I would like to see a more structured approach. However, I think for now we will stick to our current process and pull releases from debian when appropriate. At least that seems to be our teams consensus.
13:17:48 <zigo> ddellav: But moving on, we'll be only working with Gerrit and stop using git.debian.org. Does that mean you guys will stop pushing patches completely?
13:19:12 <ddellav> zigo as far as I know we will continue to push patches to alioth where they can be pulled by anyone that wishes. I'm not sure if jamespage has any plans to use the openstack infra, however I cannot speak for him.
13:19:13 <jamespage> zigo, I'll think you'll see participating still - just not sure on what form that will be
13:19:28 <ddellav> ah there we go
13:19:53 <zigo> jamespage: So, we should give you another week to think about it?
13:20:07 <jamespage> you can give me until barcelona to think about it
13:20:09 <jamespage> :)
13:20:39 <jamespage> we're so close to release now its hard to get a feel on real direction
13:20:39 <tlbr> We can push changes from Gerrit to Alioth but I still think it is not a good idea. =\
13:20:50 <zigo> jamespage: Yes, if you need that. The release is nearly cut, so we wont have much git/gerrit sync issues for until the final release.
13:20:57 <jamespage> rest assured we won't push anything to alioth
13:21:35 <zigo> Well, I do believe we're on a very good track to release all of Newton using OpenStack CI...
13:21:47 <zigo> Anyway, ok, let's give you more time.
13:21:49 <tlbr> Starting from Okata it'd be also great . :)
13:22:09 <zigo> #topic ddellav & coreycb DM status
13:22:44 <zigo> jamespage: ddellav: It'd be really nice you had DM status and could upload. Have you started? Is it planned?
13:22:55 <zigo> I'd for sure advocate for you.
13:23:36 <zigo> Can I help in some ways?
13:23:59 <ddellav> zigo it is planned, yes. I'd love your help with any suggestions on how I can prepare or what I should be doing.
13:24:20 <zigo> ddellav: Do you need pointers to the procedure and such?
13:24:34 <zigo> (URLs, etc.)
13:24:37 <ddellav> zigo not particularly, I have all the wiki posts bookmarked and i read through them regularly
13:24:45 <ddellav> i just think i need advocates
13:24:52 <ddellav> and a good way to get them
13:25:07 <tlbr> 2 advocates is more then enough I guess.
13:25:12 <zigo> ddellav: If you just point me that you've started, I'll advicate through nm.debian.org
13:25:18 <tlbr> *than
13:25:44 <zigo> Ok, moving on then...
13:25:51 <zigo> #topic PTL elections & Canonical core reviewer status
13:26:10 <ddellav> zigo the only thing holding me back right now is my key. It's not signed yet. I meant to meet up with you in austin but i got sick and spent most of the time in my room and I won't be going to barcelona this year for family reasons.
13:26:33 <zigo> ddellav: Where do you live?
13:26:39 <ddellav> i could meet up with corey to get him to sign it but I'm not sure if that's sufficient
13:26:45 <ddellav> NC, about 2 hours from coreyob
13:26:57 <zigo> NC means?
13:27:04 <ddellav> north carolina, usa
13:27:19 <zigo> Corey isn't a DM or a DD, so his signature wouldn't help.
13:27:24 <ddellav> winston salem, specifically
13:27:48 <ddellav> ok, thats what I thought
13:27:53 <zigo> ddellav: https://wiki.debian.org/Keysigning/Offers This may help though.
13:28:28 <zigo> NC, Raleigh-Durham: Eloy Paris <peloy>
13:28:30 <ddellav> ah ok, there's someone in Raleigh,
13:28:38 <ddellav> so thats only a couple hours, i could make the trip
13:28:38 <zigo> ddellav: Is it far from your place?
13:28:45 <zigo> Cool.
13:28:54 <zigo> ddellav: Do you have another signature already? Like jamespage one?
13:29:17 <ddellav> zigo no, no signatures at all.
13:29:21 <zigo> :/
13:29:25 <zigo> You need at least 2.
13:29:25 <onovy> 2 DD signs needed
13:29:44 <zigo> I'll let you try to deal with it, maybe in a nearby state.
13:29:47 <ddellav> i'll figure it out.
13:30:02 <zigo> ddellav: If you need, you can write to debian-private@lists.debian.org, and ask. Someone may reply ...
13:30:11 <ddellav> ok, thanks
13:30:22 <zigo> Every DD is automatically subscribed to that list.
13:30:41 <zigo> Anyway, moving to "PTL elections & Canonical core reviewer status" for real now.
13:31:08 <zigo> jamespage: ddellav: To be able to do new upstream release, you need to do a "merge commit", which is an ACL only core reviewers have.
13:31:30 <zigo> Should we start the procedure to give it to you 3, or should we wait until after Barcelona?
13:31:41 <jamespage> wait pls
13:31:49 <zigo> Ok
13:32:17 <onovy> zigo: so if i understand it correctly, after swift -> gerrit migration, i can't update it, right?
13:32:24 <zigo> #action As per jamespage: wait for after Barcelona to promote Canonical server team members to core
13:32:43 <zigo> onovy: I can do the project-config patches for you after the meeting if you like. Let's talk about it in channel, ok ?
13:33:05 <onovy> ok
13:33:17 <zigo> #topic Contributor documentation status
13:33:54 <jamespage> wait - what about PTL elections?
13:33:59 <zigo> Ah, right.
13:34:05 <zigo> #topic PTL elections
13:34:05 <jamespage> zigo, I'm assuming you'll be standing?
13:34:12 <zigo> jamespage: Will do, yes.
13:34:20 <zigo> I was wondering if anyone else would ...
13:34:25 <tlbr> :)
13:34:46 <zigo> I guess nobody from Canonical yet...
13:34:50 <zigo> tlbr: You maybe? :)
13:34:54 <tlbr> maybe Monty liked it a lot. :)
13:35:00 <tlbr> zigo, not yet :)
13:35:01 <zigo> LOL
13:35:03 <tlbr> :D
13:35:09 <zigo> tlbr: Maybe next cycle? :)
13:35:14 <tlbr> zigo, maybe :)
13:35:18 <zigo> jamespage: Anything esle you want to know?
13:35:21 <jamespage> I won't be standing - a) no commits a b) standing for PTL on another project
13:35:34 <zigo> Ok.
13:35:39 <zigo> jamespage: What other project?
13:35:56 <jamespage> zigo, the one I'm already PTL of - OpenStack Charms
13:36:07 <zigo> Which was my guess! :)
13:36:23 <zigo> #action zigo to stand for PTL, nobody else wants to stand for now
13:36:50 <zigo> #topic Contributor documentation status
13:37:08 <zigo> Contributor "doc" started in the wiki:
13:37:12 <tlbr> #link https://wiki.openstack.org/wiki/DEB-packaging
13:37:23 <zigo> Thanks, you're faster than I ! :)
13:37:27 <tlbr> :)
13:37:42 <zigo> It's only a start, and probably we will move to a sphinx doc within openstack-pkg-tools.
13:37:52 <tlbr> You've enough information for that, I guess.
13:37:57 <tlbr> *added
13:38:02 <zigo> However, I'm really not up to speed with sphinx doc writting skills.
13:38:20 <jamespage> zigo, tlbr: its easier to review and manage that way imho
13:38:27 <zigo> jamespage: ddellav: Any comment on the wiki entries would be appreciated.
13:38:30 <jamespage> https://docs.openstack.org/developer/charm-guide
13:38:57 <jamespage> changes can be reviewed just like any other code; wikis are a bit edgey for offical docs imho
13:38:57 <zigo> It appears down for me right now, I'll look later.
13:39:09 <tlbr> jamespage, yep, I may do that.
13:39:16 <zigo> jamespage: I very much agree. Though we needed to have a content to start with.
13:39:27 <zigo> Now that we have it, we probably should start with sphinx doc.
13:39:58 <zigo> Or maybe wait for another week or 2?
13:40:03 <zigo> tlbr: Your thoughts?
13:40:46 <tlbr> zigo, do you want add it to openstack-manuals ?
13:41:06 <zigo> tlbr: After some discussions, it looks like openstack-pkg-tools is the right place to use.
13:41:19 <zigo> It could also be published in docs.openstack.org, that shouldn't be a problem.
13:41:28 <zigo> I don't know technically how that's done, but it's possible.
13:41:36 <tlbr> zigo, well, I guess we may start working on it.
13:41:41 <zigo> Then we'll also have it packaged, so that's double win!
13:41:52 <tlbr> Yeah, agree.
13:42:01 <zigo> tlbr: Will you take on starting to move there? Do you have time?
13:42:22 <tlbr> zigo, Sphinx doc ?
13:42:25 <zigo> Yup.
13:42:29 <zigo> I wont have time for it.
13:42:34 <tlbr> Ok.
13:42:40 <zigo> I prefer working on the install-guide (which is next topic...).
13:42:57 <tlbr> I have a proposed change there, added it recently.
13:43:07 <zigo> You mean the install-guide?
13:43:10 <tlbr> But already have -1 :P
13:43:12 <tlbr> Нуы
13:43:14 <tlbr> yes
13:43:15 <zigo> Link? :)
13:43:18 <zigo> Hang on ...
13:43:29 <zigo> #topic install-guide review and contrib
13:43:33 <zigo> Post your link ... :P
13:43:36 <tlbr> #link https://review.openstack.org/#/c/368806/
13:43:37 <tlbr> :)
13:44:45 <zigo> I think some of it needs discussion, especially the first paragraph, which goes against what we wanted to do.
13:44:52 <zigo> Let's take the discussion on Gerrit then.
13:45:04 <zigo> Now, the install-guide team will need a full review of the install procedure.
13:45:12 <zigo> jamespage: Do you guys already have a working b3 release?
13:45:17 <tlbr> Ok.
13:45:53 <zigo> In Debian, not yet, since I've been working on Gerrit stuff, and hoped to be ready with it.
13:45:58 <jamespage> zigo, yes
13:46:02 <zigo> Good! :)
13:46:18 <jamespage> I think coreycb sent to openstack-announce
13:46:19 <zigo> jamespage: I'd suggest you give an update to the openstack-docs list then.
13:46:22 <zigo> Ok.
13:46:53 <zigo> Moving on...
13:47:01 <zigo> #topic Patch self approval vs peer reviews
13:47:30 <zigo> I've been doing a lot of self-approval, but 1/ many were trivial addition of a .gitreview file, or 2/ sync of git from Alioth
13:47:51 <zigo> So far, we were not using a peer-review process, and it worked quite well.
13:48:03 <zigo> I was wondering what was the team's view on that.
13:48:23 <zigo> It is my own opinion that we are grown-ups, and we can judge if a patch needs peer-review or not.
13:48:34 <zigo> tlbr: jamespage: onovy: Your thoughts?
13:48:45 <onovy> code review is good thing
13:48:51 <onovy> but we are small now
13:48:51 <tlbr> zigo, May be once we'll finish with bootstraping ?
13:49:01 <onovy> after bootstraping, we can try
13:49:20 <zigo> Yes, but some trivial changes shouldn't be slowed down by the procedure either.
13:49:25 <tlbr> Actually we just re-use what is already done.
13:49:33 <zigo> tlbr: That, IMO, we already agreed on the exception of bootstraping everything.
13:49:39 <zigo> So let's take that aside.
13:49:41 <zigo> But after?
13:49:42 <jamespage> ftr even for a trivial change we require peer +2 before landing in charms
13:49:43 <tlbr> zigo, ok, got it.
13:49:57 <jamespage> but after bootstrap would make sense
13:50:00 <onovy> my opinion is to use code review everytime, even for simple change
13:50:03 <tlbr> I agree with jamespage.
13:50:22 <onovy> my guys already screwed production "with small changes" without code review :)
13:50:34 <tlbr> :)
13:50:59 <zigo> Ok, 3 persons for peer reviews, I haven't expressed an opinion and it's not even needed.
13:51:02 <tlbr> Ok, let's then review every change afterwards.
13:51:02 <zigo> So let's do that ! :)
13:51:28 <zigo> tlbr: onovy: Will you have time for reviewing patches?
13:51:34 <tlbr> zigo, sure!
13:51:42 <zigo> Because it will be just the 3 of us until Barcelona ...
13:51:56 <zigo> (since IgorYozhikov will be doing something else...)
13:52:08 <tlbr> Yep.
13:52:12 <tlbr> Next topic ?
13:52:15 <zigo> Sure.
13:52:39 <zigo> #topic signed tags for debian/1.2.3-4 uploads
13:52:56 <zigo> So, I had this topic in mind, but after some tries, I believe the procedure works.
13:53:08 <zigo> So I will just explain, so everyone else is on the same page.
13:53:24 <zigo> On each new merged commit, the OpenStack CI will increase the build number.
13:53:38 <jamespage> really?
13:53:48 <zigo> Meaning version 1.2.3-4 will become 1.2.3-4+5 after 5 commits.
13:54:08 <zigo> In fact, 1.2.3-4+5~bpo8+1.
13:54:37 <zigo> That is only so that reprepro is happy importing new releases...
13:54:41 <zigo> That's not a big issue.
13:54:44 <zigo> The issue is with tagging.
13:54:55 <zigo> Since the system is using "git describe" to find out how many commits.
13:55:03 <zigo> So, in order to not break anything the procedure should be:
13:55:07 <onovy> zigo: sure4
13:55:13 <zigo> 1/ Make sure everything is rightly commited in Gerrit
13:55:22 <zigo> 2/ Upload to debian
13:55:45 <zigo> 3/ git tag -s debian/1.2.3-4 -m "Debian release 1.2.3-4"
13:55:51 <zigo> 4/ git push gerrit --tags
13:55:59 <zigo> If you do that, this will reset the number of commits.
13:56:13 <onovy> q1) is it possible to replace tags in gerrit?
13:56:17 <zigo> Meaning the next thing the CI will produce will be 1.2.3-4+1
13:56:29 <zigo> If we had 5 commits earlier, that wont work.
13:56:42 <onovy> because dak can say: REJECT :]
13:56:43 <zigo> Which is why your next commit *MUST* open a new Debian release 1.2.3-5
13:56:59 <zigo> onovy: Not dak, reprepro here in the OpenStack CI. But that's the same idea...
13:57:11 <onovy> 2/ Upload to debian
13:57:14 <onovy> dak replies: REJECT
13:57:19 <onovy> how can i fix + retag?
13:57:22 <zigo> So, on the next CR, it should normally produce 1.2.3-5+1~bpo8+1
13:57:44 <zigo> Note that everything is quite silent, only the POST job will fail, so you should all pay attention.
13:57:55 <zigo> onovy: I don't think ou can "fix" tags, no.
13:58:10 <zigo> onovy: Though, for things like dogpile.cache, it's fine to re-tag upstream tags, for example with:
13:58:27 <onovy> so if someones forgots to call 'dch -r', tags it, gerrit-push it, noone can fix it?
13:58:29 <zigo> git tag -s 0.6.2 rel_0_6_2
13:58:29 <zigo> git push gerrit --tags
13:59:06 <zigo> onovy: The problem if you forget to tag, is that you will have to do it *after*, which will break the increasing build number that uses git describe.
13:59:20 <onovy> will we code-review tags? :)
13:59:20 <zigo> So you'll break the POST import job until the increment goes high enough...
13:59:31 <zigo> onovy: That's unfortunately not possible with Gerrit.
13:59:40 <zigo> Anyway, that's said.
13:59:48 <zigo> Let's switch to last topic:
14:00:04 <zigo> #topic Schedule (time & day) for next meeting
14:00:31 <zigo> jamespage: onovy: tlbr: ddellav: We discussed about 8pm UTC on Monday, is it still fine?
14:00:52 <ddellav> zigo that works for me
14:00:54 <zigo> Will correy be able to attend?
14:00:55 <jamespage> youch - that time generally is tricky for me
14:00:57 <onovy> it's 10pm during summer for my TZ
14:01:16 <zigo> onovy: Same over here, which is convenient: kids are asleep already! :)
14:01:21 <zigo> onovy: Is that too late for you?
14:01:35 <onovy> 1-2pm utc is much better for me
14:01:39 <ddellav> he should be able to attend, yes, at least nothing on his calendar has him busy at that time
14:01:52 <zigo> onovy: This doesn't work for West coast guys like ddellav and corey.
14:02:11 <onovy> right
14:02:13 <zigo> jamespage: Would the same time another day of the week be ok for you?
14:02:42 <jamespage> don't block on me
14:02:48 <jamespage> I'll make it if I can
14:03:03 * bauzas glares at zigo for the clock :p
14:03:08 <jamespage> evenings are generally awkward due to pesonal commitment
14:03:10 * edleafe glares too
14:03:11 <jamespage> xig
14:03:11 <onovy> ok, so 8pm is "fine" for me
14:03:13 <zigo> Ok, let's do that for next week, and see if it works.
14:03:19 <zigo> No time for open discussion.
14:03:23 <zigo> Thanks guys.
14:03:25 <zigo> #endmeeting