01:00:27 <markvoelker> #startmeeting defcore
01:00:30 <openstack> Meeting started Thu Jul  9 01:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is markvoelker. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:00:34 <openstack> The meeting name has been set to 'defcore'
01:00:41 <markvoelker> #chair hogepodge
01:00:42 <openstack> Current chairs: hogepodge markvoelker
01:00:52 <markvoelker> o/
01:00:59 <catherineD> o/
01:01:22 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreFlag.7 Agenda for today
01:01:35 <markvoelker> hogepodge: around?
01:01:37 <hogepodge> o/
01:01:52 <markvoelker> anyone else today?  Rob and Egle are out.
01:01:57 <hurricanerix> o/
01:01:59 <rockyg> o/
01:02:17 <markvoelker> Ok then, off we go....
01:02:20 <hogepodge> Please drop your timezone also.
01:02:24 <hogepodge> PDT
01:02:30 <hurricanerix> CST
01:02:36 <catherineD> PDT
01:02:38 <markvoelker> EDT
01:02:51 <markvoelker> #topic Alternating meeting schedule review
01:03:15 <markvoelker> So earlier in the flag cycle we adopted an alternating meeting schedule and set an AI for today to talk about whether it's working out or not.
01:03:31 <markvoelker> The idea was to make DefCore meetings more accessible to global participation.
01:03:55 <markvoelker> Looking back over past meeting logs, we have gotten some AsiaPac participation...though not a lot.
01:04:21 <markvoelker> Personally I'm fine with the current alternating times, but it's worth discussing.  Any strong opinions?
01:04:26 <rockyg> pdt
01:05:07 <hogepodge> I've noticed smaller participation for the later time, and some europeans stating the later time is not possible for them.
01:05:47 <hogepodge> I'd prefer the early morning (PDT) time, but it's not an overly strong preference.
01:06:29 <markvoelker> hogepodge: we are getting some participation from AsiaPac at the later time though...do you know of European folks interested in attending that aren't because of the time?
01:07:20 <markvoelker> Personally today's meeting time isn't super great for me, but it's not horrible either and I'm happy to keep it if it means we're letting AsiaPac participate.
01:07:27 <hogepodge> one person from the tailgate group was adamant that the meeting time for tonight isn't possible to attend.
01:07:48 <catherineD> do we get European folks at the earlier time?
01:08:00 <rockyg> tailgate?
01:08:02 <markvoelker> hogepodge: what about the other alternating week timeslot (15:00 UTC).  That should be much more doable for Europe, no?
01:08:18 <hogepodge> rockyg: it's an interoperability and testing group formed in Vancouver
01:08:29 <hogepodge> markvoelker: I can check
01:08:51 <markvoelker> Ok.  I'm happy to take this up on the ML again if folks think it's worth a broader discussion.
01:09:14 <markvoelker> (feel free to say "yes, do that Mark!" or "No, don't do that Mark!" now folks =p)
01:10:04 <hogepodge> Yes, take it to the mailing list Mark! :-D
01:10:05 <rockyg> I know someHuawei folks have attended the later meetings.  I don't know if they spoke up, though ;-)
01:10:23 <markvoelker> hogepodge, rockyg: duly noted.
01:10:58 <markvoelker> Ok, the other meeting thing we had to talk about was separating out capabilities meetings again since we've spent approximately zero time on that so far in Flag cycle meetings.
01:11:18 <markvoelker> I think there's no real opposition to doing this (speak up if there is), so I'll put something out on the ML.
01:11:44 <markvoelker> WE're going to talk about capabilities scoring a bit more later in today's meeting, so I suggest we move on.
01:12:12 <markvoelker> #action: markvoelker to start ML discussion meeting times and capabilities meeting breakout
01:12:21 <markvoelker> #topic midcycle agenda
01:12:43 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreFlag.MidCycle Midcycle agenda (tentative)
01:13:06 <markvoelker> Those of you who expressed interest in helping plan the midcycle got together last week to frame up a tentative agenda, which is in the etherpad above
01:13:08 <markvoelker> One note:
01:13:25 <markvoelker> since then we've spoken to the Neutron and Nova PTL's and they've agreed to attend
01:13:45 <markvoelker> But the timeslot we had doesn't work for them (one is in the UK, one is in Minnesota for what it's worth)
01:13:50 <rockyg> waht about glance?
01:14:01 <markvoelker> They're available on the morning of the first day, so we'll be moving the networking discussion to then
01:14:16 <rockyg> OK by me.
01:14:19 <markvoelker> rockyg: good question.  hogepodge, you were going to reach out to Nikhil?
01:14:50 <hogepodge> markvoelker: yes, I haven't yet. I'll add it to my todo for tomorrow.
01:15:07 <markvoelker> FWIW, the Nova PTL said he'd be interested in doing that right after the networking discussion.
01:15:21 <markvoelker> hogepodge: ok, thanks
01:15:34 <rockyg> He'll be in Virginia, so if we need him with the nova ptl, it's a bit easier, maybe.
01:15:41 <markvoelker> #action: hogepodge to reach out to Glance PTL about remoting in to midcycle on the morning of the 29th
01:16:19 <markvoelker> We also need to settle on a remote attendance mechanism and get that set up (Google Hangout/Join.me/whatever)
01:16:39 <markvoelker> But that's not particularly urgent.
01:17:10 <markvoelker> I'll give myself an AI to work out the mechanics with our esteemed chairs and get the final schedule published so folks can plan.
01:17:41 <markvoelker> #action markvoelker to work with zehicle, eglute, hogepodge to finalize remote attendance details and agenda once we hear from Glance PTL
01:17:50 <markvoelker> Any other midcycle stuff we need to talk about?
01:17:50 <hogepodge> IBM may have a sophisticated system in place. Do you know catherineD?
01:18:13 <rockyg> Maybe.  Hotels nearby?
01:18:15 <hogepodge> Just a reminder that the board meeting is the day before
01:18:25 <catherineD> hogepodge: you will be connected to IBMVisitor wireless network ..
01:18:28 <rockyg> Like within walking distance?
01:18:32 <markvoelker> rockyg: I'm staying at Aloft which is basically across the street.
01:18:49 <rockyg> cool.  How's that mesh with the board meeting location?
01:19:03 <hogepodge> I'll be looking for an AirBnB, and maybe the Aloft since I'll be there for the entire week.
01:19:36 <rockyg> And, IBM might need pre-registration or picture ID.  Only an issue for non-flyers
01:19:36 <markvoelker> rockyg: not great but not horrible I think?  I won't be in town in time for the Board meeting so I didn't take that into account.
01:20:02 <rockyg> Thanks
01:20:18 <markvoelker> rockyg: yeah, I think vince was going to send out a note with whatever was needed.
01:20:33 <markvoelker> Ok, anything else on midcycle?
01:20:39 <catherineD> rockyg: markvoelker:  hogepodge:  do you all leave on Thursday?
01:20:47 <vinceb> We will need a list of people that are in attendance so that I can enter them in to the system
01:20:51 <hogepodge> I leave early Friday morning
01:20:57 <markvoelker> catherineD: I'm flying out early Friday too.
01:21:04 <vinceb> You all will need picture IDs to show to security for temporary badges.
01:21:19 <catherineD> oh if that is the case I should leave Friday also .... Thanks ..
01:21:38 <markvoelker> vinceb: Just names?  We could use the etherpad for that perhaps?
01:21:47 <rockyg> I think I'm Friday, am, too.
01:21:48 <markvoelker> or whatever is easiest for you...
01:22:23 <vinceb> markvoelker: Just names and you can email me a list or we can put them in etherpad.  Either way works for me
01:22:34 <markvoelker> vinceb: ok, thanks.  And so:
01:23:00 <markvoelker> #action everyone If you're coming to the midcycle, please add your name to https://etherpad.openstack.org/p/DefCoreFlag.MidCycle
01:23:57 <vinceb> As for accomodations for those that are travelling.  The IBM address is 11501 Burnet Rd.  Austin, TX
01:24:16 <vinceb> You should be able to find plenty of accomodations near by.
01:24:39 <markvoelker> And in case anyone forgets, that address is also in the etherpad. =)
01:25:08 <markvoelker> Ok, anything else on midcycle?
01:25:56 <markvoelker> #topic Review backlog
01:26:39 <markvoelker> We have a bunch of reviews in the queue that have been sitting around for a while.
01:26:56 <markvoelker> We can spend some time on these at the midcycle if necessary, but many of them seem like they're low-hanging fruit that we could easily clear off the plate before then.
01:27:04 <markvoelker> (and thus free up more time for other stuff)
01:27:36 <markvoelker> I've taken a stab at bucketizing them in the etherpad for today's meeting: https://etherpad.openstack.org/p/DefCoreFlag.7
01:27:46 <rockyg> Yeah, I did two in the time I connected to the meeting and its start
01:29:02 <markvoelker> I figured I'd bargain a little tonight. =)  If we move on to the last item on the agenda for tonight, we'll probably finish early.
01:29:30 <markvoelker> So if we do that, would folks be willing to hang around and use the extra time to review the first 10 or so on the list?  Those should all be pretty low-hanging fruitish I think.
01:29:48 <markvoelker> So probably an easy way to slice the backlog in half before the hour is out.
01:30:31 <markvoelker> Sound good?
01:30:38 <rockyg> Works for me.
01:31:11 * markvoelker sits quietly hoping for more positive acknowledgements
01:31:19 <markvoelker> Pretty please? =)
01:31:37 <vinceb> I have to drop.  You all have a good day/evening.
01:31:47 <markvoelker> vinceb: thanks, you too
01:31:50 <catherineD> markvoelker: works for me too
01:32:17 <hurricanerix> works for me as well
01:32:19 * markvoelker looks in hogepodge's direction although he's probably the submitter on some of these and has reviewed others already
01:32:44 <markvoelker> Excellent!  I'll count that as a win.  Ok, moving on then....
01:32:52 <markvoelker> #topic Capabilities review
01:33:13 <rockyg> I'd like to discuss two that are related.  The glance ones, https://review.openstack.org/#/c/189867/ and https://review.openstack.org/#/c/196154/
01:33:41 <rockyg> Oops.  Sorry.  Jumped the gun...
01:33:46 <markvoelker> rockyg: want to leave your comments in gerrit and we'll discuss at the end of the meeting if there's time?
01:34:20 <rockyg> Yup.  Just wondering if they might really be the same thing and should be merged or something
01:34:25 <markvoelker> We've very briefly discussed capabilities scoring a little bit on the tail end of previous meetings, and it'll be on the agenda at the midcycle too
01:34:37 <markvoelker> But I think there's a little pre-work we need to do before then
01:35:41 <markvoelker> In a nutshell, I think we need to split up the work of identifying candidates to addition to the next Guideline.  There's just no way we have enough bandwidth to do it all in meetings.
01:36:12 <markvoelker> So, I'd like to see if there are folks interested in working on particular projects.  I'm already working on networking, so I'm happy to tackle Neutron/Nova.
01:36:49 <markvoelker> Basically you just need to identify candidate capabilities that you think are strong enough canddiates to include in a future spec to have a discussion about.
01:37:08 <markvoelker> Preferably you consult with the PTL and/or technical contributors.
01:37:50 <markvoelker> Then once we decide on a fomrat, you can post them to gerrit for folks to review.  We'll use meeting time for ones that there's not consensus on.
01:38:04 <markvoelker> Generally make sense?
01:38:21 <markvoelker> If we can at least decide on owners before Austin, we'll have a nice head start.
01:38:26 <rockyg> so we have nova, neutron, cinder, keystone.. what else?
01:38:32 <markvoelker> (or co-owners....nothing says you have to do it alone)
01:38:34 <rockyg> Oh, swift
01:38:46 <markvoelker> rockyg: I put a list in the etherpad.
01:38:53 <rockyg> Thanks!
01:39:05 <markvoelker> It's not all of the components in the last integrated release, but it's most of the ones that are widely deployed in the last user survey.
01:39:39 <hurricanerix> If there is Swift stuff, I can help with that if needed since I already contribute to it.
01:39:47 <hogepodge> I'd like to note that we had an error crop up in the keystond capabilities and components
01:39:50 <rockyg> I think we can count glance out until they come to some agreement with nova and themselves
01:40:08 <hogepodge> It's not a required component in 2015.05, but has a required capability.
01:40:10 <markvoelker> And to be clear: you're not signing up for work that has to be done immediately.  We're obliged to complete the scoring by September 27th according to the 2015A process doc.
01:40:34 <markvoelker> hurricanerix: excellent!
01:40:35 <hogepodge> #link http://lists.openstack.org/pipermail/defcore-committee/2015-July/000891.html
01:41:00 <markvoelker> hogepodge: duly noted, can I sign you up to work on keystone again this time around?  You did that last time and are well familiar with it I believe. =)
01:41:10 * markvoelker isn't buttering hogepodge up....nope, not at all
01:41:18 <hogepodge> yes, although there isn't much there in terms of non-admin api
01:41:37 <rockyg> I would go for cinder, but I've got booth duty at OSCon :P
01:41:40 <hogepodge> ptl might have some minor changes
01:42:05 <markvoelker> rockyg: OSCON shouldn't be a problem.  You have months before it all needs to be done (but the sooner the better)
01:42:35 <rockyg> Oh.  then count me in.  I've got a sorta working relationship with Mike Perez
01:42:44 <markvoelker> rockyg: thanks!
01:43:23 <markvoelker> I can take Nova as well I suppose, since I'm talking with them about networking stuff anyway....
01:43:46 <markvoelker> Anyone for Glance, Heat, Ceilometer, other?
01:44:04 <catherineD> I can take Heat
01:44:05 <hogepodge> I'll do glance
01:44:32 <markvoelker> thank you catherineD, hogepodge
01:44:43 <rockyg> maybe some morning person will sign up for ceilometer :_)
01:45:14 <markvoelker> Ceilometer anyone?  I know some of the ceilometer devs, but nova and neutron seem like they're going to be mighty time consuming already....
01:46:23 <markvoelker> Ok, we'll table that one for now and ask for volunteers again later....we're missing some folks tonight so still able baodies at hand.
01:46:35 <rockyg> Put it in the meeting summary and ask for volunteers in it.  A morning cycle person might volunteer.
01:47:12 <catherineD> So we will use the Capability names from https://docs.google.com/spreadsheets/d/15Fkt2n95WPPe7CYH-0WIKz3dhMeW3FW2gl5aSlamEeY/edit?pli=1#gid=561264013?
01:48:01 <markvoelker> catherineD: that's a fine starting point, yes.
01:48:06 <markvoelker> One other note on capabilities: VanL and I were supposed to try to meet last week before he went on PTO to discuss scoring mechanisms, but couldn't work out a time before the holiday.
01:48:19 <markvoelker> I'll be circling back with him next when when he's back
01:48:41 <markvoelker> So look for a note from one or both of us on the ML with a proposed mechanism after then.
01:49:19 <markvoelker> #link https://docs.google.com/spreadsheets/d/15Fkt2n95WPPe7CYH-0WIKz3dhMeW3FW2gl5aSlamEeY/edit?pli=1#gid=561264013? capability names
01:49:55 <markvoelker> Anything else on this?
01:50:14 <markvoelker> #topic open floor
01:50:27 <markvoelker> Anything else anyone wants to bring up tonight before we adjourn to go review patches?
01:51:16 <markvoelker> Going once...
01:51:21 <catherineD> Let's review patches ..
01:51:37 <markvoelker> catherineD: sold!
01:51:39 <markvoelker> #endmeeting